Jump to content

Recommended Posts

Hi guys, probably my observation will have already been made.  I noticed that in passages at low altitude, despite having a fixed 60 fps if I observe the ground I notice a certain stutter, and this I find strange.  For example, in clod the stutter on the ground is confirmed by a decrease in fps.  The same thing happens even if I set the fps target to 30. How did you solve the problem?

Best regards

Share this post


Link to post
Share on other sites

What GPU are you running? 
If you have only a 3GB Video card and use certain settings when you get low it will go over 3GB Usage and start paging to system Ram. 

If you have a 6GB Card 
Ultra Preset.
Terrain Filter - Sharp.
Terrain Distance - Max.
 

Share this post


Link to post
Share on other sites
2 hours ago, =TBAS=Sschatten14 said:

What GPU are you running? 
If you have only a 3GB Video card and use certain settings when you get low it will go over 3GB Usage and start paging to system Ram. 

If you have a 6GB Card 
Ultra Preset.
Terrain Filter - Sharp.
Terrain Distance - Max.
 

Hi

I have gtx1050 2gb. In any case why fps do not decrease? 

Share this post


Link to post
Share on other sites

I have the same problem . . . But it’s only certain maps while playing online on WoL. I haven’t been able to figure it out either. It’s like a brief pause every second or so. 

  • Upvote 1

Share this post


Link to post
Share on other sites

If you have a 2GB card then you can only use Balanced preset with low shadows @ 1080P 
anything higher you will run out of Videom Ram (the 2gb) and when it uses system ram it will be very slow and jerky.. 

The listed min Specs are to play @ 1080P on Low preset with most things turned off maybe even 720P

Minimum system requirements

  • OS: 64-bit Windows® 7 (SP1) / Windows® 8 / Windows® 10
  • CPU: Intel® Core™ i5/i7 2.8 ГГц
  • GPU: GeForce GTX 660/Radeon HD 7770 with 2GB VRAM or better

Share this post


Link to post
Share on other sites
9 minutes ago, =TBAS=Sschatten14 said:

If you have a 2GB card then you can only use Balanced preset with low shadows @ 1080P 
anything higher you will run out of Videom Ram (the 2gb) and when it uses system ram it will be very slow and jerky.. 

The listed min Specs are to play @ 1080P on Low preset with most things turned off maybe even 720P

Minimum system requirements

  • OS: 64-bit Windows® 7 (SP1) / Windows® 8 / Windows® 10
  • CPU: Intel® Core™ i5/i7 2.8 ГГц
  • GPU: GeForce GTX 660/Radeon HD 7770 with 2GB VRAM or better

Thanks for the reply. I try to make it 

Share this post


Link to post
Share on other sites
Posted (edited)

I know exactly what you're talking about. Got this for a long time until deciding to get rid of it. I have a gtx1080 with 8Gb + i5 3570K@4.4Ghz and this occurs if I'm using full max specs. I think that this may have something to do with transferring textures to memory during gameplay... not sure as I was using everything on ultra/max settings+SGSSA.

To the point: to get rid of this, try the settings shown on pictures attached, along with a frame rate limit capable to let your card working around 60 to 70% while flying at 500m alone, thus making everything ultra smooth. With this, your gfx will have enough room to go from idle moments to heavy combat (several planes at low alt over forest) without hitting 100% - with these settings on my end, heavy moments are around 95% give or take. Also, the terrain stuttering at low alt (which plagued IL2 since forever) is 100% gone. 
If I remember correctly, the change that got rid of the stuttering is the combination of grass quality with not using the sharper filter. Try on your end, use my settings as a guide. 
Obs: I limit the frame rate using nvidia profiler, although I haven't shown this on the picture attached. 

Hope it helps. Cheers.

 

EDIT: for those who haven't seen the effect, it is well apparent when using Trackir and looking to the side while flying low over forests.

EDIT2: see new Profile Inspector settings on my next post after this.

 

profiler.png

settings.png

Edited by jokerBR

Share this post


Link to post
Share on other sites

What?? @jokerBR
The game(Il2) does not support MFAA and you cannot use FXAA and MFAA at the same time.
Then you have 4 x MSAA ingame needed to enable MFAA in most games (but here its turned off in the Il2.exe MFAA is blocked) 

So all the Anti A you are getting is ingame MSAA 4x and NVCP FXAA 2x 
then you are forcing a Lod Bias in NVCP which is only used for supersampling AA but you not using SSAA.

Best of with DSR & run your game at 5120 x 2160 and No Anti Aliasing At all 

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks for the info @=TBAS=Sschatten14, didn't know about the MFAA not working on IL2 or LOD bias only applying to SSAA. These settings are remnants from previous tests when I messed with for some long hours - the moment it worked I stopped and never looked back. Strange thing is that although they may be "wrong", the image and smoothness that I'm playing are perfect at the moment. Perhaps they're simply not making any effect, but the combination of the other (working) settings is working like a charm, which on my end vanished the terrain stuttering, maintaining a beautiful image.

Anyway, best to try and get things wrapped up correctly. Will adjust according to your tips and see, doesn't hurt to cut some gpu cycles. 🙂

 

curious to see if the OP got same results.

 

EDIT: after removing nVidia Inspector's settings as instructed, I was able to put my shadows on HIGH. Further tests shown that in my case the main culprit of the terrain stuttering is the grass quality, better not go above normal.

About the DSR, I've never been able to make it work better than native resolution + AA. In this particular case, I got 15% more GPU usage for no gain in image, so back to native res and 4x AA ingame. Happy camper. Thanks again for your tips.

il2settings.png

Edited by jokerBR

Share this post


Link to post
Share on other sites

Thanks guys for your valuable advice, I will try to mess around with these settings

Share this post


Link to post
Share on other sites
Posted (edited)

You're welcome @Startrek66, see my last edit in the post above yours (I was editing it the moment you replied). Test the grass settings first. Cheers.

Edited by jokerBR

Share this post


Link to post
Share on other sites

Hi guys, I tried these settings. 

I enclose two videos obtained with these settings for evaluation.  What do you think of fluidity?

 

 

 

IMG_20190818_003652.jpg

  • Like 1

Share this post


Link to post
Share on other sites

Hey, seems good to me. If you feel your system is responsive and smooth with shadows on high, then leave them there.

If you want to squeeze a little bit more room (just to be on the safe side when there are more players/objects/etc), try to lower them to medium. I've found that shadows have good impact on fluidity as well as grass.

Cheers.

Share this post


Link to post
Share on other sites
Posted (edited)
6 hours ago, jokerBR said:

Ehi, mi sembra buono. Se ritieni che il tuo sistema sia reattivo e fluido con le ombre in alto, lasciali lì.

Se vuoi spremere un po 'più di spazio (solo per essere al sicuro quando ci sono più giocatori / oggetti / ecc.), Prova ad abbassarli a medio. Ho scoperto che le ombre hanno un buon impatto sulla fluidità e sull'erba.

Saluti.

Hi jocker

I noticed that increasing the quality of the shadows solves a shadow problem around the trees.  Before the shadow was shaking it is now fixed.  I will try to lower to medium.  I also believe I have solved, but I'm not sure, the effect of seeing the trees rotate on themselves, when flying over them at low altitude in a circle.

Screenshot_20190818_100306.jpg

Screenshot_20190818_100436.jpg

Screenshot_20190818_100347.jpg

Edited by Startrek66

Share this post


Link to post
Share on other sites
Posted (edited)

Hi Startrek, the annoying rotating trees has been here since the RoF times. Never occurred to me that they could be solved through graphics settings, thinking they must be something more related to the code. Will try your settings disabling the filters like you've shown on your pictures and report back. Let's hope it work here too, as they are really distracting.

About the shadows, haven't seen them flickering on my end yet. Running on medium for a few weeks already, but it's good to know that high can cure it if this happens.

 

EDIT: Unfortunately, after doing the changes/tests, my trees are still rotating. 

Edited by jokerBR

Share this post


Link to post
Share on other sites
19 hours ago, jokerBR said:

Hi Startrek, the annoying rotating trees has been here since the RoF times. Never occurred to me that they could be solved through graphics settings, thinking they must be something more related to the code. Will try your settings disabling the filters like you've shown on your pictures and report back. Let's hope it work here too, as they are really distracting.

About the shadows, haven't seen them flickering on my end yet. Running on medium for a few weeks already, but it's good to know that high can cure it if this happens.

 

EDIT: Unfortunately, after doing the changes/tests, my trees are still rotating. 

You're right I checked myself and unfortunately the trees and continue to rotate but the shadows tremble less and then the shadow of the tree is more stable.

Share this post


Link to post
Share on other sites

Yesterday I did a practice session with this configuration.

I performed two quick missions and the ram used is about 1GB.  Subsequently I performed two missions of the career and the vram used is of around 1.4 Gb.  50 and 70 percent respectively of the available vram of 2gb of the gtx 1050.

The temperature of the GPU is around 50 degrees Celsius.  In my opinion this is a good starting point to eventually improve.  For completeness, the other data are CPU i5 2400 3.2ghz and 8gb of ram.

Screenshot_20190819_120822.jpg

Share this post


Link to post
Share on other sites

If you're playing stutter free, then this is the sweet spot. Enjoy. :salute:

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...