Jump to content

Recommended Posts

I tried to update my game and it failed.  reading the forums I tried the suggestions of backing up the startup.cfg file along with the Input directory and the lua scripts/snapview directory and then emptied and/or deleted the updates folder and then tried the Launcher.exe.

 

I got "failed to load the backend library" before anything else happened.

 

any suggestions?

  • Like 1

Share this post


Link to post
Share on other sites

Yesterday it "Failed to update". First time it got to around 98%, now it does nothing for three minutes before giving the failure message. 

Share this post


Link to post
Share on other sites
Posted (edited)

i had that, download stuck at 100%. Tried to start BoS, failure. Starting second time around it worked however. Lucky?

Edited by jollyjack

Share this post


Link to post
Share on other sites
Posted (edited)

I have the same problem. I uninstalled it, installed it again, but the graphics are broken. I have a 2560x1080 monitor resolution and an AMD RX 590.

Dude has IL2 on Steam, R9 290X FHD monitor and it works well

Edited by -CSM-KlaurungCZ

Share this post


Link to post
Share on other sites

Try deleting your games Update Folder in the games main directory, Program Files (x86) > 1CGameStudios>IL2BattleofMoscow , then update the game. I have done that and its now updating

  • Like 1
  • Upvote 2

Share this post


Link to post
Share on other sites
4 minutes ago, Spyboy said:

Try deleting your games Update Folder in the games main directory, Program Files (x86) > 1CGameStudios>IL2BattleofMoscow , then update the game. I have done that and its now updating

I have updated but the graphics are broken

Share this post


Link to post
Share on other sites

Sneaksie from the Developer Team wrote:-

If you have 'failed to update' message in the launcher (if you're using non-Steam version), please close it, navigate to the installation folder of the game and delete the folder called 'updates' and backup data/startup.cfg file (it contains your settings) and data/luascripts/snapviews folder if you altered the default camera positions for yourself. Then run the laucher again. Sorry for inconvenience!

Share this post


Link to post
Share on other sites

I"m trying to update all night, after "failed uupate" I've done fresh install BUT my Kaspersky antivirus deleted starter.exe and renamed .dll libraries, becasue "Suspicious behaviour" (?).

It looks like distro server is contamined!

Please give some attention to the issue!

 

Share this post


Link to post
Share on other sites
Posted (edited)

Failed update on two separate  computers at two different locations.....

Edited by SCG_Neun

Share this post


Link to post
Share on other sites

Just reinstalled completely (fresh install) on a comp previously scanned for viruses - launched as admin - lodaing failed after few seconds..somethoing must be very wrong ..

Share this post


Link to post
Share on other sites
Posted (edited)

IMHO Virusscanners that are not MS-native-builtin are only seldom really worth it.

I get more problems from Virusscanners then I get the benefit from claimed extra protection.

When I get into trouble with any application (installation) :

-  first disable all Virus scanner and/or AD blockers ...

- If that is no help then reboot PC and try again.

Edited by simfan2015

Share this post


Link to post
Share on other sites

After another downoload and complete reinstall it finally works -but I have to launch ti via restarter.exe, original launcher is somehow missing...

 

Share this post


Link to post
Share on other sites

today I got Steam login error:

 

#10027: Packet data verification failed.

Please restore original packed data files.

 

I tried verify integrity of game files via steam, but didn´t help.

 

 

Share this post


Link to post
Share on other sites
Posted (edited)
2 minutes ago, Brzi_Joe said:

today I got Steam login error:

 

#10027: Packet data verification failed.

Please restore original packed data files.

 

I tried verify integrity of game files via steam, but didn´t help.

 

 

 

Hey man, I have launched the game today, could play a bit. Then I changed some graphic settings and the game had to restart. After that I could not login anymore. I think this error is not caused by us it is on their end because I got the same error message on login.

Edited by Scheintot

Share this post


Link to post
Share on other sites

Yes, you are right. And I do not have other antivirus than from win10, so that is out of the question. Steam refuse to talk to game, something like that.

Share this post


Link to post
Share on other sites

I m NOT on a STEM and got the same "

#10027: Packet data verification failed.

Please restore original packed data files.

Still in dark land..

 

Share this post


Link to post
Share on other sites
Posted (edited)

I solved it, with file from Sneaksie; do as prescribed in his post, it works for steam version also:

 

 

Edited by Brzi_Joe

Share this post


Link to post
Share on other sites

Got the same error here and I just ran the launcher again and the game updated.

 

Share this post


Link to post
Share on other sites

I re-installed everything.  It only took one hour and now it works perfectly.  Thanks to all who helped.

  • Like 1

Share this post


Link to post
Share on other sites

I have tried evreything  all suggested, However if I attempt to update it hangs up and will no update at all/can not enter the game . AT DEAD END NOW 

 

WHAT A MESS .

  • Like 1

Share this post


Link to post
Share on other sites
39 minutes ago, vx111vx111swift said:

I have tried evreything  all suggested, However if I attempt to update it hangs up and will no update at all/can not enter the game . AT DEAD END NOW 

 

WHAT A MESS .

feeling your pain Years of trouble free updates  until  yesterday ! completely got rid of all files and new reinstall without luck . I'm done with it 

Share this post


Link to post
Share on other sites
11 minutes ago, Rekt said:

Did a complete reinstall...upon running the game, Kaspersky quarantined the launcher and some .dlls as "Adware".

 

 

I think I can "restore" it from Quarantine, but the real question is why did Kaspersky identify the launcher as adware...is it adware?

Kaspersky.JPG

 

Adware? Certainly not! It's a typical false positive which happens from time to time by virus protection software, and yes, even by those renown ones...

It is a bit nasty, but sure it will be fixed or someone already reported this to them. So, don't worry, mate.

  • Upvote 1

Share this post


Link to post
Share on other sites
Posted (edited)

I have tried two reinstalls but launcher shortcut warns that the file is no longer there. When looking for it and the other replacement tip from earlier post, they all seem to have been renamed with .backup extension - as are many other files. If I rename them to exe they still don't work. They seem to be referencing other miss-named files.

I have the non-steam install, and no trouble from my Kaspersky.

 

launcher.exe.backup

rofuplib64.dll.backup

rofuplib64.dll.update

 

Third install is a charm!

Delete all residual files after un-install and re-boot before new install. Got these error messages, but after forcing launcher to quit and restarting it it finally worked.

 

IL2_error_msg.jpg.5747a9471ab7f0826f2fc1c6cb0cc018.jpgIL2_error_msg2.jpg.af72f3d79312753bea2b0fabb2269c55.jpg

 

 

WTF?! I started game everything worked. The day after all the files have been renamed again!!!!!

 

IL2_error3.thumb.jpg.e71ef9c918108388849f5197da02c653.jpg

 

OK, now it seems it WAS Kaspersky after all, limiting setup and IL-2.exe to "yellow" status. I just didn't get a warning message but had to look manually.

 

 

 

Edited by GreenSocialist

Share this post


Link to post
Share on other sites

A broken launcher is unacceptable in payware.  I'm going to wait for the fix.

Share this post


Link to post
Share on other sites

With the last update your game files are no longer Battle of Stalingrad (Moscow or Kuban). Now the files are to Great Battles.

Delete your old desktop icons and go to > D:\Program Files (x86)\1C Game Studios\IL-2 Sturmovik Great Battles\bin\game and create new shortcuts for the launcher and exe.

Share this post


Link to post
Share on other sites

Why should anyone be required to install adware having already paid for this game and all the controllers to run it? Am I mistaken or is there a total silence on this concern?

Share this post


Link to post
Share on other sites
30 minutes ago, Dagwoodyt said:

Why should anyone be required to install adware having already paid for this game and all the controllers to run it? Am I mistaken or is there a total silence on this concern?

 

Wha......?:unsure:

Share this post


Link to post
Share on other sites
Posted (edited)

If you want the latest game version with its' new planes, tanks and improvements, one has to download said updates.

 

The game is a work in progress. It is not finished and continues to expand and improve. 

 

There is probably little comment on this because the vast majority of us understand the situation. 😑

Edited by Thad

Share this post


Link to post
Share on other sites
Posted (edited)

Early access = WIP

The rest is non responsive.

kasp0 Cpy.jpg

Edited by Dagwoodyt

Share this post


Link to post
Share on other sites
1 hour ago, Dagwoodyt said:

Early access = WIP

The rest is non responsive.

kasp0 Cpy.jpg

 

 

It's not adware. It's a game launcher, like many others. Antivirus programs aren't infallible.

 

For the record, I'm running Kaspersky too, and it's not detecting my launcher as adware.

Share this post


Link to post
Share on other sites

Does anybody else notice the "Add to exclusions" selection box?

 

I wonder..... could that work? Makes one think doesn't it?   :coffee:

Share this post


Link to post
Share on other sites
Posted (edited)

Having the same problem with Kaspersky. I'm not getting any options, just deleting the launcher

Edited by 3uster3oo
more info
  • Upvote 1

Share this post


Link to post
Share on other sites
Posted (edited)

There should ALWAYS be an option to refuse adware/“riskware”. If not then the game is essentially held hostage. I think it is likely a mistake to assume that Kaspersky is mis-identifying the launcher as adware. Of concern is that the “adware” is an obligatory attachment to the launcher.

“Add to exclusions” seems to be the equivalent of “allow”, thus a distinction without a difference. Once the adware is allowed by the customer there is no way to know what it might do inside an operating system as time passes. I have been using both Il2 and Kaspersky for years now and have never before been forced to make such a choice. 

Edited by Dagwoodyt

Share this post


Link to post
Share on other sites

I see.  So no adware at all.:rolleyes:   

Share this post


Link to post
Share on other sites
57 minutes ago, DD_Arthur said:

I see.  So no adware at all.:rolleyes:   

it added a couple of new planes...

Share this post


Link to post
Share on other sites

When you launch the launcher, it will show the latest IL-2 news updates (right now, it will show Dev Blog 227 and also the Update 3.102). That's what (most likely) triggers the adware waring, which i'm also getting on Kaspersky btw.

 

The default setting on Kasperky is to automatically delete the file that's suspicious (even adware), so if you're using that setting (which i don't use, but Kasperky recommends), then it will be a problem to launch Il-2 and you'll not get the option to "allow" the launch yourself.

Share this post


Link to post
Share on other sites

Detected: not-a-virus:PDM:AdWare.NSIS.ConvertAd.bcb

 

I have no idea what this program does, if not what the title describes. None of the planes are "freebies". Everything received has been paid for in advance. If the planes were provided free on condition of accepting adware that would be a choice that  the recipient would need to make. It is a totally different situation "if" the customer must accept adware/riskware in order to access content already purchased.

Share this post


Link to post
Share on other sites

This update is a mess, totally messed up my game!! First, i contacted support because the update kept failing...then I followed their advise, removed everything from the updates folder, and it successfully updated, but as soon as I launched the game, it crashed and my launch.exe disappeared, could no longer even start the game, so out of frustration I ended up doing a system restore back a few days before the update. Now my game has a "Play" button without doing an update, but I STILL can't play the game because when I get to the login stage, I now get this nonsense (see screenshot) then I noticed I no longer have an updates folder. This is a complete mess, I don't think there's a way to do a manual update... I'm wondering if we have to do a completely fresh re-install... this is not good!!!!!

il2.JPG

Share this post


Link to post
Share on other sites

If you do have to do a complete reinstall be sure to save your key settings folder before you delete the game.  Then after the new install put the saved folder back, hit rewrite to everything and then you won't have to do all those key bindings again!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...