Jump to content
Sign in to follow this  
Finkeren

IL-2.exe going missing???

Recommended Posts

Since the last update, I have had a very odd issue pop up three times now. The game application itself, IL-2.exe, suddenly goes missing, suddenly it is simply not in the game directory anymore! Consequently, when I try to launch the game via the launcher, a long error text pops up and the launcher closes down shortly thereafter.

 

First time I encountered this issue, I was able to fix it simply by inserting a copy of the .exe file given to me by another player into the /game folder. Then a couple days later, the same issue pops up again, no .exe file to be found. This time I was completely unable to copy the .exe file into the /game folder, even when running as administrator (windows telling me, that I didn't have permission to do this). I then went and did a complete reinstall, because obviously something was very wrong. It worked fine for a day, but now all of a sudden the .exe file is missing again and again I am denied, when I try to insert a copy of the file into the directory.

 

Any suggestions as to what causes this? I never had any issue like that before the last update. 

Share this post


Link to post
Share on other sites

Check your disk somehow. And use mini program "Take ownership" to set read write permissions (usually that should be avoided, but in yours case may be cure).

Share this post


Link to post
Share on other sites
3 minutes ago, Brzi_Joe said:

Check your disk somehow. And use mini program "Take ownership" to set read write permissions (usually that should be avoided, but in yours case may be cure).

 

I have done a disk search, the file is not there, and I actually have "taken ownership" of the folders and sub-folders through the security settings (even though as administrator it shouldn't be necessary)

 

Also, I wonder how I get the file to stop disappearing, not just how I can replace it.

Share this post


Link to post
Share on other sites

Check disk for errors, bad sectors, or similar. Is it too hot?

Share this post


Link to post
Share on other sites

Nope, everything normal it seems. The hard drive functions perfectly as it should, and it's only that specific file that keeps disappearing.

Share this post


Link to post
Share on other sites
3 minutes ago, namhee2 said:

System recovery, also very useful

 

Seems a bit extreme, since everything else seems to be working alright. 

Share this post


Link to post
Share on other sites

Reset your PC before the problem has occurred and then secure your IL2 exe

Share this post


Link to post
Share on other sites

Antivirus software deciding it doesn't like it, and sending it to quarantine?

  • Upvote 1

Share this post


Link to post
Share on other sites
9 minutes ago, AndyJWest said:

Antivirus software deciding it doesn't like it, and sending it to quarantine?

 

That was it! Stupid AVG! Thanks a bunch.

 

Now I just have to figure out, how the hell I get it out of quarantine. When I try to restore the file, it simply displays a message, that the file can't be restored. Probably something to do with the game directory being hard locked in "read only" mode. Something I can't seem to change, despite running as administrator, taking ownership of the folders and subfolders etc. Whenever I try to alter the security settings for that directory, it immediately reverts back, and for the love of me I can't figure out how to make the change permanent. Online instructions have been no help at all.

Share this post


Link to post
Share on other sites

Best to Install IL-2 somewhere not in program files, 

 

This will stop the read only issue that Windows can sometimes force

 

Cheers, Dakpilot 

  • Like 1

Share this post


Link to post
Share on other sites

As Dakpilot says, and NEVER plce games in the "C:\program files" folder as it´s a sacred M$ scrine that has a nasty habit of denying the user of full access!

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

I will try that. Thanks guys. 

Share this post


Link to post
Share on other sites

Hey, it worked! So it really was just Windows being an ass the whole time (helped along by AVG initially)

 

Thanks a lot people.

Share this post


Link to post
Share on other sites
On 7/7/2019 at 9:10 AM, FlyingH said:

............NEVER plce games in the "C:\program files" folder...........

 

Thanks for the advice. I've heard this before, but as I've never had any problems with having Il2 located in my 'Program Files (x86)' folder, where it was installed by default, I've just left it there. Finkeren's problem makes me think it may be time to follow this advice.  

If I move it, eg to a 'Games' folder, will future updates be able to find the new location?

Also, it'll be easy to place a new quick-launch icon on my desktop, but will the game-installed 'launcher' icon still work?

Share this post


Link to post
Share on other sites
1 hour ago, jaygee485 said:

 

 

If I move it, eg to a 'Games' folder, will future updates be able to find the new location?

Also, it'll be easy to place a new quick-launch icon on my desktop, but will the game-installed 'launcher' icon still work?

Just create new shortcuts to both exe's and updates will be fine.

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...