Jump to content
fogpipe

Just got a steam update and hoping against hope...

Recommended Posts

But it still stutters. Just enough to let you know that you are playing a game.

 

Its no good being able to run a game at 120 frames per second at 2560x1440 if it wont run smoothly even at 1600x1050 and 60 frames per second.

 

You guys need to work on porting this game to an engine that can drop frames smoothly and load and unload textures smoothly the way other modern games do. This is the only flight game i play that refuses to run smoothly at any decent level of detail or resolution.

 

While i have tweaked the worst of the stutters out, its still just bad enough to ruin any sense of immersion i might get out of it.

 

First stutter free il2 update i get, i will buy more 1c products.

Share this post


Link to post
Share on other sites

What kind of specs do you have, and what settings are you using? There was a thread on settings to avoid the microstutters people started getting after the 3.0 update.
 


I follow some of these settings, more or less, and I don't get much in the way of stutters on a mid-range rig on High settings.

Share this post


Link to post
Share on other sites
Posted (edited)
8 minutes ago, RedKestrel said:

What kind of specs do you have, and what settings are you using? There was a thread on settings to avoid the microstutters people started getting after the 3.0 update.
 


I follow some of these settings, more or less, and I don't get much in the way of stutters on a mid-range rig on High settings.

I have read it all and tried it all. Its the only game i can run on medium graphics settings at 1600x1050 at 150 fps (fast vsync) and still get stutters.

I have a gforce 1060 an i7 8700 and 16 gigs of ram an a good chunk of a 125 gb ssd is devoted to il2 and it still doesnt run as smoothly as i would expect a modern game to.

I spend more time trying to tweak the damn thing into running acceptably that i do actually playing the game, so im somewhat averse to even starting it up and certainly dont want to spend anymore time tweaking it.

Edited by fogpipe

Share this post


Link to post
Share on other sites

I ran stutter free on my old i5 2500k, GeForce 970. I upgraded everything when I got the 4K monitor (Ryzen 2700 and 1080 now) and still only notice some micro-stutter on Kuban - steady 60fps most of the time.

Share this post


Link to post
Share on other sites

I have never had any stutters at any point in the games history. Worst thing I experienced was screen tearing in full screen even though gsync was on. Couldn't explain it. 

 

If you could possibly try to uninstall the steam version and download the official launcher and run it from that to see if there is a difference? 

 

Clod with the older TF patch (not blitz) used to run fine but now for some reason my UI is completely bugged and my fps is terrible. Having to go through steam just killed it I guess. 

Share this post


Link to post
Share on other sites
19 minutes ago, fogpipe said:

I have read it all and tried it all. Its the only game i can run on medium graphics settings at 1600x1050 at 150 fps (fast vsync) and still get stutters.

I have a gforce 1060 an i7 8700 and 16 gigs of ram an a good chunk of a 125 gb ssd is devoted to il2 and it still doesnt run as smoothly as i would expect a modern game to.

I spend more time trying to tweak the damn thing into running acceptably that i do actually playing the game, so im somewhat averse to even starting it up and certainly dont want to spend anymore time tweaking it.

I have a 1060 gtx 6gb, i7 7700k and 16 gb of ram...

 

Pretty close to what you have, I have no micro stutters at all running in 1080p (running ultra settings)...  Might make sure your HDD isn't failing, or perhaps your page file is causing you issues.

 

Could try disabling the page file in windows, or even make sure you don't have any background programs running...

Share this post


Link to post
Share on other sites

Try the one stop shop for all stutter problems @fogpipe
 



Also disabling landscape filter/ssao/hdr/vsync and setting the game to balance/low will yield the quickest performance increase. 

  • Upvote 1

Share this post


Link to post
Share on other sites
18 minutes ago, fogpipe said:

I have read it all and tried it all. Its the only game i can run on medium graphics settings at 1600x1050 at 150 fps (fast vsync) and still get stutters.

I have a gforce 1060 an i7 8700 and 16 gigs of ram an a good chunk of a 125 gb ssd is devoted to il2 and it still doesnt run as smoothly as i would expect a modern game to.

I spend more time trying to tweak the damn thing into running acceptably that i do actually playing the game, so im somewhat averse to even starting it up and certainly dont want to spend anymore time tweaking it.

We have the same video card and your processor is leaps and bounds ahead of mine (I have an i5 4400 or something like that...) and I only have 8gb of RAM. I don't use steam, maybe there is an issue there? 

I'm not saying I don't get any stutters but no more than maybe a couple times a flight when there's a lot of stuff going on. Nothing game breaking.

Share this post


Link to post
Share on other sites
Posted (edited)

I am not sure if this will help, but i have a similar problem. My specs are fine for IL2 and i get easily 60+ FPS, but the thing is, if i turn off VSYNC i will encounter screen tearing, which is not really a surprise, but if i enable VSYNC i encounter micro stutters, even though the FPS never drop below 60 FPS or so...

For me it is better to play with VSYNC off and live with the screen tearing artifacts, which is annoying but not as much as the micro stutters. I have tried many different settings etc. but couldn't fix it til now.

 

Do you experience the same when you turn off VSYNC?

Edited by dukovac
typo

Share this post


Link to post
Share on other sites
3 minutes ago, dukovac said:

I am not sure if this will help, but i have a similar problem. My specs are fine for IL2 and i get easily 60+ FPS, but the thing is, if i turn off VSYNC i will encounter screen tearing, which is not really a surprise, but if i enable VSYNC i encounter micro stutters, even though the FPS never drop below 60 FPS or so...

For me it is better to play with VSYNC off and live with the screen tearing artifacts, which is annoying but not as much as the micro stutters. I have tried many different settings etc. but couldn't fix it til now.

 

Do you experience the same when you turn off VSYNC?

Apparently the screen tearing can be affected by teh senstivity of the camera movement and TrackIR settings. Geronimos thread above has stuff about that. I haven't tried it myself but if you can avoid screen tearing without Vsync I would think that would improve performance quite a bit.

  • Upvote 1

Share this post


Link to post
Share on other sites
Just now, RedKestrel said:

Apparently the screen tearing can be affected by teh senstivity of the camera movement and TrackIR settings. Geronimos thread above has stuff about that. I haven't tried it myself but if you can avoid screen tearing without Vsync I would think that would improve performance quite a bit.

 

I don't have IR, but i will try to play around with the sensitivity of the camera movement. And just for the record, the performance of IL2 is no problem at all, it's just a little bit annoying but nothing close to game breaking.

Share this post


Link to post
Share on other sites

I can also note that the game overly leans on graphics card performance for frame rate. Ram and CPU do very little in this game. Which is a huge waste of possible performance. I hope the devs improve on this aspect sooner than later.

  • Haha 4

Share this post


Link to post
Share on other sites
2 hours ago, Geronimo553 said:

Ram and CPU do very little in this game

 

Oh, yes they do.

  • Like 1
  • Haha 1
  • Confused 1
  • Upvote 1

Share this post


Link to post
Share on other sites
On 6/6/2019 at 1:32 PM, Gambit21 said:

I ran stutter free on my old i5 2500k, GeForce 970. I upgraded everything when I got the 4K monitor (Ryzen 2700 and 1080 now) and still only notice some micro-stutter on Kuban - steady 60fps most of the time.

 

Have you noticed any improvement since the recent windows update that fixed the scheduler for ryzen?

Share this post


Link to post
Share on other sites
On 6/15/2019 at 3:47 PM, LizLemon said:

 

Have you noticed any improvement since the recent windows update that fixed the scheduler for ryzen?

 

I was getting 60 fps with the 4K monitor pretty steady before, (except on the airfield) so I probably wouldn't notice. 

In order to have noticed something like that I'd have to have been aware that the update was coming, and done some airfield testing just before, and just after.

I've also been taking a bit of a break in anticipation of getting to work on the next campaign.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...