Jump to content
Sign in to follow this  
spudkopf

Bf109K4 official 4k Skins historically corrected (updated PM 08/04/19)

Recommended Posts

Posted (edited)

UPDATE 18:25 AU time 08/04/2019 - Don't quite know what's going on with some of the uploads, seems to be some kind of cashing issue that prevents me re-uploading the failed uploads, even when trashed it treating the new upload the same as it is replacing, the fact that it uploads in seconds is a dead giveaway.

 

So like with the 05 skin for the Fw190D9, I have had to resort to substituting zipped versions of the affected files instead. As such bf109k4_skin_01 and bf109k4_skin_08 should now be good to go, but let do me know if there are any problems.

 

By the way has anybody else had familiar kind of problem with Mediafire?

 

G'day 

 

Was meant to be doing other things, but did these instead.

 

Pictured below is my previously released Default 4K K4 skin (K4 skin, that always makes me giggle), I have re-linked it in the following links for use as the game default, naturally the file will need to be renamed to "bf109k4.dds" in order for it to replace the existing default in the planes directory.

 

Spoiler

3.thumb.jpg.2a63612d185a5d02a0df9880b481a4ef.jpg


Default (replaced on 10/04/19, please contact me if there are further downloading issues, now does not require renaming)

bf109k4_skin_01 (replaced on 10/04/19, please contact me if there are further downloading issues)

bf109k4_skin_02

bf109k4_skin_03

bf109k4_skin_04

bf109k4_skin_05

bf109k4_skin_06

bf109k4_skin_07

bf109k4_skin_08 (replaced on 10/04/19, please contact me if there are further downloading issues) (link to zipped file)

bf109k4_skin_09

bf109k4_skin_10

 

After yesterdays shenanigans, can the usual suspects let me know if their are any download issues.

 

 

Oh and remember to enable MODs in the Game - Setup!!

 

1200860669_enablemos.JPG.0c52e71c214782936e56cda4a5032823.JPG

 

As always enjoy.

 

Edited by spudkopf
fixed links
  • Like 2
  • Thanks 5

Share this post


Link to post
Share on other sites

Hi Spudkof ;)...Thanks for your works :good:...Problem of download with skins 01 and 08...:(

  • Thanks 1

Share this post


Link to post
Share on other sites

Hi Spudkopf,

 

only problems here is skin 8.

 

The others had no issues for me!

  • Like 1

Share this post


Link to post
Share on other sites
10 hours ago, Swing said:

Hi Spudkof ;)...Thanks for your works :good:...Problem of download with skins 01 and 08...:(

 

2 hours ago, Yankee_One said:

Hi Spudkopf,

 

only problems here is skin 8.

 

The others had no issues for me!

 

OK to play it safe both 01 and 08 have been replaced by zipped files.

 

Enjoy

 

 

  • Thanks 2

Share this post


Link to post
Share on other sites

Hey Spudkopf, thanks a lot for updating all those skins. However there is an issue with skins 06 &10. When I wanted to apply those skins when I selected them, they showed a default template without any number or Haken. Hope you can help.

 

Cheers

Share this post


Link to post
Share on other sites
Posted (edited)

Skin downloaded.

 

Everything is ok works fine!

Edited by Yankee_One

Share this post


Link to post
Share on other sites

Working fine here, I down loaded earlier with no problems.

Do remember to shut down the viewer after you have installed the skins as sometimes it will show the standard skin even if you have put the Haken version into it.

Once you reopen the viewer it will show the haken version.

Share this post


Link to post
Share on other sites

I just re-downloaded both skins and added them into the skins folder but somehow when I select these textures the game won't recognize and apply them ... All others work fine just skin 6 & 10 won't for some odd reason.

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, GucciGang_Gold_Leader said:

I just re-downloaded both skins and added them into the skins folder but somehow when I select these textures the game won't recognize and apply them ... All others work fine just skin 6 & 10 won't for some odd reason.

 

 

Well just to see for myself, I just down downloaded both skins 06 and 10 and put them into \IL-2 Sturmovik Battle of Stalingrad\data\graphics\skins\bf109k4\ and...............

 

Bf109k4_skin_06 (listed as "White 5" in the selection screen)

 

Spoiler

185152096_skin06white5.thumb.jpg.6cf66f84c85cfced2eba10648e0454b8.jpg

 

Bf109k4_skin_10 (listed as "White 6" in the selection screen)

 

Spoiler

412840607_skin10white6.thumb.jpg.f9c9f780bd8d972fff199834054812ef.jpg

 

So sorry I'm not sure what's up with them not working for you?

Edited by spudkopf

Share this post


Link to post
Share on other sites
Posted (edited)
12 hours ago, spudkopf said:

 

 

Well just to see for myself, I just down downloaded both skins 06 and 10 and put them into \IL-2 Sturmovik Battle of Stalingrad\data\graphics\skins\bf109k4\ and...............

 

Bf109k4_skin_06 (listed as "White 5" in the selection screen)

 

  Hide contents

185152096_skin06white5.thumb.jpg.6cf66f84c85cfced2eba10648e0454b8.jpg

 

Bf109k4_skin_10 (listed as "White 6" in the selection screen)

 

  Hide contents

412840607_skin10white6.thumb.jpg.f9c9f780bd8d972fff199834054812ef.jpg

 

So sorry I'm not sure what's up with them not working for you?

 

 

Yes, that's what it's supposed to look like but somehow all I get is this

 

20190409142830_1.thumb.jpg.4e6da25aa482ccdcdcc08835a35bc9f7.jpg

 

It's so weird and the first time it's ever happened to me..

Edited by GucciGang_Gold_Leader
some additional information

Share this post


Link to post
Share on other sites

I'm having the same problem with the White 6 skin as GuccuGang. Also with the default skin even with the rename done. Like Gucci I've never come across this problem before either. Odd that all the other skins the haken shows up fine.

Follow-up: My apologies Spudkopf. I had failed to download the White 6 skin. It works! I've probably done something wrong on renaming the default skin too. Thank you for providing us with these historical skin fixes.

Share this post


Link to post
Share on other sites
8 hours ago, GucciGang_Gold_Leader said:

 

 

Yes, that's what it's supposed to look like but somehow all I get is this

 

20190409142830_1.thumb.jpg.4e6da25aa482ccdcdcc08835a35bc9f7.jpg

 

It's so weird and the first time it's ever happened to me..

 

Gucci that looks like the default skin.......

 

1 hour ago, trek said:

I'm having the same problem with the White 6 skin as GuccuGang. Also with the default skin even with the rename done. Like Gucci I've never come across this problem before either. Odd that all the other skins the haken shows up fine.

Follow-up: My apologies Spudkopf. I had failed to download the White 6 skin. It works! I've probably done something wrong on renaming the default skin too. Thank you for providing us with these historical skin fixes.

 

So just a thought, are you both sure you are placing the default skin into the correct place, remembering that the defaults live in different directory all together:

 

Default Skin = \1C Game Studios\IL-2 Sturmovik Battle of Stalingrad\data\graphics\Planes\Bf109K4\Textures\Bf109K4.dds

 

Share this post


Link to post
Share on other sites

Follow-up: My apologies Spudkopf. I had failed to download the White 6 skin. It works! I've probably done something wrong on renaming the default skin too. Thank you for providing us with these historical skin fixes.

Thanks again Spudkopf. Yes I was putting the default skin in the wrong place. Obviously, I have my stupid cap on today. I think I will remove it now as I've done enough damage for one day.

  • Haha 1

Share this post


Link to post
Share on other sites

Just updated the links for the default skin (will no longer require renaming) a also for skins 01 & 08 (these are no longer zips), as usual please let me know if there are any download issues..

 

Cheers

Share this post


Link to post
Share on other sites

I haven't put the skins into the default skin folder, but into the folder for additional skins:

 

\1C Game Studios\IL-2 Sturmovik Battle of Stalingrad\data\graphics\Skins\Bf109K4\

Share this post


Link to post
Share on other sites
6 hours ago, GucciGang_Gold_Leader said:

I haven't put the skins into the default skin folder, but into the folder for additional skins:

 

\1C Game Studios\IL-2 Sturmovik Battle of Stalingrad\data\graphics\Skins\Bf109K4\

 

All quite strange, so can you go into the skin viewer and in the dropdown can you see all the names and more specifically the names White 5 and White 6, which are skins 06 and 10 display names?

 

Next thing to do would be to delete my 06 and 10 skins from the skins directory and see if it reverts back to using the faux haken versions of White 5 and White 6 and not the game default (the one you have in your screen shot).

Share this post


Link to post
Share on other sites
11 hours ago, spudkopf said:

 

All quite strange, so can you go into the skin viewer and in the dropdown can you see all the names and more specifically the names White 5 and White 6, which are skins 06 and 10 display names?

 

Next thing to do would be to delete my 06 and 10 skins from the skins directory and see if it reverts back to using the faux haken versions of White 5 and White 6 and not the game default (the one you have in your screen shot).

In my first attempt I have renamed all skins to: Default_Weiße 5 and Default_Weiße 6 respectively (I've done the same thing with your D9 skins and all other K4 skins and there everything worked perfectly) so I can relate which skin is which. Once I start a mission then go to Aircraft configuration to see the skin in the hangar (since you can't view third party skins in preview) and there it was listed but the skin would not apply.

In my second attempt I re-downloaded the skins and added them into the skins folder without renaming them and they would NOT show up in the list of skins for some odd reason.

Share this post


Link to post
Share on other sites
Posted (edited)

Ok the display names like white 6, etc are what the game GUI uses to ID the skins, you do not need to change the file names and leave them as Bf109k4 _skin_01 etc, as these are what the original game embedded versions are named, by placing these new files into the skins directory the game should ignore the skins embedded in the gtp (game) files, and use the new ones instead. "There is no need to rename the files"

 

So with no other skins in the directory it should look like this:

 

805758613_k4dir.jpg.7131e4c76d5346e4ffa4e2e18caf5a48.jpg

 

As can be seen in the spoiler below the displays names are not the same as the file names.

 

Spoiler

1929200668_k4name.thumb.jpg.936b094ee06886b193e100922c44e47e.jpg

 

You also need to load the skin from the Offical skins drop down menu and NOT the custom skins drop down menu, the thumbnails will still have a faux haken but the loaded skin will have a historical haken.

 

gui.thumb.jpg.40f3ca453da9383cf1d8e932799181fb.jpg

 

Edited by spudkopf

Share this post


Link to post
Share on other sites

That is exactly what I did now. I removed other skins I had for the K4 out of the folder and just put those skins into the skins folder (re-downloaded now and haven't renamed them).

However when I want to select third party skins on the K4 NO skins are being listed anymore. Skins 1-10 do not show up on the list anymore. "Benutzerdefinierte" stands for customized skins.

Screenshot (63).png

20190411123454_1.jpg

And this is what it looks like when I put back all my other skins for the K4 including your skins (the one you uploaded for the first time and I renamed them). All of them work perfectly.

Spoiler

20190411124903_1.thumb.jpg.93410cc07febe0acb2067d5e0788edeb.jpg

 

Share this post


Link to post
Share on other sites
Posted (edited)

Benutzerdefinierte is the Custom skin menu the skins Sind nicht da (are not there), you need to select them from the Offiziell menu as these skins replace the official ones.

 

Just select Weiße 6 from menu with all the Miniaturbilder (thumbnails images) and once in game you should see a haken. 

 

The English skin menu selections are Official and Custom 

 

My wife is a German speaker, but is out at the moment if you are still having problems I can get her to translate and PM you.

Edited by spudkopf

Share this post


Link to post
Share on other sites
Just now, spudkopf said:

Benutzerdefinierte is the Custom skin menu the skins Sind nicht da (are not there), you need to select them from the Offiziell menu as these skins replace the official ones.

 

Just select Weiße 6 from menu with all the Miniaturbilder (thumbnails images) and once in game you should see a haken. 

 

The English skin menu selections are Official and Custom 

 

My wife is a German speaker, but is out at the moment if you are still having problems I can get her to translate and PM you.

I'm not having issues with translations. I'm a native speaker btw :P

 

I just tried what you just told me now but it still does NOT want to work. I selected them from the official skin as you said but still not Haken :(

20190411125707_1.jpg

20190411125723_1.jpg

Share this post


Link to post
Share on other sites

Scheisse!

 

Sorry just assumed as you had the DE version that my instructions may be getting lost in translation , I did not even know that you could select skins from that screen, so just to make sure I just selected White 6 and it worked fine, so now I have know idea why it does not work for you.

 

I see that you are on a steam version, do you know if your is on the latest build, my version is not a steam version so mine is always on the current build.

 

Only other thing I can think of at this point is that when put skins into a directory, you must restart the game before you can see them as the game cashes all the skins into memory at startup or something like that, it's a real pain when you are doing minor tweaks to a skin and have to restart each time you want to see them. By the way what are you seeing in the bos viewer, Viewer.exe

Share this post


Link to post
Share on other sites
Posted (edited)

Damn now I know why it didn't work for me as you described. It's because I haven't enabled mods for the game in the settings !! The way you described on how to select those skins got me thinking and voilà it works just as you told me !!

20190411131847_1.jpg

Edited by GucciGang_Gold_Leader

Share this post


Link to post
Share on other sites

Cool!

Share this post


Link to post
Share on other sites

Thanks a LOT Spudkopf for your continuous help and support in solving this issue !! When I come back to Australia I wanna buy you a beer 🍺

 

But now since mods are enabled ... Does anyone know how to stop this annoying pop up message from showing up whenever I launch the game ? haha

20190411134819_1.jpg

Share this post


Link to post
Share on other sites

🍺 idea sounds excellent!

 

As to the popup it is our guilty reminder that we are straying to the dark side, and sadly can't be got rid of.

 

Wife is Swiss and has several German relies, so where about's are you at the moment?

 

 

Share this post


Link to post
Share on other sites

 

1 hour ago, spudkopf said:

🍺 idea sounds excellent!

 

As to the popup it is our guilty reminder that we are straying to the dark side, and sadly can't be got rid of.

 

Wife is Swiss and has several German relies, so where about's are you at the moment?

 

 

 

As of now I am in Aachen, Germany studying aerospace engineering and used to live in Sydney, Manly

Share this post


Link to post
Share on other sites

Mexican myself, currently living in Melbourne, but in the process of moving a little further east into country Victoria.

 

Aachen or more accurately Merzbrück Airfield will be more or less central on upcoming Bodenplatte map, which I'd think should be somewhat of a novelty for you! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...