Jump to content
Popsschubert4

IL-2 1946 loading problem

Recommended Posts

I bought the IL-1946 disc a few years ago when it first came out. Now, with my Windows 10, I cannot load it onto my computer. I get a message "This version of DirectX is not compatible with the version of Windows."  Is there any way around this?

Share this post


Link to post
Share on other sites

Thread revived as my problem is apparently trying to load IL-2 1946 with W10. It starts loading but at 50% it stops every single time.

 

Searches prove futile as recommended fixes are all over the place.

 

So in this day and age without having another computer available that is 10-15 years out of date is there any way to have it fully load and start?

Share this post


Link to post
Share on other sites
Posted (edited)

I think something has changed very recently in Win10 lately. It ran fine on my old Win10 PC, but I'm having the same issue on my new PC - hanging at 50%. If I figure out a fix, I'll post it here, though it's not a priority for me right now, as I hardly play '46 any more. Would be nice to get it running though...

 

Edit: seem to have got it running now, though I've not tested it properly - il2fb.exe needs to be set to run as administrator (which from memory was always advised anyway). Also, don't install in your Program Files or Program Files (x86) folders, as (with a lot of games) this can cause issues too.

 

If you are still having problems, you may do better to ask for help on the  'old' IL-2 1C Games forum, rather than here:

http://forum.1cpublishing.eu/forumdisplay.php?s=84fd8740e721e6c5a359d09c6a225698&f=98

Edited by AndyJWest
  • Upvote 1

Share this post


Link to post
Share on other sites
13 hours ago, AndyJWest said:

I think something has changed very recently in Win10 lately. It ran fine on my old Win10 PC, but I'm having the same issue on my new PC - hanging at 50%. If I figure out a fix, I'll post it here, though it's not a priority for me right now, as I hardly play '46 any more. Would be nice to get it running though...

 

Edit: seem to have got it running now, though I've not tested it properly - il2fb.exe needs to be set to run as administrator (which from memory was always advised anyway). Also, don't install in your Program Files or Program Files (x86) folders, as (with a lot of games) this can cause issues too.

 

If you are still having problems, you may do better to ask for help on the  'old' IL-2 1C Games forum, rather than here:

http://forum.1cpublishing.eu/forumdisplay.php?s=84fd8740e721e6c5a359d09c6a225698&f=98


Thank you sir! Going to check for admin rights. All my games are installed on their own partition luckily. Learned about dreaded (x86) problems long ago. Yeah, just posted here as a shot in the dark but thanks! I’ll go over the exe. file to make sure.

Share this post


Link to post
Share on other sites

It's not hanging up, it's just going to take a really long time to load.  It happens at 50% and again at 70%.  It's because your current display is connected via display port.  You can find a mod here: https://www.sas1946.com/main/index.php/topic,57243.msg632638.html#msg632638

 

This will fix the issue.  I had the same problem.  This took care of it for me.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...