Jump to content
SeaW0lf

Severe lag / stutter (?) with Windows 10 in multiplayer.

Recommended Posts

On 4/1/2019 at 5:51 AM, SAS_Storebror said:

This however might be interesting, GN illustrates a CPU related frame spike issue on the 9600K:

 

 

 

On the case of BOX I don't think it should be relevant, because he says the game is "asking for more cores / or threads in some instances", hence the spikes. BOX runs fine in a quad core and does not use hyper threading. I did not watch the whole video, but it seems to be a core / thread count thing in some games. Perhaps in VR an i7-9700K would be more advisable, but I know nothing about VR.

 

By the way, yesterday I played for some time on Berloga and JG1 and the problem seems to be really solved on my end. Whoever has M.2 SSDs, check if you have the original driver, not the Microsoft one. A firmware update, if available, is advised as well (I usually do it ASAP).

Share this post


Link to post
Share on other sites

Note however that an M.2 SSD doesn't necessarily come with a driver.

My Crucial MX500 for instance, even if it's the M.2 version, doesn't have any driver: https://eu.crucial.com/eur/en/support-ssd-mx500

In such case you're stuck with the Microsoft driver.

And to be honest, I haven't seen many SSDs with specific drivers in the wild yet...

The only driver update being related I could think of was the controller of the SSD.

In my particular case, the SATA AHCI controller can either have a standard Microsoft Driver, or the Intel Rapid Storage one.

 

:drinks:

Mike

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Yes, I correct myself. I was talking generally. People should check if their storage devices have a factory driver for Windows 10, not from Microsoft. Heck, I'm not even sure if this is the case with Windows 7 for some brands.

Edited by SeaW0lf

Share this post


Link to post
Share on other sites

Unfortunately I played today at JG1 and the stutters are back with a vengeance:dash: Berloga as well. IIRC, yesterday I tested both servers around the same time and they were fine. I have to play over the week to perhaps identify a pattern?

 

Damn... Yesterday was a day of relief. Short lived. This really spoils multiplayer / big time. If I could only go back to my Windows 7 and i7-3770K... Unfortunately some things move on and it will be not supported anymore in 2020. I also have to keep with the market.

Share this post


Link to post
Share on other sites

So I stand corrected concerning the network thing.

Yesterday we've been flying online again, stuttering occured at the same occasions as before (crowded airfield, furball) but this time I have it in the recording as well.

This is me flying through a furball with 13 planes involved: 2 Player fighters, 8 AI fighters, 3 AI bombers (Peshkas).

I guess the issue is quite obvious.

Meanwhile I've also tried to uninstall the Intel Rapid Storage Driver (using Microsoft Standard AHCI instead) and manually setting the PCIe slot version to 3.0, each to no avail.

I've also tried lowering settings, like shadows high->medium, landscape filter blurred->off, landscape distance 130->70km, grass ultra->distant, SSAO off, all of them together - no difference concerning these stutters.FPS is rock solid at 90 as you can see, that's because I've limited it to that value (that was for testing purpose, I've had it uncapped before with the same result).

Both CPU and GPU temps are fine.

GPU usage is at it's limit, but it has been like that on my old system on 3.011 as well, without these stutters.

I'm lost with this, running out or ideas what to try next.

 

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, SAS_Storebror said:

I'm lost with this, running out or ideas what to try next.

On 3/31/2019 at 4:06 PM, SAS_Storebror said:

Accidentally the upgrade falls in the same timeframe as the latest BoX update and for the moment, I chalk the stutters on something that got messed up in 3.012 and not on my end.

Maybe something related to Natural Point software? Just by analogy, in Il-2 TrackIR is known to pick up inputs from other data sources such as FFB, a problem I don't seem to have with OpenTrack+budget hardware.

Share this post


Link to post
Share on other sites

Not saying that it's impossible, but I strongly doubt that it's TrackIR related.

TrackIR is one of the things that didn't change, it was working stutter-free before.

Add to that, the stuttering isn't necessarily induced by moving the head.

In the short clip I've posted above, you can see that rolling the plane makes the horizon etc. stutter severely.

Last but not least, almost all stutter is gone as soon as I switch to external view. Back inside the cockpit, stutter is back.

 

:drinks:

Mike

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, SAS_Storebror said:

Last but not least, almost all stutter is gone as soon as I switch to external view. Back inside the cockpit, stutter is back.

That's why I inferred that the stuttering might be viewpoint/TrackIR related. I don't say it's TrackIR itself, but TrackIR implementation in Il-2 has some quirks, hence my reference to the FFB issue. Anyway, switch off TrackIR and see if the horizon still stutters when you roll. If it does, you ruled TrackIR out.

Share this post


Link to post
Share on other sites

Okay, I will give it a try.

Just to be on the safe side: "Switch off TrackIR" doesn't mean to turn it off completely, temporarily disabling it by hitting the TrackIR "pause" hotkey should do the trick too?

 

:drinks:

Mike

Share this post


Link to post
Share on other sites
1 minute ago, SAS_Storebror said:

Okay, I will give it a try.

Just to be on the safe side: "Switch off TrackIR" doesn't mean to turn it off completely, temporarily disabling it by hitting the TrackIR "pause" hotkey should do the trick too?

I think so, but to be completely sure I'd test it both ways, by pausing and by not even starting it.

Share this post


Link to post
Share on other sites

Ok here is a clip showing the stutter I saw last sunday in multiplayer:

 

https://youtu.be/pywh2k3iFeo

 

And attached are my computer specs.

 

Like I said earlier, they seem to be gone now that I checked/unchecked some things. Have yet to get into any populated (more than 5) server yet.

Specs.JPG

Share this post


Link to post
Share on other sites
On 4/3/2019 at 3:35 PM, sniperton said:

switch off TrackIR and see if the horizon still stutters when you roll. If it does, you ruled TrackIR out.

 

Sorry for my late reply but I've had no time to play BoS last week.

Today I've tried again, unplugged TrackIR and didn't have the Software started.

Nothing changed, still the same stuttering.

So I reinstalled BoS completely, meaning: I've wiped the whole game folder, let Steam complain about the missing files, uninstalled it from the Steam library so everything was gone.

The reinstalled from scratch, adjusted graphics settings (SSAO off, HDR off, Target FPS off, Screen Resolution set accordingly, no fullscreen, 4k skins on, everything else on default as far as I remember).

Reapplied my keyboard/Joystick bindings and then tried another round (again without TrackIR).

Same thing.

Still stuttering in the very same situations to the very same extent.

So I took DDU and completely uninstalled the Nvidia driver, reinstalled it from scratch, setup G-Sync accordingly and tried again.

Same thing.

Still stuttering in the very same situations to the very same extent.

It's really as simple as that: As soon as there are more than let's say 5 planes very near by, or 10 planes within visual distance, the stutter fest begins.

Here is a short sample clip I took on my very last attempt, remember it's after reinstalling game and nvidia drivers from scratch, without TrackIR:

 

And these are my PC specs:

1785153577_PCspecs.PNG.3b7b6fadc5e7e27e183fbdf8d9782b4c.PNG

 

:drinks:

Mike

  • Upvote 1

Share this post


Link to post
Share on other sites
Posted (edited)
57 minutes ago, SAS_Storebror said:

It's really as simple as that: As soon as there are more than let's say 5 planes very near by, or 10 planes within visual distance, the stutter fest begins.

 

Have you tested the speed of your connection to the area of the servers you play? Download and upload?

 

I wonder if everyone goes through these stutters in different forms and just some people report them. Flying Circus is new and the missions don't have enough objects to be a problem for most of the players, but I wonder if Berloga stutters with every player in those big furballs. Because dserver is an issue and I hear talks that they were working on a new code to replace the old one, which is still single threaded and appears to have heavy limitations. At the time being, we appear to be getting only patches to alleviate the problem. It that is really a problem, but people in general doesn’t tend to talk about it and the subject ends up dying.

Edited by SeaW0lf

Share this post


Link to post
Share on other sites
Posted (edited)
On ‎4‎/‎3‎/‎2019 at 12:37 PM, SAS_Storebror said:

 

Last but not least, almost all stutter is gone as soon as I switch to external view. Back inside the cockpit, stutter is back.

 

:drinks:

Mike

Yep , here the same Mike , external view is oke …. inside the cockpit , stutter ans micro freezes come back

Try this

 

 

I just tested , and it works a bit better

 

 

Naamloos 2.jpg

Edited by 1.JaVA_KEBEN
  • Like 1

Share this post


Link to post
Share on other sites

The strange thing is that I fly on the same mod-friendly server as Mike does (FAC), albeit I usually come a bit later when he has already left, but sometimes we fly the very same missions. We both have very good broadband connections with pings in the 20s to the server.

 

In the past few days I was involved several times in situations where 5 to 10 AI planes were nearby (just as in Mike's case), but I've never noticed that kind of stuttering that his vids record. I did experience micro-freezes, as usual, but they are most probably GPU related, since they occur when I change FOV or a closing plane changes LOD, or there are too many objects rendered, etc, etc. The FAC server is cleverly optimized for AIs and CPU load.

 

The differences are in

-- hardware (here a budget one with i5-6500, 8GB RAM, GTX 1050 Ti);

-- settings (in NCP mostly default, in-game mostly "ultra" with several settings tuned down for performance, i.e. shadows, mirror, grass, SSAO off, etc.);

-- mods activated (here Lefuneste's Migoto mod and No Fog Mod active);

-- planes flown (here Il2s, LaGG, P-39, P-40, P-47, all in different configurations).

 

It might be a complex issue: hardware (9600K?), individual planes models, and netcode can all play a role IMO.

 

 

  • Like 1

Share this post


Link to post
Share on other sites
12 hours ago, SeaW0lf said:

Have you tested the speed of your connection to the area of the servers you play? Download and upload?

Yes, did that already.

As mentioned by @sniperton, my Internet connection is quite fine, as is the Server's one.

I'm on a 100/20 (Down/Up) Mbit/s Cable connection and I can reach both limits reliably 24/7 in speedtests as well as transfers to the very server we're playing on.

That Server actually is mine, it's located 460km away, we're both in Germany.

The ping time is in the low 20ms and the jitter is 2-3ms.

The Server is on an unmetered symmetric 1GBit/s line and it can reach that limit reliably 24/7 as well.

 

I'll rule out the SSD as

  1. The tool mentioned by @1.JaVA_KEBEN is for Samsung SSDs only (I've got a Crucial and a Sandisk in my PC) and Windows 10 has all "optimization" settings applied by default already (checked).
  2. There has been no such issue with the very same SSD on the very same OS prior to my hardware upgrade either.

As @sniperton lined out correctly, it could be related to a side effect of my hardware upgrade and/or the planes we're flying.

I've lately suffered from those stutters the most while flying german kites (190s), will try the russians again for comparison soon.

The 9600K could play a role, as could the mainboard.

Last but not least the onboard LAN chip and/or it's driver could be part of the deal as well.

Yesterday evening I've applied all kind of "optimization" settings for the onboard Intel LAN chip I could find on gaming sites, and I ran the "TCP Optimizer" tool and let it apply "optimal" settings.

Will see whether that changes anything...

 

:drinks:

Mike

  • Like 2

Share this post


Link to post
Share on other sites

Just a small update, the changes to the LAN chip settings and the "TCP Optimizer" settings didn't change anything in terms of this stutter issue either.

In the meantime I've tried lowering down the graphics settings to a ridiculously low level, again no change.

Just for comparison, I've set them to Ultra and everything on highest settings, which of course gives worse overall framerates, but the stutter issue is just the very same as before.

That's the funny part about it: Whatever I have touched, changed, tuned, intentionally messed up - it just doesn't change anything in terms of this stuttering thing.

I cannot make it any better, but I cannot make it any worse either.

Today I've had two "click" moments.

First was when I watched a War Thunder Cockpit video where someone was flying alongside a coastline in a Heinkel 111. He had that very same stuttering at times.

Second was when I've played IL-2 1946 with the FAC chaps today. There's been a quite crowded mission with lots of AI, and once I met like 40 AI planes fighting below and inside clouds, right above a small pacific island with lots of AAA on it. And then... the very same stutter.

 

I conclude that this is not an IL-2 Great Battles issue.

Maybe it has been there all the time and I just didn't notice, because on my old system there has always been some lag here and there.

Maybe I'm just much more picky now that I usually reach 144 FPS most of the time.

Maybe it's really an issue, but if it is, it's rather related to the Motherboard/CPU/GPU/RAM combo than anything else.

 

Therefore, thanks for all your support and for your attention, but I don't think we need to try and fight this within IL-2 Great Battles any longer.

 

:drinks:

Mike

  • Upvote 2

Share this post


Link to post
Share on other sites

I've been suffering from this affliction again since 3.012 (mostly in multiplayer but also somewhat noticeably in single player). I told @SeaW0lf about it as we were flying on the same server in FC today.

 

My usual solution of disabling fullscreen mode no longer seems to cut it.

 

What I did to reduce my stutters was follow @SYN_Jedders's advice and disable Vsync in-game and forcing it on in the Nvidia CP. I've also enabled fullscreen mode again and disabled the FPS limiter (setting Off). There's still some microstutter present, but it's playable again.

  • Thanks 1

Share this post


Link to post
Share on other sites

Salutations,

 

Do you have 4k Textures enabled?

Share this post


Link to post
Share on other sites

I have them disabled right now, though I had them enabled before. Let me check if it makes a difference.

Share this post


Link to post
Share on other sites
Posted (edited)

Cool, I'll try that. So far no luck. Heavy stutters since day one with Windows 10. I'll let you guys know how it goes. But it is hard during the week, because the stutters get mild, so I think my problem is with ethernet. Or the game is not setting it right.

Edited by SeaW0lf

Share this post


Link to post
Share on other sites
Posted (edited)

4K textures seems to mostly eliminate the microstutter as well...

 

The stutter I experienced today wasn't microstutter at all, though, it was a strong irregular stutter (about three in a row) visible mostly when rolling or when making a sharp sustained turn, as if the landscape was lagging behind a bit. It definitely happened more often as there were more planes around, but I haven't been able to get into a dogfight since then (BERLOGA is not up either).

 

Will try again soon and report back.

Edited by J5_Hellbender

Share this post


Link to post
Share on other sites

I'm glad it helped. Good luck up there. Watch your six. :good:

  • Thanks 1

Share this post


Link to post
Share on other sites
5 hours ago, J5_Hellbender said:

4K textures seems to mostly eliminate the microstutter as well...

 

 

 

Sorry but did you eliminate the microstutter by disabling the 4k textures checkbox???     

Share this post


Link to post
Share on other sites
1 hour ago, Dutch2 said:

 

Sorry but did you eliminate the microstutter by disabling the 4k textures checkbox???     

 

No, the opposite. I now have 4K enabled again and the game is noticeably smoother with almost no microstutter. I will post my full settings as soon as I get home.

 

 

This is a separate issue from the multiplayer stutter, though. I will make a video of it next time I’m on a server with lots of close activity.

Share this post


Link to post
Share on other sites

I went onto BERLOGA just now in a dogfight with around 10 planes, and (apart from the fact that I am absolutely hopeless in anything post-WWI) I am happy to say that I experienced no major stutters and only marginal microstutter. Yesterday it was almost unplayable on J5 FC.

 

My settings:

 

iCECGd2.png

 

NVIDIA CP:

 

lWozzsY.png

 

startup.cfg:

 

lcIS4at.png

 

 

I do have a theory that stutters will still happen because of some Windows-related memory buffer / garbage collection process causing latency, and I'd suggest you run IL-2 only after a reboot and with as few background tasks as possible. I usually have Steam on for voice comms and friends list, but I think I'll move to Discord now.

 

Please let us know if it's any help at all.

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites

I'll try this maybe at the end of the week (a bit slammed right now). I also have to reset my  followed content in this website ( for some reason I can't find it). So it might take a while for me to reply any posts. I only have the general discussion page for FC.

 

NOTE: this interface is so much worse than ROFs website...

Share this post


Link to post
Share on other sites

Hi!

For those experiencing micro-stutters during multi-player sessions, maybe tuning the Network adapter settings could help a bit. 

 

My line of work requires developing software that consumes a LARGE number of video streams simultaneously.

These streams are broadcast using the UDP protocol (as most networked  games do, and I would expect BoX not to be an exception). This basically means that there is no retransmission protocol in case a data packet is not correctly received (this would increase latency to unacceptable levels in these scenarios).

 

Tuning the Network adapter in our use-case is vital if we want to reduce dropped Network packets when the server is under moderate to heavy load. In our case, the dropped packets reach the Network card, where they are buffered and a notification is sent to the application that is expecting the data, however, sometimes the application fails to retrieve the data on time.  Since the memory where these packets are stored is limited, it is reused, and very frequently - by the time the application reacts to the notification,  the expected data has been overwritten with fresh data,  creating a gap in the data stream. This most probably manifests in the simulation as a stutter.

 

Not all Network cards expose the same configuration parameters, but many do.  I will show you the parameters available in mine, hoping you find the same (or similar) parameter in your Network card.  Feel free to post your available parameters in case you don't find exactly the same ones I will detail.  Before editing any of the parameters, please take note of the current value, in case you need to rollback changes if something is not working

 

1) Open Device Manager and expand the Network adapters section.

2) Locate the network card that is connected to your Internet Modem/Router

image.png.d55f714f24559e213e8d068867d44d46.png

3) Right click on the Network card and select properties, this will open a Property dialog window.  Click on the Advanced tab

image.png.4a6a9531e27b3df6b276520df7616f03.png

 

Parameters to adjust:

 

1) Interrupt Moderation . If this value is found make sure it is DISABLED. This setting is perhaps the most important one to adjust.  If the value is enabled, the network card will wait for several packets to be received before notifying the application (via an interrupt) that fresh data is available.  This batching reduces CPU consumption, but greatly increases latency, increasing the chance that some of those packets are overwritten before the application responds and fetches the data.

 

2) Max IRQ per second.  If this value is found, try doubling or quadrupling the value. Basically it throttles how many interrupt requests the Network card can generate in a second. Adjusting value 1) will increase this interrupt rate and you don't want the notifications to be possibly  capped by this value.  In my adapter card,  this value is a free-text value.  If I input an unsupported value, I don't receive an error notification, but the network card becomes disabled (appears with a yelllow ! sign on the Device Manager view).  Make sure you don't input a value that disables your adapter card.

 

3) Maximum Number of RSS Queues. If found, select the maximum value available in the drop-down list. 

 

4) Receive Buffers. Again, this is a free-text value for my Network card. Try to double or quadruple the current value, making sure the new value does not cause the Network card in Device manager to become disabled (similar to #2)

 

Reboot your system before trying the effect of these values.  I sincerely hope they help.

 

Cheers!

 

Sergio

 

image.png

image.png

  • Thanks 2

Share this post


Link to post
Share on other sites
2 hours ago, Rosco said:

1) Interrupt Moderation . If this value is found make sure it is DISABLED. This setting is perhaps the most important one to adjust. 

 

Mine is enabled! I will disable it and test it (with the other settings) as soon as possible. I'll let you guys know.

  • Like 1

Share this post


Link to post
Share on other sites
22 minutes ago, SeaW0lf said:

 

Mine is enabled! I will disable it and test it (with the other settings) as soon as possible. I'll let you guys know.

Hope the settings help! 

 

Truth is, the amount of data transmitted by the simulation must be very low compared to a video transmission so maybe the settings won't help, but it is worth trying, don't you think?

Also, I noted on Hellbender's image that he is setting the update frequency of the Force Feedback parameters to 5.0   You can lower it up to 0.5 and still get decent force feedback with reduced jerkiness when moving your head around. (the lower the value, the less jerky the movement, yet it is not completely eliminated).

 

Good Luck!

 

  • Thanks 2

Share this post


Link to post
Share on other sites
7 hours ago, Rosco said:

Hope the settings help! 

 

Truth is, the amount of data transmitted by the simulation must be very low compared to a video transmission so maybe the settings won't help, but it is worth trying, don't you think?

 

Also, I noted on Hellbender's image that he is setting the update frequency of the Force Feedback parameters to 5.0   You can lower it up to 0.5 and still get decent force feedback with reduced jerkiness when moving your head around. (the lower the value, the less jerky the movement, yet it is not completely eliminated).

 

Good Luck!

 

Thanks for all the tips, Rosco!

 

Besides interrupt moderation, my network controller has an interrupt moderation rate setting which is set to adaptive. Since it's meant to dynamically adjust the interrupt moderation according to packet size, I'm inclined to leave it as-is. For me it's all just speculation at this point, since I wasn't able to reproduce the stutters since Sunday last.

 

Regarding the FFB microstutters, decreasing it to 0.5 really does appear to eliminate them almost entirely, but then one force update every two seconds is not enough for me. I found 2.0 to be the minimum in terms of responsiveness and found no discernible change in smoothness compared to 5.0. Going from 10.0 to 5.0 really does make a tremendous difference. I should add that I'm playing on a rather old 60Hz monitor, so I'm sure I'm not as sensitive to stutters as some others might be.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

From my time (I mean endless hours) of combating the stutter issue. I have noticed that the stutters most often occur when the screen it looking at light reflecting from glass or particles emitted from gunfire smoke. I get the most stutters when online in MP and there a several planes dog fighting. In SP in F2 view, I notice 10-20 fps drops when I fire the guns and the particle smoke is emitted when closely viewing the plane.  I think our stutter issues are related to unoptimized particles and reflective lighting for the game.

Edited by Geronimo553

Share this post


Link to post
Share on other sites

Without attempting to count my chickens before they are hatched, I think I have made a leap forward in terms of my stuttering issues.

 

This is what I did since my last post and it did not cure my stuttering issues:

  • Uninstalled Nvidia Driver completely using DDU
  • Reinstalled latest driver (430.39 at the time of writing this)
  • Rechecked my Nvidia Control Panel settings (see below)
  • From here on, tinkered with Graphics Settings:
    Set Shadows Quality to "Low" (was "Medium" before)
  • Set Distant landscape detail to "Normal" (was 2x before)
  • Set Landscape filter to "Off" (was "Blurred" before)
  • Set Grass quality to "Distant" (was on all kind of settings in my previous tests)
  • Set Target FPS to "60" (was "Off" before)
  • Set Antialiasing to "2" (was "4" before)
  • Disabled Full screen (was enabled before)
  • Disabled SSAO (was enabled before)
  • (HDR was disabled all the time)

My Nvidia Control Panel Settings:

  • DSR Factors = Off
  • Anisotropic filtering = Application-controlled
  • Antialiasing - FXAA = Off
  • Antialiasing - Setting = Application-controlled
  • Antialiasing - Gamma correction = On
  • Antialiasing - Mode = Application-controlled
  • Antialiasing - Transparency = Multisample
  • Preferred Refresh rate = Highest Available
  • CUDA - GPUs = All
  • Triple buffering = Off
  • Power management mode = Prefer Maximum Performance
  • Optimize for compute performance = Off
  • Maximum pre-rendered frames = Use Settings for 3D Applications
  • Monitor-technology = G-SYNC
  • Multi-Frame Sampled AA (MFAA) = Off
  • OpenGL-rendering GPU = Auto
  • Shadercache = On
  • Texture filtering - Anisotropic sample optimization = Off
  • Texture filtering - Negative LOD bias = Allow
  • Texture filtering - Quality = Quality
  • Texture filtering - Trilinear Optimization = On
  • Threaded optimization = Auto
  • Vertical sync = Fast (not really necessary due to G-SYNC, but still...)
  • Pre-rendered VR-Frames = 1

As mentioned before, all of this didn't change a thing - whenever I've been entering a crowded area, be it a well populated airfield or a furball dogfight, massive stuttering occured.

Tinkering with the aforementioned settings has been my "hobby" for weeks now, as well as tinkering with network settings.

Nothing ever changed, neither to the better, nor to the worse.

 

And now comes the catch.

 

This is what I did today, and guess what? No stuttering in 3 test sorties I've made so far:

  • Changed from "HIGH" to "ULTRA".

Period. Nothing else. Just that. Changed the overall setting to "ULTRA" and the stuttering is gone.

Who would have guessed that?

 

:drinks:

Mike

  • Upvote 1

Share this post


Link to post
Share on other sites

I tested only selecting ultra and the only change I noticed was 20 fps less than usual.  

Share this post


Link to post
Share on other sites

I'll try to ultra thing, but I think I tested it before. From what people say, and their solutions, I can only imagine what kind of engine we have under the hood to behave so erratically from one computer to the other. If I could only go back to Windows 7... It is no fun to fly multiplayer as it stands.

Share this post


Link to post
Share on other sites
1 hour ago, SeaW0lf said:

I'll try to ultra thing, but I think I tested it before. From what people say, and their solutions, I can only imagine what kind of engine we have under the hood to behave so erratically from one computer to the other. If I could only go back to Windows 7... It is no fun to fly multiplayer as it stands.

Wish I could have win 7 or 8, anything but 10.  It didn't have the stutter on 8 either.

Share this post


Link to post
Share on other sites
Posted (edited)
6 hours ago, SAS_Storebror said:

This is what I did today, and guess what? No stuttering in 3 test sorties I've made so far:

  • Changed from "HIGH" to "ULTRA".

Period. Nothing else. Just that. Changed the overall setting to "ULTRA" and the stuttering is gone.

Good news, but still strange. I'm on ultra all the time and I have been experiencing frequent stuttering online since 4.012c. Formerly it hasn't been the case, but as I'm using an FFB, I started to believe that it was the FFB pestilence that I've finally cought with the new patch. Now it seems that different hardware (a budget one here) react to game changes differently. Changes to Win10 can be ruled out, there were none in the meantime that I can remember.

Edited by sniperton

Share this post


Link to post
Share on other sites

I agree that it's strange.

Remember I've been on "HIGH" before with my i5-2500k system and did not suffer any such stutter.

Since this has been a try&error thing, I'm quite reluctant to give explanations as to why "ULTRA" setting should have fixed it.

One idea would be that the new i5-9600k was too fast for "HIGH" setting.

In the end I've been on 144 FPS almost all the time, including the moments where the severe stuttering started.

Maybe if the CPU gets too bored while too many other things are going on, strange things happen.

I've got no idea, really. I don't even know whether this state of stutter-free gameplay will persist.

Just thought I'd let you guys know about the latest observations because after weeks of trying almost everything with absolutely no effect (neither positive nor negative), this single setting change suddenly really made a difference.

 

:drinks:

Mike

Share this post


Link to post
Share on other sites
1 hour ago, SAS_Storebror said:

One idea would be that the new i5-9600k was too fast for "HIGH" setting.

Is a reduced maximum core clock a try worth? I had no problems yet, but a comrade of me.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...