Jump to content
Sign in to follow this  
Sakivano

Link power manager in Windows 10

Recommended Posts

Well, I've been playing with Blitz for the last 3 months (since Christmas) and it's wonderful. Yet, I've been experiencing a kind of problem which was mainly noticed when I panned around in search of contacts with my TrackIr. It was rather annoying, because there were micro-pauses here and there and a sense of no smoothness. My pc is new, therefore I was getting really angry with those pauses. I really got obsessed, so I began to google and saw that a lot of people suffers from the same problem, mainly related to trackir (Just google "trackir micro stutter" and you'll see). No fluidity, micro-stutters, micropauses and so on. I followed all of the advices, but to no avail. I changed the trackir to another USB port, I downloaded a different driver (older) just in case, I updated the nVidia drivers, blah blah blah. Eventually, the only thing which more or less improved it was to change the forest quality in-game from "Very high" to "High". The pauses, although they were there, had been reduced, so I could sleep better.

 

Until yesterday. Searching I don't remember what, I came across a web in which somebody said that disabling the Link power manager in Windows 10 solves lots of problems with games and micropauses. I didn't know what the hell was that, but then I realized I have an ssd hard disk with with Intel Rapid Storage Technology, therefore I was affected by tyhe same problem. Well, I disabled it and to my surprise, everything goes as smooth as butter. It's incredible that a problem I thought was caused by TrackIr was eventually caused by this software. I've been flying all the afternoon today, to see that the improvement is not a placebo effect, and I can confirm it. Of course, I have forests on "Very high" again, and the sim is smoooooooooooooooth!!!!!!!!

 

This is what the original message (the one I read) mentioned: " Find the Intel Rapid Storage Technology Icon in START. Open it up and go to the Performance tab and set Link Power Management to disable. You must restart your machine for it to take effect. I had tried all other performance/stuttering tweaks with minimal results, and after doing this my stutters are finally gone. "

 

 

  • Thanks 3

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...