Jump to content
Sign in to follow this  

Thrustmaster T.A.R.G.E.T. delayed or unregistered key presses

Recommended Posts

After the update 3.010 I noticed that when I run a T.A.R.G.E.T. profile that there is delayed or even unregistered key press within IL-2. I have to repeatedly hit every button to get it to register. You can imagine the frustration during a dive bombing run. I'm curious if anyone else has noticed this, or even use the Thrustmaster GUI. 


I know there was an issue during version 1.0 where if you programmed a command within target that used a modifier key, the only key press registered was what came after the modifier key. This is not that issue, it's even happening for my recenter VR button which is KP5 (located on pinky). (I remember having that issue, fixed it by changing their type from pulse to hold, even though it's a momentary press.) [However, before this last update, pulsed commands that were for example "Shift + 5" seemed to be working fine in IL-2. Not sure what verdict is there]


Should mention I'm using a Thrustmaster Warthog. When I open the even tester while the profile is running, every key press gets registered, with 0 delay. Even my key binds that utilize modifier keys register flawlessly.


Yea yea, don't use TARGET. But how else can you get modifier keys within IL-2 BoX? I'd love to see the Devs implement something like that, similar to DCS, but I can't imagine that's something on their priority list.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...