Jump to content

IL2 Great Battles Easy Mission Generator


SYN_Vander
 Share

Recommended Posts

SYN_Vander
On 8/27/2021 at 3:07 PM, =gRiJ=ToReRo said:
Hi Vander,

 

First: Thanks for keeping this great tool up to date!
 I am an admirer of his work I try to create cop p vs p this would be possible ????


Yes, pvp in coop mode is possible. Just make sure you select “both” as side.

Link to comment
Share on other sites

hsthhsth

@SYN_Vander,

 

Thanks for looking into it.

It might be that I engaged outside this 15 km radius. Didn't know that counting only happened there. That maybe also explains the differences in mission accomplished I received.

 

A minor detail, when you're changing the generator could you please also have a look at the date settings in the Situation tab? When you select the Front date (can only be 1918 for the Arras map) the year in the Date could also only be in the Front range. Just one of those details.🙂

Link to comment
Share on other sites

spreckair

Hi Vander:

 

Looking for a little help please.  I just downloaded the EMG and gave it a try.  It seems to be creating and saving a mission, but is not showing up in the game.  My config, mission generator, and missions files are attached.  Any help would be greatly appreciated.  Given the super comments on this application, I hope that I can get it to work.  Thank you.

 

 

config.zip.zip mission_generator.zip.zip Missions.zip.zip

Link to comment
Share on other sites

SYN_Vander
8 minutes ago, spreckair said:

Hi Vander:

 

Looking for a little help please.  I just downloaded the EMG and gave it a try.  It seems to be creating and saving a mission, but is not showing up in the game.  My config, mission generator, and missions files are attached.  Any help would be greatly appreciated.  Given the super comments on this application, I hope that I can get it to work.  Thank you.

 

 

config.zip.zip 885 B · 2 downloads mission_generator.zip.zip 663 B · 0 downloads Missions.zip.zip 4.28 MB · 0 downloads

 

Well there is nothing wrong with that mission. I unzipped it in my \data\missions folder and I could select and start it.

 

Perhaps the mission list cache is corrupt? Try deleting the mtreecache.eng file in the \data folder.

 

  • Thanks 1
Link to comment
Share on other sites

spreckair

Thank you very much for the quick reply.  I deleted the mtreecache.eng file but it did not remedy.  If you think of anything else that might help, please let me know.  I will keep my eye on this string to see if anything comes up that I might try.

Link to comment
Share on other sites

@hsthhsth, I just tried putting another mission in the directory.  It appears that the tool is working, but I am not seeing the mission in the sim.

Link to comment
Share on other sites

Oddly enough, after installing the Mission Generator for the first time, I have the same problem.
All mission files are being created and saved in the correct folder but are invisible in the game Mission menu.

Other 3rd party missions all appear and work fine.

Any ideas?

Thanks

Link to comment
Share on other sites

9 hours ago, Thad said:

Would, not owning  a craft used in a mission cause such a problem? 😗

 

That could be it. I can't test it, because I own all the planes....

 

11 hours ago, Skipper- said:

Oddly enough, after installing the Mission Generator for the first time, I have the same problem.
All mission files are being created and saved in the correct folder but are invisible in the game Mission menu.

Other 3rd party missions all appear and work fine.

Any ideas?

Thanks

 

Apart from not owning the aircraft in the mission all I can think of is some windows file permission right problem. Where do you run the mission generator from and where is your IL2 install located?

Edited by SYN_Vander
Link to comment
Share on other sites

1 hour ago, spreckair said:

@hsthhsth, my Missions page does not show any SYN_Generated mission.  

 

Are you sure you generated the correct type of mission you are trying to find. for example Dogfight missions will be in /multiplayer/Dogfight and Co-ops in /Multiplayer/Coop and the singles in Missions?

Link to comment
Share on other sites

 

Hi Spreckair

your uploaded mission shows up, loads and starts for me.
It contains a Bf109-F2 on Moscow Map, because there is only a FC-batch in your profile, I assume you own BOM via Steam, did you checked Il-2 game integrity via steam? If not give it a try, please. Maybe this might help.

 

  • Upvote 1
Link to comment
Share on other sites

@CorvusX  Thank you for the message.  I followed your suggestion and verified the file integrity in Steam.  Still a no-go.  This is a head-scratcher, and I am about to go bald (no offense to those who are).

 

Also, I have been trying this out on both my laptop and my desktop, and get the same negative result on both.

Edited by spreckair
Link to comment
Share on other sites

3 hours ago, spreckair said:

Still a no-go.  This is a head-scratcher, and I am about to go bald (no offense to those who are).

 

Also, I have been trying this out on both my laptop and my desktop, and get the same negative result on both.

Hmmm... it is indeed.

 

Maybe Vander is right and it is because of what he said:

On 9/13/2021 at 9:20 AM, SYN_Vander said:

I can think of is some windows file permission right problem. Where do you run the mission generator from and where is your IL2 install located?

 

Can you post the complete path of the missions location
(because of the config.ini I guess it's  C:\Program Files (x86)\1C Game Studios\IL-2 Sturmovik Great Battles\data\Missions),

also of the Mission generator  and can you post a screenshot of your ingame mission list, like hsthhsth did, please.

What happens if you dl your mission and copy  it into the Mission directory? (if its the same result, what if you rename it?)
Do other 3rd party missions show up like it happens for Skipper?

Edited by CorvusX
Link to comment
Share on other sites

Looks like there are some 6 or 7 files missing:  the briefing files for the other languages, the .list file, and the .msbin file.

 

Try running EMG as an administrator, (right mouse click EMG icon, select 'Run As Administrator')

To me it looks like windows file protection is kicking in... 

Link to comment
Share on other sites

spreckair

@DD_FT-Thank you for the input.  I just tried running as an admin and it is still a no-go; same files as before.  I also removed and reloaded EMG beforehand.

It's always seems to be that the things you love most are what drive 

Edited by spreckair
Link to comment
Share on other sites

SYN_Vander
2 minutes ago, spreckair said:

@DD_FT-Thank you for the input.  I just tried running as an admin and it is still a no-go; same files as before.  I also removed and reloaded EMG beforehand.

It's always seems to be that the things you love most are what drive you mad!

 

So the EMG process is as follows:

1) You start the EMG and configure the mission by choosing this and that

2) You press ' Generate' and the mission is generated. This results in a .Mission and a.eng file as you see in your folder.

3) Then EMG runs a little program called 'MissionResaver.exe'. This comes with the game and sits in <your IL2 install folder>\bin\resaver. This will resave the mission file to a binary file, but will also generate the .list and other language files.

 

It looks like step 3) is not happening. Can you check if MissionResaver.exe does indeed exist in your IL2 install ? Even if it does it can still be a windows permission problem in that it doesn't allow you to run this program.

 

 

Link to comment
Share on other sites

spreckair

@DD_FT-Your guesses are very welcome and truly appreciated.  I think I tried it once with the anti-virus software off, but if so I will give it a try again.

 

Update:  ...and it is still a no-go.  Ugh...why me!!!

Edited by spreckair
Update
Link to comment
Share on other sites

SYN_Vander
49 minutes ago, spreckair said:

@SYN_VanderThank you for the info.  Is this what you were explaining:

 

image.png.9f77dc921e9e2881baf8242daee4093d.png

 

Yup. So that is in the right place.

Link to comment
Share on other sites

Hm.

The files in your resaver folder differ in size compared to mine:

image.png.32c9fcf3198e239c4dd1e4844d041d84.png

 

As you're from the USA - by the looks of it, yours are dated April 9th.

That's rather old. Maybe you need to run the Launcher.exe so the game can update itself to the latest version...

 

Edited by DD_FT-
Link to comment
Share on other sites

Hi @spreckair,

 

I can confirm DD_FT-s file sizes and dates, also the Mission zip you uploaded includes the missing files he was mentioning.
 

What irritates me is the "updates" folder blow the data and bin folders, that indicates that this game install was made by the Il-2 game installer. 
But BOM ist owned by you via steam (right?). Steam does not install an updates folder.

 

Is it possible that you have two il-2 installations?

 

One in the folder that you send the screenshot from and one in your Steam\SteamApps\common\IL-2... folder?

 

If it is so, then this causes that issue, link the  Mission generator ("file" page "IL2 main folder" line) to your il-2 steam installation root folder and try again to make a mission, then run the steam IL-2 installation and tell us the result, please.

 

 

Edited by CorvusX
Link to comment
Share on other sites

spreckair

@CorvusX  Yes!  I do have two installations and one is in the Steam\SteamApps\common\IL-2 folder.  Let me give this a try.

 

Update:  PROBLEM SOLVED!!!!  Thank you so much for sticking with this; you, Vander, DD_FT_, and others are really great.  I plan to really enjoy my upcoming weekend with this.  Hurrah!

Edited by spreckair
Update
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...