Jump to content
Han

Game version 3.008 discussion: Damage model update, fixes and improvements

Recommended Posts

2 minutes ago, Legioneod said:

But those aren't really good high altitude performers irl. If they are overperforming in-game then I agree they should be fixed, I just don't have enough experience with them up high to make a judgment on this though.

 

One thing that does need to be worked on is the DM for all engines and especially radials.

I want to run few tests in upcoming weeks because I am really bugged about that LA5FN sticking with my K4 at 11.5km altitude. Hopefully this will show us the answer :) So far I have read that LA5FN and A3 are hugely overperforming at high alts.

Share this post


Link to post
Share on other sites
4 hours ago, GridiroN said:

 

A defining characteristic of radials is that they suck at altitude without supplemental equipment.

 

What issue are you referring to?

 

1 hour ago, Legioneod said:

But those aren't really good high altitude performers irl. If they are overperforming in-game then I agree they should be fixed, I just don't have enough experience with them up high to make a judgment on this though.

 

One thing that does need to be worked on is the DM for all engines and especially radials.

 

check in fm discasions Performance at high altitudes of 10000m, radial engines topic, its from 3 months ago so who knows maybe things are differant now with all new updates, but i offten see early 190s up high flying like they are born to be high alt interceptors :)

Share this post


Link to post
Share on other sites
On 12/7/2018 at 10:23 PM, coconut said:

I'm also disappointed that the old behaviour of retriggering a timer has changed. In the past, triggering a non-deactivated timer would always (re)start it. I used this to implement non-trivial conditions such as "Spawn AI patrol when enemy close, then repeatedly try to despawn it after 1 min unless there is still an enemy nearby". It would not be too hard to change it to use the new timer reset mechanism, but it does not work. Old trick no longer works, new mechanism doesn't work yet. I'll figure something out, but it will make the logic even more complex than it was.

Can't stress enough how important this part is.

The fact that triggering a non-deactivated timer doesn't (re)start it anymore is a complete show stopper.

At the moment, it renders all missions on our FAC gameserver broken.

I'm not ready to check and touch hundreds of timers on the missions to work around this bug, especially not without knowing what further changes to this issue there will be.

I definitely vote for a quick hotfix that restores the old functionality at least.

Really, really, really...: This is a showstopper bug.

 

:drinks:

Mike

Share this post


Link to post
Share on other sites
17 hours ago, SAS_Storebror said:

Can't stress enough how important this part is.

The fact that triggering a non-deactivated timer doesn't (re)start it anymore is a complete show stopper.

At the moment, it renders all missions on our FAC gameserver broken.

I'm not ready to check and touch hundreds of timers on the missions to work around this bug, especially not without knowing what further changes to this issue there will be.

I definitely vote for a quick hotfix that restores the old functionality at least.

Really, really, really...: This is a showstopper bug.

 

:drinks:

Mike

Yes. The Finnish VirtualPilots' server is currently down because of this.

  • Upvote 2

Share this post


Link to post
Share on other sites

Hi all,

 

Last try before I lock this topic. Keep it on topic, bug reports have a section for that, do not post test related post here (third time its have been said) and also do not get personal with each other, if you feel someone is doing so (by using the reactions icons or otherwise) let us know and we will deal with him.

 

Haash

  • Upvote 2

Share this post


Link to post
Share on other sites
On 12/10/2018 at 4:54 AM, SAS_Storebror said:

Can't stress enough how important this part is.

The fact that triggering a non-deactivated timer doesn't (re)start it anymore is a complete show stopper.

At the moment, it renders all missions on our FAC gameserver broken.

I'm not ready to check and touch hundreds of timers on the missions to work around this bug, especially not without knowing what further changes to this issue there will be.

I definitely vote for a quick hotfix that restores the old functionality at least.

Really, really, really...: This is a showstopper bug.

 

:drinks:

Mike

 

From Han.

 

Both a bugs and to be fixed
Except 2nd one:
"I can set counters, e.g. to 1 using Set Val (data[0] = 1, index = 0). According to @Han this should change the threshold to 1. This is a minor issue, changing the value of a counter is what I expect I'll need, changing the threshold I don't have uses cases for yet."

From update notes:
"To alter a Counter value, use the 0 index of the controllable value or alter Counter threshold using the 1-st index"

So IDX=0 controlling counter's current value, IDX=1 controlling counter's treshold

 

Jason

  • Like 2
  • Thanks 4
  • Upvote 4

Share this post


Link to post
Share on other sites

Thanks Jason, that's good to hear and good to know.

So we can sit back and wait for the fix of the "re-trigger timer" issue instead of further trying to work around it.

I'm sure we'll get our heads wrapped around the value/threshold setting for counters as well ;)

 

Thanks again and best regards

:drinks:

Mike

Share this post


Link to post
Share on other sites

Great work on damage modeling was hit a few times in my 190 and i made it home landed .

Normally i wouldnt of made it . This for me is a far better experience than what I had before .

Thank you .

Edited by II./JG77_Con
  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites
17 hours ago, 22GCT_Hollywood said:

Hello,

with this version 3.008, IL2 on startup  does not recognize anymore Oculus rift. Somebody have the same problem?

Thx.

I narrowed it down to oculus home being the problem and not IL-2. I just had to make sure home started fully before launching the game and voila it works. I read you can disable oculus home but I have games on there too.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×