Jump to content
Sign in to follow this  
il2fan

Cant link steam account?

Recommended Posts

Hey guys I’m having a bit of a problem. When I go to switch my name from Player_12345 or whatever number I was assigned, it doesn’t link. I am typing in the right email and password and it’s still giving me wrong email/password.  Any idea what I’m doing wrong? Thanks for the replies :fool:

 

EDIT: FIXED. Mods please remove

Edited by NickandMuse

Share this post


Link to post
Share on other sites

How did you fix? I have the exact same issue. Bought game on steam, trying to link with existing IL-2 account, game always says wrong email or password even though the email/password works fine at il2sturmovik.com.

Share this post


Link to post
Share on other sites

Hi, same problem - whats the solution plz ty :)

 

EDIT:

 

Hm okay I have solved my problem but damn what a hazel 😒

 

First of all, I went to the IL2 website and created an account with the username I also want the game to show.

Start the game normally through Steam

Click on the auto-generated player name.
Now you should get (like me) a couple of options. I chose the possibility that I have played the game through only Steam (as I remember since I can not get this page up anymore)

Then you should have a Explore, Chrome or whatever you're using page up where you enter your Steam user name and associated password.

Start Il2 again normally in through Steam - afterwards, for me at least .... yipeee .... username changed to the username I had created for the account I created independently at il2sturmovik.com .... peew !!
 
And as I just remember, I did not do anything else.
I'm sorry if it does not work for others, so I've forgotten something - but, as I just remember, I did not do anything else.

So changing a simple player name was just NOT as easy and straightforward as IL2 proclaims.😥
Edited by Redich
Solved

Share this post


Link to post
Share on other sites

Hi,i have the same problems,but your solution doesn,t work for me. Anything else have an idea?

Share this post


Link to post
Share on other sites

I am having issues registering as well.  When I go to the "Link Accounts and Login" I get a:

 

#4: Wrong e-mail or password

 

However, verified and changed password without success.

 

 

Share this post


Link to post
Share on other sites

8 months after the OP & still no official replies or real solutions. its at least good to know what level of support is forthcoming before paying for any other products.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...