Jump to content
c6_lefuneste

3Dmigoto mod : icon masked by cockpit, zoom for VR, color change, sight strengthened,...(13 features)

Recommended Posts

Thanks lefuneste, update works perfectly.

The only minor problem is I can see the horizon line when zoomed in, but it is not a big problem to me. 

Share this post


Link to post
Share on other sites

First post updated with the 17.0.1 that fix horizon problem. I though it was a shader that makes problem previously, so it was disabled for zoom.

  • Like 3
  • Thanks 5

Share this post


Link to post
Share on other sites

I’m sorry to be such an idiot, but I am having trouble getting this mod (zoom settings particularly but maybe if they aren’t working, nothing is). I have had it working before when the mod was preconfigured already for pimax5k+ so I guess I didn’t really need to set it up in the first place, just assign keys to joystick.

V 17.01 is in the mods folder, and I have used JGME to activate it. I have mods enabled in IL2. Pressing insert key or home or page up does nothing in the zoom department - maybe that is to be expected if the default at the start is turned off? Then how do I turn it on, so I can then use L Alt and F9 and see the new instructions on the screen telling me which keys are used to adjust the Zoom settings?

I suppose I have missed something basic but any help to get the zooms working with v 17 and then new hot fix version of IL2 like they were previously would be much appreciated.

Share this post


Link to post
Share on other sites
36 minutes ago, ZiggyBClark said:

V 17.01 is in the mods folder, and I have used JGME to activate it. I have mods enabled in IL2. Pressing insert key or home or page up does nothing in the zoom department -

Check that you have the mod files (d3dx.ini,...)  in the directory  where il2.exe is. And, of course, the zoom works only in VR.

 

Share this post


Link to post
Share on other sites

Hi Lefuneste, I have a Pimax 5k+ and am always in VR on IL2. The path is: program files(x86)>Steam>steamapps>common>il2 stumovok Battle of Stalingrad>MODS>3Dmigoto_VRBOS_17.0.01>bin>game>then folders and dll files

Do I have this all correct?

Actually, the folder 3Dmigoto_VRBOS_17.O.1 is also in the IL2 Stumovik Battle of Stalingrad folder also, so is there twice. Both inside the MODS folder and outside. Could that be the problem?

Share this post


Link to post
Share on other sites

I still have version 17.00 and didn't notice anything wrong with the horizon. I played for about 2h yesterday and everything was fine.

Share this post


Link to post
Share on other sites
2 hours ago, ZiggyBClark said:

The path is: program files(x86)>Steam>steamapps>common>il2 stumovok Battle of Stalingrad>MODS>3Dmigoto_VRBOS_17.0.01>bin>game>then folders and dll files

Do I have this all correct?

Actually, the folder 3Dmigoto_VRBOS_17.O.1 is also in the IL2 Stumovik Battle of Stalingrad folder also, so is there twice. Both inside the MODS folder and outside. Could that be the problem?

 

You should store your JSGME MODS folder in another place than IL2 installl DIR.

The target folder for JSGME to deploy mod should be program files(x86)>Steam>steamapps>common>il2 stumovok Battle of Stalingrad>

At the end of activation of the mod, all the files and dir of the .zip file should be in the same place than IL2.exe.

If you do not know how to use JSGME, unzip the mod in a dir anywhere. Copy all the mod files and DIR (d3dx.ini, shaderfixes,..) that are in bin\game of the mod in bin\game of IL2 installation.

Share this post


Link to post
Share on other sites

After installing 17.0, the zoom IPD adjustment has no response (SHFIT + END OR PD). The file is not overwritten but deleted and reinstalled. It still has no effect.

Share this post


Link to post
Share on other sites

 

2 hours ago, =GW=a7610783 said:

After installing 17.0, the zoom IPD adjustment has no response (SHFIT + END OR PD). The file is not overwritten but deleted and reinstalled. It still has no effect.

 

Did you do ALT+F9 ? If no, please read the first post.

  • Like 1

Share this post


Link to post
Share on other sites

It worked fine initially, but I uninstalled it because was having low performnace.

Then re installed it and now 5X zoom looks double vision

Share this post


Link to post
Share on other sites
41 minutes ago, SCG_motoadve said:

It worked fine initially, but I uninstalled it because was having low performnace.

Then re installed it and now 5X zoom looks double vision

Use the zoom setting process documented in first post. I did not check performance but it should be the same as before: ~3 fps on 70 fps.

  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks for the update!

 

I have noticed fha using the X5 and more so the X10 zoom it makes my eyes hurt and gives me a headache...any ideas? Have I set it up wrong?

Share this post


Link to post
Share on other sites

Working great! Thanks lefuneste!

 

Badders, make sure you have each zoom adjusted properly. You may have to tweak them. You can adjust either fine or coarse (small or large). Adjust broadly with coarse; then dial in with fine. Also, keep in mind that once you zoom, you really need to stay still or the image will bounce. I have gotten used to holding my breath, especially in high zoom.

Edited by SCG_redcloud111
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, SCG_redcloud111 said:

Working great! Thanks lefuneste!

 

Badders, make sure you have each zoom adjusted properly. You may have to tweak them. You can adjust either fine or coarse (small or large). Adjust broadly with coarse; then dial in with fine. Also, keep in mind that once you zoom, you really need to stay still or the image will bounce. I have gotten used to holding my breath, especially in high zoom.

Thanks Red... I feel that it is adjusted properly but maybe it need some fine tuning. I have merged the two images and aircraft look pretty clear when zoomed in... If I get some time, I'll try and fine adjust...  Cheers! 

Share this post


Link to post
Share on other sites
2 hours ago, Badders46_VR said:

Thanks Red... I feel that it is adjusted properly but maybe it need some fine tuning. I have merged the two images and aircraft look pretty clear when zoomed in... If I get some time, I'll try and fine adjust...  Cheers! 

You should not have to "accomodate" (I do not know the word in english) when going in or out zoom. That is your eyes convergence  should be ok for both views, without any adaptation delay.

Edited by c6_lefuneste

Share this post


Link to post
Share on other sites

The mode works perfectly.
Thank you for providing the perfect mode for free.
It's a small amount, but I'm happy to be your supporter.

  • Like 1

Share this post


Link to post
Share on other sites
8 hours ago, -IRRE-Nyechou said:

Anyone knows how to turnoff gunsight on one eye now ?

That's no more possible now. At first I think it necessary, but with some improvement mades by devs some time ago it looks to me no more needed. It should be possible to add it again, but would involve making testing in shader, that may have a very slight fps impact.

  • Like 1

Share this post


Link to post
Share on other sites

@ all 

 

at the high zoom. INSERT + Lshift + END does not work for me.  do you have any idea why?

 

Quote

to increase/decrease global convergence for a zoom level :
press and maintain zoom key (PRIOR, HOME or INSERT)
press multiple time Lshift+PAGE DOWN or Lshift+END key

 

INSERT + Lshift+END not work 

INSERT + Lshift+PAGE DOWN     work fine

Edited by StG2_Raven_VR

Share this post


Link to post
Share on other sites
On 12/22/2019 at 8:00 AM, c6_lefuneste said:

You should not have to "accomodate" (I do not know the word in english) when going in or out zoom. That is your eyes convergence  should be ok for both views, without any adaptation delay.

I think it is set up correctly... I did find that where I am looking when zoomed was completely different so have adjusted up/down as necessary... Will keep going with it and it might be that I need to close my eyes as I zoom!

 

1 hour ago, StG2_Raven_VR said:

@ all 

 

at the high zoom. INSERT + Lshift + END does not work for me.  do you have any idea why?

 

 

INSERT + Lshift+END not work 

INSERT + Lshift+PAGE DOWN     work fine

 

I am still having the issue I was with ver 16 with Page Up zoom (1.5) and LShift+Page Down not working but Lefuneste couldn't replicate... Hopefully you can be fixed 👍🏻 It is strange as Pg Dwn works with all the other zooms and modifying inputs (shift, alt)

 

Thanks for the swift update! 

Share this post


Link to post
Share on other sites

I noticed some strange artifacts while using the latest version of the zoom while flying on CombatBox this weekend on one of the older Russian maps - the mission name is "Battle-For-Kalinin-Aug-1944". It appeared that clouds were casting shadows on the ground where they should not. Only occurred a few times and was not very noticeable. Probably not worth investigating unless others have noticed something similar.

Share this post


Link to post
Share on other sites

Dear Lefuneste, thank you so much for your work and time! This version of the mod in my opinion is the best one - pretty easy and fast to setup all zoom options and no need to watch .txt file to recall key combinations! Very impressive! Thank you!:good:

  • Like 1

Share this post


Link to post
Share on other sites
On 12/20/2019 at 11:13 AM, c6_lefuneste said:

Version 17.0 available in first post. As usual when the mod is broken, I did not spend too much time to test it.

Warning : it includes the new zoom help screen and the new sight strenght so  all user*.ini files have changed. If you are using files of version prior to 16.0 you must replace your files by the new ones and update them with your settings.

 

man, you're the best! Thank you for fixing it ASAP.

 

What scares me is that you're the only one who can fix this mod. What will happen if you stop playing IL2 ? 😄  Hopefully that day will never come!

 

 

Everyone, please sign up to lefuneste's Patreon account here:  https://www.patreon.com/lefuneste

 

It's an excellent incentive for the author to stay with the community for years to come! 😄

 

  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites
On 12/21/2019 at 10:40 AM, c6_lefuneste said:

 

 

Did you do ALT+F9 ? If no, please read the first post.


I tried this and the help menu is displayed well off to the right off with only a few words showing.  Is there a way to center the help menu?  Have a Pimax 8K and use the Pimax version of 3Dmigotofrom SCG_Fenris_Wolf.

Share this post


Link to post
Share on other sites
19 minutes ago, VBF-12_Stick-95 said:


I tried this and the help menu is displayed well off to the right off with only a few words showing.  Is there a way to center the help menu?  Have a Pimax 8K and use the Pimax version of 3Dmigotofrom SCG_Fenris_Wolf.

not so easy, I didn't think it wont work for a HMD. That's a shame because I have a 5K+ and did not try for other fov than small (too much stutter even with small settings...)

Edit setting_helper.hlsl in shaderfixes directory and try to modify the line #define DEST_BOX_UL_X 0.35

Replace 0.35 by a greater value if the text is too much on left, or decrease value if the text is too much on right. I'll add a setting in user files for next version.

Share this post


Link to post
Share on other sites

Thanks c6_lefuneste.  I have had another issue for a while and maybe it's related to the above.  When I try to converge any of the zoom levels I need to move them using the End key to bring the images together.  The problem is they only go so far then stop moving even though they need much more movement to converge.  When not in zoom everything else looks focused.  Convergence in zoom used to work in versions long ago but not the ones for the last, say, 6 months.  Could the #define DEST_BOX_UL_X 0.35 also help this issue?

 

One thing I do not understand in your instructions is:

"Very Coarse / Coarse / Fine settings mode can be toggled using CTRL + DEL key.  Start with Coarse mode (default), once you have find the rough setting go to fine mode."

 

Does this apply to zoom convergence keys also?  I am holding Page Up (low zoom) and then pressing LShift and End to move the images, how can I also use the CTRL and DEL keys for coarse movement?

 

Thanks for any help and enjoy the holidays!

 

Share this post


Link to post
Share on other sites
On 12/24/2019 at 6:08 PM, VBF-12_Stick-95 said:

Thanks c6_lefuneste.  I have had another issue for a while and maybe it's related to the above.  When I try to converge any of the zoom levels I need to move them using the End key to bring the images together.  The problem is they only go so far then stop moving even though they need much more movement to converge.  When not in zoom everything else looks focused.  Convergence in zoom used to work in versions long ago but not the ones for the last, say, 6 months.  Could the #define DEST_BOX_UL_X 0.35 also help this issue?

 

One thing I do not understand in your instructions is:

"Very Coarse / Coarse / Fine settings mode can be toggled using CTRL + DEL key.  Start with Coarse mode (default), once you have find the rough setting go to fine mode."

 

Does this apply to zoom convergence keys also?  I am holding Page Up (low zoom) and then pressing LShift and End to move the images, how can I also use the CTRL and DEL keys for coarse movement?

Did you switch parallel projection off in Pitool ? That's a great thing to do to improve fps but it involve changing your settings...

You toggle very coarse / coarse / fine settings outside zoom changing. The current increment setting is used for every setting change. Normally, you should start with very coarse setting, try to find the best convergence, change to coarse, make things better, change to fine and finalyze your settings.

The helper text show the current setting.

Edited by c6_lefuneste

Share this post


Link to post
Share on other sites

The zoom convergence buttons dont work, and fiddling in the files do nothing anymore, how i can fix the zoom now? :huh:

Share this post


Link to post
Share on other sites
8 hours ago, Cpt_Siddy said:

The zoom convergence buttons dont work, and fiddling in the files do nothing anymore, how i can fix the zoom now? :huh:

Did you try  Lalt + F9 ?

Share this post


Link to post
Share on other sites

never mind, i had keyboard language issues, switching back to eng fixed it. 

Share this post


Link to post
Share on other sites

@staff777 You need or joy2key or joystick gremlin for that. 

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...