Jump to content
c6_lefuneste

3Dmigoto mod : icon masked by cockpit, zoom for VR, color change, sight strengthened,...(13 features)

Recommended Posts

9 hours ago, rowdyb00t said:

 

Can you make this mod usable without 3Dmigoto?

 

No.

 

  

On 11/23/2019 at 2:00 AM, wju said:

 

of course!

...at least I do. 🙂

screenshots look very very nice

 

please, a small kick for dummies:  how to use it? simple copying both files into  "...\bin\game\ShaderFixes\"    seems to be not working

 

If you don't see banding without it you probably wont notice it. 

 

On 11/22/2019 at 3:51 AM, peregrine7 said:

 

Have you uploaded that tree fix anywhere? Looks fantastic!

 

Need to figure out the plane tree lighting first.

 

Also betelgeuse is actually in game, its just one of a decent number of literally black stars.

928489565_orionbeetblackstar.png.42b0bff4741b3e716280e7d795259ed9.png

  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites

New version 15.1 available in first post.

What's new:

  • Fix some bugs, especially with cloud and view rotation, shadow on ground,..
  • New mode for sight : same behavior as original but more brighter. A brightness factor can be customized in user_var_initialization.ini
  • Cloud fix is back, I can not wait the final fix by devs, I need to lower cloud settings to save fps untill there will be a fix for stuttering.
  • Capacity to use 3Dmigoto zooms in 2D (not very usefull from my point of view) by setting a variable (and modifying zoom keys)
     

Warning : user files are updated, you better have to update the new ones with your settings.

 

Here is an example of the improvement :

Cloud_fix.gif

Edited by lefuneste
  • Like 1
  • Thanks 3
  • Upvote 1

Share this post


Link to post
Share on other sites

Dear Lefuneste,

For me , last version from today is turning all the screen black, but only when you start flying. At first, I thought it was a problem caused by the inclussion I do of some LizLemon shaders. (his sun shader he created is a must for me).  But that was not the problem. I uninstalled everything and started from zero, with no external shaders, and the black screen appeared anyway.

Can you check it?   Thanks a lot.

 

  • Upvote 1

Share this post


Link to post
Share on other sites

@Lefuneste

Me too,😢! When start flying i've black screen (game running ) any hint, please?

Anyway, Thanx so much for your outstanding work!

Share this post


Link to post
Share on other sites
1 hour ago, SARFlytitus said:

@Lefuneste

Me too,😢! When start flying i've black screen (game running ) any hint, please?

 

That's strange. I install again the mod from the provided zip and it works...did you use all the files provided in users_settings without modifying them or using  your old files ?

In this case, can you post your graphics settings ?

 

Share this post


Link to post
Share on other sites

@lefuneste

 

Hi, Lefuneste, Thanx for your reply! Anyway, first i've disabled  ver. 15   and then, as usual, installed via jsgme  ver. 15.1 without using my old settings. 

Launched the game and when i'm ready to fly : black screen!

I can ear clearly the game running but: Black Screen.

Exit from mission, exit to desktop, reversing the process, back to ver. 15 ,reenter the game, launch mission : all works flawlessy, smooth as the silk.

 

I play in VR, Win 10, Oculus CV1 , OTT, Open Composite, ASW off, 1.1 ss via OTT, RTX 2060 Super, 24 Gb Ram , I7 @4,5 Ghz , SSD,

 

HIGH

Shadows= medium

Mirrors= simple

Dist. Landscape=x2

Horiz. draw dist.= 100km

Landscape filter=blurred

Grass=normal

Clouds=high

AA=4

Fullscreen 

HDR

Sharpen

4K text.

No FPS limit

Vsync=off

 

With these settings the game is super smooth and a joy to fly, maybe now and then, some drops of frames but never below 45 fps.

 

I hope I have provided sufficient explanations to allow you to shed light on this problem

Thanx again and keep up the good work!😉

ListOfMods.thumb.jpg.76f3ad929a6a3cf5ac3e1f07f9b806e4.jpg

Edited by SARFlytitus

Share this post


Link to post
Share on other sites
16 hours ago, LizLemon said:

If you don't see banding without it you probably wont notice it. 

 

 

I was adoring very nice tree screenshot not the banding, and consequently was asking how to enable it.  Simple copying your files into lefuneste mod did not change anything, at least in my VR

never mind, I can live without it..

Share this post


Link to post
Share on other sites
8 hours ago, SARFlytitus said:

@lefuneste

 

Hi, Lefuneste, Thanx for your reply! Anyway, first i've disabled  ver. 15   and then, as usual, installed via jsgme  ver. 15.1 without using my old settings. 

Launched the game and when i'm ready to fly : black screen!

I can ear clearly the game running but: Black Screen.

 

 

HIGH

Shadows= medium

Mirrors= simple

Dist. Landscape=x2

Horiz. draw dist.= 100km

Landscape filter=blurred

Grass=normal

Clouds=high

AA=4

Fullscreen 

HDR

Sharpen

4K text.

No FPS limit

Vsync=off

 

 

It was linked to HDR, I comment out some lines in d3dx.ini by mistake. It should be ok with the 15.1.1 in the first post.

 

Share this post


Link to post
Share on other sites

I did not write it, but setting for cloud is handled in the same way than zoom, now. Set it on or off with key mapping and save it by F12.

Share this post


Link to post
Share on other sites

I've just downloaded Game Update 4.002 (1.21Gb) and am very happy to report the mod was not affected.

Still works perfectly.

  • Thanks 3

Share this post


Link to post
Share on other sites
1 hour ago, Gordon200 said:

I've just downloaded Game Update 4.002 (1.21Gb) and am very happy to report the mod was not affected.

Still works perfectly.

Thanks so much for reporting that! I saw the update and was dreading that heheh

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Gordon200 said:

I've just downloaded Game Update 4.002 (1.21Gb) and am very happy to report the mod was not affected.

Still works perfectly.

copy this 👍

 

  • Like 1

Share this post


Link to post
Share on other sites
18 minutes ago, lefuneste said:

And the cloud fix is still improving things, even with the new clouds (at least for med. cloud)

 

I like the contrast boost. Hey what's the consensus on the minimum cloud required for competitive multiplayer? Previously I would run 'High' clouds because they just plain looked like garbage on anything lower (they animated in a very unrealistic and distracting way). But if they look okay on Medium I'll take the extra FPS please.

 

Edit: I've just noticed the additional gunsight setting. Could you describe the approximate difference between setting 6 (original with mul factor) and your modified sight? I'm pretty sure I have been using the modified sight up until now. Is setting 6 better in some way?

Edited by Alonzo

Share this post


Link to post
Share on other sites
1 hour ago, Alonzo said:

Edit: I've just noticed the additional gunsight setting. Could you describe the approximate difference between setting 6 (original with mul factor) and your modified sight? I'm pretty sure I have been using the modified sight up until now. Is setting 6 better in some way?

 

In fact I'm so convinced that I will suppress the former modes in next version of the mod. The former modes are using a threshold and replace current color with new color if pixel transparency is lower than threshold. The "6" mode is only multiplying 1/transparency value by a factor. It works for both VR and 2D, there is no more need to track sight texture and it allows to easilly have different brightness  values in game (for night flight for example) or to switch it off. I could add settings to choose eye, but finally I found new sight rendering correct for both eyes (except the brightness).

Share this post


Link to post
Share on other sites

It seems the kneepad function has stopped working in the new version? Anyone else see this, or just on my end?

Share this post


Link to post
Share on other sites
1 hour ago, lefuneste said:

 

In fact I'm so convinced that I will suppress the former modes in next version of the mod. The former modes are using a threshold and replace current color with new color if pixel transparency is lower than threshold. The "6" mode is only multiplying 1/transparency value by a factor. It works for both VR and 2D, there is no more need to track sight texture and it allows to easilly have different brightness  values in game (for night flight for example) or to switch it off. I could add settings to choose eye, but finally I found new sight rendering correct for both eyes (except the brightness).

As long as we can keep the standard sight available, so I can keep alternating between "on/off". Having it in just one eye is unrealistic anyway, no tears if you remove that 🤩

  • Upvote 1

Share this post


Link to post
Share on other sites

Completely disabled tracer scaling effect. This is probably going a bit to far but try it out and tell me what you think. Its pretty easy to change. Might be best to keep the length scaling and nerf the width.

619647539_tracertest.thumb.jpg.3d3ee80240deee31200c1213635d29c1.jpg

PUT IN SHADER FIXES FOLDER.zip

  • Like 1
  • Upvote 2

Share this post


Link to post
Share on other sites
On 11/11/2019 at 4:53 AM, SCG_redcloud111 said:

KreamSickle. This happens after every update and is expected. Lefuneste has stated he will get to it end of the week.

 

I was merely trying to provide more information so he could troubleshoot the issues further and more accurately.

I understand it will break. Working in IT this is all too common and expected.

 

Lefuneste - Also I seem to be having an issue now with JSGME. After downloading 15.1.1 and removing 14.1 I enabled 15.1.1 and none of the keybinds seem to be working.

I checked the IL2.exe path, and only found the D3DX_USER.ini file was not being updated from 11/10/2019 so I removed it to see if it would create the file again, but it didn't.

 

Is there anything else I should make sure is removed that JSGME might have missed?

 

Edited by KreamSickle

Share this post


Link to post
Share on other sites
8 hours ago, KreamSickle said:

I checked the IL2.exe path, and only found the D3DX_USER.ini file was not being updated from 11/10/2019 so I removed it to see if it would create the file again, but it didn't.

 

Is there anything else I should make sure is removed that JSGME might have missed?

 

 

d3dx_user.ini contains only values for zoom settings. It is only updated when you press F12.

I hope you saved it, otherwise you'll have to redo all your convergence settings.

If no key binding is working, maybe that's because the mod was not installled where you think ?

Best thing to do : unsintall the mod and check that only d3dx_user.ini remains (no d3dx.ini or shaderFixes dir) in the same directory than IL2.exe

Install the mod and check that you have at least d3dx.ini and shaderFixes dir in the same directory than IL2.exe.

That should works.

Share this post


Link to post
Share on other sites
3 hours ago, c6lefuneste said:

 

d3dx_user.ini contains only values for zoom settings. It is only updated when you press F12.

I hope you saved it, otherwise you'll have to redo all your convergence settings.

If no key binding is working, maybe that's because the mod was not installled where you think ?

Best thing to do : unsintall the mod and check that only d3dx_user.ini remains (no d3dx.ini or shaderFixes dir) in the same directory than IL2.exe

Install the mod and check that you have at least d3dx.ini and shaderFixes dir in the same directory than IL2.exe.

That should works.

Yeah I did that a couple times and no go. Functionality for me with jsgme is broken. I ended up installing the mod the manual way and it works as expected.

 

It's not a big deal without jsgme. I'm happy the mod is working and love what you've done here. I wouldn't be able to enjoy this sim as much as I do.

 

Thank you for your hard work sir.

  • Like 1

Share this post


Link to post
Share on other sites

Hello,

 

Here is the new 16.0 version to test: http://www.mediafire.com/file/y9xkoq8wnv64yjx/3Dmigoto_VRBOS_16.0.zip/file

I had to spread the 15.1 version before finished it, because of the bug with cloud and rotation, so that makes a lot of version in a few time...

What's up:

  • New sight strenghtenent, the "6" mode of the 15.1 is now the only one available, I found it very nice and less prone to bug than other implementations, after some testing. By default the mode provide a 2x strenght. The LALT+K key cycle through this settings: 4x strenghtened (for Ru sight ?), normal, half strenght (for night flights ?), no sight, 2x strenghtened.
    Of course you can customize it
  • New way to setup zoom parameters. You have now to press "LALT+F9" in order to modify parameters. This will display help messages and realtime values of different settings, depending of the current mode (none, low zoom, Med zoom, high zoom, IPD). I also add a "very coarse" increment setting, to lower the number of keypress to setup convergence.
    I had to display help messages for one eye only to avoid convergence problems. Here is what it looks like :
    2019_11_29__9_53_1.thumb.jpg.6b52704d8d01df5d777a2a02fd4a6299.jpg

I place and size the messages hoping that it will works for all VR helmet. It is OK for my Pimax 5K+.

I did not find the messages too cumbersome to setup zoom parameter.

 

Can some of you test this version and report what they think about the new setting mode, before I update the first post with this version ?

All files in user_settings have been updated, so you'll have to put your custo inside them again, if you had some. Of course, your zoom settings will be kept, as they are stored in d3dx.user.ini, that is not included in mod.

 

  • Like 5
  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, c6_lefuneste said:

Can some of you test this version and report what they think about the new setting mode,

It's fantastic! Very handy addition, lefuneste.

Now there is no question the adjustments are being made and in which direction with the LALT-F9 feature.

 

Share this post


Link to post
Share on other sites

Thanks for all the improvements!

The latest mod 16.o seems to have disabled the option to shut off the propeller spin with Lshift K.

QB. Piranha

Share this post


Link to post
Share on other sites
On 11/30/2019 at 12:24 AM, QB.Piranha said:

The latest mod 16.o seems to have disabled the option to shut off the propeller spin with Lshift K.

 

a "$" is missing in user_keymapping.ini as shown below:

 

[Key5]
; toggle propeller
; 0  :propeller on
; 1 : propeller off
Key = SHIFT no_alt no_ctrl k
type = cycle
$propellerOffFlag = 1.0, 0.0

 

I will include the fix in the official version but meanwhile you can modify the file yourself.

Share this post


Link to post
Share on other sites
On 11/27/2019 at 9:02 PM, LizLemon said:

Completely disabled tracer scaling effect

 

I'm interested in this modification, but when I try it with v15.1.1 (unzip the file to bin\game\ShaderFixes) I get a conflicting shader message when starting the game, and tracers don't seem to be displayed. Am I doing something wrong?

Regarding the options you mention, I'd prefer no scaling at all. Is it possible to also disable the scaling of plane lights?

Edited by yeikov

Share this post


Link to post
Share on other sites

I'm using this mod for at least a year now and I'm feeling I should simply express my gratitude to @c6_lefuneste for having created this gem.

 

Many features are somewhat things I would expect to be part of the core game, like the icon management. 

 

What I like the most is the ability to switch the reticle on and off. This is a feature that I was really missing since BoS started. 

I edited the config in that way, that the reticle is toggled on and off by hitting the space key and I have not to cycle through the 4 or 5 different versions of the reticle delivered with this mod. This is just awesome. 

 

So it's time to just say a big TY! :)

  • Upvote 1

Share this post


Link to post
Share on other sites

Hello guys. 

First of all thanks  thanks to c6_lefuneste for suck a great mod, its made my VR experience way better, was having some trouble at first with crossed eyes view zoom with my Rift S but then I found the version corrected for Rift S and it works perfectly. 
The only issue I'm having is I was using the 14.1 and it worked fine with the gunsight mode using only the right eye, once I've updated for the 15.1 (Rift S  Version) It went back to the normal view, alredy changed the the line in the "user_var_initialization" y2 = 0 to y2 = 4 and it didnt work. 
Any ideas? 

"S"

 

Share this post


Link to post
Share on other sites
On ‎12‎/‎9‎/‎2019 at 3:52 AM, Dark_Jak said:

The only issue I'm having is I was using the 14.1 and it worked fine with the gunsight mode using only the right eye, once I've updated for the 15.1 (Rift S  Version) It went back to the normal view, alredy changed the the line in the "user_var_initialization" y2 = 0 to y2 = 4 and it didnt work. 

 

That should work... But I will disengage the left/right eye feature (already done in the 16 version, see the post of the November, 29 above) because it's no more cumbersome, as devs made some improvement for sights. 

Edited by c6_lefuneste

Share this post


Link to post
Share on other sites

The latest version of d3dx.ini seems to cause the game to crash to desktop immediately on launch.  I get a black screen for a fraction of a second then the game dies.

 

Windows 10 Event viewer gives me:

Faulting application name: Il-2.exe, version: 1.0.0.1, time stamp: 0x5ddc197a
Faulting module name: ucrtbase.dll, version: 10.0.18362.387, time stamp: 0x4361b720
Exception code: 0xc0000409
Fault offset: 0x000000000006db8e
Faulting process id: 0x2e0
Faulting application start time: 0x01d5afdd62eb6509
Faulting application path: C:\games\Steam\steamapps\common\IL-2 Sturmovik Battle of Stalingrad\bin\game\Il-2.exe
Faulting module path: C:\WINDOWS\System32\ucrtbase.dll
Report Id: 068d377c-a8fe-4d2c-a677-1d19ce84883b
Faulting package full name: 
Faulting package-relative application ID: 

 

I'm using Generic Mod Enabler.  The game loads successfully with my old v11.0 install.  When I put 15.1.1 or the 16.0 beta in, the crash returns.  Video drivers are up to date.  Bodenplatte content is purchased but not yet installed.

 

Anything else I can provide that'll be of use?  Thanks!

 

Share this post


Link to post
Share on other sites

Hey, Lefuneste. With 15.1.1, I was flying Stalingrad/winter on TAW at 6k (Pimax 5k+, Normal FOV). When I used the snap turn to either side (30degrees) there is some strange horizontal banding along the far horizon. See the track. Let me know if you need anything else. Thanks!

Tracks.zip

Edited by SCG_redcloud111

Share this post


Link to post
Share on other sites

Guys is it possible to map ie. zoom button directly to joy key wthout the use of the given  joystick programming tool? If its possible can any1 give an example of config?

Share this post


Link to post
Share on other sites
1 hour ago, SCG_redcloud111 said:

Hey, Lefuneste. With 15.1.1, I was flying Stalingrad/winter on TAW at 6k (Pimax 5k+, Normal FOV). When I used the snap turn to either side (30degrees) there is some strange horizontal banding along the far horizon. See the track. Let me know if you need anything else. Thanks!

Tracks.zip 736.07 kB · 0 downloads

There are a lot of glitches for high angles, this is why I provide default values for 20° only. Can you check if the problem exists also for low angles ?

Share this post


Link to post
Share on other sites
1 hour ago, JG700_Benek said:

Guys is it possible to map ie. zoom button directly to joy key wthout the use of the given  joystick programming tool? If its possible can any1 give an example of config?

 

The tool "joy2key" will do this.

It is not possible without a 3rd party program afaik.

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...