Jump to content
lefuneste

3Dmigoto mod : icon masked by cockpit, zoom for VR, color change, sight strengthened,...(13 features)

Recommended Posts

4 hours ago, Alonzo_LW said:

 

It works on the Rift S, we just need to help people get the convergence dialled in. There are a couple of users with config settings floating around (me included but I only have the 5x zoom working for the moment).

 

Im away for work at the moment but I’ve got some profiles to try when I get back home. It’s my job for Monday. 

 

Do do you have your 5 x zoom settings? That would probably do me if combined with the standard zoom.

Share this post


Link to post
Share on other sites
Posted (edited)

there is an issue on external view, the blur effect is applied every where on low level flying, cockpit view is not effected by this

Edit: after turning landscape to "Sharp" the issue is resolved for the moment but i would like to have blur filter, hop you can fix it soon.

thank you for your work.

2019_6_8__17_7_7.jpg

2019_6_8__17_7_5.jpg

Edited by IV./JG51-G_Schwarz

Share this post


Link to post
Share on other sites
On ‎6‎/‎8‎/‎2019 at 9:01 AM, Alonzo said:

 

It works on the Rift S, we just need to help people get the convergence dialled in. There are a couple of users with config settings floating around (me included but I only have the 5x zoom working for the moment).

 

Alonzo, follow this link to Durafen's post. He has done  a great job on Rift S zoom settings.

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Today zoom does not work for ground (cockpit, roads, woods and planes are zoomed). Is maybe my installation broken, or is it for all?

  • Upvote 1

Share this post


Link to post
Share on other sites

You must pray to Lefuneste and sacrifice a lamb. For he is the holy mod creator, second only to Charlemagne and czech Pilsen.

  • Haha 1
  • Upvote 1

Share this post


Link to post
Share on other sites
Posted (edited)

@lefuneste.

I have the same problem that @307_Tomcat and @Brzi_Joe are experiencing.

When using the 10X zoom (Odyssey+) the landscape remains unchanged and all target objects like buildings, planes, boats and trains disappear.

Before updating today I disabled the mod using PSGME. Updated and reactivated the mod with above results.

Only tested in QM but all maps and planes I tried had same result.

Edited by Gordon200

Share this post


Link to post
Share on other sites

if you read the first post, you will notice it is mentioned the mod will be broken once 262 is out...

Share this post


Link to post
Share on other sites

Same issue here. If you used JSGME, just de-activate the mod for now - that will fix the weird ground texture and disappearing objects when using zoom.

Share this post


Link to post
Share on other sites

Guys, each patch the mod has to get updated. Lefuneste spends hours into it to do that, to find the shaders again.

 

And he doesn't even have a Patreon account.... 🤯

Share this post


Link to post
Share on other sites

 

Is it possible to hope that the zoom will return to working condition?

without him at vr almost unreal. I wondered why the developers
will not sew in the game some sort of 5-fold official zoom

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, =VP=Duke__ said:

 

Is it possible to hope that the zoom will return to working condition?

without him at vr almost unreal. I wondered why the developers
will not sew in the game some sort of 5-fold official zoom

 

I don't think developers have coded the zoom we have in VR. It must come pre-packaged in the VR API and likely the devs don't even know how to change it

Edited by Nibbio

Share this post


Link to post
Share on other sites

Hello,

I know the impact of new version, unfortunately the program I used to modify shaders has a bug for this version.

Not a blocking issue, but time to spend. As they did relase the version a Monday instead than a Friday, I'm not sure to be able to find the time before the next week end.

  • Like 2
  • Thanks 11
  • Upvote 3

Share this post


Link to post
Share on other sites
5 hours ago, lefuneste said:

Hello,

I know the impact of new version, unfortunately the program I used to modify shaders has a bug for this version.

Not a blocking issue, but time to spend. As they did relase the version a Monday instead than a Friday, I'm not sure to be able to find the time before the next week end.

Thank you man for the update... !!!

Share this post


Link to post
Share on other sites

I appreciate the time and hard work you put into this for the community... Thank you!

Share this post


Link to post
Share on other sites

Hi Guys.

First I'd like to thank everyone with this effort, especially Lefuneste. It is greatly appreciated.. I've been playing IL-2 for some time now but wasn't dedicated due to children! haha.. However, I'm getting more and more time and want to get real with it!

With that said, I just picked up the new Oculus Rift S... and i've made some changes to VR settings ( steam) and OTT (Pixel density and SS, etc). I use to get no higher than 45 FPS.. .Now i'm strictly between 45 FPS and 75 FPS... I would say its closer to 50-55 FPS.. I want to make everything as smooth as possible and just learned about the 3DMigoto mod. I'm just a little bit unsure of what i'm doing. Is there a blanket version I can download. I see there are many versions of it.. 12.2, 12.3, 12.4, 12.5.... I'm sure sure where to go. Haha.. With that said, my specs are i7 7700HQ / GTX 1070 8 gb / 16 gb RAM.

I'm unable to run the Rift S without running the Oculus home exe. Apparently that changed between the CV1 and S. 

Any help would be appreciated. After installing, I think i'd be fine with editing the configs, just unsure which one to use. 

Additionally, for key mapping, is it possible to key map zoom and other features to my VKB Gladiator? 

Thanks again,
Scott

Share this post


Link to post
Share on other sites
Posted (edited)

Hi Guys,

 

I just started playing in Rift S and I have some questions regarding settings in Steam VR and Oculus Tray.

 

I would like to play without ASW if possible. I find it better when I get 80 fps instead of 40fps and ASW. 80 fps is less nauseating.

 

I am confused about Steam VR and OTT. Would changes to OTT have effect on IL-2 in VR since it seems to run on Steam VR?

 

I changed Steam VR settings from 150 % to 100% and can't really see any decrease in image quality.

 

Steam VR says Reprojection is ON , can I switch it off there or is it only possible in OTT app.

 

Any other tricks to get better performance? 

 

Anything in BOS settings that can be reduced to increase FPS without greatly ruining image quality?

 

Only time I get 80fps currently is when flying solo over see on Kuban map.

 

specs: i7 4770K stock speeds, 2133 Mhz RAM and GTX 1080.

 

I have new mobo and i7 9700K and 3600 Mhz DDR4 RAM but I will not build my new PC until weekend.

 

Any suggestions guys?

Edited by 307_Banzai

Share this post


Link to post
Share on other sites
29 minutes ago, Gamble said:

I want to make everything as smooth as possible and just learned about the 3DMigoto mod. I'm just a little bit unsure of what i'm doing. Is there a blanket version I can download. I see there are many versions of it.. 12.2, 12.3, 12.4, 12.5.... I'm sure sure where to go. 

I would suggest holding off until we get a new version of the mod. 12.5 isn't working with the latest patch that was released.

Share this post


Link to post
Share on other sites
24 minutes ago, TWC_Creep said:

I would suggest holding off until we get a new version of the mod. 12.5 isn't working with the latest patch that was released.

 

Sounds good. That last patch that came out a day or two ago? It was a hefty one...

So I'll stick to what I have for now.

33 minutes ago, 307_Banzai said:

Hi Guys,

 

I just started playing in Rift S and I have some questions regarding settings in Steam VR and Oculus Tray.

 

I would like to play without ASW if possible. I find it better when I get 80 fps instead of 40fps and ASW. 80 fps is less nauseating.

 

I am confused about Steam VR and OTT. Would changes to OTT have effect on IL-2 in VR since it seems to run on Steam VR?

 

I changed Steam VR settings from 150 % to 100% and can't really see any decrease in image quality.

 

Steam VR says Reprojection is ON , can I switch it off there or is it only possible in OTT app.

 

Any other tricks to get better performance? 

 

Anything in BOS settings that can be reduced to increase FPS without greatly ruining image quality?


I don't have all the answers to yours... but... Changes in OTT do have effect even though IL-2 is running on Steam VR... Do I know why? No.

 

I would also like to know the answer regarding Reprojection? Is projection the same as ASW? If that's the case, I disabled it on OTT.

Sub'd for any other tricks for better performance. 

What are you current FPS in a dog fight close to ground level? I'm right around 45...

Share this post


Link to post
Share on other sites
1 hour ago, 307_Banzai said:

Hi Guys,

 

I just started playing in Rift S and I have some questions regarding settings in Steam VR and Oculus Tray.

 

I would like to play without ASW if possible. I find it better when I get 80 fps instead of 40fps and ASW. 80 fps is less nauseating.

 

I am confused about Steam VR and OTT. Would changes to OTT have effect on IL-2 in VR since it seems to run on Steam VR?

 

I changed Steam VR settings from 150 % to 100% and can't really see any decrease in image quality.

 

Steam VR says Reprojection is ON , can I switch it off there or is it only possible in OTT app.

 

Any other tricks to get better performance? 

 

Anything in BOS settings that can be reduced to increase FPS without greatly ruining image quality?

 

Only time I get 80fps currently is when flying solo over see on Kuban map.

 

specs: i7 4770K stock speeds, 2133 Mhz RAM and GTX 1080.

 

I have new mobo and i7 9700K and 3600 Mhz DDR4 RAM but I will not build my new PC until weekend.

 

Any suggestions guys?

You need to go to the VR section of the forums, a subsection to hardware forums.

 

But to take the answer away ahead, I must tell you no, there is no option on your old PC to increase FPS without ruining image quality. The GPU is fine, but the rest is not. You need to build your new i7 in with the new RAM and overclock the CPU to 4.9 or better 5.0GHz - with AVX offset to 0 - in order to not bottleneck the system for IL-2 in VR.

  • Thanks 1

Share this post


Link to post
Share on other sites
On 6/11/2019 at 1:58 AM, SCG_Fenris_Wolf said:

Guys, each patch the mod has to get updated. Lefuneste spends hours into it to do that, to find the shaders again.

 

And he doesn't even have a Patreon account.... 🤯

 

Good news: bug fixed in the program I used to modify shaders. Zoom are working now, but I have to chase all shaders that must not be zoomed (otherwise there are glitches), some of them have change, as usual.

@SCG_Fenris_Wolf : I made a Patreon account : https://www.patreon.com/lefuneste

I did not know what it was. Now I will show off with colleagues and attempt to make them believe I'm a creator 😀

  • Thanks 10
  • Upvote 3

Share this post


Link to post
Share on other sites

Thanks to Fenris for setting up the Patreon account. I am happily contributing. Small price to pay for the benefit, for sure!

  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks all for your contributions. I'll be able to show off with colleagues, now :)

There is a new hotfix, I'm happy that I did not find the time to finish the mod yesterday, it may have new shaders...

Anyway, I wonder what means "all closed gunsight cameras have 2x zoom enabled by default"

They double zoom factor when your PoV is close to sight ? It won't help too much if you have to line up your plane for each  target you want to look at.

But maybe a good solution for ground straffing.

 

Share this post


Link to post
Share on other sites
9 hours ago, Gordon200 said:

The increased zoom in VR is for tank gun sight view and did not effect normal pilot zoom.

 

Share this post


Link to post
Share on other sites

Extension of building draw distance. This has the downside of making the building fade-in distance shorter which means they will 'pop in' a bit more noticeably. On the plus side high-alt bombing is now much more feasible.

1690771496_drawdistance3dmigoto.thumb.png.a59116160a53b78c9db63ba42ed3045f.png

 

 

 

~~~~~~~~~~~~~~~~~~~~INSTALL~~~~~~~~~~~~~~~~~~~~~~~~~~~~

copy this shader to the shaderfixes folder in xxxxxx\IL-2 Sturmovik Battle of Stalingrad\bin\game

dd 3dmigoto.zip

  • Upvote 2

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, LizLemon said:

~~~~~~~~~~~~~~~~~~~~INSTALL~~~~~~~~~~~~~~~~~~~~~~~~~~~~

copy this shader to the shaderfixes folder in xxxxxx\IL-2 Sturmovik Battle of Stalingrad\bin\game

dd 3dmigoto.zip 4.98 kB · 3 downloads

Is your dither fix still working with the last BoS version ? It seems to me that I saw bandwith during my testings

EDIT : I think that your shader may break the zoom for the building...

Edited by lefuneste

Share this post


Link to post
Share on other sites
Posted (edited)

Hi Lefuneste! Appreciate all your work and the time you`ve  invested in...Keep going!!!

 

 as you not update your "Fix" on HelixmodBlog and many 3DVision Users suffer from the mysterious DXBufferMan11:VB/ dxgi Error , i will describe my solution here as i have in the Nvidia Problems Thread in this Forum, because your newest Fix worked like a charm with 3D Vision;

 

Hi Guys! After weeks and weeks with the DXBufferman:vb Error,that only occurs with 3D vision on in NCP on all older an newer Drivers from GTX700 Cards to all newer 2000 RTX Cards (tested all from 416-430... with 3D Vision extra installed after 425 😉),   and a Win 10 reinstall i found a fucking simple Solution: Install the newest Reshade, and the Bufferman Error/dxgi Error is gone for me....Has installed IL2 4/5 times in the last 2 weeks, never used Reshade for this Game , cant explain this ...

 

 

Edited by 4aoStk15

Share this post


Link to post
Share on other sites

New 13.0 version online, see first post. I made few testings, so there may be missing shaders or glitches.

You can keep the user_keymapping_zoom.ini prior to 12.5, it should works.

For guys who have installed 12.5, you may have a red text at Il2BoS launch, pressing  F12 should solve it. I changed the way to set IPD like modifier, it use now same keys than zoom for convergence but it creates this message.

I made a bench with first mission of panzerknacker campaign. The mod still create  a loss of 5-6 fps, I did not find an obvious thing to change.

 

  • Thanks 2

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks lefuneste. Great work and excellent turn around on the new mod.

 

I am still getting artifacts after installing 13.0 on x5 and x10 zoom.   Trying to find something obvious for it.

One thing I can think of is I took the D3DX.ini file out of BOS ......Steam\steamapps\common\IL-2 Sturmovik Battle of Stalingrad\bin\game folder prior to installing 3D Migoto13.0

Noticing BOS was running ok but got the red text warning of an issue with D3DX.ini. Doh obvioulsy because I took it out of there earlier. So I repasted the original back in there.  Red text message disappeared next time I started the game. Now I have x5 and x10 zoom again but the artifacts are back.

 

Using JGSME to use the mod.

Edited by TWC_Sp00k

Share this post


Link to post
Share on other sites
Posted (edited)
56 minutes ago, TWC_Sp00k said:

Thanks lefuneste. Great work and excellent turn around on the new mod.

 

I am still getting artifacts after installing 13.0 on x5 and x10 zoom.   Trying to find something obvious for it.

One thing I can think of is I took the D3DX.ini file out of BOS ......Steam\steamapps\common\IL-2 Sturmovik Battle of Stalingrad\bin\game folder prior to installing 3D Migoto13.0

Noticing BOS was running ok but got the red text warning of an issue with D3DX.ini. Doh obvioulsy because I took it out of there earlier. So I repasted the original back in there.  Red text message disappeared next time I started the game. Now I have x5 and x10 zoom again but the artifacts are back.

 

Using JGSME to use the mod.

 

Uninstall the mod. Check that there is nothing remaining of it in BOS ......Steam\steamapps\common\IL-2 Sturmovik Battle of Stalingrad\bin\game folder

Install it again with default files.

Launch BoS, do not use your helmet but screen mirroring, because convergence may be KO.

See if there is still problems.

  • It yes, give a track and your graphics settings so I can try to reproduce.
  • If no, try to customize the mod for your settings and see if the problems are created by this operation.
Edited by lefuneste

Share this post


Link to post
Share on other sites
2 hours ago, lefuneste said:

New 13.0 version online, see first post. I made few testings, so there may be missing shaders or glitches.

 

Hi Lefuneste. Mod looks like it's working, I did a quick test flight around an airfield. I have discovered a problem with the vertical offset of the zoom.

 

I noticed that using Durafen's settings for the Rift S (and previously in my own testing) that there is a 'snap' between the initial zoom, and where the zoom goes once you press a vertical adjustment hotkey. First is medium zoom. Camera is roughly centered on the fuel drums. Medium zoom goes below the drums, but then when I push LCTRL + PGDN it 'snaps' to the correct position. Same for the 10x zoom. This behavior is the same in flight and leads to both the 5x and 10x zoom being too "low" compared to centered view, and the fine-tuning does not help, because it activates the extra correction.

 

Here is a video demonstrating the issue. To get the zoom to 'snap' up to the correct vertical, I am pressing LCTRL+PGDN, one of the "fine tune" hotkeys.

 

 

Share this post


Link to post
Share on other sites

im confused how to adjust zoom convergence in this new update.... before i would change the 1.3 and then the 0.6 ... now i am just confused, can someone explain to me how to adjust the zoom convergence please

 

Share this post


Link to post
Share on other sites
2 hours ago, Alonzo said:

 

Hi Lefuneste. Mod looks like it's working, I did a quick test flight around an airfield. I have discovered a problem with the vertical offset of the zoom.

 

I'll have a look. The Pimax dors not need vertical offset, so I did not test it fully.

 

10 minutes ago, -332FG-Buddy said:

im confused how to adjust zoom convergence in this new update.... before i would change the 1.3 and then the 0.6 ... now i am just confused, can someone explain to me how to adjust the zoom convergence please

 

No more needs to fill values. You have two options : either you copy your old user_keymapping_zoom or you use the interactive way described in "customisation" section of first post.

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Alonzo said:

 

Hi Lefuneste. Mod looks like it's working, I did a quick test flight around an airfield. I have discovered a problem with the vertical offset of the zoom.

 

Stupid me. I already fixed this problem some time ago but did not report it in the last version.

Remove the line "; $zoomYoffset = 0.0    " for each key section  of "user_keymapping_zoom.ini'. Anyway, I will update a new 13.0.1 version with the good file.

Edited by lefuneste
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...