Jump to content
c6_lefuneste

3Dmigoto mod : icon masked by cockpit, zoom for VR, color change, sight strengthened,...(13 features)

Recommended Posts

There is an uninstall.bat file included as part of the mod that can remove the mod. Not sure of its exact location as I am at work. I want to say the bin folder.

Share this post


Link to post
Share on other sites

Do that only if you are using a 10

7 hours ago, =EXPEND=Tripwire said:

There is an uninstall.bat file included as part of the mod that can remove the mod. Not sure of its exact location as I am at work. I want to say the bin folder.

 

The file is where the mod is installed, and where the IL2.exe is (game/bin or bin/game, I do not remember I can not check now). Use it only if you are using a version >= 10.6 otherwise you will have to install again directX.

Share this post


Link to post
Share on other sites
16 minutes ago, lefuneste said:

New 11.0 for 3.010 available in first post.

I finally find the time today 😀

 

double upvote for you, bud! Only if I could double upvote though... 😄  will try it out in couple of hours!

Share this post


Link to post
Share on other sites

To install the new update, I can just copy the content from the new patch zip into my IL2 directory like I did with the previous mod, right?

 

I've only been using the mod since last week, it seems I don't have to worry about .ini files or anything?

Edited by flyinj

Share this post


Link to post
Share on other sites

It is always best to remove the previous version.

If you have modified some files in user_settings you should also backup them before removing the version.

 

Share this post


Link to post
Share on other sites

Just installed and seemed to fix the floating buildings.  Just remember to save your user settings as it will be uninstalled or written over.

Thanks lefuneste!

Share this post


Link to post
Share on other sites

Was there another game patch that broke zoom again? On my pimax 5k+ seems, that right eye zoom is zooming way too far to the right (I tried to change zoom factor in user settings file without success) . I started game with 10.7 mod today, and it had this issue. Afer removing with bat uninstal file and updating to 11.0 still have the same issue. I see in the steam that there were IL 2 download 59.8 Mb today.

Edited by =LwS=Balapan

Share this post


Link to post
Share on other sites

Lefuneste thanks for your work.

 

Was trying the IPD modifier but does not work anymore in this latest version.

 

How can I custom program the IPD modifier now?

 

You gave me this instructions before

 

======================================================================================

You can modify the IPD modifier by the value you want. To do that :

  • set the default value in user_var_initialization.ini by adding the following lines (x is the value you want)
    ; Xxshift for zoom (not to be modified)
    y6 = 0.0x
  • modify IPD toggle by modifying in user_keymapping.ini the section
    [Key8]
    ;Global Shift toogle
    ; Key = ALT no_shift no_ctrl VK_LEFT
    Key = ALT no_shift no_ctrl VK_DELETE
    type = cycle
    ; modify here the first value for global shift
    x6 = 0.0x, 0.0

    By default the value is 0.02, so you can try 0.01.

If the IPD is not enough, you can also modify he default zoom factor (eg 1.05) add a line "w=1.x" in user_var_initialization.ini (where x is the default zoom value you want).

But you must be aware that there are some glitch or didabled effects in 10.5 with IPD or zoom, the 10.6 will be better (but there is still a problem with grass)

Share this post


Link to post
Share on other sites

I forgot to remind you that you can not backup your user_settings files if you were using a version older than 10.6

In this case you must update the user files provided with the new version, in order to introduce tour settings.

Share this post


Link to post
Share on other sites
15 hours ago, II./JG77_motoadve said:

Lefuneste thanks for your work.

 

Was trying the IPD modifier but does not work anymore in this latest version.

 

How can I custom program the IPD modifier now?

 

Well, I forgot to add this in "customization" section.

Now you must edit user_keymapping_zoom.ini and modify the following lines:

[Key8]
;Global Shift toogle
; Key = ALT no_shift no_ctrl VK_LEFT
Key = ALT no_shift no_ctrl VK_DELETE
type = cycle
; modify here the first value for global shift
x6 = 0.008, 0.0        

Maybe 0.008 is too big, you may have to lower it.

Share this post


Link to post
Share on other sites
В 06.02.2019 в 21:09, =LwS=Balapan сказал:

Was there another game patch that broke zoom again? On my pimax 5k+ seems, that right eye zoom is zooming way too far to the right (I tried to change zoom factor in user settings file without success) . I started game with 10.7 mod today, and it had this issue. Afer removing with bat uninstal file and updating to 11.0 still have the same issue. I see in the steam that there were IL 2 download 59.8 Mb today.

I found the reason why it didn't work. I turned off shadows, and that led to zoom not working. After turning it back on zoom is back at normal

Edited by =LwS=Balapan

Share this post


Link to post
Share on other sites

This is the best thread for everything IL2 VR related. The work you guys put in is awesome.

 

I feel as if my set up is under performing. Oculus rift, gtx1070.

 

I have 75+ fps in the start menu, but as soon as i enter a plane, even in a quick mission, my fps drops to 45.

 

Could ASW be the culprit? I am having issues trying to find a fix for that.

 

Or is it hardware dependant and I should just suck it up and upgrade the GPU?

 

Share this post


Link to post
Share on other sites
8 hours ago, =LwS=Balapan said:

I found the reason why it did't work. I turned off shadows, and that led to zoom not working. After turning it back on zoom is back at normal

That's strange. I use a shader to define which eye is being used, but it is not related to shadow.  I'll have a look.

5 hours ago, SCG_Rejected_Rudis said:

This is the best thread for everything IL2 VR related. The work you guys put in is awesome.

 

I feel as if my set up is under performing. Oculus rift, gtx1070.

 

I have 75+ fps in the start menu, but as soon as i enter a plane, even in a quick mission, my fps drops to 45.

 

Could ASW be the culprit? I am having issues trying to find a fix for that.

 

Or is it hardware dependant and I should just suck it up and upgrade the GPU?

 

This is not the right place for these kind of question. You should better got there.

Share this post


Link to post
Share on other sites

I briefly tried v11.0 last night using my 3 user setting files copied over from v10.6.2 and the zoom IPD was off for all zoom levels. I play with shadows OFF by default. I did not think of trying with shadows on. I'll check when I'm home.

Share this post


Link to post
Share on other sites
3 hours ago, -[HRAF]Black_Sab said:

I briefly tried v11.0 last night using my 3 user setting files copied over from v10.6.2 and the zoom IPD was off for all zoom levels. I play with shadows OFF by default. I did not think of trying with shadows on. I'll check when I'm home.

 

I can also confirm that enabling shadows fixed the zoom IPD off issue.

Share this post


Link to post
Share on other sites
20 hours ago, SCG_Rejected_Rudis said:

I feel as if my set up is under performing. Oculus rift, gtx1070.

 

I have 75+ fps in the start menu, but as soon as i enter a plane, even in a quick mission, my fps drops to 45.

 

Could ASW be the culprit? I am having issues trying to find a fix for that.

 

Or is it hardware dependant and I should just suck it up and upgrade the GPU?

 

You might get a good response asking in the VR performance benchmarking thread by Chili, most likely. There's a lot of info in there, but basically IL2 is highly CPU dependent and so you might have a CPU or GPU bottleneck, depending on where you're flying and with what settings. Here's a recent thread where someone has a 1070ti:

 

 

Share this post


Link to post
Share on other sites

Just wanted to pop in and once again thank Lefuneste for this mod.

Its unfortunate that with each patch, things get broken - and time after time you spend your time fixing this for us.

 

Many thanks.

:good:

Share this post


Link to post
Share on other sites
On 2/5/2019 at 8:51 PM, flyinj said:

The instructions are a little hard to understand...

 

How do I uninstall this mod (from a manual install)?

 

 

Use JSGME or OvGME for uninstall this mod and other mods. 

This tool, I only uses JSGME, is rather handy piece of software, because if your game contains mods while updating, mods could be corrupted or the game itself could have difficulties. 

 

Share this post


Link to post
Share on other sites
14 hours ago, -[HRAF]Black_Sab said:

 

I can also confirm that enabling shadows fixed the zoom IPD off issue.

 

Correction - with shadows on, the zoom on terrain and objects are good, but ground object smoke is still off. It's not detached from objects but the IPD is off. And something is wrong when zooming on clouds too. It's hard to tell exactly what. It' like the close and far clouds are OK, but the middle range clouds disappear.

Share this post


Link to post
Share on other sites

I can confirm that last night on Wings, smoke from ground explosions seemed to appear properly only through one eye. This causes slight disequilibrium when zooming. I am also noticing that the labels in the map appear translucent, as if being able to partially look them.

 

Edited by redcloud111

Share this post


Link to post
Share on other sites

Record tracks guys, its probably the easiest way to help lefuneste reproduce the issue and then build a fix.

 

Share this post


Link to post
Share on other sites

I had 10.5 and had no problem. Had to go to latest version 11.0 when patch game. I have SamsungO+ and i see double vision when using the max zoom. I have done all what i did in 10.5 and cannot get rid of this double vision with max zoom.  

 

I use OVGME for this mod

 

I can go back to 10.5 and max zoom is normal,just have the floating ground objects. 

Share this post


Link to post
Share on other sites
4 hours ago, AKA_Big10 said:

I had 10.5 and had no problem. Had to go to latest version 11.0 when patch game. I have SamsungO+ and i see double vision when using the max zoom. I have done all what i did in 10.5 and cannot get rid of this double vision with max zoom.  

 

I use OVGME for this mod

 

I can go back to 10.5 and max zoom is normal,just have the floating ground objects. 

If you did not use the file provided for 11.0 in user_settings but keep the ones from 10.5 you will have this problems.

 

On 2/9/2019 at 10:54 AM, -[HRAF]Black_Sab said:

 

Correction - with shadows on, the zoom on terrain and objects are good, but ground object smoke is still off. It's not detached from objects but the IPD is off. And something is wrong when zooming on clouds too. It's hard to tell exactly what. It' like the close and far clouds are OK, but the middle range clouds disappear.

Maybe this version will solve the problem. At least it is solving the contrails (As you provide me a track). It will also work with shadow off.

For the explosion and label on map, I was not able to reproduce the problem.

Edited by lefuneste

Share this post


Link to post
Share on other sites
17 minutes ago, Dutch2 said:

The new 11.1 in that link I suppose. 

yes. I will  not update the first post without feedback for this version.

But I forgot to include the "no shadow" fix in d3dx.ini, you'll have to download it again if you have done that before this post...

Edited by lefuneste

Share this post


Link to post
Share on other sites
3 hours ago, lefuneste said:

If you did not use the file provided for 11.0 in user_settings but keep the ones from 10.5 you will have this problems.

 

I swap mods with OVGME. Never the less, I complete deleted my IL2 and reinstalled and only loaded latest mod and same problem. Double vision when zoom. 

Share this post


Link to post
Share on other sites
8 hours ago, AKA_Big10 said:

 

I swap mods with OVGME. Never the less, I complete deleted my IL2 and reinstalled and only loaded latest mod and same problem. Double vision when zoom. 

What are your graphic options ?

Share this post


Link to post
Share on other sites

It'd be nice if we could just get a damn official enhanced zoom option from the devs that doesn't break with every single tiny patch.

Share this post


Link to post
Share on other sites

 

 

I guess I have correctly installed the patch 11 These things happen to me:

1- the terrain of the track aerodrome is hooked to zoom, only the track objects not

2- the smoke of the planes appears displaced Do you happen to the rest with the latest version?bug.thumb.png.ba0d78b52543492f8e9756c67c1e988a.png

Share this post


Link to post
Share on other sites

I get terrible performance with the latest 2 version of 3D Migoto.

Loose about 15fps and its not smooth anymore.

 

Any ideas?

 

Share this post


Link to post
Share on other sites
On 2/11/2019 at 12:13 AM, lefuneste said:

What are your graphic options ?

 

 

On 2/11/2019 at 3:23 PM, Ala13_UnopaUno_VR said:

 

 

I guess I have correctly installed the patch 11 These things happen to me:

1- the terrain of the track aerodrome is hooked to zoom, only the track objects not

2- the smoke of the planes appears displaced Do you happen to the rest with the latest version?bug.thumb.png.ba0d78b52543492f8e9756c67c1e988a.png

 

I also experienced this as well. Will try latest patch and report. 

Edited by AKA_Big10

Share this post


Link to post
Share on other sites

Just me, or are those options all wrong?

 

Bare minimum to change:

Reduce screen resolution (unnecessary GPU load for VR) to 1080

clouds high

HDR on

Target FPS off

 

 

Share this post


Link to post
Share on other sites
6 hours ago, AKA_Big10 said:

 

I also experienced this as well. Will try latest patch and report. 

That should be linked to "shadow off" option. Try the last version posted above.

 

8 hours ago, II./JG77_motoadve said:

I get terrible performance with the latest 2 version of 3D Migoto.

Loose about 15fps and its not smooth anymore.

I did not see fps loss with my PC.

Try to desactivate cloud fix and see if there are any improvements.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...