Jump to content
BlueMind

Magnetic notches with the turrets ?!?

Recommended Posts

I need help because I have a small problem with the turret movements on Ju87, He-111, tanks, etc.

 

First of all, I know the keys to take control of the turret, nestle to the gunsight, etc.
My concern lies in the mouse movements, because I have a sort of magnetic line horizontally (X axis) and vertically (Y axis) which makes my mouse block slightly when I go through these axes (a bit like there was a notch to know where is the center position of the gun). Unfortunately, I find it unplayable... I can't aim correctly when I'm near these axes !

 

So if anyone could explain me how to remove this magnetic effect on the axes because I can't find anything in the game settings or forums related to this.
Please help! I would love to start a career in Ju87 but if I can't control properly the rear turret, it will be much less fun :(

 

PS: I hope you understand what I mean and ask with my poor english :p

Share this post


Link to post
Share on other sites

Check in Settings->Controllers if you don't have some mouse filter set, smoothing, sensitivity or something.

Share this post


Link to post
Share on other sites

@BlueMind

I had this issue as well .

Go to 

Key Mapping > Pilot head control >

"Bow pilot head vertically": Set Dead zone: 0%

"Turn pilot head horizontally" : Set Dead Zone : 0%

 

Let me know if it works!

I hope the devs will put this by default because everybody who wants to use turrets has this issue

 

  • Upvote 1

Share this post


Link to post
Share on other sites
7 hours ago, bies said:

Check in Settings->Controllers if you don't have some mouse filter set, smoothing, sensitivity or something.

Thanks for the suggestion... but I checked my mouse settings and nothing.
 

3 hours ago, TG1_Nil said:

@BlueMind

I had this issue as well .

Go to 

Key Mapping > Pilot head control >

"Bow pilot head vertically": Set Dead zone: 0%

"Turn pilot head horizontally" : Set Dead Zone : 0%

 

Let me know if it works!

I hope the devs will put this by default because everybody who wants to use turrets has this issue

Nice... Glad not to be the only one with this problem... This function isn't practical at all and I don't understand why it's implemented !? I hardly dared to ask on the forum ! :rolleyes:
Tank you, I will try it ! :salute:

  • Like 1

Share this post


Link to post
Share on other sites

Yes try it and please for the love of Junkers 52, tell me if it works.

By all means I promise your issue will be fixed.

Share this post


Link to post
Share on other sites

Unfortunately, I don't have DeadZone options for the mouse, only for the joystick but, I can't assign it... sadly :cray:

 

I can't find where to set them to 0% (I checked the config files on the "input" folder but no deadzone lines to change... or I missed them).

 

PS: I really don't understand what is the purpose of this function !!? :crazy:

Share this post


Link to post
Share on other sites

I‘ve had this problem too. As soon you have a Joystick axis set to use your „head rotation“ (like the mini stick on the Saitek x55) and you use a deadzone to do something against this spikey, flickery sensor used in the ministick, then this dead zone applies to the mouse as well. Result is that the mozse gets stuck slightly in the center, making aiming impossible.

 

It is really something that the devs need to adress. Different input devices MUST use different dead zones, even if they are used for the similar function in the game.

 

 

Share this post


Link to post
Share on other sites

Thanks ZachariasX, I will check tonight my settings. I confirm that I have a Logitech G940 with ministicks, maybe I need to delete all entries with hotas and ministick to check if this problem is gone...

 

20 minutes ago, ZachariasX said:

It is really something that the devs need to adress. Different input devices MUST use different dead zones, even if they are used for the similar function in the game.

:good:

...or at least, a message or a text wich clearly explains a possible conflict.

 

I'll keep you informed...

Share this post


Link to post
Share on other sites

@BlueMindI understood your problem,

I found a fix.

Simply assign those 2 function with 2 axes of your current joystick like that for example:

then set deadzone to 0%

Then hit "accept" to return to the game.

Then go back to this screen to delete the 2 assignations you just made!

It works for me !

Please Let me know!

 

 

InkedIl-2 2018-07-31 13-57-38-91_LI.jpg

  • Like 1

Share this post


Link to post
Share on other sites

@TG1_Nil Damned, you saved my life :yahoo::dance:

Your fix works perfectly !!! Thank you all for your advice and help... Now I can enjoy even more this great game:hunter:

  • Like 1

Share this post


Link to post
Share on other sites

@BlueMind I told you!!!

I am so happy, I would never ever let you down.

Your problem is also my problem!

Enjoy!

Share this post


Link to post
Share on other sites

Wow, quelle dévotion !

Merci encore pour ton coup de main ;)

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...