Jump to content
StG2_Raven

Autologin with Autoplay.cfg not work

Recommended Posts

Brief description: Autologin with Autoplay.cfg not work
Detailed description, conditions:

 

3.005C launcher version.  

 

 I've been around, it should not work for a long time

1. The login is successful
2. Then the game jumps immediately into the mission overview
3. And then immediately comes a permanent hourglass
4. And now the menu is no longer controllable. The game must be stopped by force

 

Additional assets (videos, screenshots, logs):

 

&enabled=1                       // =1: turn on the autologin
&loginOffline=0                  // login mode, =0: online, =1: offline
&login=MY EMAIL                          // your login (e-mail)
&password=MY PASSWORD                     // your password
&autoIngame=0                    // =1: start mission without plane settings
&missionSettingsPreset=1         // =0: custom difficulty settings (last stored), =1: normal dificulty preset, =2: expert difficulty preset
&missionPath=missions/   // mission path to be loaded
//&trackPath=tracks/

 

autoplay_bug.PNG

 

 

Share this post


Link to post
Share on other sites

Having the same issue. Fingers crossed this will be fixed in the next patch... as of right now autoplay.cfg is not working for me at all.

Share this post


Link to post
Share on other sites
&missionPath=missions/   // mission path to be loaded

This line is incorrect. If you don't want to autoload a mission, comment this line out:

 

//&missionPath=missions/   // mission path to be loaded

Share this post


Link to post
Share on other sites

Just checked right now:

 

&enabled=1                       // =1: turn on the autologin
&loginOffline=0                  // login mode, =0: online, =1: offline
&login=***                          // your login (e-mail)
&password=***                       // your password
&autoIngame=1                    // =1: start mission without plane settings
&missionSettingsPreset=2         // =0: custom difficulty settings (last stored), =1: normal dificulty preset, =2: expert difficulty preset
&missionPath=Missions/BoK/A-20B - Airfield Attack   // mission path to be loaded

 

works ok.

Share this post


Link to post
Share on other sites

Thanks for the replies!

 

I seem to have a very specific case where I am trying to load missions from a different directory (not from the Il-2 installation directory). E.g. my autoplay.cfg looks like this:

&enabled=1
&loginOffline=1
&login=
&password=
&autoIngame=0
&missionSettingsPreset=0
&missionPath="C:\TestMissions\test"

Is this functionality still supported (used to work before)?

Share this post


Link to post
Share on other sites
24 minutes ago, Jason_Williams said:

Han says to use the Missions folder. Is that possible?

 

It should be, yes. Will need to make some changes on my end.

Thanks for the help Jason & team,

Edited by Sim

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×