Jump to content
Sign in to follow this  
SCG_TheHighwayman

Cooperative Missions do not appear

Recommended Posts

Hello,

 

I have made a few cooperative missions, but when I do to Multiplayer Hosting > Cooperative > Create Server > the missions I created are not visible for selection. 

 

This is true, even when I merely make an edit to a mission that is available... 

 

I have checked all my file placements, extensions, settings and everything is identical in every way between the missions I have created and the missions that show up. 

 

Mission has the nine files associated with it, has the .MISSION, .msnbin, is in the Multiplayer/Cooperative folder. 

 

Clearly I am missing something, probably something basic and fundamental. I just need to know what it is. 

 

Thank you for your help. 

Share this post


Link to post
Share on other sites

Did you set the aircraft advanced setting to 'cooperative start'?

  • Like 1

Share this post


Link to post
Share on other sites

Thank you. 

 

I checked the box, but it still did not show up as it should. 

 

Presently, I have these connections: 

 

Mission start > Timer 2 sec > Order Takeoff > 109G2.

 "                                                                        "   > Yak 1-69

 

One plane is German, the other Soviet, although it did not seem to matter what side they are set to. My goal is to build a simple  1 vs. 1 training mission to fly with my son. 

 

 

BrendanCoOp.zip

Share this post


Link to post
Share on other sites

You may need to "forward" the following ports on your router:

    - 28000 TCP (for communication with each player's PC)

    - 28000 UDP (for communication with each player's PC)

    - 28100 UDP (for downloading the mission files to player PCs)

Check the documentation for your router to learn how to forward ports.

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi Jim. 

 

We have no problem connecting. The problem is the mission I create isn't visible for selection under the Cooperative Multiplayer section. We are able to connect and fly other missions just fine. The problem seems to be me. I'm just not sure what I am missing as to why my own mission does not show up for me to host on my own machine. 

 

 

Share this post


Link to post
Share on other sites
45 minutes ago, 1./JG54TheHighwayman said:

Hi Jim. 

 

We have no problem connecting. The problem is the mission I create isn't visible for selection under the Cooperative Multiplayer section. We are able to connect and fly other missions just fine. The problem seems to be me. I'm just not sure what I am missing as to why my own mission does not show up for me to host on my own machine. 

 

 

 

Ah, I see what you mean. I tried placing your mission under ...\1C Game Studios\IL-2 Sturmovik Battle of Moscow\data\Multiplayer\Cooperative\JG54TheHighwayman and it showed up in the mission list in my coop Create a Server screen. Do you have a similar path for your copy?

Edited by JimTM
  • Upvote 1

Share this post


Link to post
Share on other sites

Looks OK to me. So you are not seeing anything starting with "Brendan" in your coop setup missions list, right? In my list, I see "Brenden-Training", the name in your mission properties "Name" box.

  • Upvote 1

Share this post


Link to post
Share on other sites

Yeah, he says he can run the other missions. My guess is something in the base file. Highway, try opening it and saving it to another name and see if that works. I've had things go haywire by copying and as soon as I save it as another name, and change the name in the description it works.

  • Thanks 1

Share this post


Link to post
Share on other sites
On 7/1/2018 at 5:08 PM, JimTM said:

You may need to "forward" the following ports on your router:

    - 28000 TCP (for communication with each player's PC)

    - 28000 UDP (for communication with each player's PC)

    - 28100 UDP (for downloading the mission files to player PCs)

Check the documentation for your router to learn how to forward ports.

 

So... like everyone or just the host ?  Router, modem, ISP, local firewall ???

Share this post


Link to post
Share on other sites
26 minutes ago, AKA_Recon said:

 

So... like everyone or just the host ?  Router, modem, ISP, local firewall ???

 

Just the host.

 

I have a combination modem/router, which is where I forward the ports. I'm not sure about other setups but I suspect the router after your modem is where you forward ports. Check your hardware documentation.

Edited by JimTM

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...