Jump to content
Sign in to follow this  
SYN_Mugue

# of controllers allowed by game?

Recommended Posts

Is there a hard limit to the number of controllers the game will recognize? Or am I limited only by my OS and hardware?

The reason I ask, of course, is...I seem to collect controllers like a dog collects ticks. And I wondered if I can have the new toys I've ordered plugged in and working too. Or do I have to make a choice about which ones I keep?

 

In the end I guess I'll find out, just hoping someone knows so I can plan ahead.

 

Thanks, M.

Share this post


Link to post
Share on other sites

It'll recognize as many as you can plug in.

Share this post


Link to post
Share on other sites

Well Luke, my friend, maybe it isn't that simple...
---------------------
Here's my setup
System: ASUS Sabertooth x79 MB, i7-3820 @ 4.32GHz, 32 GB RAM, GTX 1080, Window 7 64bit pro
Peripherals: Logitech 810 keyboard, Razor Naga mouse, G940 ffb stick, MFG Crosswind V2 rudder pedals, TM Warthog throttle, DSD Race King & P-series button boxes, Saitek throttle quadrant
With the above setup, everything works fine in BoS, no problems.
--------------------
Now on to my issue...
To that setup I'm trying to add a second Saitek/logitech throttle quadrant(just arrived) and another DSD P-series button box I'm going to morph/hack into a trim control box.(still to come and likely a whole other problem)

Here's the rub...When I plug in the new throttle quadrant, Windows recognizes it (and everything else too) and all functions correctly. In Windows, (and in DCS too) so I know it all works.
But when it comes to BoS I've got a strange set of issues.


First: Mapping the axis' and buttons in the game as per usual.(to my existing profile) Appeared to map normally. Ran a quick mission to test my new engine controls, and I got nothing from the new axis' yet the buttons on it did work.  Then I looked at the axis tuner function in game and sure enough no axis movement. So, the axis IS mapped in the games control menu, but not working/recognized when the game is running.  Strange I thought!


Second: Then I tried, backing up, then deleting the 'input' folder. Thereby resetting things and carefully remapped every control...
This time around, everything mapped and  functioned in the control setup menu. And all buttons and axis worked in game too. Great! Or so I thought...When I started a mission and took off, I discovered that I had lost all Force Feedback from the pitch axis on my G940.  (no forces or shake)  Roll axis was unaffected and worked like normal.


At first I didn't panic cause I've had, and know others that have had, ffb glitch in BoS and RoF before. Usually adjusting, applying, then readjusting and re applying the force levels in game will sort it out. And/or a game restart or system reboot too if needed.  Tried all that obviously, but no joy.(stick force, ha ha)


So then I made a virtual controller out of both of the saitek quadrants using vjoy and joystick gremlin. (Thinking that perhaps I had exceeded the maximum number of controllers allowed in BoS.) Once I got that working, I mapped everything again in a freshly reset input folder.  Again everything works but the ffb on the pitch axis.  :/

 

What in the name of Gods Gray Earth could be causing this strange behavior? Anyone else run into this problem before? Any thoughts how to solve this short of me throwing my new quadrant out the window?

 

Any help or black humor would be appreciated at this point. :)

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...