Jump to content
77.CountZero

[MOD] Extra Zoom , Cockpit min FoV

Recommended Posts

This is simple mod alows cocpit FOV to be changed all the way to minimum insted default 30 that is in game now.

http://www.mediafire.com/file/lz0cv8mcspr40oz/modextrazoom.zip

 

When you unzip "modextrazoom.zip" content, place "ExtraZoom" folder in your "MODS" or "JSGMEMODS" folder located in your "Il-2 Sturmovik Battle of Stalingrad" folder, and activate it by JSGME.exe program to enable this mod.

 

This will only work if you have Mods On in game. To turn mods on to your game, start it and then go in "Settings", then in "Game" and click on "Enable mods", and restart game.

Or to avoid start restart every time you wont to change this you can do it also by opening "startup.cfg" file located in your "1C Game Studios\IL-2 Sturmovik Battle of Stalingrad\data" folder, and change "modes = 0" to 1.

 

Pictures:

Spoiler

 

default max zoom:

20h7k9j.jpg

 

extra zoom with mod:
17btld.jpg

 

 

 

 

 

Edited by 77.CountZero
add pictures
  • Thanks 2
  • Upvote 1

Share this post


Link to post
Share on other sites

Very nice!

 any idea where to change the VR Zoom? i'd imagine it would be on the same file

Edited by 19//SAG

Share this post


Link to post
Share on other sites

I dont have VR so i dont know how this works in VR, i would expect it will work same but some one with VR can test and see if he can now zoom in more then without it when in cockpit. I didnt found any extra conf file just for VR, there is few for all external fixed, free, padlock, bombaim, flyby, turet and so on views.

Share this post


Link to post
Share on other sites

Nope it doesn't work in VR. A couple of days ago I tried changing minimum FOV from 30 to 10 for every camera file, and it works only in 2D.

 

Edited by Nibbio

Share this post


Link to post
Share on other sites

Thanks for the mod 77.CountZero, that zoom is legit now.

 

How does the maximum FOV work though? I'm trying to lower/limit it slightly so as not to create such a fisheye effect inside the cockit, but it doesn't seem to be making any difference and I can still zoom out all the way.

 

Thanks again :salute:.

Share this post


Link to post
Share on other sites

Hi Schultz, you need to start by editing  "MaximumFOVGrad = 180.0000" in "cameracockpit.cfg" like you probably try, but start with changing it to "80.0000"  (dont forghet to diactivate mode and then make change and then activate it again for it to work) and then raise it slowly by 10 or 20 to what you like. 180 is to high so, real max fov you see in game is less then that, i dont remenber what it was from my tests, something is limiting max fov in cockpit so by default it doesent show 180, so maybe you tryed with numbers that were still abow limit and didnt saw change because of that. When i changed that to 80 i could see it limited me to that FoV on max zoom out in cockpit.

  • Thanks 1

Share this post


Link to post
Share on other sites

It doesen't work for me ( no VR )

I tried with the M.C. 202 and wanted to zoom out a bit more, but couldn't see a difference

Am I missing something ?

Thank you

 

LE :

    DefaultFOVGrad = 60.0000
    MaximumFOVGrad = 180.0000
    MinimumFOVGrad = 1.0000

 

 

Are those values okay ??

Edited by Avyx

Share this post


Link to post
Share on other sites

Yes values are ok, this mode is for incresing zoom in, i left zoom out on default, so when mod is activated you shold be able to zoom in mutch more then by default.

 

In previous post im explaining Schultz how he can decress zoom out if he wonts, but your not able to incress zoom out from whats now in game from what i saw in test. ( if you wont in controls you can set key for pilot seat backwards and that will move you more back and help a little, no need for mod)

Edited by 77.CountZero

Share this post


Link to post
Share on other sites

I didn't know this option with " pilot seat backwards" 

Where exactly is this option? 

Thank you 

Share this post


Link to post
Share on other sites

Start game, go in settings and key mappings, then in pilot head control, and set key you wont for "move pilot head backwards", i use this key a lot when im in Fw-190 for example 

Share this post


Link to post
Share on other sites

I did already, but all i could do, was to zoom in very close to the cockpit instruments

Tried with both, move pilot head backwards and forwards.

Share this post


Link to post
Share on other sites

Sorry but i dont know any other way to incress zoom out in cockpit, and changes to MaximumFOVGrad = 180.0000 to something higher in mod dont make any differance. So only zoom in works.

Share this post


Link to post
Share on other sites

Thanks for the response 77.CountZeroI had tried all of the above already but unfortunately it didn't seem to work for me.

 

I started with about 120, then went to 90, 80, 60, and even as low as 20, but still wasn't seeing a change (the extra zoom works fantastically however!). I was also disabling/enabling the mod after every change and restarting IL2. I'll give it another try and let you know if I have any luck, but is the max FOV setting working for you if you lower it to say 90 or so?

 

 

Cheers  77.CountZeromuch appreciated :salute:.

Share this post


Link to post
Share on other sites

Hi i tested it with 80 max zoom out and it works, it limited me to 80FoV, but when i moved my head with Track ir it alowed me again to move abow that FoV i set, ill check other conf files and report if i see somthing there helps in limiting it when you use head tracker, it seams he is overwrighting that limit.

  • Thanks 1

Share this post


Link to post
Share on other sites

Cool mod!
Wanna ask is it possible to create mod for EXTERNAL views with such feature? Especially for  F11 camera while playing tracks.

Share this post


Link to post
Share on other sites
On 4/25/2018 at 11:36 PM, samson said:

Cool mod!
Wanna ask is it possible to create mod for EXTERNAL views with such feature? Especially for  F11 camera while playing tracks.

 

i try and didnt work, was able only to make F2 view zoom in more but not any use for it

On 4/28/2018 at 11:53 AM, PA_Spartan- said:

Can you post pictures? :gamer:

ill post tomorow

  • Thanks 2

Share this post


Link to post
Share on other sites
15 hours ago, padrino12pacolin said:

This mod is not working ,how can i make this to work

 

Hi

I just redownload it from link and checked it in 3004 version of game, and it still works as before, so it should work for you also as its simple mod

 

Lets first check:

1. do you have other mods that work on your game, or this is first you try ?  

2. do you have modifications enabled in game, when you start game and you come in main menu does game warn you that you have mods on ?

3. is your MODS folder where you place this mod files and JSGME.exe located in your main game folder (Battle of Moscow or Stalingrad and so on) ?
4. when you open your JSGME.exe to activate this mod , whats name of mod you see there is it "ExtraZoom" or "modextrazoom" ?
5. are you starting game from steam or game lancher without steam ?

6. are you using VR ?, this mod dont work with VR headset

Edited by 77.CountZero

Share this post


Link to post
Share on other sites

Wow! based on the initial images, this mod would be a great aid in spotting or identifying enemy aircraft and or ground forces:salute:

  • Like 1

Share this post


Link to post
Share on other sites

yes it helps a lot, im mostly using it in SP and in tank missions it works also in drivers and comanders position ( hope they add binoculars for tank comanders when they do tank crew )

Share this post


Link to post
Share on other sites

Salutations,

 

I just downloaded and installed as directed in the readme. Worked immediately. Well done. :salute:

 

Nice to know it works with armor too. Yes, a binocular option would greatly add to immersion.

 

I start my game from the launcher.

Edited by Thad

Share this post


Link to post
Share on other sites

Excellent mod. Installed, and worked like a breeze. No issue. Many thanks.

Share this post


Link to post
Share on other sites
Posted (edited)

Does this still work?  I did not see a difference when I tried to install it.

 

Edit: Got it working after I installed JSGME and enabled it from that program.  

Edited by SCG_Limboski

Share this post


Link to post
Share on other sites

This mod not for multi player, if I put it into game files (*.gtp), could I play online and use the better zoom in ability? will I catch by cheating?

Share this post


Link to post
Share on other sites

Almost all of the multiplayer servers disappear when you have "mods enabled" in game.  How is that VR users get to run with mods enabled for their extra zoom level?  Or am I missing something?

Share this post


Link to post
Share on other sites
Posted (edited)
10 hours ago, Gordon200 said:

@Oyster_KAI @SCG_Limboski This mod works when enabled with JSGME and with Mods Off in game. It works on all servers in multi-player.

 

I just tested to see if this mod works with mods off in the game and enabled in JSGME but it does not work for me.  I only see it working when mods are enabled.

 

Are you sure about this?  Is there any other way to get it to work with the multiplayer servers or elaborate more on this?

 

Edited by SCG_Limboski

Share this post


Link to post
Share on other sites
Posted (edited)

Mod should work like any other, only when game has MODs ON, and you can then use it on servers that have MODs ON (that would be only servers you see when you turn on mods for your game).

 

EDIT:

Just download it, and try it again on latest game version, and it works as intended.

You can only see servers that also have mods on.

Edited by 77.CountZero

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...