Jump to content
II./JG77_motoadve

Pauses when turning icons ON or OFF

Recommended Posts

Is it just me getting this?

All runs real good and smooth, even with icons ON.

Its the turning them ON or OFF process what creates pauses, and in Career mode they are even worse.

 

I am thinking or doing a re install.

 

Share this post


Link to post
Share on other sites

You mean the game actually pauses or drops fps 

 

It's not just icons, the Hud and the zoom, all seem to be a little more erratic than they used to be when used in game, though maps are about the same. I've never even tried icons.

Share this post


Link to post
Share on other sites

Its a mini pause, yes same with map, and zoom also a mini pause.

Didnt have that before.

 

So maybe no need to re install if I am not the only one.

Share this post


Link to post
Share on other sites

Yep I get those mini pauses as well, when turning icons on or off, hud on or off, map, etc.

 

 

Share this post


Link to post
Share on other sites

Yes, I also have those minipauses as well. It is just about 0.2 seconds where the STeamVR sensors are displayed.

 

I only suffer this in the Kuban map, but not in Stalingrad map.

Share this post


Link to post
Share on other sites

I noticed it today too. Not a pause or a stutter just a slight jerk. Like a frame was cut out from a movie film.

 

I'm not sure if it's related but I've noticed when using either the mini map or the full map (O) that my plane icon doesn't move as smoothly as before. It feels like a second or two in between my plane's icon position and the next one displayed.

 

The OP mentioned maybe doing a new install to possibly fix the issue. I'm running a clean install. I do a fresh install after all major updates. It seems to run better for me when I do. Might be my imagination but it works for me.

Edited by Rjel
additional comments

Share this post


Link to post
Share on other sites

I have this issue as well. Just a very quick screen flash which shows my Rift sensors, then it's back to normal. 

Happens when I turn off/On the technochat and also when opening the map.


SD

Share this post


Link to post
Share on other sites

I have noticed the same problems when trying to activate the HUD, Labels etc.

Requires multiple presses on the joystick switch to finally activate and the keyboard reacts the same.

Share this post


Link to post
Share on other sites

Yup, same here. I get the same pauses when I play with Oculus or on my monitor. Occurs when I display the HUD, turn labels on or off and when I bring up or increase size of the minimap. It also takes about a second longer to display the full screen map with the briefing info then it used to before the latest update.
 

Madmatt

Share this post


Link to post
Share on other sites

Same here.

I try to keep the hud off as much as possible for obvious fps drop reasons, the stutter or mini pause only started happening with the Kuban update.

 

Rift + 1070

 

EDIT : does not happen when flying a simple Quick mission (no AI).

Edited by Boneboys

Share this post


Link to post
Share on other sites

Same here, switching indicators on and off or going to map causes some kind of stutter.

I have no performance impact when the hud is on or off, just when I switch.

 

I am not sure what it is, i currently avoid doing it towards the end of a sortie as i don’t want to risk a game-crash or something...

 

Edited by JagdFalke_B00MER

Share this post


Link to post
Share on other sites

I switch on and off the icons and maps, constantly. I assume they did some optimisations to the hud, and this is the trade-off. I hope this is fixed soon, as it's very jarring.

Share this post


Link to post
Share on other sites

I feared that I was the only one experiencing these pauses and screen flashes when using the Hud/Map changes and VR zoom.

Once I have selected and remain on one Hud/Map setting everything is fine but switching from one to another is very disconcerting.

VR zoom works but is not smooth at all.

these are the only serious issueS that I have found with 3.001, however it should be addressed by the DEVs.

Edited by fiddlinjim
Update Info

Share this post


Link to post
Share on other sites

Ive always had this but in this latest release the effect is much reduced.  WORSE!

 

Edit: I have no idea why i said it was reduced. must have been drunk or asleep at the time, my apologies.

Edited by OrLoK

Share this post


Link to post
Share on other sites

I just posted this listing in the Bug reporting section for the developers.

Edited by fiddlinjim
Update Info
  • Upvote 1

Share this post


Link to post
Share on other sites

I also experienced fps drops when I turn on or off the hud.

However, since the patch the hud doesn't seem to punish your fps anymore, I can just have it on, and all is good :)

Share this post


Link to post
Share on other sites
2 hours ago, Starcos said:

I also experienced fps drops when I turn on or off the hud.

However, since the patch the hud doesn't seem to punish your fps anymore, I can just have it on, and all is good :)

 

Interesting, HUD on still seems to have the same impact on performance for me as it did prior to 3.001.

Share this post


Link to post
Share on other sites

Getting the map issue as well, brings up the controllers. 

Share this post


Link to post
Share on other sites
On 3/23/2018 at 4:00 PM, dburne said:

 

Interesting, HUD on still seems to have the same impact on performance for me as it did prior to 3.001.

 

Funny thing, just flew my first MP sortie since the patch (until now I was lost in career mode ;) ), and in multiplayer the hud still ruins my fps. 

Share this post


Link to post
Share on other sites
On 22/03/2018 at 8:17 PM, OrLoK said:

Ive always had this but in this latest release the effect is much reduced.  WORSE!

 

Edit: I have no idea why i said it was reduced. must have been drunk or asleep at the time, my apologies.

 

Share this post


Link to post
Share on other sites
On 2018-03-23 at 1:44 PM, Starcos said:

I also experienced fps drops when I turn on or off the hud.

However, since the patch the hud doesn't seem to punish your fps anymore, I can just have it on, and all is good :)

On 2018-03-23 at 4:00 PM, dburne said:

 

Interesting, HUD on still seems to have the same impact on performance for me as it did prior to 3.001.


Been turning hud off out of habit but if it has less of an Fps hit than before it would explain the new lag when switching off/on. This needs benchmarking.

Share this post


Link to post
Share on other sites

When using the map/labels/hud the game stutters. But when I do it flying the P-39 it crashes the game. It's likely related. 

 

Edited by claw

Share this post


Link to post
Share on other sites

I accidentally/intentionally stumbled upon a way to disable at least the Rift camera symbols, that appear in the sky each time I turn on/off the HUD or map.

 

I found these so annoying that I dug for hours through every possible file in the steamVR folder. I finally found that in:

 

     SteamVR - resources - rendermodels - rift_camera

 

In the folder: rift_camera there is a file called:  rift_camera.mtl

 

While tinkering with the settings in the file to get rid of the rendermodel or make it transparent, I accidentally renamed it without noticing.

Next time I started Il-2, the flying rift camera symbols were gone. It's not the most elegant solution, but it works at least for me.

 

Just rename the file to something like rift_camera_orig.mtl  and hopefully it is gone for good.

 

There is still the flicker when opening the map or HUD, but without the black cameras in the sky the immersion isn't broken as badly any more . . .

 

Greetings

           little Guardian

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...