Jump to content
ShamrockOneFive

Does anyone else now have extreme microstutter? (Solved)

Recommended Posts

The new content looks fantastic but my enjoyment has been curtailed a bit right now as the game is microstuttering in a big way. I had microstutter issues before that were always happening but they are magnified under 3.001 for some reason. I keep adjusting one setting at a time but with no luck.

 

This isn't specifically frame rate. Frame rates are good in the high 40s and up to 80s if I turn off Vsync. With Vsync on its locked at a max of 60 of course.

 

I can go down to low details and get higher frame rates but the stutter is there anyways. I'm confused and not sure what to do and I'm curious if others are struggling.

 

For tech sake:

Core i5 6600

GTX 960 2GB

8GB DDR4

  • Upvote 1

Share this post


Link to post
Share on other sites

If you are running 4K or close to it, don't run Vsync On with Full Screen On (uncheck Full Screen, leave Vsync checked) and turn on 4K Textures. In beta we saw some possible conflicts between these three settings at very high resolutions only. They guys don't have a top end 4K system in the office yet to help diagnose what it was. They should have one soon though. 

 

You're going to have to film your stutters for us to look at it with a camera. Also try lowering your cloud settings. And don't apply any additional Nvidia settings, always use Use Application Setting.

 

And if you have G-sync of Free-Sync monitor turn it on it can help smooth it out a little.

 

I don't have any other suggestions at this point. Everything is running smooth on my systems. 

 

Jason

  • Thanks 1

Share this post


Link to post
Share on other sites

I reduced the 'distant terrain detail' option - worked for me!

Share this post


Link to post
Share on other sites

I have the same stutter as OP. V sync is on, my fps stay at a constant 60. Previous versions have been smooth on ultra. Stutter is there no matter what gfx setting. I have forced my card to use software settings.  Nvidia 1060gtx.

 

 

Edited by CastorTroy

Share this post


Link to post
Share on other sites

Strange. Some people are reporting perfect performance while others have terrible stutter, particularly in campaign. 

 

Hardware strength doesn't seem to be a factor; even 5 GHz Intel + GTX 1080 is affected for some people. Perhaps there is some other variable here. 

Edited by Mitthrawnuruodo

Share this post


Link to post
Share on other sites
37 minutes ago, Jason_Williams said:

If you are running 4K or close to it, don't run Vsync On with Full Screen On (uncheck Full Screen, leave Vsync checked) and turn on 4K Textures. In beta we saw some possible conflicts between these three settings at very high resolutions only. They guys don't have a top end 4K system in the office yet to help diagnose what it was. They should have one soon though. 

 

You're going to have to film your stutters for us to look at it with a camera. Also try lowering your cloud settings. And don't apply any additional Nvidia settings, always use Use Application Setting.

 

And if you have G-sync of Free-Sync monitor turn it on it can help smooth it out a little.

 

I don't have any other suggestions at this point. Everything is running smooth on my systems. 

 

Jason

 

Thanks for the suggestions Jason. I'm working my way systematically through different settings and options to see what I can do to affect it.

 

I'm running at a slightly unusual 16:10 (1920x1200) but until semi-recently I'd not really had any problems. I'm not sure if a nVidia driver update did it but upgrading to 3.001 seems to have really brought the effect out to the fore. I'm starting from lowest settings all around and then working my way back up to see what happens.

Edited by ShamrockOneFive

Share this post


Link to post
Share on other sites
50 minutes ago, Jason_Williams said:

If you are running 4K or close to it, don't run Vsync On with Full Screen On (uncheck Full Screen, leave Vsync checked) and turn on 4K Textures. In beta we saw some possible conflicts between these three settings at very high resolutions only. They guys don't have a top end 4K system in the office yet to help diagnose what it was. They should have one soon though. 

 

You're going to have to film your stutters for us to look at it with a camera. Also try lowering your cloud settings. And don't apply any additional Nvidia settings, always use Use Application Setting.

 

And if you have G-sync of Free-Sync monitor turn it on it can help smooth it out a little.

 

I don't have any other suggestions at this point. Everything is running smooth on my systems. 

 

Jason

Will try that, i'll also try verify game files trought steam before messing with ingame setting.

Share this post


Link to post
Share on other sites

I'm suffering with the same issue, fps stays at 60, but stuttering is driving me batty. 1920x1080, GTX 1070, 4690 at 3.9 ghz. Previous version had an occasional stutter, this one is really bad. Still experimenting with settings but running in windowed mode seems to have helped some. Will do some more testing.

Share this post


Link to post
Share on other sites

I'm getting some microstutter, but it's slight and intermittent. Good FPS, max settings, with 25% FPS drops in the mountains. One plane in the air, just flying for fun.

 

I'm happy with the performance.

 

i5-6500/1060 3GB/8GB RAM

Share this post


Link to post
Share on other sites

Start with Balanced not High or Ultra and turn off clouds and then go from there.

 

And there are two different kinds of stutters so I have no idea what you guys are calling micro-stutter. Could be a different kind of stutter I found with certain settings mentioned above. Again, a video filmed third person that shows the stutters is what is needed to identify what kind of stutter you are referring to.

 

Do you "stutters" look like my video when I was having some in the Alpha?

 

 

Jason

  • Upvote 1

Share this post


Link to post
Share on other sites
30 minutes ago, Jason_Williams said:

Start with Balanced not High or Ultra and turn off clouds and then go from there.

 

And there are two different kinds of stutters so I have no idea what you guys are calling micro-stutter. Could be a different kind of stutter I found with certain settings mentioned above. Again, a video filmed third person that shows the stutters is what is needed to identify what kind of stutter you are referring to.

 

Do you "stutters" look like my video when I was having some in the Alpha?

 

 

Jason

 

Yep, that's pretty much exactly what I'm seeing. A little worse.

 

I've been running through different settings up and down the settings list. I dropped everything down to low, AA off, nVidia settings to default, and set all settings to the lowest possible. There, with Vsync off, I can get 120+ frames in nearly all situations but that stutter is still there. I go up in settings and its still there. There's got to be something else to this that I'm just not understanding.

 

I'll borrow a tripod, setup my DSLR, and capture it as soon as I can (probably weekend).

Edited by ShamrockOneFive

Share this post


Link to post
Share on other sites

Like I said above. Set to Balanced. Full Screen Off, Vsync On and 4K textures On. No clouds in the sky. Test in QMB. See if you still have it.

 

Jason

Share this post


Link to post
Share on other sites
36 minutes ago, Jason_Williams said:

Like I said above. Set to Balanced. Full Screen Off, Vsync On and 4K textures On. No clouds in the sky. Test in QMB. See if you still have it.

 

Jason

 

Tried that and suddenly things are running very smoothly. A definite improvement!

Share this post


Link to post
Share on other sites

Did some testing both in VR and non-VR Tir5+2k monitor configuration.

 

Tir5+2k monitor:

Enabled and maxed everything (fullscreen/vsync on, 4k on) and runs smooth as butter on Kuban map hills.

So i guess mixed settings were problem.

 

VR:

In VR there is stutters noticable regardless what graphic settings configuration i choose (tried low/balanced/high and every other setting).

Kuban map flat area.

However still i need to check oculus traytool settings, maybe AWS settings are messed up or not applied for il2 after update.

One more thing, when going from sea to mountain area there are stutters but same like on flat area, seems it doesn't affect performance but if i spawn directly on mountain area stutters become terrible (on any settings).

 

 

Share this post


Link to post
Share on other sites

Just to punch in with you guys  - I was also getting some significant stutter and following these ideas smoothed it out for me as well. Hah - I actually might leave it at Balanced because my fps is in the 100's, and I don't mind the way it looks...:cool:

Share this post


Link to post
Share on other sites
2 minutes ago, gn728 said:

Just to punch in with you guys  - I was also getting some significant stutter and following these ideas smoothed it out for me as well. Hah - I actually might leave it at Balanced because my fps is in the 100's, and I don't mind the way it looks...:cool:

 

Is it the 4K textures ON that smoothed it out? I'm able to fly very normally, like 2.012, with this setting on. With it off its really unpleasant.

Share this post


Link to post
Share on other sites

I'll try turning it off and see...I thought VSync might be the culprit - but now I have Vsync, Full Screen, SSAO,HDR, and 4K checked and it's running basically like it was in 2.012..

Share this post


Link to post
Share on other sites
11 minutes ago, ShamrockOneFive said:

 

Is it the 4K textures ON that smoothed it out? I'm able to fly very normally, like 2.012, with this setting on. With it off its really unpleasant.

Confirmed!

I disabled 4k setting and stutters are back (tir5 monitor)

  • Upvote 1

Share this post


Link to post
Share on other sites

Yup - same here - in both Ultra and Balanced...

Share this post


Link to post
Share on other sites

If you have a G- sync monitor check NVIDIA inspector. Leave "multi display performance mode" default. Single display mode caused terrible stutter to me at least before 3.001. 

Power management can be set" prefer maximum performance"

Share this post


Link to post
Share on other sites

I'm glad to see I'm not the only one and I'll be trying these suggestion the next time I play! Glad there seems to be a workaround!

  • Upvote 1

Share this post


Link to post
Share on other sites

Can't get rid of the stutters in VR, tried different maps and settings but nothing helps.

My plane movements and controls are smooth, but terrain/map stutter a lot.

Anyone with same problem, or advice?

Edit: plane controls are also affected by sttuters!

Edited by EAF_Ribbon

Share this post


Link to post
Share on other sites
5 hours ago, EAF_Ribbon said:

Can't get rid of the stutters in VR, tried different maps and settings but nothing helps.

My plane movements and controls are smooth, but terrain/map stutter a lot.

Anyone with same problem, or advice?

Edit: plane controls are also affected by sttuters!

 

When happens when you turn 4K textures to ON?

Share this post


Link to post
Share on other sites
Just now, ShamrockOneFive said:

 

When happens when you turn 4K textures to ON?

Tried both, ON and OFF, no help!

I'm not sure is it problem with Oculus tray tool settings since i updated tool this morning.

If i find out anything i'll report back.

Share this post


Link to post
Share on other sites

Turning on 4k textures has helped a lot, along with running full-screen disabled. NVIDIA settings set to default, default ultra settings in game. Similar to pre 3.001 release. Full-screen setting has me puzzled for sure. Will take a further look at things later on today. Similar to Jason's flight, my go-to test is: Kuban map, 4 - Yak 1b's, 4 PE-2's vs 4 109E's, and 4 HE-111's. 

Share this post


Link to post
Share on other sites
10 hours ago, CastorTroy said:

I have the same stutter as OP. V sync is on, my fps stay at a constant 60. Previous versions have been smooth on ultra. Stutter is there no matter what gfx setting. I have forced my card to use software settings.  Nvidia 1060gtx.

 

 

Same here. Same card same issue. 1080p resolution. FPS locked to 60 and never go below as before patch. But stutters are crazy specially online. Settings doesnt matter. It was butter smooth BEFORE patch.

This has nothing to do with our PCs or graphics settings. It was very  smooth before patch and now its heavy micro stuttering. It happened before after big updates but in smaller scale. Changing any settings or resolution doesnt help. The problem lies within game. It was happening both in BOS and in ROF in the past.

 

Edited by blackram

Share this post


Link to post
Share on other sites

despite the fps counter reporting 89/90 fps, it didnt feel as buttery as before (stuttering passing planes/cocktpit view). thankfully a clean install solved this issue for me

 

P:S. forgot to mention > VR

Edited by ironk79

Share this post


Link to post
Share on other sites

Turning on 4k textures has gotten rid of my microstudder which was happening at any framerate.  Anyone with microstudder, try turning on 4k textures first even if you don't have a 4k monitor.

Share this post


Link to post
Share on other sites
13 minutes ago, Wedgewood said:

Turning on 4k textures has gotten rid of my microstudder which was happening at any framerate.  Anyone with microstudder, try turning on 4k textures first even if you don't have a 4k monitor.

I will do that when I get home. I hope this will fix it for me also as before patch the game was super smooth both offline (with 16 AI planes around me) and online with 80ppl.

Bugger that a new feature broke the engine...

Team should definitely investigate that since not everyone are reading forums...imagine a frustration for guys (who dont visit forums) who has latest rigs and who run this without issues before update.

Edited by blackram

Share this post


Link to post
Share on other sites
1 hour ago, EAF_Ribbon said:

Tried both, ON and OFF, no help!

I'm not sure is it problem with Oculus tray tool settings since i updated tool this morning.

If i find out anything i'll report back.

 

I 'm not noticing any stutters in VR. I've started a career in BOM though and plan to work through. I fly with balanced settings, low shadows, and clouds set to high.

Share this post


Link to post
Share on other sites

No stutters here. Maybe the people with stutters should send their graphic settings (game) and those of the graphic card too?

 

Another question: are the 4k textures only better on monitor resolutions over 1920x1080 ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...