Jump to content
Smiley_ie

Stutter or vsync problem ?

Recommended Posts

I just got BOS i can run it at 60 - 120 fps and it runs smooth but f2 external view when i move mouse or controller around i get a strange stutter in cockpit view its smooth but if a zoom i get the same stutter.

Tried vsync  on/off. Set frames to 60, Nvidia control panel - vsync on - adaptive vsync no matter what i try can remove this stutter

i5 8600k @ 4.6

16 gig 3600

GTX 1070 @ 2560x1080

Edited by Smiley_ie

Share this post


Link to post
Share on other sites

Try turning off/unchecking 'cinematic' in camera settings

 

could be that

 

Cheers, Dakpilot

  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks for the replay Dakpilot.

No joy tried other % on camera same problem, Was at a friends seen it running on i7 7700k, GTX1060 and he has the same as me ? Game is smooth pan on external views or zoom in cockpit with mouse/controller/flight stick same stutter.

Share this post


Link to post
Share on other sites

On my oldie but goodie i5-2500K system I have experienced certain stutters lately too.

I've been fiddling around with CPU/GPU/RAM overclocking (not seriously, just testing purpose) during the past two weeks so I first thought it could be related to it.

Unrolled all OC changes, stutter was still there.

To cut the long story short, I finally uninstalled the Microsoft Meltdown patch (KB4056892 in my case, Win 10 x64 Fall Creators Update Build 1709) and so far the stutters seem to be gone.

As it's highly unlikely that Intel will release Microcode updates for Sandy Bridge CPUs and even if so, ASUS will rather not want to touch the BIOS for mainboards at the age of 7 years, the whole Spectre/Meltdown thing will remain an open issue on my current hardware anyway and an upgrade is due this year, so for the moment I take the risk and have a smooth system again.

As a side effect, the Meltdown Patch also killed some ASUS services and rendered a couple of chipset drivers unusable, so it seems compatibility of that patch could indeed be a problem.

 

Cheers!

Mike

Edited by SAS_Storebror

Share this post


Link to post
Share on other sites

Thanks for the reply's guys

@icecream no joy

@Mike are you talking overall stuttering or in the same location I'm experiencing them.

Edited by Smiley_ie

Share this post


Link to post
Share on other sites

It's actually hard to tell where the stutter happens.

I've first noticed it on a campaign mission when I watched a Ju-88 taking off. I was sitting in the cockpit and the Ju-88 was going like in "online jitter" mode, nearly standing still for a split second, then jumping forward by 50m in a loop.

Mission looked fine afterwards, until I came to combat area and entered a dogfight with three MiG-3. They were all warping around like crazy.

Tried the same campaign mission again after uninstalling that Meltdown patch and everything was fine.

It was not related to being in- or outside the cockpit in my case though.

 

Cheers!

Mike

Share this post


Link to post
Share on other sites

When I had this issue, it was because I had to turn "hardware acceleration" off in my internet browsers. 

Share this post


Link to post
Share on other sites

Please try these settings, especially #2.

 

https://forum.il2sturmovik.com/topic/26746-trackir-and-ffb-working-together-cause-terrible-stuttering/?p=557302

 

 

It does not make the stutters go away completely but it reduces them, especially a kind of micro warping that you can see when you turn your head.

 

I'm not sure how system depending that is so please give feedback if you try. I know it helped some already.

Edited by Blue_Jordan

Share this post


Link to post
Share on other sites

@Gridiron made no difference.

@Blue_Jordan tried option 2 made no difference still stutter.

If i shift-f2 to ground units and pan around i also get this stutter.

Share this post


Link to post
Share on other sites

When I had this issue, it was because I had to turn "hardware acceleration" off in my internet browsers.

 

Tried that but no change.

I must admit I knew before that it won't change a thing, because my setup is with dual monitor, and on the second screen I have Rainmeter with GPU monitoring running where I can clearly see that browsers (regardless which one) don't occupy your GPU when they're minimized.

 

 

 

Okay let's see...

 

#1 - Go to your task manager -> tab details - > right click TrackIR -> select priority -> high

 

#2 - Go to your Nvidia control panal -> manage 3D settings -> il-2 game profile -> set threaded optimization "off" (see picture)

Tried both #1 and #2, one each and together, no change.

 

Cheers!

Mike

Share this post


Link to post
Share on other sites

Thanks for letting me know. Most stuttering is very specific, guess we have different causes then.

 

Some stuttering is due to the engine though and hardly possible to get rid of. It was the same with Dx9, panning around was horrible, might also have something to do how landscape is drawn.

Share this post


Link to post
Share on other sites

Yes there's a lot of possible reasons for issues, I fully agree.

 

Yesterday with a rather lightweight mission for instance, I faced an FPS drop down to 30-40 FPS on my i5-2500K/GTX970 system @2560x1440, where usually the game runs at 70+ FPS all the time.

Not a big deal since I have a G-Sync Monitor, but nevertheless I wanted to see what's the reason behind, and even though there were just about 16 planes flying on the map in total, plus another 20 cars/tanks etc., the limiting factor was CPU load apparently as the GPU core load was just @70% roughly. That's been a bit of a surprise to me. Not to mention the fact that dserver seems to be strictly single core, but the client doesn't seem to scale well with available cores either (the overall CPU load was below 50%, counting all cores).

But that's a different story again, I'm just mentioning it because there can be oh-so-many factors influencing our sometimes rather different results.

 

Cheers!

Mike

Edited by SAS_Storebror

Share this post


Link to post
Share on other sites

I also tried Vsync enabled/disabled in game with Nvidia Inspector, Triple buffering - on, Vsync - on, Vertical sync smooth - on, Vertical sync tear - adaptive tried a few different settings but all end up with the same stutters in the same place's.

Hopefully new update fix's it.

Thanks for the reply's

Share this post


Link to post
Share on other sites

try the smoothness setting - think its under camera... between 0-100. give it a whirl at both ends.  default is 50. should do something. 

Share this post


Link to post
Share on other sites

I have a i7 3930k overclocked to 5.1Ghz with a 1080 Ti and I get it as well. It's something that's been reported time and again since the October Update. While your frames might be stable in the mid 50's to upper 60's it still stutters for some reason. Hell, my frames can plummet into the low 20's at times. This occurred as they began adding graphical features during said update going forward. Still, something somewhere is eating resources.

 

There isn't a fix, unfortunately. 

Share this post


Link to post
Share on other sites

I just got BOS i can run it at 60 - 120 fps and it runs smooth but f2 external view when i move mouse or controller around i get a strange stutter in cockpit view its smooth but if a zoom i get the same stutter.

Tried vsync on/off. Set frames to 60, Nvidia control panel - vsync on - adaptive vsync no matter what i try can remove this stutter

i5 8600k @ 4.6

16 gig 3600

GTX 1070 @ 2560x1080

Please try together :

Vsyn off, fps limit to 60, windowed mode.

Share this post


Link to post
Share on other sites

On those specs unless something very wrong should be able to run (at least under windows 7)

150-200FPS (with hud on vsync off)
------------------
2560 x 1080P
Ultra preset,
Ultra shadows,
SSAO / HDR / AA Turned on
Fps limit Off,
Vsync off (2560x1080 screen should be Gsync? if not then Vsync on.)

Did you setup Nvidia control panel Individual profile for IL2.exe
All games must have their own profile for best performance and compat.

If you made a profile did you accidently set Pre-rendered frames to 2 or 3?
(default should be 1 frame ahead, the more frames the more input lag then lots of stutter then crash at around 5-6 frames ahead on some systems)

also make sure power management set to Prefer maximum performance
this will set the GPU to max clock speeds and keep them there entire time game is running so it dont stutter when card suddenly has to power up

Edited by =TBAS=OccludedLight14

Share this post


Link to post
Share on other sites

Please try together :

Vsyn off, fps limit to 60, windowed mode.

 

 

 

 

 

Might be worth trying for users with "standard" monitors.

For G-Sync users like me, VSync Off is a no-go.

You get tearing regardless the framerate you have and regardless what you cap it to.

Any user with G-Sync + TrackIR can easily check this by shaking his head in cockpit view while VSync is off.

 

Cheers!

Mike

Edited by SAS_Storebror

Share this post


Link to post
Share on other sites

Might be worth trying for users with "standard" monitors.

For G-Sync users like me, VSync Off is a no-go.

You get tearing regardless the framerate you have and regardless what you cap it to.

Any user with G-Sync + TrackIR can easily check this by shaking his head in cockpit view while VSync is off.

 

Cheers!

Mike

I know what I'm talking about, I have Acer Predator x34 g-sync. Use NV option to use g-sync in windowed mode. Turn off vsync in game gfx menu, turn off fullscreen. Test , then turn on fps limit to 60 ,test.

Share this post


Link to post
Share on other sites

why with Gsync would you aim for only 60fps on such a system.
80fps would be better but capping at 120-144 would make it nicer.
(or in the case of the Acer Predator x34 then 100hz overclock it comes with and run 100fps)

i suggest nvidia profile

also why use windowed mode.
unless something broken in most cases Fullscreen is faster and more stable,
 

Share this post


Link to post
Share on other sites

why with Gsync would you aim for only 60fps on such a system.

80fps would be better but capping at 120-144 would make it nicer.

(or in the case of the Acer Predator x34 then 100hz overclock it comes with and run 100fps)

 

i suggest nvidia profile

 

also why use windowed mode.

unless something broken in most cases Fullscreen is faster and more stable,

 

I don't have problems. Yes it my look odd but you are on right track ;)

Share this post


Link to post
Share on other sites

Okay, that much I agree, VSync should be enabled in Nvidia Control Panel and disabled in IL-2 if you have a G-Sync Monitor.

That's exactly my setup.

I don't see no use in capping FPS and/or running the game in windowed mode, but then again, I'm not affected by stuttering issues either (or might not have noticed them).

 

For the record, these are my system specs:

CPU = Intel Core i5 2500K @4.4GHz
GPU = Nvidia GTX 970 4GB DDR5 (Palit Jetstream), default clocks
Memory = 16GB DDR3-1600 (4x4GB, dual channel)
Display =  2560x1440 144Hz G-Sync (Acer Predator XB271HUbmiprz), display port
HDD = 256GB SSD (Sandisk)
 
Deeper FPS investigations on my system can be found here:

 

Cheers!

Mike

Share this post


Link to post
Share on other sites

You can have it (vsync) disabled in NV panel and still working G-sync during frames below refresh rate and automatically disabled when fps are above refresh rate. This will reduce input lag and I didn't notice frames tearing. (Windowed mode). This behavior is officially supported by Nvidia.

Edited by 307_Tomcat

Share this post


Link to post
Share on other sites

If you disable VSync both in Nvidia Control panel and in IL-2 you definitely get horrible tearing regardless which framerates you actually get.

Been there, done that.

 

Cheers!

Mike

Share this post


Link to post
Share on other sites

If you disable VSync both in Nvidia Control panel and in IL-2 you definitely get horrible tearing regardless which framerates you actually get.

Been there, done that.

 

Cheers!

Mike

No if windowed mode is enabled.

Share this post


Link to post
Share on other sites

If you set only 1 pre-rendered frame ahead
input lag is not noticeable to humans its 11ms/frame at most cost.

11m/s we cant judge - it takes average person 100-150ms to blink

Share this post


Link to post
Share on other sites

If you set only 1 pre-rendered frame ahead

input lag is not noticeable to humans its 11ms/frame at most cost.

 

11m/s we cant judge - it takes average person 100-150ms to blink

Say that to pro FPS players, but yes in CFS is not that important.

Share this post


Link to post
Share on other sites

If you set only 1 pre-rendered frame ahead

input lag is not noticeable to humans its 11ms/frame at most cost.

 

11m/s we cant judge - it takes average person 100-150ms to blink

Still the same stutters in the same location's, Also thanks for the help guys appreciate it.

Share this post


Link to post
Share on other sites

Due to the problem in win10 update with Gsync monitors the best settings for tear free are:

 

Default settings in NV panel for Il2.exe except Vsync which must be ON, single monitor performance (unless you have more!), and Maximum performance for power.

 

No Vsync in game, no FPS limits or dynamic resolution and set for Full Screen.

 

It’s also good to set Gsync both desktop and full screen so to avoid confusion if you alt-tab for some reason.

Edited by KG200_Volker

Share this post


Link to post
Share on other sites

I'm also experiencing this issue, I've tried every solution I could find in forums, and I'm now close to just giving up.

 

Vsync on/off does nothing, nvidia options changes nothing, FF on/off changes nothing, removing joystick - nada. Drivers reinstalled, game reinstalled etc.

 

Link below for details.

 

Specs:

Laptop

i7-7700HQ @2.8GHz

8GB RAM

64bit Win10

NVIDIA GTX1050 (laptop version)

 

Any help will be very much appreciated. 

 

 

VIDEO of problem: 

 

 

Share this post


Link to post
Share on other sites

Sorry to say but this is definitely a VSync issue, nothing to do with stutter.

Turn on VSync in Nvidia Control Panel.

I know you said you tried, but try again please.

Choose BoS on the programs tab and turn it on there, don't use the general tab.

 

Cheers!

Mike

Share this post


Link to post
Share on other sites

Due to the problem in win10 update with Gsync monitors the best settings for tear free are:

 

Default settings in NV panel for Il2.exe except Vsync which must be ON, single monitor performance (unless you have more!), and Maximum performance for power.

 

No Vsync in game, no FPS limits or dynamic resolution and set for Full Screen.

 

It’s also good to set Gsync both desktop and full screen so to avoid confusion if you alt-tab for some reason.

Bos do not support G-sync yet.

Share this post


Link to post
Share on other sites

G-Sync is not something that is supported by a title, its only between a GFX card and monitor. When your frame-rates dip bellow your monitors refresh rate instead of them being dumped the monitor changes its own refresh rate to match them in order to avoid tearing (aprox down to 35 FPS bellow that it doesn't work). This used to be done by V-Sync but it introduced other problems.

Share this post


Link to post
Share on other sites

G-Sync is not something that is supported by a title, its only between a GFX card and monitor. When your frame-rates dip bellow your monitors refresh rate instead of them being dumped the monitor changes its own refresh rate to match them in order to avoid tearing (aprox down to 35 FPS bellow that it doesn't work). This used to be done by V-Sync but it introduced other problems.

.

Well you wrong about Bos.

Share this post


Link to post
Share on other sites

Might be worth trying for users with "standard" monitors.

For G-Sync users like me, VSync Off is a no-go.

You get tearing regardless the framerate you have and regardless what you cap it to.

Any user with G-Sync + TrackIR can easily check this by shaking his head in cockpit view while VSync is off.

 

Cheers!

Mike

 

You get tearing with G-synch on?

 

Your G-synch isn't working correctly my friend.

 

I get no tearing with G-Synch enabled - that's kind of the point of G-Synch after all.

 

I disable V-Sync - ensure G-Synch is enabled in the NVidia c/panel and no more stutters no matter what FPS you get.

 

 

G-Sync is not something that is supported by a title, its only between a GFX card and monitor. When your frame-rates dip bellow your monitors refresh rate instead of them being dumped the monitor changes its own refresh rate to match them in order to avoid tearing (aprox down to 35 FPS bellow that it doesn't work). This used to be done by V-Sync but it introduced other problems.

 

This is correct. G-sync works in conjunction with your GFX card driver and your monitor. 

 

If it isn't working in any given game then it's not down to the game.

 

Makes me laugh when people spend an not inconsiderable amount extra to buy a G-Sync monitor without really understanding how to use it.

 

 

G-Synch ON in NVidia Control Panel + V-Sync OFF in game.

Edited by Extreme_One

Share this post


Link to post
Share on other sites

 

You get tearing with G-synch on?

 

No.

 

 

 

I disable V-Sync - ensure G-Synch is enabled in the NVidia c/panel and no more stutters no matter what FPS you get.

 

In that case you'll get tearing. You probably just haven't noticed it yet.

 

 

Makes me laugh when people spend an not inconsiderable amount extra to buy a G-Sync monitor without really understanding how to use it.

 

G-Synch ON in NVidia Control Panel + V-Sync OFF in game.

 

Let me laugh back.

The important point is to enable G-Sync and V-Sync in Nvidia Control panel.

 

Cheers!

Mike

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...