Jump to content
DDoutel

Users Of CH Products Gear With Control Manager Software - BE ADVISED!

Recommended Posts

Sorry I can't help you on the hardware issue.  For hardware questions this forum is probably OK but there is another forum for the older IL-2 Series.  You might find helpful information there.  The game you have is listed and referred to as IL-2 1946.

 

Link:  https://forum.il2sturmovik.com/forum/20-other-1c-game-studios-games/

 

1946 was a great game in it's day and a lot of fun.  Good place to learn things inexpensively.  As far as the two products being the same except for graphics though, this just isn't the case.  The new series (IL-2 BOX) also has higher fidelity flight, engine, ordnance, damage, map, mission and weather models.  Just advances in technology.

 

Welcome to the forums.

Thanks VBF-12.

 

So the version I have IL-2 UE (which has Forgotten Battles, Forgotten Battles ACE Expansion Pack, 1946, and Pacific Fighters), is an older one superseded by IL-2 BOX....... correct?  I'll check that link, but aside from fixing my stick issue, I'm hoping this one can be upgraded with better graphics patches. Probably not, but hey, one can hope.  I did some more testing and found that the stick and pedals are responding to the calibration in IL-2 settings, but still not in the games menu option "Hardware". Oddly, the rudder pedal brakes are registering, but not the movement of the pedals or the stick. Somewhere there is a setting, and "click this box" option that is screwed up. I'm sure it's something simple if it's working in the settings under the game's breakdown menu in programs, but not fully in the game itself. I'll keep messing with it and see what happens.

Share this post


Link to post
Share on other sites

A little improvement.  After messing with it a few times, I got the game to recognize my stick again, except now the ailerons are reversed. ???!!!  All other functions are responding normal, but left stick shows right roll and right stick shows left roll.  I've continued messing with it and still no fix for that.  It's hard for me to believe this thing was working perfectly the night before and the next morning, but later in the day...... nothing worked!  Took a while to get it to where it is now (with reversed ailerons),  but it's a step in the right direction at least. 

Share this post


Link to post
Share on other sites
On 3/19/2018 at 12:48 PM, Blue352 said:

I got the game to recognize my stick again, except now the ailerons are reversed. ???!!! 

 

You can ‘reverse’ an axis in game. Go to settings, then to the control assignments. Look where you assigned the ailerons and click that arrow that looks like a U-Turn.

Share this post


Link to post
Share on other sites
Quote
2 hours ago, BP_Lizard said:

 

You can ‘reverse’ an axis in game. Go to settings, then to the control assignments. Look where you assigned the ailerons and click that arrow that looks like a U-Turn.

 

 

But this 'U-Turn' thing is in Bo'X controls, and the guy are asking about the "grandpa" IL-2 UE... :)

 

 

Share this post


Link to post
Share on other sites

While I appreciate that this is an old thread, I wanted to add my own comments on this as I've just come across this over the weekend and I was even considering re-installing Windows 10 as I could not get rid of the Virtual devices added by the manager software.

 

However in between re-installs and uninstalls, I tried removing all the registry entries with no success at removing the devices.  But I did come to a realisation.

 

The issue appeared to be down to CM Control Center.  I concluded this as it only happened after I added the map to the CM Control Center program and loaded it.

I also realised that as CM Control Center remembered the last loaded profile it had to either have configuration details somewhere.  Removing the registry entries meant that the settings were more likely stored in an ini file.

 

With that I did two things.

1. Deleted the .map profile from My documents.

2. Set about looking for the .ini file.  Most programs will either store settings in either the program directories, or in %APPDATA%\ or %LOCALAPPDATA% - Note that these environment variables are specific to the current user.

 

I found the files in question in %LOCALAPPDATA%\CH Products\Control Manager\ Data

 

The two files in there are:

CHCtlMgr.ini

History.dat

 

Both files are text files.  The ,ini file contains the startup settings

 

[CurrentMaps]
CurrentLoadPath=C:\Users\timdu\Documents\EliteDangerous.map
CurrentMapPath=C:\Users\timdu\Documents\EliteDangerous.map
[LoaderOptions]
StartAction=2
LastMode=1

While the History,dat file contains a history of loaded maps.

EliteDangerous.map
C:\Users\timdu\Documents\EliteDangerous.map

I suspected that if I deleted the files they would be recreated the next time I ran Control Manager but with the default settings. (i.e. No maps and no History)

 

So I first closed down CM Control Center and Control Manager.  Then I deleted the files.

 

On relaunching CM Control Center, I noted that while the Mapped Mode button was still grayed out, the Off and Direct Mode buttons were now enabled.  Which was the default state of the software as there was now no map loaded.

 

The final step was to recreate the map file and put the system into mapped mode.  This once again allowed me to use the joystick and throttle combination properly.  While I can't say that I won't have the same problem again, but so far since Saturday I have been able to play Elite Dangerous with the previous binds I've set up.

 

So at worst this is a temporary fix that can be re-applied.  I will post back with an update in about a weeks time.

 

Hopefully this will help anyone else using CH Products Joysticks with Windows 10.

 

I'm using Windows 10 Professional Version 1809 Current Build 17763.253

 

Again apologies for resurrecting an old thread but I do hope this proves useful.

  • Like 1

Share this post


Link to post
Share on other sites
On 12/21/2017 at 3:29 AM, kendo said:

Is this due to the recent Win 10 Fall Update?

 

I'm still on the Spring update - I usually try to delay installation for 6 months until all the bugs are thoroughly worked out - and everything seems to be ok.

 

I suspect CH will need to remedy this situation in some way as they can't just write off new sales because their products don't work with Windows.

 

CH doesn't give two hoots in hell for the consumer market.   They are only interested in industrial sales now.   They have NEVER had a software engineer for their game controllers and don't want to hire one now.    They're done with us.   

  • Sad 1

Share this post


Link to post
Share on other sites
2 hours ago, Jodet said:

CH doesn't give two hoots in hell for the consumer market.   They are only interested in industrial sales now.   They have NEVER had a software engineer for their game controllers and don't want to hire one now.    They're done with us.   

 

They did have a guy a while back who did program the CH Control Manager, but he's long moved on. So, what people have now is all they're going to get.

Share this post


Link to post
Share on other sites

Opera resume: CH's are the same product as in 2000, but no longer work as in 2000. 😀

Share this post


Link to post
Share on other sites

 

I THINK I HAVE A FIX FOR THIS. 

 

1)  You've got to be able to restore the previous version of Windows.   Do that, then do step two immediately. 

 

2) Do a 'Start, Run' on 'services.msc'.    Scroll to the bottom, find 'Windows Update' and change it to 'disabled' and then STOP it.  

 

When you are ready to reboot it might say 'update and shut down' or 'update and reboot' but here's the thing... on my system it DIDN'T do the update once I'd stopped the Windows update service. 

 

The old version of Windows worked.    If you can restore that version this will stop Windows from pushing down the update.    Now I'm thinking Windows may have some tricky nonsense where they give you a week, or a month, or something like that and then PUSH IT DOWN ANYWAY. 

 

But maybe not.   Maybe with 'Windows Update' in services.msc disabled we can keep the version of Windows that doesn't break Control Manager.

 

I've tried literally everything else and literally nothing has worked.   Until now. 

 

I talked to the President of CH Products once and he just hated the software part of their business.   Let's hope they do the right thing here and get this fixed. 

 

If this works for you please let us know! 

 

 

Share this post


Link to post
Share on other sites

Restoring an old version of Windows sounds like a bad idea. You won't get security fixes and whatnot. I came across this potential solution a few minutes ago on Reddit, so I'm spreading the word:

 

Post 1:

When the buttons grey out, sign out of windows and then sign back in. The devices will reinitialize and Control Manager will be in the mode you had tried to switch to. 

 

Post 2:

Turn off and Disable the Windows Service called SysMain. That fixes all the issues. It gets reenabled by updates though. 

*Edited for better wording.*

The service has something to do with precaching for the windows metro apps. If the buttons grey out again, just open the Windows Store app. Disabling SysMain completely fixes it.

 

Post 3:

Killing the Microsoft Store process in the task manager literally fixed every single problem I've had with Control Manager in Windows 10.

 

Edited by Eclipse4349
  • Like 1

Share this post


Link to post
Share on other sites

I had the icons Grey out again tonight. As the first poster I quoted said, logging off and logging back on worked! The controllers were back, nothing was greyed out, and it was in the mode I attempted to put it in when it greyed out. 

Share this post


Link to post
Share on other sites

I've had a similar problem with the CH Control Manager software on my rig running Win7. After much futzing around, I figured out that Teamspeak would leave a process running after closing. Disabling it in Windows task manager fixes it.

 

Good hunting,

Conky

Share this post


Link to post
Share on other sites

how do I kill the Microsoft Store process in the task manager ? I´m probably looking for the wrong thing. 😚 Is it an app or is it called "Microsoft Store", is it in process or in services?

I´m very exited to find a solution.

Share this post


Link to post
Share on other sites

image.png.82e8ed4bc0261887e265342bb149f1e6.png in task manager then end task. It worked twice for me.

 

Have fun

Share this post


Link to post
Share on other sites

Start/Cortana box, type: gpedit.msc

 

Computer Configuration -> Administrative Templates -> Windows Components -> Store 

 

Set Enable for all Disable options. After all, who need Microsoft Store running all time?

 

https://social.technet.microsoft.com/Forums/windows/en-US/a8405957-5025-427e-9405-331b1a8dde21/uninstall-or-disable-the-microsoft-store?forum=win10itprogeneral

Share this post


Link to post
Share on other sites

Control Manager in W10 is still working for me. At least for calibration which was all I ever used it for. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...