Jump to content
PatrickAWlson

PWCG 6.1.5 Released - Another Bugfix Patch

Recommended Posts

I bet you're using the Cold Start version.  It's looking at the new US and Brit squad files, and doesn't know what to do with them.  If you go into your squadrons directory and delete all the US and RAF squads, it should work.  Although my missions still aren't cold start for some reason.

 

For the smoke, I have no clue.

 

Oops, I just re-read your post and saw that you are indeed using that version.  I don't think it's really working quite yet.  Hence the "experimental" label.  😄

Edited by Napping-Man

Share this post


Link to post
Share on other sites
6 hours ago, tkcamp56tkcamp said:

I have just installed PWCG  for the first time and all went smooth till I tried to start the campaign.  I get an error stating that I must change the Startup.cfg file to 

 "Mission_text_log = 1 "    which I have done. And I still get the error. 

 

I also noticed when I installed PWCG it said I didn't have it installed in the right Directory. I installed it into my Game directory in steamapps/common/ il2sturmovk

Hum, I don't have BOX  installed with steam. I do have COD thru steam and the folder structure is different.  I may be mistaken  but I wonder if should it should be installed the missions folder?  I hope someone  has the answer because PWCG is a wonder full single player addition. 

Edited by Taxman

Share this post


Link to post
Share on other sites

I'm not a steam guy so I don't know if the install is any different.  I didn't think it is.  The game produces a directory structure, with one folder in the base game directory being the data folder.  PWCG should be installed in the base game directory.  PWCG uses a relative offset of ../data to reach the in game data directory.

 

If we got a screen shot of exactly where PWCG is installed we could resolve things pretty quickly.

Edited by PatrickAWlson

Share this post


Link to post
Share on other sites

Is there a way to adjust flight speeds? Doing a 109 campaign and the flights are running at nearly 450kph in a climb somehow I just can't keep up without running the plane on full boost. I am unsure how even the AI is able to maintain such speeds during a climb.

Share this post


Link to post
Share on other sites
7 hours ago, PatrickAWlson said:

I'm not a steam guy so I don't know if the install is any different.  I didn't think it is.  The game produces a directory structure, with one folder in the base game directory being the data folder.  PWCG should be installed in the base game directory.  PWCG uses a relative offset of ../data to reach the in game data directory.

 

If we got a screen shot of exactly where PWCG is installed we could resolve things pretty quickly.

I did get an error stating that I had put it in the wrong directory during installation.  I moved the folder contents to the game root , didn't help so I moved it back. The error went away and let me open PWCG. I then created a campaign in coop. and then O received the error again when I tried to launch it. I wonder if it is Steam's path? 

Share this post


Link to post
Share on other sites
1 minute ago, tkcamp56tkcamp said:

I did get an error stating that I had put it in the wrong directory during installation.  I moved the folder contents to the game root , didn't help so I moved it back. The error went away and let me open PWCG. I then created a campaign in coop. and then O received the error again when I tried to launch it. I wonder if it is Steam's path? 

You are supposed to put the actual PWCG folder in the main Il2 folder. Not the one with the exe. Also you shouldn't be taking anything out of the PWCG folder and placing those folders anywhere.

Share this post


Link to post
Share on other sites
1 minute ago, JonRedcorn said:

You are supposed to put the actual PWCG folder in the main Il2 folder. Not the one with the exe. Also you shouldn't be taking anything out of the PWCG folder and placing those folders anywhere.

I did that originally. I only tried taking the files out after I couldn't get it to work. The folder is in the main IL2 folder now,  it just won't let me launch. I am not home now but it looks something like   steamapps/common/battleofstalingrad/…….folder here

Share this post


Link to post
Share on other sites

If PWCG is unzipped whole it will always run, given an up to data Java installation (could that be the problem?).  It won't work properly until it is in the right directory, but it will run. There are error logs in the PWCG directory that might help.

Share this post


Link to post
Share on other sites
3 minutes ago, tkcamp56tkcamp said:

I did that originally. I only tried taking the files out after I couldn't get it to work. The folder is in the main IL2 folder now,  it just won't let me launch. I am not home now but it looks something like   steamapps/common/battleofstalingrad/…….folder here

Yeah that's where the main PWCG folder is supposed to go, and then you run the exe do you have java installed?

Share this post


Link to post
Share on other sites

Yes, I had to install Java before I could install PWCG. I didn't have it prior to then.  I thought it strange that the error seemed to go away on its own just by moving the files in and out of that folder

Do you think a reinstall of PWCG might help? The reason I want to do this is, my brother and I fly together and I am wanting to put together some missions for us to fly the p47 in multiplayer if its possible

17 minutes ago, PatrickAWlson said:

If PWCG is unzipped whole it will always run, given an up to data Java installation (could that be the problem?).  It won't work properly until it is in the right directory, but it will run. There are error logs in the PWCG directory that might help. 

I just let java download from the prompt that came up, so I cant verify the version. I will check the log this afternoon and try again. I'm not sure I'm savvy enough to parse through a error log to figure it out though.

 

Thanks for your replies guys 

Share this post


Link to post
Share on other sites
2 hours ago, tkcamp56tkcamp said:

Yes, I had to install Java before I could install PWCG. I didn't have it prior to then.  I thought it strange that the error seemed to go away on its own just by moving the files in and out of that folder

Do you think a reinstall of PWCG might help? The reason I want to do this is, my brother and I fly together and I am wanting to put together some missions for us to fly the p47 in multiplayer if its possible

I just let java download from the prompt that came up, so I cant verify the version. I will check the log this afternoon and try again. I'm not sure I'm savvy enough to parse through a error log to figure it out though.

 

Thanks for your replies guys 

 

Error logs are plain text.  Post the file here

Share this post


Link to post
Share on other sites
4 hours ago, PatrickAWlson said:

 

Error logs are plain text.  Post the file here

Here is my path....but where do I look for the error log file?Untitled.thumb.png.10c26097ad6ec1aaf8a5f37aa9e95909.png

Share this post


Link to post
Share on other sites

Error logs should pop into that main directory you have displayed as PWCGErrorLog.txt - not sure why your's arent (???) 

Share this post


Link to post
Share on other sites
2 minutes ago, dburne said:

You sure you have logging enabled?

PWCGErrorLog.txt

 

Yes I have triple checked :)        I found another Error log file this one makes it look as though its looking for things on my "C" drive

Share this post


Link to post
Share on other sites

@tkcamp56tkcamp ErrorLog.txt does indicate that it is looking for PWCG in a different directory - on your desktop.  Did you pull out the application and drop it on your desktop?  That's what it looks like.  You can create a shortcut to the PWCG application and put that on your desk top but if you put the application itself there the app will try to run with the desktop as its root directory. Good chance that you have PWCGErrorLog.txt on your desktop as well.

 

Try deleting any reference to PWCG from your desktop.  Run the PWCG application from the folder - make sure it works.  Then try creating a shortcut to the app and putting the shortcut on your desktop.

 

 

Share this post


Link to post
Share on other sites

I´ve found two strange things going on in my campaign.

 

1. Bf-109G´s flying in African camo (sand yellow. Maybe related to the new skin pack) Looks weird.

2. The Pe-2´s I have to protect in some missions dont care about bombing. They attack (or better gangbang) enemy fighters. This looks very weird ^^

Share this post


Link to post
Share on other sites
50 minutes ago, Semor76 said:

I´ve found two strange things going on in my campaign.

 

1. Bf-109G´s flying in African camo (sand yellow. Maybe related to the new skin pack) Looks weird.

2. The Pe-2´s I have to protect in some missions dont care about bombing. They attack (or better gangbang) enemy fighters. This looks very weird ^^

 

Noticed similar in a Bodenplatte P47 campaign - A20s we were tasked to escort had Russian markings.

Share this post


Link to post
Share on other sites
11 hours ago, No457_Stonehouse said:

 

Noticed similar in a Bodenplatte P47 campaign - A20s we were tasked to escort had Russian markings.

 

Th A20s I get.  I have not yet implemented skin assignments for them so they will use the Russian defaults.  The Me 109s I do not get as I am pretty sure that African camo is neither a default nor a assigned skin.  Any information on the squadron is helpful.  Posting the mission file would also help.

 

@tkcamp56tkcamp

It looks like mission log set is one.  That leads me to believe that PWCG is not finding that PWCG is not finding that instance of your startup cfg.  PWCG expects the startup cfg to be in its standard place - I think the data directory but I'm not 100% sure.  I i will look further tonight.  Was I right about the desktop thing?  Just want to make sure that one issue is resolved before moving to the next.

Share this post


Link to post
Share on other sites

Yes, you were right about the desktop. I had a copy on there but it has been removed. The startup file is in my data dir. This all under Steam's file path though. it does drop the error log into the proper place now.

 

 

Share this post


Link to post
Share on other sites

I am having an issue with the PWCG skins.

 

I just got back into PWCG. Dowloaded the PWCG Skin Pack and latest PWCG version, and extracted both into my root Il-2 folder. All of PWCG skins are selectable in the in-game loadout menu via the custom tab. Further, PWCG is generating missions just fine.

 

However, the skins are not appearing in Skin Assignments and PWCG is not assigning the skins to any of the squadrons' aircraft when it generates missions.

 

I also notice that in the PWCG Skins/Configured jsons for each aircraft no skins are listed as configured? Could this be causing it?

Untitled.jpg

Untitled1.jpg

Share this post


Link to post
Share on other sites
Posted (edited)

@Andrei_Dragovic The skins will not appear in the assignment menu.  The reason is that they are being used as squadron skins and not individual skins.  PWCG intentionally excludes squadron skins from the individual skin lists.


If you really want to use a squadron skin as an individual skin you can copy it and give it a new name.  IMHO a better option is to download some different skins for use as individual skins.  If you drop them into the correct game folder PWCG will pick them up as loose skins.

Edited by PatrickAWlson

Share this post


Link to post
Share on other sites
Posted (edited)

There is a distinction between "Squadron" skins and "Individual skins associated with a squadron", and I concede that theUI does not do a good job of explaining this distinction.  A squadron skin is the default for every member of the squadron.  These skins are defined in the squadron file.  An individual skin associated with the squadron would generally combine squadron and individual markings.  These skins are defined by aircraft type in the data/input/skins directory.

 

This first cut is far from ideal.  The skins used as squadron skins are probably better used as individual skins.  Ideally a squadron skin would be a relatively simple skin with only squadron markings. For German squadrons this is tough because every airplane had individual markings.  That leaves me with a choice of no individual markings (probably preferable) or what we have now: many "Yellow 4" aircraft in a flight.  In Russian squadrons you will get several planes with the same patriotic slogan.  Such is the state of things at this point.  

 

Going forward I would like to make more generic squadron skins and start adding more individual skins.  It's just a ton of work, and I am already occupied with other PWCG development.  With that in mind, if anybody sees a squadron skin that they disagree with and wishes to post a better alternative, please feel free to do so.  

 

Edited by PatrickAWlson

Share this post


Link to post
Share on other sites
10 hours ago, PatrickAWlson said:

There is a distinction between "Squadron" skins and "Individual skins associated with a squadron", and I concede that theUI does not do a good job of explaining this distinction.  A squadron skin is the default for every member of the squadron.  These skins are defined in the squadron file.  An individual skin associated with the squadron would generally combine squadron and individual markings.  These skins are defined by aircraft type in the data/input/skins directory.

 

This first cut is far from ideal.  The skins used as squadron skins are probably better used as individual skins.  Ideally a squadron skin would be a relatively simple skin with only squadron markings. For German squadrons this is tough because every airplane had individual markings.  That leaves me with a choice of no individual markings (probably preferable) or what we have now: many "Yellow 4" aircraft in a flight.  In Russian squadrons you will get several planes with the same patriotic slogan.  Such is the state of things at this point.  

 

Going forward I would like to make more generic squadron skins and start adding more individual skins.  It's just a ton of work, and I am already occupied with other PWCG development.  With that in mind, if anybody sees a squadron skin that they disagree with and wishes to post a better alternative, please feel free to do so.  

 

Sorry to quote you for another topic, but is there a way to alter the cruise speed of your teammates? I can't seem to keep up especially if my wingmen are in say f4's and I am in a f2. They seem to be able to climb at an incredible rate. Had to run nearly emergency power to even stay with them 2 or 3 km back.

Share this post


Link to post
Share on other sites

Tried a reinstall still no joy. I have tried all suggestions and it still says needs set to 1 .....it is!  

Share this post


Link to post
Share on other sites
On 2/27/2019 at 7:47 PM, tkcamp56tkcamp said:

 

 

 

It still is stating that mission logging is not enabled and asks me to "set mission_text_log=1"

 

startup.cfg.txt    here is my cfg file

 

Just to be sure: the file should be called startup.cfg and not startup.cfg.txt.  Did you append .txt to the end of the file just to post it here or is it really startup.cfg.txt on your disk?  If the latter rename it to  startup.cfg.  Also it should be in your BoS install data directory.

Share this post


Link to post
Share on other sites
1 hour ago, PatrickAWlson said:

 

Just to be sure: the file should be called startup.cfg and not startup.cfg.txt.  Did you append .txt to the end of the file just to post it here or is it really startup.cfg.txt on your disk?  If the latter rename it to  startup.cfg.  Also it should be in your BoS install data directory.

Ok, I figured it out. I am not sure why but I had an old Startup file in my data Dir. that was called "oldstartup.cfg"  I saved the original file in case I had trouble after copy and pasting Fenis_wolf's settings for 3dmigoto.  After deleting this file everything work OK. Flew first mission Thank you for this Pat, lots of fun!!! 

Share this post


Link to post
Share on other sites
14 minutes ago, tkcamp56tkcamp said:

Ok, I figured it out. I am not sure why but I had an old Startup file in my data Dir. that was called "oldstartup.cfg"  I saved the original file in case I had trouble after copy and pasting Fenis_wolf's settings for 3dmigoto.  After deleting this file everything work OK. Flew first mission Thank you for this Pat, lots of fun!!! 

 

Glad it's working.  👍

 

Share this post


Link to post
Share on other sites
Posted (edited)
On 3/1/2019 at 3:32 PM, PatrickAWlson said:

There is a distinction between "Squadron" skins and "Individual skins associated with a squadron", and I concede that theUI does not do a good job of explaining this distinction.  A squadron skin is the default for every member of the squadron.  These skins are defined in the squadron file.  An individual skin associated with the squadron would generally combine squadron and individual markings.  These skins are defined by aircraft type in the data/input/skins directory.

2

Hi Pat,

 

please help me, I am still not able to figure out why my squadron teammates do not use the skin defined in the squadron file...

 

I fly I/JG51 FW 190A3 campaign (25.06.1942)  Kuban map  PWCG 5.1.2

 

My I_JG51.json file contains these lines:

    {
      "skinName": "I_JG51",
      "planeType": "fw190a3",
      "startDate": "19400801",
      "endDate": "19421101",
      "squadId": 20111051,
      "country": "Germany",
      "category": "Squadron",
      "definedInGame": false
    },
    {
      "skinName": "I_JG51_W",
      "planeType": "fw190a3",
      "startDate": "19421101",
      "endDate": "19430301",
      "squadId": 20111051,
      "country": "Germany",
      "category": "Squadron",
      "definedInGame": false
    },

 

For my skins folder see attachment

(manually I can assign skin I_JG51 to my aircraft)

 

THX

 

skins_folder.jpg

Edited by Tapi

Share this post


Link to post
Share on other sites

Found more skins who doesen´t fit in the timeframe.

 

Cuban career/La-5/start date: 01.3.1943. Player plane has Winter cammo and in my first combat sortie a FW-190 (possible I./JG51) in white cammo crosses my path.

 

 

Semor,mission text..rar

Share this post


Link to post
Share on other sites
On 3/3/2019 at 8:39 PM, PatrickAWlson said:

@Tapi I'll see what I vcan do about verifying application of squadron skins.  

Thanks Pat. I have thought I am doing something wrong with my PWCG setup but if I understand your comment correctly, the problem is the game do not recognize the skin  correctly specified inside the squadron file?

Share this post


Link to post
Share on other sites
Posted (edited)

I have been trying to use the PWCG cold start version but I cant create a new campaign it gives an error no matter what I do. I uploaded the errorlog here. I can select the airplanes I own but at the point of making a new career, when I select the faction it errors for all of the factions.

I would appreciate some help, if possible.

Have a great night 😃

PWCGErrorLog.txt

Edited by hayraddin
writing errors

Share this post


Link to post
Share on other sites

@hayraddin Thanks for posting.  That is odd - the error logs (and the service code) are saying that they do not understand the service that you are trying to join.

 

FYI the cold start was an experiment.  At the moment it seems to be too error prone to proceed with.  At some future date when bandwidth allows maybe we can revisit.

Share this post


Link to post
Share on other sites

PWCG 5.1.3

Added FW 190 D9 Dora.

-  Start with JG 26 in October 1944 or JG 2 in November 1944.

Fixed: Payloads modifications on several planes.  Me109 G14 and K4, FW190 A5 and A8, Macchi.  

 

  • Like 1
  • Thanks 3

Share this post


Link to post
Share on other sites
Posted (edited)
47 minutes ago, PatrickAWlson said:

PWCG 5.1.3

Added FW 190 D9 Dora.

-  Start with JG 26 in October 1944 or JG 2 in November 1944.

Fixed: Payloads modifications on several planes.  Me109 G14 and K4, FW190 A5 and A8, Macchi.  

 

YES!!!!! Also I asked ya a few times but I guess you didn't see it, if there was any way to adjust waypoint speeds without being squad lead is that a possibility?

Edited by JonRedcorn

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...