Jump to content
Sign in to follow this  
Augusto_Vicco

Optimization?

Recommended Posts

Hello there,

 

I recently tried jumping back into IL-2 BOS, and quickly realized why i had stoped in the first place. The problem being that even on low settings with options like HDR, SSAO, and antialiasing turned down or off completely, the game barley reaches 20 FPS. This is odd considering that my system is an MSI GE72VR with a i7-7700HQ, GTX 1060, 16gb ram, and windows 10. So I was wondering if there was something I could do about this, or whether this is just down to poor optimization?

Share this post


Link to post
Share on other sites

The sim seems to be quite well optimized for most people. I play on Ultra with everything maxed out and I get consistent 60fps on my six year old system.

 

Don't know enough about your hardware to say, what you can do, but no doubt someone can help.

Share this post


Link to post
Share on other sites

There must be something wrong with your settings. I have gtx1070 + i5 6600k. I run petty much everything in maximum with a QHD monitor and the FPS never goes below 60.

 

Didn't see you are on a laptop. Check whether you used the correct graphics card.

Edited by SwallowFire

Share this post


Link to post
Share on other sites

I basically have your computer, OP, aside from that my CPU is an older-model i5 from 2011-2012. I can run the game at the High preset, 4x terrain detail, SSAO and HDR on, shadows set to Ultra, grass to Detailed and mirrors to Complex, and 2x antialiasing, and I get ca 55-100 fps.

 

Something is wrong with your rig. First thing I'd do is to make a clean reinstall of the graphics drives.

Edited by Inkoslav

Share this post


Link to post
Share on other sites

I have the same laptop except mine is a 1070 and it's not our optimization. You are using the Intel integrated graphics chip by mistake instead of your 1060. You have to go into your Nvidia settings and tell the computer to use the 1060 and not Intel. Very simple. Takes 2 seconds.

 

I can max out everything and break 100 FPS on this 120Hz screen that this laptop has.

 

Jason

  • Upvote 4

Share this post


Link to post
Share on other sites

Hello there,

 

I recently tried jumping back into IL-2 BOS, and quickly realized why i had stoped in the first place. The problem being that even on low settings with options like HDR, SSAO, and antialiasing turned down or off completely, the game barley reaches 20 FPS. This is odd considering that my system is an MSI GE72VR with a i7-7700HQ, GTX 1060, 16gb ram, and windows 10. So I was wondering if there was something I could do about this, or whether this is just down to poor optimization?

What?? I have similar specs and I play on ultra preset ,ssao on other option mostly maxed out @3440x1440 and my fps are in range of 80 on the ground to 170 in the air.

Share this post


Link to post
Share on other sites

I have the same laptop except mine is a 1070 and it's not our optimization. You are using the Intel integrated graphics chip by mistake instead of your 1060. You have to go into your Nvidia settings and tell the computer to use the 1060 and not Intel. Very simple. Takes 2 seconds.

 

I can max out everything and break 100 FPS on this 120Hz screen that this laptop has.

 

Jason

This is my first thought too. That, or power saving settings.

 

Check Nvidia control panel to make sure you're using the 1060 for IL2 and best performance settings instead of balanced or power saving.

Share this post


Link to post
Share on other sites

As others said something is wrong with your pc (drivers or something).

I run it on ultra and max settings and lowest fps count i get is 80fps as i noticed.

I7 6700k stock speed, gtx1070, 16gb 2400mhz ram on 2k 144hz monitor.

Share this post


Link to post
Share on other sites

Something must be wrong there as others say. I get a consistent 40-60fps even in demanding situations on the new Kuban map (which is more demanding itself) on my Core i5 6600, GTX 960, 8GB DDR4 ram. IL-2: BoX series is now very well optimized and has been improved significantly in the last 9 months.

Share this post


Link to post
Share on other sites

i hated the experience on my homebuilt Rig (I7 7700k, amd Rx580, 32GB, M.2 and ssds all around...)
the results was black screens every few seconds.
unplayable.

disabled the Gfx card, removed the drivers. and put it all together again...
4K, medium settings and cruising at 30 fps locked.

i too,  think that there is a gremlin in your Laptop :-(
Try jason´s tip and please let us knoow :)
 

Share this post


Link to post
Share on other sites

i hated the experience on my homebuilt Rig (I7 7700k, amd Rx580, 32GB, M.2 and ssds all around...)

the results was black screens every few seconds.

unplayable.

disabled the Gfx card, removed the drivers. and put it all together again...

4K, medium settings and cruising at 30 fps locked.

i too,  think that there is a gremlin in your Laptop :-(

Try jason´s tip and please let us knoow :)

 

You too most certainly were suffering on the broken HD630 GPU that is integrated in the Kaby Lake CPU. Check your BIOS setting.

Share this post


Link to post
Share on other sites

Hello there,

 

I recently tried jumping back into IL-2 BOS, and quickly realized why i had stoped in the first place. The problem being that even on low settings with options like HDR, SSAO, and antialiasing turned down or off completely, the game barley reaches 20 FPS. This is odd considering that my system is an MSI GE72VR with a i7-7700HQ, GTX 1060, 16gb ram, and windows 10. So I was wondering if there was something I could do about this, or whether this is just down to poor optimization?

I play IL2 with similar PC-hardware under Windows 10 and never ever got that bad fps.

 

As mentioned first check if the NVIDIA is activated and not the on board GPU.

Second check if you have the newest NVIDIA driver installed and get the newest.

 

I'm sure, that will solve your fps problems.

Share this post


Link to post
Share on other sites

You too most certainly were suffering on the broken HD630 GPU that is integrated in the Kaby Lake CPU. Check your BIOS setting.

hey thaks for the tip!

Share this post


Link to post
Share on other sites

Guys,

 

Thank you all for your quick responses, but as Jason first said; I had to mess with some setting in the Nvidia control panel to make sure IL2 was not using integrated graphics. And now im breaking 100 FPS

 

-Best regards AV

  • Upvote 4

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...