Jump to content
Sign in to follow this  
SierraKiloGulf

Can't Move Property Dialog

Recommended Posts

Hi there, just trying to make some missions, but I have noticed I can not move the Property Dialog box, and about 1/4 of it is well past the top of my monitor, so I can not drag it down to name a mission, change the date, or time. I have tried to reset the settings, with no luck. Any advice on how to actually be able to move that box down so I can set the fields to what I want? Everything above Mission Type is missing!

Edited by SierraKiloGulf

Share this post


Link to post
Share on other sites

Hi there, just trying to make some missions, but I have noticed I can not move the Property Dialog box, and about 1/4 of it is well past the top of my monitor, so I can not drag it down to name a mission, change the date, or time. I have tried to reset the settings, with no luck. Any advice on how to actually be able to move that box down so I can set the fields to what I want? Everything above Mission Type is missing!

 

Try the solution in this post.

Share this post


Link to post
Share on other sites

Try the solution in this post.

Actually, scratch that. It worked once, then once I closed the Editor, it is now in the same spot, and regardless of how many PC restarts I do it is in the same spot. Any other suggestions?

Share this post


Link to post
Share on other sites
haz click en el cuadro de dialogo, luego pulsa ALT-Space, se te desplega un menu, elige move. luego con las flechas del cursor las vas llevando donde queres.

espero que me hayas entendido

 

Google Trans


Click on the dialog box, then press ALT-Space, you will be displayed a menu, choose move. Then with the arrows of the cursor you take them where you want.

I hope you have understood me

  • Thanks 1
  • Upvote 1

Share this post


Link to post
Share on other sites

 

haz click en el cuadro de dialogo, luego pulsa ALT-Space, se te desplega un menu, elige move. luego con las flechas del cursor las vas llevando donde queres.
espero que me hayas entendido
 
Google Trans
Click on the dialog box, then press ALT-Space, you will be displayed a menu, choose move. Then with the arrows of the cursor you take them where you want.
I hope you have understood me

 

 

 

Unable to move the Property Dialog box in that fashion, move is greyed out. It has actually now moved up since my last PC restart, so now even more of it is missing! That was one of the first things I tried. Unable to now even select the map or terrain presets, how incredibly annoying.

Edited by SierraKiloGulf

Share this post


Link to post
Share on other sites

From your game directory run IL-2 Sturmovik Battle of Stalingrad\bin\editor\ResetEditorSettings.cmd

 

This will reset the floating dialog to there default position.

Share this post


Link to post
Share on other sites

From your game directory run IL-2 Sturmovik Battle of Stalingrad\bin\editor\ResetEditorSettings.cmd

 

This will reset the floating dialog to there default position.

As mentioned in the OP, it resets to above my monitor. I can not ALT Space because I can not see the menu come up either. It was the very first thing I tried. Appreciate the suggestions, but as I already mentioned those are not doing the trick. 3/4 of the menu is above the end of my monitor, reseteditorsettings does not work, and can not see alt space menu, and when the menu was mostly visible it was greyed out. No combination of the above has worked. No offence, I would not have created a thread int he first place if I had not already tried those things. 

 

I'm on W10 if that makes any difference. Obviously the settings the cmd resets to are conflicting with my monitor resolution or with dual monitor setups. But I have tried disabling my second screen, and vice versa, and it still wont come down. Every other box is fine, just the property dialog is bugged. 

Share this post


Link to post
Share on other sites

Maybe this is an odd suggestion, but might it work to rotate your desktop through 90 degrees then, when you can see the top edge of the property box, drag it to a more useful point on the screen then rotate your display back again and save the setting?

 

It's probably totally stupid and not going to work, but I thought that I would put it out there.

Share this post


Link to post
Share on other sites

ResetEditorSttings.cmd does only one thing, it delete all the registry files for the STEditor in HKEY_CURRENT_USER\Software\1CGS\. If the .cmd file hasn't done this on your system because maybe it wasn't run as administrator, then you can manually remove them with Regedit.exe.

Share this post


Link to post
Share on other sites

Hi there, just trying to make some missions, but I have noticed I can not move the Property Dialog box, and about 1/4 of it is well past the top of my monitor, so I can not drag it down to name a mission, change the date, or time. I have tried to reset the settings, with no luck. Any advice on how to actually be able to move that box down so I can set the fields to what I want? Everything above Mission Type is missing!

 

Hello, did you ever find a solution to this problem...

 

I have tried all the above ideas and nothing work for me. The dialog box is just as you describe...out of reach of everything, making the editor unusable.

 

Anyone got a solution to this?

Edited by Pict

Share this post


Link to post
Share on other sites

I had the same problem last week and managed to fix it - but having trouble remembering how :(  - but it certainly can be reset to the normal position.

 

Things I remember trying include changing my resolution (with the editor closed), also changing my dpi for custom text.

 

If I have the same issue again and solve it I will try to remember to post the answer here.....  

Share this post


Link to post
Share on other sites

Also try setting your editor to restore down - ie small window, resize and drag it as far away as possible from the properties box.  Close editor, then reopen. I just had your problem in the RoF editor and this fixed it.

Share this post


Link to post
Share on other sites

Thanks for the reply, I tried your trick and it moved the property box...further up off the screen :)

 

Then I tried changing my screen resolution, but that did nothing

 

So just for kicks I tried changing my screen rotation and bingo it worked...it doesn't always work and it always goes back to just off screen when I restart the editor

 

I hope someone looks into this and with any luck fixes it a changing the screen rotation every time I want use the editor is gonna be a drag

Share this post


Link to post
Share on other sites

What causes the issue for me is closing the editor when the main window is not in full size mode. The next time I open the editor, the properties box is half hidden top left.  

 

If I maximize the main window, exit the editor and restart the editor, the mission properties box is now where it should be.  

 

 

Worth a try - but I have no idea how system specific this behaviour is.

Share this post


Link to post
Share on other sites

After getting the properties box in the middle of the screen, I tried your suggestion of closing when the mission editor i maximized...but when I restart the editor, the box is back up out of reach

 

There is definitely something not right about it

 

Thanks anyway :)

Share this post


Link to post
Share on other sites

Maybe this is an odd suggestion, but might it work to rotate your desktop through 90 degrees then, when you can see the top edge of the property box, drag it to a more useful point on the screen then rotate your display back again and save the setting?

 

It's probably totally stupid and not going to work, but I thought that I would put it out there.

 

I must have missed this 1st time around...

 

Turns out to be the only solution for me, even if it is a ton of hassle, it's not so stupid :)

Edited by Pict

Share this post


Link to post
Share on other sites

I was having the same issue and found this tread. I realized my settings in windows 10 were wrong.

 

I had to change display settings, specifically “Change the size of text, apps, and other items.” Mine was set to 150% for some reason. Reset to 100% and that fixed it.

  • Thanks 1

Share this post


Link to post
Share on other sites

I still can't get this to work for myself despite all the suggestions in the thread. I've had to use the program on my laptop instead of my workstation which a major pain in my butt but its the only workaround to work for myself

Share this post


Link to post
Share on other sites
On 1/19/2018 at 12:48 AM, Dave_America said:

I was having the same issue and found this tread. I realized my settings in windows 10 were wrong.

 

I had to change display settings, specifically “Change the size of text, apps, and other items.” Mine was set to 150% for some reason. Reset to 100% and that fixed it.

This is the answer that solves the problem, thanks

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...