Jump to content
Sign in to follow this  
vee333

failed to create d3d device

Recommended Posts

so like 3 monts a go i stoped playin il2 bos so i tride to play it again and tride to lunch it sase failed to create d3d device so i updated the comeputer and the video card drivers and betlen lan I stoped playin it and tride to lunch it i dindit update the game could somebody help me thanks

Share this post


Link to post
Share on other sites

so like 3 monts a go i stoped playin il2 bos so i tride to play it again and tride to lunch it sase failed to create d3d device so i updated the comeputer and the video card drivers and betlen lan I stoped playin it and tride to lunch it i dindit update the game could somebody help me thanks

 

What video card are you using? 

Share this post


Link to post
Share on other sites

https://il2sturmovik.com/about/#5

 

 

At the bottom of the page the min system specs are listed.  for nvidia cards min spec is gtx 660 with 2gb vram.    With patch 2.006 they ugpraded the game to run on DX11.. which your card is dx11 compatible but that is a pretty old card. 1gb of vram isn't a lot these days.   But you said the issue changed when you updated drivers to the game launcher choosing not to update? So you might still be able to run the game. 

 

Did you try clicking "settings" and try d/ling with "prefer web distrubution" checked?   If all else fails maybe try a fresh install of IL-2 BoS to see if that gets the launcher working for you. 

 

 

 

Sorry if I'm misunderstanding you.   There are about 5 generations of graphics cards out newer than your 560ti however.. even if you do manage to get BoS running I'd say it might be time to save up for a 1070 or at least something newer than a 700 series card.   Then again.. how much you might benefit from such might be dependent on the rest of your system specs. 

Edited by headwarp

Share this post


Link to post
Share on other sites

i ment i dide NOT update eney thing on the pc or the game beten wan i stoped playin and lunched it again and it dide not work. so then updated the pc and the video card drivers and it still dose not work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...