Jump to content
Sign in to follow this  
Remontti

Computer restart required to get more that 24 FPS

Recommended Posts

I've been having this strange issue with BOS for a while. I have not noticed it happening with other games.

 

When I start computer and launch BOS my in-game FPS meter is showing 24 at hangar and while flying. It just doesn't go above that.

 

When I re-start computer and launch BOS all is well. In hangar I have 50 fps and flying it goes to 99.

 

This happens now every time but it hasn't been like this very long. But basically I need to re-start computer once before I can play BOS. I just tried updating Nvidia drivers from 378.49 to 378.66 but same thing still happens. This is just so strange. How can I find out what is different between "cold" starting and re-starting computer? Anyone else having this?

 

EDIT:

Changing resolution in Windows to something else then back to native also fixes the issue.

Edited by Remontti

Share this post


Link to post
Share on other sites

Temps were in order. Around 25c in iddle and 47c while running the game.

 

I wonder if these is related to the G-sync issue that came up in recent updates? I'm pretty sure I didn't have this issue when game was running with dx9.

Share this post


Link to post
Share on other sites

I've been having this strange issue with BOS for a while. I have not noticed it happening with other games.

 

When I start computer and launch BOS my in-game FPS meter is showing 24 at hangar and while flying. It just doesn't go above that.

 

When I re-start computer and launch BOS all is well. In hangar I have 50 fps and flying it goes to 99.

 

This happens now every time but it hasn't been like this very long. But basically I need to re-start computer once before I can play BOS. I just tried updating Nvidia drivers from 378.49 to 378.66 but same thing still happens. This is just so strange. How can I find out what is different between "cold" starting and re-starting computer? Anyone else having this?

 

EDIT:

Changing resolution in Windows to something else then back to native also fixes the issue.

 

Remontti, I'm having the same issue. When I first start up the computer it usually does this, restarting the game does not help, and a full restart usually fixes it. It seems to only have happened since the last patch. When the problem persists I get around 20 fps or less, normally its at around 120. Did you ever figure out the problem? 

 

Looks like I have a similar set up, i5-4690k @ 4.4 GHz, GTX 1080, 16 GB Ram, Windows 10, resolution 2560x1440 with x27 predator and G-Sync on. 

 

 

Never had this issue personally.. but the fact that it goes away when you reboot would make me check a few things on my system, especially during the occurrence of your issue. 

 

 Have you tried launching other games on your systems when this is happening to verify that it's just BoS or not?   If it's not just BoS then there's a host of troubleshooting steps to go through that might narrow down your issues. (Not saying it isn't BoS.. seems weird that a resolution change fixes it)

Edited by headwarp

Share this post


Link to post
Share on other sites

Have you MSI afterburner or any other monitoring tool?

If so you can look if your GPU clocks correctly, its worth a try to figure out what the problem is maybe your graphics card dosent go into 3D mode and stays on a low clock like in desktop mode.

Try to start the game in windowed mode for gsync to work and also set gsync to both, fullscreen and windowed mode, hopefully that helps.

 

If you done that already i have no idea, never had such a problem.

Share this post


Link to post
Share on other sites

I had similar issue but caped to 60 FPS, remedium was turn game in full screen then exit and run in windowed mode. After NV driver update and choosing g-sync on full and windowed mode together with Vsync off made this issue gone for good. Now I have Gsync on and to 100 hz, and max FPS without screen problems like tearing or stuttering.

Share this post


Link to post
Share on other sites

After some tests and searching the net I think it's safe to say this is not any issue related to BOS but rather G-sync and windowed mode. This occurs on G-Sync monitors that are not turned on before boot and the game is run in windowed mode. Seems to effect a lot of users in these conditions and restarting the computer or running the game fullscreen does fix the problem. 

 

Thanks again for your help!

 

I'm glad you feel sorted.  I guess I've never booted my pc with the monitor turned off. ;) I haven't checked to see if 2.008 fixed the fullscreen issue but last I had heard fullscreen is locked to 60fps.  Dev confirmed they'd be sorting it out eventualy.  Windowed borderless has been working fine for me on my Acer x34... just have to ensure g-sync is enabled for windowed mode in NV control panel. 

 

Thanks for letting me know to make sure my monitor's always on first if I turn my entire system off over night. 

Share this post


Link to post
Share on other sites

I got this fixed. I suppose it was a driver issue. I used 3rd party program called Display Driver Uninstaller to completely uninstall Nvidia drivers. After that I re-installed Nvidia drivers and everything is ok now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...