Jump to content
Kappone

hotas warthog e layout tastiera italiana

Recommended Posts

Ho chiesto anche in zona international, il problema è che nel software TARGET è prevista l'associazione dei comandi del joy dalla tastiera ma questa ha il layout inglese, quindi non so come associare ad esempio tutte le lettere accentate. Sarebbe prevista una codifica con un codice usb, ma anche qui, online, non ho trovato il corrispondente codice usb per le lettere accentate.

PS: il consiglio di impostare tastiera inglese in windows non datemelo grazie.... ;)

 

Se qualcuno conosce la faccenda sono tutt'orecchie !

Share this post


Link to post
Share on other sites

Io non ho trovato grosse difficoltà soprattutto perché anche il gioco "converte" il layout tastiera in inglese.

Non devi far altro che premere un tasto qualsiasi della tua tastiera italiana e nel gioco sarà visualizzato il corrispondente della tastiera inglese che individuerai facilmente in TARGET.

Secondo me è tutto più facile.

Share this post


Link to post
Share on other sites

Ciao luigi, io anche ho il warthog ma oltre agli accenti ho il problema di associare addirittura la combinazione con shift+tasto o alt+tasto e cosí via. Avevo lo stesso problema con rof.....se sei riuscito a risolvere tale problema una sera di queste ci vediamo su ts e mi spieghi come hai fatto? Grazie mille.....

Share this post


Link to post
Share on other sites

Ciao, generalmente quando ho problemi, clicco sulla 'virtual keyboard' e seleziono manualmente dalla tastiera virtuale il tasto controllo che mi interessa e poi il tasto combinato. In questo modo lui inserisce i codici dei due tasti direttamente. 

Ma i codici non sono in utf8? in tal caso:

http://www.utf8-chartable.de/

Su BoS in realtà ho avuto il problema di non poter inserire direttamente ctrl-l (ad esempio), ma ho dovuto separarli su eventi onpress e onrelease con ritardi impostati. Altrimenti prendeva sia la pressione che il rilascio come pressione aggiuntiva. Non ho controllato con l'ultima patch comunque.

Share this post


Link to post
Share on other sites

Provo a spiegarmi meglio, voglio assegnare ad un pulsante un comando che si effettua nel simulatore col tasto " à " ( a accentata), bene vado nella virtual keyboard e... cosa premo? la " à " semplicemente non esiste.....

 

Allego immagine della virtual keyboard

 

post-4741-0-20058500-1386159845_thumb.jpg

 

EDIT: Ho trovato per puro caso che se nel campo del usb code scrivo 39 mi appare di fianco la lettera à , perfetto dico io , faccio set key , nel campo key command mi appare usb[39],

salvo il tutto, ma se vado ad usare l'event tester quando premo il pulsante a cui ho assegnato il comando non mi appare la à ma lo 0 ... boh...

Edited by Kappone

Share this post


Link to post
Share on other sites

Ehm chiedo venia, il discorso della à accentata con usb code 39 mi veniva perchè avevo definito la tastiera francese in target, che corrisponde al tasto 0 in quella inglese, quindi ritiro quella parte. Rimane il fatto che non riesco a assegnare la à come comando ( o ogni lettera accentata...)

Share this post


Link to post
Share on other sites

Ma come ha detto LG, hai provato a pigiare semplicemente la à sulla tastiera mentre hai il focus sul campo 'key command'? Senza aprire la virtual keyboard.

Share this post


Link to post
Share on other sites

Ma come ha detto LG, hai provato a pigiare semplicemente la à sulla tastiera mentre hai il focus sul campo 'key command'? Senza aprire la virtual keyboard.

Ho provato, ma se lancio il tester quando premo il pulsante corrispondente non mi da nessun output ... quindi mi sa non funzioni.

Ma possibile che nessun italiano abbia avuto questo problema?  :(  se qualcuno ha un profilo ove vi siano delle lettere accentate me lo puo' postare che vedo se mi funzia o no? o semplicemente come è compilato lo script? ( per qualsiasi sim ovviamene è solo per test) gracias !

Io non ho trovato grosse difficoltà soprattutto perché anche il gioco "converte" il layout tastiera in inglese.

Non devi far altro che premere un tasto qualsiasi della tua tastiera italiana e nel gioco sarà visualizzato il corrispondente della tastiera inglese che individuerai facilmente in TARGET.

Secondo me è tutto più facile.

 

Mhhh non sono sicuro di avere capito ciò che hai scritto, appena  BOS è online di nuovo provo...

Edited by Kappone

Share this post


Link to post
Share on other sites

Ok risolto e capito la questione, in pratica me ne frego di avere un layout italiano, tanto il simulatore traduce in inglese il layout come diceva LG965, in pratica il tasto  ' corrisponde a -  ; ì corrisponde a = ecc ecc. Scusate di avervi tediato con 'sta cosa, ora risolto!

 

Ma comincio con un altra, sempre riguardante la programmazione in TARGET, in pratica per i comandi con combinazioni di tasti mi pare ci sia un problema di " timing" nella pressione della combinazione, mi spiego con un esempio che se no è un casino:

 

voglio assegnare flap su/giu , non ho problemi ad assegnare il comando flap giù ( tasto f ), ma il comando flap su ( LSHIFT + F) non va, semplicemente proprio non produce nessun effetto. Dopo un po' di studi e guardando altri script del forum inglese ho visto che la soluzione sia appunto applicare un ritardo tra la pressione del tasto LSHIFT e il tasto F. 

Assegnando la gestione dei flap al tasto BOAT SWITCH della throttle destra ecco lo script risultante e funzionante ( riguardo proprio solo questo tasto ):

 

include "target.tmh"

//program startup
int main()
{
    Configure(&HCougar, MODE_EXCLUDED);
    Configure(&T16000, MODE_EXCLUDED);
    Configure(&LMFD, MODE_EXCLUDED);
    Configure(&RMFD, MODE_EXCLUDED);
    if(Init(&EventHandle)) return 1; // declare the event handler, return on error
    SetKBRate(32, 50);
    SetKBLayout(KB_ENG);
    SetShiftButton(0, 0, 0, 0, 0, 0);
    MapAxis(&Joystick, JOYX, DX_X_AXIS, AXIS_NORMAL, MAP_ABSOLUTE);
    SetSCurve(&Joystick, JOYX, 0, 0, 0, 0, 0);
    MapAxis(&Joystick, JOYY, DX_Y_AXIS, AXIS_NORMAL, MAP_ABSOLUTE);
    SetSCurve(&Joystick, JOYY, 0, 0, 0, 0, 0);
    
    //add initialization code here
    
    MapAxis(&Throttle, SCX, DX_XROT_AXIS, AXIS_NORMAL, MAP_ABSOLUTE);
    SetSCurve(&Throttle, SCX, 0, 0, 0, 0, 0);
    MapAxis(&Throttle, SCY, DX_YROT_AXIS, AXIS_NORMAL, MAP_ABSOLUTE);
    SetSCurve(&Throttle, SCY, 0, 0, 0, 0, 0);
    MapAxis(&Throttle, THR_RIGHT, DX_Z_AXIS, AXIS_NORMAL, MAP_ABSOLUTE);
    SetSCurve(&Throttle, THR_RIGHT, 0, 0, 0, 0, 0);
    MapAxis(&Throttle, THR_LEFT, DX_ZROT_AXIS, AXIS_NORMAL, MAP_ABSOLUTE);
    SetSCurve(&Throttle, THR_LEFT, 0, 0, 0, 0, 0);
    MapAxis(&Throttle, THR_FC, DX_SLIDER_AXIS, AXIS_NORMAL, MAP_ABSOLUTE);
    SetSCurve(&Throttle, THR_FC, 0, 0, 0, 0, 0);

     
    MapKey(&Throttle, BSB, DOWN+'f');                                                          // FLAPS down command
    MapKey(&Throttle, BSM, CHAIN(UP+'f', UP+ L_SHIFT+'f'));                       // RELEASE OF FLAP UP/DOWN COMMAND
    MapKey(&Throttle, BSF, CHAIN(DOWN+ L_SHIFT, D(50), DOWN+'f'));    // FLAPS UP COMMAND, delay between L_SHIFT and F

}

//event handler
int EventHandle(int type, alias o, int x)
{
    DefaultMapping(&o, x);
    
    //add event handling code here
}

Share this post


Link to post
Share on other sites

Aggiorno l'elenco dei tasti ( corretto alcuni errori...) e seguendo il consiglio datomi ho impostato il pulsante fuoco mg/cannons sulla manetta, quindi ecco un nuovo profilo per il Thrustmaster hotas warthog.

 

KEYBOARD xls alpha4.zip   Keyboard layout  xls format

 

keyboards pdf alpha4.zip    Keyboard layout pdf format - total and compact layout

 

BOS ALFA4.zip                    Hotas Warthog script profile

 

 

bos alpha 4 v1.pdf               Hotas Warthog description

Edited by Kappone
  • Upvote 1

Share this post


Link to post
Share on other sites

Hai fatto un bel lavoro, complimenti, peccato però che non lo potrò utilizzare.

 

Infatti, come in molti credo, da quando "volo" ho sempre avuto la tendenza ad assegnare gli stessi comandi su tutti i mei joystick e su tutti i sim... mi spiego meglio: io la possibilità di variare l'angolo di visuale (zoom/normal/wide ecc) la imposto, in tutti i sim (e quindi in IL2, in CoD, in Bos,, in DCS ecc) sempre sul tasto H3 (R/D/L), come invece tutti i tasti per la gestione motore sono sulla manetta.

 

In questo sono sempre stato aiutato dal fatto di avere ora un Warthog, ma prima un Cougar per 7 anni e prima ancora un F22/FLCS, e un F16 ecc  tutti Thrustmaster, e quindi con impostazione simile dei tasti.

 

Pertanto troverei estremamente difficile abituarmi ad usare tasti se non anche dita diverse, ormai mi sono "fossilizzato" un po'... :)   (deve essere anche per gli anni, che sono ormai sopra i 50... :biggrin:  )

 

Per il resto, devo dirti che io personalmente non ho trovato problemi con l'assegnazione dei tasti nel warthog, né per i flaps (che funzionano benissimo) né per il resto... mi ero un po' incartato quando volevo assegnare la funzione fire all guns (space) al Tg2, in modo da sparare con tutte le armi al secondo scatto del grilletto, e non funzionava... poi ho risolto semplicemente assegnando le mitragliatrici al Tg1 e solo i cannoni al Tg2... tanto quando arrivi a premere il 2 stai già premendo l'1, per cui comunque spari con tutte le armi! :salute:   (per sparare solo con i cannoni, invece, utilizzo un altro tasto)

 

Ciao

Share this post


Link to post
Share on other sites

E' da un po' che non posso volare e fare prove per perfezionare il layout, appena potro' sfornero' un nuovo profilo, mi fa già molto piacere ricevere suggerimenti su cosa assegnare ai vari tasti, sicuramente la cosa è molto personale ma sfruttare l'esperienza degli altri puo' essere utile!

Share this post


Link to post
Share on other sites

Ok, invece devo correggere quanto detto sopra... ho un problema per retrarre i flaps sul '109, probabilmente dovuto a ciò che hai detto più sopra.

Il fatto è che non funziona la retrazione dei flaps solo sul 109, mentre su un IL-2 il comando funziona perfettamente sia per abbassare che per alzare... che sia dovuto al fatto che per quest'ultimo aereo serve solo un impulso, mentre con il 109 bisogna tenere premuto?

Share this post


Link to post
Share on other sites

Ciao Know your Enemy (inter alias sono originario anch'o della Sardegna......per cui è un piacere rispondere).

 

Il file che governa il Warthog non è utilizzabile con l'X52 pro (posseggo entrambi).

Ciò non toglie che tu possa usare il software di programmazione dell'X52 per programmarlo con layout analogo a quello che è stato postato qui.

Ciao

Share this post


Link to post
Share on other sites

Ciao Fenice! Per caso ti chiami Marco? E' possibile che ci siamo incontrati questo tardo pomeriggio online?  :huh:  :biggrin: 
Grazie per le info!
Io sono nuovo nei giochi di aerei ma se capita mi farà piacere giocare online insieme, non so se avete un gruppo..
Ps: usate anche la chat vocale?
Scusate l'off topic! 

Share this post


Link to post
Share on other sites

Si sono io...tu che nickname hai ?

Io di solito gioco con il vecchio IL2, sono uno degli amministratori del server "Skies of Valor" e quindi gioco li. Anzi per la verità non gioco tantissimo neanche li perchè creo le missioni per il server.....e il tempo è quello che è. Sto giocando anche con BOS perchè abbiamo in programma di adottarlo.

Uso il team speak del server (198.12.65.128:9987), però è un po' raro che ci si trovi solo italiani..e quindi..di solito usiamo l'inglese.

Ben lieto in ogni caso...

Share this post


Link to post
Share on other sites

Per errore ho inserito il mio nome, il nick è Federico2
C'è un modo per aggiungere giocatori ai propri amici?
Non ho ben capito come funziona.
Io ora ho solamente il2 bos ci vediamo li se ti va ;)

Share this post


Link to post
Share on other sites

Ho fatto anch'io lo stesso errore. Tra l'altro pensavo fossi "Filippo2" ieri c'era uno che aveva un nickname molto simile.

Su steam hai la possibilità di inserire gli amici credo, ma non sul BOS normale.

Va bene, penso che nel futuro incrementerò la mia presenza su BOS e ci sono alcuni dei miei compagni di volo abituali che hanno lo stesso programma. Se del caso si può usare il TS di Skies of Valor dove c'è un canale dedicato.

Share this post


Link to post
Share on other sites

Ciao a tutti..

Ho letto tutto il "post" nella speranza di trovare il problema che ho scoperto da poco di avere..

Mi scuso per la rottura ma:

 

Il software Target Gui non mi parte più..

premetto che negli anni è sempre andato è l'unica cosa che può aver compromesso il suo funzionamento sono gli aggiornamenti del W7 64bit su cui è installato... oppure l'aver installato un paio di giochi da Steam o altri programmi ...ma prima era sempre andato..

Non lo usavo più credo da un annetto...l'altra sera lo carico per giocare a DCS..macché non parte...

escono 2 finestre lunghe la quaresima in italiano (però fanno parte del softwear della thurmaster) 

quando dopo qualche secondo esce la finestra di windows..il titolo è: " Target gui ha smesso di funzionare" 

dettagli: 

 

Firma problema:
  Nome evento problema: CLR20r3
  Firma problema 01: TARGETGUI.exe
  Firma problema 02: 1.0.11.304
  Firma problema 03: 4d710708
  Firma problema 04: UIAutomationTypes
  Firma problema 05: 4.0.30319.34209
  Firma problema 06: 5348b4d5
  Firma problema 07: e
  Firma problema 08: 9
  Firma problema 09: System.BadImageFormatException
  Versione SO: 6.1.7600.2.0.0.256.1
  ID impostazioni locali: 1040
  Informazioni aggiuntive 1: 1c54
  Ulteriori informazioni 2: 1c54cbca5c0c89d30f51a81539c67292
  Ulteriori informazioni 3: 7c50
  Ulteriori informazioni 4: 7c50abd402221423b02f5527e70a7f74
 
 
Ho provate molte cose ...su internet non sono riuscito a trovare un granchè... ho disinstallato e reinstallato varie volte seguendo le "delicate" manovre sulla pagina di supporto della Thurmaster... (la prima volta appena comprato aggiornando i firmwire mi si bruciò il basamento del joistik e dovetti sostituirlo..poi mai più problemi...
Non riesco a farlo più partire 
Qualcuno ne sa qualcosa??
ciao a tutti

Share this post


Link to post
Share on other sites

Mai visto un problema del genere. Hai provato a installare il programma su un'altra macchina ed a connetterci il warthog ?

Share this post


Link to post
Share on other sites

Più che un'altra macchina potrei installarlo su un'altro sistema operativo avvero un Vista a 32 bit... la macchina è la stessa ma il sistema operativo è in un'altro disco dello stesso PC (ho la possibilità di scegliere attraverso un boot di avvio ai due differenti S.O.)

Però faccio presente che il problema sulla stesa macchina e sullo stesso S.O. non l'ho mai avuto...solo non avevo più piu usato TARGET GUI penso da un'annetto.. ma sere fa riaccendendovi scopro il problema ..pensando di risolverlo ho fatto vari tentativi..mahh.... l'unico e provare come dici tu .. e poi chiamare l'assistenza telefonica...certo davvero strano

Grazie Fenice per l'interessamento e del consiglio

Share this post


Link to post
Share on other sites

Di nulla,

piu' che altro facendo delle prove in altre condizioni puoi capire qualcosa di piu' sul problema.

fai la prova con l'altro disco ed os, se non va li allora puoi provare con un'altra macchina.

se invece va allora il problema è sul software del tuo pc.

Per la prova puo' andar bene anche un portatile, tanto per capire se il problema e' o meno sul warthog.

se la scheda del warthog ha qualche problema, puo' essere che il programma non dialoghi correttamente con lo stick.

Share this post


Link to post
Share on other sites

Si lo farò..nel frattempo ho mandato un email al supporto online della Thurmaster  con in allegato le finestre descrittive del problema..vediamo cosa dicono... si ho sia il joistik che la "manetta" che però funzionano entrambe... è proprio il software Target che non ne vuole sapere di avviarsi ..sembra litighi con Windows...

Grazie per i consigli e l'aiuto..non essendo il mio un inglese buono farò fatica a dialogare col supporto..usro il traduttore di google.-)

vi saprò dire.. ma se nel frattempo qualcuno ha una miracolosa soluzione...

Share this post


Link to post
Share on other sites

.

Edited by =CAM=mb339pan

Share this post


Link to post
Share on other sites

Ho iniziato a programmare con il TARGET GUI, mi sembra che il gioco non riconosca alcune combinazioni, i.e. LShift+L mi dà solo L, dall'event tester risulta corretta la sequenza, ma in gioco proprio non ne vuole sapere.  Le altre volte ho riconfigurato tutti i comandi di BoS, ma visto che vanno riprogrammati ogni due aggiornamenti volevo inserire in TARGET i comandi di default che però mi danno il problema sopra descritto. Qualcuno sa a cos'è dovuto? Grazie in anticipo!

Edited by 72sq_Savinio

Share this post


Link to post
Share on other sites

Ciao, generalmente quando ho problemi, clicco sulla 'virtual keyboard' e seleziono manualmente dalla tastiera virtuale il tasto controllo che mi interessa e poi il tasto combinato. In questo modo lui inserisce i codici dei due tasti direttamente. 

Ma i codici non sono in utf8? in tal caso:

http://www.utf8-chartable.de/

Su BoS in realtà ho avuto il problema di non poter inserire direttamente ctrl-l (ad esempio), ma ho dovuto separarli su eventi onpress e onrelease con ritardi impostati. Altrimenti prendeva sia la pressione che il rilascio come pressione aggiuntiva. Non ho controllato con l'ultima patch comunque.

 

 

Ho iniziato a programmare con il TARGET GUI, mi sembra che il gioco non riconosca alcune combinazioni, i.e. LShift+L mi dà solo L, dall'event tester risulta corretta la sequenza, ma in gioco proprio non ne vuole sapere.  Le altre volte ho riconfigurato tutti i comandi di BoS, ma visto che vanno riprogrammati ogni due aggiornamenti volevo inserire in TARGET i comandi di default che però mi danno il problema sopra descritto. Qualcuno sa a cos'è dovuto? Grazie in anticipo!

 

A quando sembra quindi non lo hanno corretto :D. Sinceramente non ho capito a cosa è dovuto, a naso il gioco non riesce a riconoscere quale dei due tasti è stato il primo a premersi in caso di pressione contemporanea. Alla fine ho rinunciato a funzioni complesse nel profilo. Quelle poche che ho inserito per l'appunto lo faccio in questo modo: 

 

-press Ctrl

-press L delay 50 ms

 

-release L

-release Ctrl delay 50 ms

 

Non ricordo la nomenclatura corretta sul target visto che mi trovo in ufficio, nel caso correggo.

Share this post


Link to post
Share on other sites

Serate lunghissime quelle della configurazione dei tasti... e pensare che sono solo al profilo per i 109 che è comunque abbastanza "light". Grazie 6S.Evil provederò ad utilizzare il tuo metodo.

Share this post


Link to post
Share on other sites

E' un problema di non riconoscimento dei "doppi tasti" o, se leggi più sopra nel post, del ritardo tra la pressione dei due tasti, che pare TARGET non riconosca (o meglio, li attiva contemporaneamente, ed il gioco prende per buono il secondo).

Però non per tutte le combinazioni è così: ad esempio non funziona LShf+F per retrarre i flaps, ma funziona benissimo Lshf+S per attivare la sirena dello Stuka... :rolleyes:

A mio parere conviene comunque farsi un profilo, magari avendo l'accortezza di cambiare qualche assegnazione nei controlli di BoS... ad esempio io ho messo la Q per retrarre i flaps, e la X per sganciare le bombe (prima le sganciavo ogni volta che estraevo gli aerofreni...  :biggrin:  :biggrin:  ) tanto ci sono parecchi tasti non assegnati, e molti si possono riutilizzare prendendoli da quelli che non si usano più per gli assi del Joy, TrackIr ecc.

In caso di aggiornamento, devi solo rimappare qualche tasto, e gli altri li avrai già nel profilo...  ;)

Share this post


Link to post
Share on other sites

Salve a tutti

Volevo dire che ho risolto.. questo per chi avesse problema con l'avvio del Target GUI quando il problema descritto da Windows è il "CLR20r3".

Il problema è Net.Framework. và disinstallato completamente da windows.. e poi reinstallato a partire dal 4.0...

Buon volo a tutti

Andrea 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...