Jump to content
Sign in to follow this  
=IL2AU=astrix_au

BUG: Freesync not working in Fullscreen 2.006c

Recommended Posts

Hey guys great update hats off to you guys,

 

I am currently running borderless as Freesync doesn't work in fullscreen anymore since 2.006.

 

I have my monitor set to 144hz and if I try and run Vsync to stop the really bad tearing it locks my FPS to 60 when running the game in Fullscreen. So that is not a option for me.

 

Not only does freesync and Gsync not work in full screen but there is the issue with Vsync. Could the bugs be related? I've seen others say that Gsync isn't working as well on the 2.006x updates.

 

 

My Setup:

 
  • Windows 10 64bit
  • Radeon Crimson ReLive 16.12.1
  • ASUS Maximus VI Formula - BIOS 1603
  • i7 4770K - OC 4.5Ghz
  • AMD R9 Fury X 4GB HBM
  • BenQ XL2730Z - 2560x1440p 144hz Freesync (Freesync range 40-144hz)
  • Kingston HyperX 16GB 1600Mhz DDR3
  • Seasonic 1000w 80 plus Platnum

 

 

If you guys need anything from me to help troubleshoot this I am happy to help by sending my DxDialog or game logs to help find the fix.

 

Keep up the great Work!

Edited by =WFPK=astrix_au

Share this post


Link to post
Share on other sites

Good morning,

 

I'm having exactly the same issue as Astrix_au.

 

Similar spec, but with a R290 and an Acer predator XG270HU.

 

otherwise the new patch is fantastic, really looking forward to Kuban.

 

Cheers,

Guido

 

Share this post


Link to post
Share on other sites

Good morning,

 

I'm having exactly the same issue as Astrix_au.

 

Similar spec, but with a R290 and an Acer predator XG270HU.

 

otherwise the new patch is fantastic, really looking forward to Kuban.

 

Cheers,

Guido

Gsync is also affected in Fullscreen on the latest patch as you can see others mentioning it on the thread below towards the end especially.

https://forum.il2sturmovik.com/topic/26784-60-fps-lock-fullscreen-setting-after-update/

Share this post


Link to post
Share on other sites

Can you try to start the game without the launcher screen, and go directly to il2.exe?

I have the steam version, I tried starting from the Il-2.exe but this made no difference. What is the launcher screen? I still got the log in option going directly to the IL-2.exe in the bin/game folder.

I even tried running the Il-2.exe as administrator but it didn't help. Tearing is still there. The tearing is really bad like extremely exaggerated.

Edited by astrix_au

Share this post


Link to post
Share on other sites

I have non-steam version witch launches a little window first showing update progress. Bypassing allows me to use full screen I believe, also any sync options I set outside the program and leave sync set as off in the program.

Share this post


Link to post
Share on other sites

I also have the same thing when I launch the game - very bad screen tearing despite FreeSync. However I can fix it by turning FreeSync OFF and ON again while in-game. I have a BenQ monitor so I simply switch to a picture profile with Blur reduction enabled (which forces FreeSync OFF), then back to a FreeSync profile.

  • Upvote 1

Share this post


Link to post
Share on other sites

I also have the same thing when I launch the game - very bad screen tearing despite FreeSync. However I can fix it by turning FreeSync OFF and ON again while in-game. I have a BenQ monitor so I simply switch to a picture profile with Blur reduction enabled (which forces FreeSync OFF), then back to a FreeSync profile.

I must try this I have the Benq XL2730Z. thanks for the info ban pilot, I'll post back results.

Share this post


Link to post
Share on other sites

I also have the same thing when I launch the game - very bad screen tearing despite FreeSync. However I can fix it by turning FreeSync OFF and ON again while in-game. I have a BenQ monitor so I simply switch to a picture profile with Blur reduction enabled (which forces FreeSync OFF), then back to a FreeSync profile.

Hey thanks banPilot it works! I wonder if AMD or the devs need to fix this, might even be AMD since they re-wrote the game in DX11.

I also have the same thing when I launch the game - very bad screen tearing despite FreeSync. However I can fix it by turning FreeSync OFF and ON again while in-game. I have a BenQ monitor so I simply switch to a picture profile with Blur reduction enabled (which forces FreeSync OFF), then back to a FreeSync profile.

If your monitor is 144hz like mine I recommend setting the FPS limit in the startup.cfg to 144fps. The game settings only go up to 120 limit but manually doing it in the CFG file works.

 

 

EDIT: Turns out enabling blur reduction mode and and off changes the games state from Fullscreen to borderless so it's not a fix at all.

Edited by =WFPK=astrix_au

Share this post


Link to post
Share on other sites

I think Fullscreen still isn't as smooth as borderless, i'm going back to borderless for now till Freesync is smooth again at fullscreen. 

Share this post


Link to post
Share on other sites

Turns out turning on blur reduction on and off to stop the tearing in fullscreen turns it into borderless.


Whats weird too is if I record before doing the blur reduction hack the recorded video has no tearing but while recording the video is tearing to the max. After starting blur reduction and stopping it the tearing stops but after that it no longer records and says to turn on desktop recording. So it actually turns it into borderless, not sure if it is freesync or Vsync. We assumed the tearing stopped due to Freesync but I just found out it is no longer fullscreen after toggling blur reduction so now I have no idea if it's Vsync or Freesync.


 


ReLive uses the frame buffer which goes directly from the frame buffer to the hardware encoder without need for the driver. The tearing is happening afterwoods as the video has no tearing but the image while playing is tearing really badly.

Edited by astrix_au

Share this post


Link to post
Share on other sites

Any progress on what is causing the issue, there were a few people that said Gsync was working in fullscreen but at the same time many others say it doesn't and are using borderless. Maybe if the developers had more info on specs of those that it is working for and those having this issue in fullscreen might help get to the bottom of it. It all started with 2.006 that much I do know.

Share this post


Link to post
Share on other sites

I tried the new patch 2007, issue still persists when in cockpit mode. Below is a copy of my post in the new patch thread.

 

"Thanks for the update guys!! I was hoping that that there would be a surprise fix, fixing fullscreen tearing. Freesync still isn't working in fullscreen. When in the map screen before starting a quick mission my fps is locked at 60fps but when I start flying it goes up to 144 which I limited in the startup.cfg. I thought since this is a full update it would be fixed as it only happened after 2006 and I thought were from hot fixes. Have to go back to borderless  :( Relive doesn't record as well in desktop mode and on drivers after 16.12.1 bringing up the Relive overlay (ALT-Z) when in borderless drops the fps to 10fps and it stutters while recording. 16.12.1 doesn't have this issue I though because that was what you guys tested on 2006c. Before 2006 it recorded really well in fullscreen with freesync working.

 

The screen tearing seems to only happen in cockpit view, third person I don't see tearing at least this was on 2006c so I assume it's the same.

 

Can you guys please work on fixing fullscreen freesync on AMD and some Gsync users are also having this problem or at least were on 2006c.

 

 

Windows 10 64bit

Radeon Driver 16.12.1 

4770K

AMD Fury X

 

keep up the amazing work guys, thanks for all the new stuff."

Edited by =WFPK=astrix_au

Share this post


Link to post
Share on other sites

"Vsync" in "FullScreen" temporarily limited 60 fps

Work is under way, which will remove this limit

Thanks, I think the freesync and Gsync issue in fullscreenn or tearing in cockpit is linked together.

Share this post


Link to post
Share on other sites

"Vsync" in "FullScreen" temporarily limited 60 fps

Work is under way, which will remove this limit

newest Nvidia driver from yesterday seems to allow frames to go beyond 60 now. I have turn in vsync in game to keep 60 now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...