Jump to content
DirtyRotnFlieger

TrackIR and FFB working together cause terrible stuttering.

Recommended Posts

Do you think you could record it with Nvidia Experience? (That captures it best)

Also you need to make sure to set priority to realtime on every launch of TrackIR.

 

Do note also that in Multiplayer the graphics are heavily influenced by netcode, I always have lots of stuttering on Berloga because that a problem of dserver/netcode performance. In singleplayer I get constant 144Hz a lot of times and mostly very smooth, when I enter to Berloga it sometimes goes below 60 fps and stutters rather heavily in comparison.

Share this post


Link to post
Share on other sites

I don't have Nividia Experience installed. I tried to capture it with Playclaw an it does not show it. I think it's mostly because current video players do not show framerates above 60. Priority for TrackIR set to realtime.

 

It is not the framerate/performance that ist bad, if you only look at the figures. I'm running very high fps around 130+- most of the time and it still gets choppy. Also, for me it feels more like it is skipping frames not actually slowing down.

I only play singleplayer.

 

Thank's anyway and sorry if i couldn't be more of a help.

 

Edited by rega

Share this post


Link to post
Share on other sites

I don't have Nividia Experience installed. I tried to capture it with Playclaw an it does not show it. I think it's mostly because current video players do not show framerates above 60. Priority for TrackIR set to realtime.

 

It is not the framerate/performance that ist bad, if you only look at the figures. I'm running very high fps around 130+- most of the time and it still gets choppy. Also, for me it feels more like it is skipping frames not actually slowing down.

 

I only play singleplayer.

 

Thank's anyway and sorry if i couldn't be more of a help.

 

 

 

rega, when you are in cockpit and have the stutters, switch on the autopilot with the "a" key and look around with your trackir to see if is better

Share this post


Link to post
Share on other sites

With force feedback enabled stuttering occurs when the camera is panned or translated. 


 


I did some testing in flight with trackIR and force feedback enabled:


When parked and taxiing below 50 KPH there is no stutter.


​While taking off stutter increases with speed from very slight to severe as speed goes from 50 KPH to 150 KPH.


​Slow speed flight at 135 to 150 KPH has slightly less stutter.


​Enabling Auto-Level while in flight eliminates the stutter.


 


Tried editing the files in the input folder:


No effect on stuttering.


 


​Testing in game settings:


Disabling Force Feedback stops the stuttering.


Noise filtering is inversely proportional to amount of stuttering. Increasing Noise Filtering dramatically increases camera transform latency.


Shaking and Feedback Power have no effect on stuttering.


Pitch and Roll deadzones have no effect on stuttering, nor does sensitivity. Unbinding pitch and roll has no effect on stuttering.


 


​Testing panning with mouse (trackIR executable closed):


No effect on stuttering. Stuttering occurs without the use of trackIR.


 


​My hypothesis as to the cause of the stuttering:


 


Frame render time is not observably effected by force feedback. The stutter is in the camera's rotation and translation while force feedback is enabled.


A force feedback effect that intensifies as airspeed increases is being blended with the camera transform event.


Edited by Kalthios
  • Upvote 1

Share this post


Link to post
Share on other sites

I have the head-tracker stutters but like Rega I have no FFB stick (I disable the option anyway).

 

I have to use 'Camera Smoothing' at 100% to kill the stuttering but then head movement becomes very, very sluggish - regardless of curves, filter etc.

 

Every other game is fine.

Edited by Valis

Share this post


Link to post
Share on other sites

I find it is not enough just to change the Smoothness.  The Pan camera mode settings also have an affect on head movement.  Here are my settings, though you can increase the speeds to 100%.

 

Smoothness - 100

Pan camera mode:
Movement speed - 80%
Movement inertia - 60%
Rotation speed - 80%
Rotation inertia - 60%
FOV change speed - 40%  (not related to head movement - this controls the speed of zoom in/out)
FOV change inertia - 60%

Share this post


Link to post
Share on other sites

#1 - Go to your task manager -> tab details - > right click TrackIR -> select priority -> high

 

 

 

I fail to spot that "select priority" option, could you please explain further ?

Thank you in advance.

Share this post


Link to post
Share on other sites

Hi, i still have Microstotters, after Update 3.001. How is it to you?

Share this post


Link to post
Share on other sites

Still there too for me ... even if  i ve fixed the problem with 100 % smoothness in camera settings since a long time , but i wanted to see if 3.001 would have changed things , so i tested with 0% smoothness and the prob came back as soon as i tried ...

Share this post


Link to post
Share on other sites

I was kind of hoping that the last 3.001 will be better, but it's unfortunately on the contrary, worse than in older versions.

Since reporting the problem has passed so many time and still no light in the tunnel why?

Share this post


Link to post
Share on other sites

Hello guys,

 

3.001 definitely is a huge step forward, and here I'm going to share my experience :

 In a few words, I now can run Il-2 very smooth overall, both SP and MP, with more dynamic objects, in a better graphics setting, and of course still with FFB and Tir enabled, and with dozens of Chrome web pages background. Note that before, I was experiencing regular harsh stutters, while FPS was showing a constant 55-60, mostly 59-60, particularly online, and game was set on "balanced" graphic settings, with all the lowest settings (apart from V-Sync ticked "on").

So don't desperate, keep investigating. What saved my Il-2 experience is a graphics setting provided by Jason Williams himself :

 

- Disable all nVidia panel' setting over the game "off". (I only kept GC power setting on "no power saving")

 

Now in game :

- Start with "balanced settings".

- Turn V-Sync "on".

- Probably the most important tip : turn the new 4K resolution "on".

 

- Run QMB without any other plane nor land objects. See if things are good.

- Then if yes, try with "high" settings, test, keep trying to improve one thing at a time, test with more objects, etc, and you could get a much better game experience eventually.

 

Here are my actual graphic settings (things could be improved again here and there I guess, just I was happy to the point I just enjoyed it as it is and didn't try to further fiddle with) :

 

Hope it can help some of you !

Il-2_3_001_Settings.png

Edited by Solmyr

Share this post


Link to post
Share on other sites

Thank you for sharing and the effort, my hw system can maintain 100 fps and more, I have no drop frames. If I switch the graphics settings on low at 200 fps I effect of the image still the same. After the update to DX11, I've tried all the Nvidia drivers since the release of the GTX1080Ti. Unfortunately, a strange error ffb/trackir and change in-game settings or Nvidia has no effect.

Share this post


Link to post
Share on other sites
On 25/03/2018 at 1:42 PM, =FCU=PetSild said:

Thank you for sharing and the effort, my hw system can maintain 100 fps and more, I have no drop frames. If I switch the graphics settings on low at 200 fps I effect of the image still the same. After the update to DX11, I've tried all the Nvidia drivers since the release of the GTX1080Ti. Unfortunately, a strange error ffb/trackir and change in-game settings or Nvidia has no effect.

 

Did you try to shutdown all nVidia overcontrol and to tick 4K resolutions ?

Share this post


Link to post
Share on other sites

Same for me here... The only setting affect on this problem is camera smoothness.

As I know developers "don't belive in this bug" or don't have any time to analyze it - so it can't be fixed now and (obviously) didn't fixed in 3.001

Share this post


Link to post
Share on other sites
8 hours ago, DeadlyMercury said:

Same for me here... The only setting affect on this problem is camera smoothness.

As I know developers "don't belive in this bug" or don't have any time to analyze it - so it can't be fixed now and (obviously) didn't fixed in 3.001

happy i m not crazy, i said exactly the same as you, the camera smoothness change my tracking behavior,  since they say they did nt change any files on ir files of the game, is it possible those camera settings/files  are not consider ir tracking files and they change something in it ? camera settings are not just for tracing ir devices, if you use the hat on a joystick you will use those settings too , sorry if i am not clear (language...) but my point is  they may look at the wrong place when they keep saying they  did nt change anything to the ir tracking  files... i think it is possible that may be the same problem source of the stuttering with the ffb   

 

Share this post


Link to post
Share on other sites

I don't really get it guys : did you have those stutters before v3.001 or not ?

Share this post


Link to post
Share on other sites

First post of this thread was posted on december 21 2016    so wayyyy    BEFORE 3.001.

Camera settings (camera smoothness at 100 ) are just a walk around against stuttering that appear when you have both a track ir and a ms ffb2 ....

Just for the try : disable ffb in game settings and stuttering at 0 smoothness disapear ...enable it again and it' s back .

Edited by 13Nrv

Share this post


Link to post
Share on other sites
7 hours ago, =FCU=PetSild said:

The problems are from the first version of DX11 after 3.001, enabled 4K on the stuttering does not affect.

 

I don't understand : dX11 was before 3.001 no ?

 

7 hours ago, 13Nrv said:

First post of this thread was posted on december 21 2016    so wayyyy    BEFORE 3.001.

Camera settings (camera smoothness at 100 ) are just a walk around against stuttering that appear when you have both a track ir and a ms ffb2 ....

Just for the try : disable ffb in game settings and stuttering at 0 smoothness disapear ...enable it again and it' s back .

 

I know that : read again the thread, it's more complex than just that.

Share this post


Link to post
Share on other sites

"I don't really get it guys : did you have those stutters before v3.001 or not ?"

 

"First post of this thread was posted on december 21 2016    so wayyyy    BEFORE 3.001."

 

"

I know that : read again the thread, it's more complex than just that."

 

 

............................   

 

 

 

 

 

Share this post


Link to post
Share on other sites

This issue has nothing to do with Track IR, it is stuttering during camera transforms, no matter what the input device is, that occurs when Force Feedback is enabled.

 

Frame render time is not observably effected by force feedback. The stutter is in the camera's rotation and translation while force feedback is enabled.

 

A force feedback effect that intensifies as airspeed increases is being blended with the camera transform event.

Share this post


Link to post
Share on other sites
5 hours ago, 13Nrv said:

"I don't really get it guys : did you have those stutters before v3.001 or not ?"

 

"First post of this thread was posted on december 21 2016    so wayyyy    BEFORE 3.001."

 

"

I know that : read again the thread, it's more complex than just that."

 

Ok, we'd better not hold forth on that ; still if you take a look, you'll see that my 1st post in this thread is now more than 1 year ago, so yes I know it, what has been described, I tried myself to understand what were my own problems, I explained yet that my own heavy stutters (while FPS @60 constant) weren't clearly related to the FFB + Tir combo, (maybe more on TrackIR alone) as nothing had changed in multiple tests, and I just was explaining that on my end most of the problem was due to something else, or that it was way more complex, I sugget you to read the Jason's posts that illustrate that. Still I don't pretend that your problem doesn't exist of course, plz if you want to really get what I'm saying, just read my posts but don't take it for yourself nor believe I don't care your own problem.

 

By the way with 1st question I was asking last posters if they were in a similar situation as the first ones one year ago, because plenty of things happened in the meantime. (Some solved it, others not, game builds changed, hardware drivers changed, even hardware changed too.)

 

Edited by Solmyr

Share this post


Link to post
Share on other sites

Recently bought the game and tonight I tried using FTNoIR only to find it unusable due to sluggish camera movement. Found this thread and indeed it is related to having FFB activated on my Sidewinder 2. Made a quick video showing the camera movement stuttering with FFB on/off. I'm using the mouse inside cockpit but I get the same stutering as with FTNoIR. Tried switching autopilot on (disables FFB) /off, same results.

 

 

Edited by dominion1
  • Thanks 1
  • Upvote 1

Share this post


Link to post
Share on other sites

dominion1,

the stuttering increases as the air moves faster over the aircraft. if you park on the ground with no wind there is no stuttering, but as you take off the stuttering will increase. Also, if you set up the mission to be very windy and then start with the plane parked you will also get camera movement stutter. Disable FFB and it goes away.

Share this post


Link to post
Share on other sites

I am glade to see some Devs (Solomir) interrested about our problem of Stutter with FFB2. I hope we'll get some correction patch soon...

  • Upvote 1

Share this post


Link to post
Share on other sites
8 hours ago, I/JG2_Saladin said:

I am glade to see some Devs (Solomir) interrested about our problem of Stutter with FFB2. I hope we'll get some correction patch soon...

dev? what dev? I believe they don't care about this problem

Share this post


Link to post
Share on other sites

 I think the TiR/ffb stutter is not the only form of stutter. I have always had some stutter during heavy action. I have MSFFB2 too. 

 

Sometimes when I was inside TiR adjusting settings, I could hear faint sound from inside the MSFFB2, Some static white noise, or burring . Barely audible. And its pitch changed when I looked up and down or just did move my head around. And it was the same with 2 different MSFBB2 sticks. So I believe there are some conflict, or was. Nowadays I plug the power cable after I have adjusted the TiR settings, and dont know is the noise still there. The noise is not there if the power cable is not plugged in. Lately my controls have been good. And overall the game works better now after the latest updates. Some stutter still though when I move my head around and there are other planes near. The heavier the action the worse stutter. And also the ground objects and happenings are affecting the stutter.

 

Edited by VesseL

Share this post


Link to post
Share on other sites

I m lucky , the 100 % smoothness trick make my game playable ...

Because i always play with that settings and adapted profile in Track IR it IS playable ....

Meanwhile , at each new update i m always testing with smoothness at 0 +Track IR on , to see if there s a change or not , and also testing with no track IR smooth at 0 to be able to feel the difference with my actual settings :

It s very clear that 0 % smoothness is wayyyyyyyyyyy  more enjoyable than 100 %  .....still hoping for a patch to solve this annoying thing ... but  considering initial post is from 2016 honestly i m not very confident ....

Share this post


Link to post
Share on other sites

Personally i can't fly with smoothness at 100%. matter of taste...

No way to fly without FF so I am waiting for a patch to re-fly on BOS.

Share this post


Link to post
Share on other sites

Playing without ffb with a ffb2 is impossible , cos there s no centering at all   , the joystick is just falling , it s totally impossible to fly without  , you know it ...

 

100% smoothness , well it s possible ! you must adapt your track IR settings in order to have a feeling close to what you like   ( depends what you like ....i have a personnal profile initially based on requiem's one , but wayyyy faster to "compensate the 100 % smoothness" and with no dead zones at the center cos i dont like it ;) . i think it now has nothing in common with requiem's one ^^ )

 

However ,it doesn t feel  like with 0 % smoothness BUT the game   IS playable ,it s no more a big deal ...and yes it takes time to make his own profile and it s not fun at all ...

 

 

Edited by 13Nrv

Share this post


Link to post
Share on other sites
3 hours ago, 13Nrv said:

Playing without ffb with a ffb2 is impossible , cos there s no centering at all   , the joystick is just falling , it s totally impossible to fly without  , you know it ...

 

Eh?  If you uncheck the FF box in the games option setting then the MSFFB2 reverts to whats called the "default spring" settings.  This gives force and resistance and self-centering.

 

Does your stick not do this 13Nrv? 

Share this post


Link to post
Share on other sites
21 minutes ago, DD_Arthur said:

 

Eh?  If you uncheck the FF box in the games option setting then the MSFFB2 reverts to whats called the "default spring" settings.  This gives force and resistance and self-centering.

 

Does your stick not do this 13Nrv? 

That never worked for me. It just switched off any resistance. Never tried it after a reboot though. 

Share this post


Link to post
Share on other sites

Really?  Thats weird.  Works fine for me.  The only time I get the floppy stick syndrome is after flying DCS. 

 

Whilst it works fine with DCS, once I exit the game the stick is as dead as a Dodo.  I have to 'reboot' by pulling the USB cable out and plugging it in again!

Share this post


Link to post
Share on other sites

@ DD_Arthur Hmmm no,  my stick does not do this ... At the moment if  i switch off ffb in game settings , then my joystick has no more resistance nor centering and just fall ...i will try after a reboot to see what happens ... never try this to tell the truth ^^ ...

Share this post


Link to post
Share on other sites

I isolated the cause of this bug and documented my testing months ago (force feedback effect of control surfaces being moved by wind is being routed to the camera): 

 

Share this post


Link to post
Share on other sites

Hello guyz

 

Gave a shot at the advice on this matter but found the most effective to be combination of two things:

1. Camera smoothness set to full 100.

2. Joystick Noise Filter set to 0.75

 

If you set the filter to 1, than yo get an "over inertia" of the head movement and if you set it towards 0, than stutters increases.

 

This matter needs to be permanently fixed by the DEV's but meanwhile hope it helps, it's not perfect but playable for me.

 

My Spec: 6700K stock speed, 16gb DDR4 2800, GTX 1080TI Gigabyte Gaming. I play Nvidia DSR 3840x2400 or 1920x1200 for Contact spotting all on high settings(: 

 

Cheers

GP  

  • Upvote 1

Share this post


Link to post
Share on other sites
On ‎3‎/‎28‎/‎2018 at 6:49 PM, Lemon said:

happy i m not crazy, i said exactly the same as you, the camera smoothness change my tracking behavior,  since they say they did nt change any files on ir files of the game, is it possible those camera settings/files  are not consider ir tracking files and they change something in it ? camera settings are not just for tracing ir devices, if you use the hat on a joystick you will use those settings too , sorry if i am not clear (language...) but my point is  they may look at the wrong place when they keep saying they  did nt change anything to the ir tracking  files... i think it is possible that may be the same problem source of the stuttering with the ffb   

 

 

what i don't get is how the setting under joystick filter changes track IR smoothness.

Share this post


Link to post
Share on other sites
On ‎5‎/‎26‎/‎2018 at 11:07 PM, Paul-Jahn said:

 

what i don't get is how the setting under joystick filter changes track IR smoothness.

hi, it is in the input filter menu, it work on joystick and track ir input as well

Try your track ir with full filter, if I do , I got almost +2 seconds lag on camera view if I do a quick 180 degrees with my opentrack setup

 

good day/night

Share this post


Link to post
Share on other sites

Hello,

 

This is my first post but this bug is so annoying that I also request the help of developpers. I have a good rig (I7 950 @4 GHZ, 12 Go RAM, 1080TI). All my sims run very smooth at max setting except IL2. I have test all settings (camera, joystick filter, nvidia settings, IL2 graphic settings ...etc). I even test all optimization advices from LEMON (HPET on/off, graphic card in MSI mode, timer tool to reduce latency...). Optimisations reduce a little micro stutter but it does not remove it. I have the G940 (stick throtlle and pedal).

We really need the help of these talentuous developpers (Yes, this game is wonderfull!!!!!) to really squash this bug.

Please Devs... make another miracle!!!

 

Sorry for my bad english...and congratulations for the best WW2 flight sim I have ever play... and good luck for the russian football team.

 

Merci par avance

Bonne soirée

Dear pilots,

 

After hours of test, setup on my computer,   I have recently found something which greatly improved fluidity and mostly removed microstutter.  I used Rtss (RIVATUNER STATISTIC SERVER) and set frame limiter to 45 / 50 fps and deactivate v sync in game. As mentioned in my previous post, I also applied LEMON advices (msi mode for graphic card, hpet off, low latency,  etc...)

 

Try it, may be it will solved this very unconfortable microstutter on your rig.

 

Hope this helps community 

Regards 

Share this post


Link to post
Share on other sites
4 hours ago, AFsparrow1968 said:

Hello,

 

This is my first post but this bug is so annoying that I also request the help of developpers. I have a good rig (I7 950 @4 GHZ, 12 Go RAM, 1080TI). All my sims run very smooth at max setting except IL2. I have test all settings (camera, joystick filter, nvidia settings, IL2 graphic settings ...etc). I even test all optimization advices from LEMON (HPET on/off, graphic card in MSI mode, timer tool to reduce latency...). Optimisations reduce a little micro stutter but it does not remove it. I have the G940 (stick throtlle and pedal).

We really need the help of these talentuous developpers (Yes, this game is wonderfull!!!!!) to really squash this bug.

Please Devs... make another miracle!!!

 

Sorry for my bad english...and congratulations for the best WW2 flight sim I have ever play... and good luck for the russian football team.

 

Merci par avance

Bonne soirée

Dear pilots,

 

After hours of test, setup on my computer,   I have recently found something which greatly improved fluidity and mostly removed microstutter.  I used Rtss (RIVATUNER STATISTIC SERVER) and set frame limiter to 45 / 50 fps and deactivate v sync in game. As mentioned in my previous post, I also applied LEMON advices (msi mode for graphic card, hpet off, low latency,  etc...)

 

Try it, may be it will solved this very unconfortable microstutter on your rig.

 

Hope this helps community 

Regards 

I also use RTSS with good results too, just using MSI afterburner frame times monitoring and you can see how well it work, just use RTSS with a value of 0 to monitor frame times and you ll see how big the frametimes differences are with or without this software.

I don't know about your monitor, but if like me you got 60hz one, when  overclocked it to 75hz with CRU ,  it  made the frame times even shorter and the game even more smoother, but like you said in the first part of your post, this only mitigate the problem.

Know there is many people with this problem ,  just look all the youtube video since 3.00x, and pay attention on the background when it go relatively fast or at the ground when they look left or right of the plane and flying low , you can clearly see lot of frame skipping or stuttering in most of them.

good day

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...