Jump to content
DirtyRotnFlieger

TrackIR and FFB working together cause terrible stuttering.

Recommended Posts

It does not go away when you turn off TrackIR and leave FFB on, not even when you shut TrackIR down in the task manager and then control the view with the mouse. 

 

As long as TrackIR was running when you started the game and as long as FFB is activated the stuttering appears, no matter how you control the view.

Matt, make me a track to see if i have the problem, and when the problem is present on the track.

Share this post


Link to post
Share on other sites

Ok, sorry to disturb you, i though you want some investigation to find the problem. It was just a process to try to find what could be the problem. :sleep:

 

I apologize if I came off as being disturbed or hostile.  Just trying to keep this thread on track.   I appreciate your willingness to help very much, but you say you're not having the issue and that you're using a Warthog while the majority of the complaints come from users using an msffb2 or perhaps other force feedback stick.  That could lead us running in circles here. :)  I can very much confirm there was no such issue with my logitech extreme 3d pro, or my warthog stick.  I only noticed the difference when plugging in my msffb2 and launching BoS for the first time.  With a producer responding to the thread I think we're going down the right track now. :)

 

 

You guys are not confirming whether or not the stuttering goes away if you turn off TrackIR, but have FFB on, but look with the mouse. We have to be able to replicate this problem for us to solve it.

 

Jason

 

Hi Jason, thanks for a response to this thread and for offering some guidance on things that will help you and your team troubleshoot.   I notice I'm a bit late in replying and that others have tested this since you've asked.. but I'll also go play around with mouse look and no TIR and edit my post with my findings shortly. 

 

*EDIT POST TEST*

 

So - I went into the game without TrackIR running and my FFB enabled and at first due to the higher sensitivity of the mouse and my camera smoothness settings in game being around 90,  it was hard to tell if it was my mouse movements or not causing the stutter.   Then I reduced the camera smoothness and mouse sensitivity, and it was pretty stuttery.  I went into input options and unchecked the FFB enabled box.   Mouse look motion was 100% smooth.  Turned FFB back on without even exiting the game and the stutter was back.   Again the ingame setting for camera smoothness does clear up the stutter quite a bit when set to 80 or 90  and I'm getting used to kind of but it's still not the fluid motion received prior to investing in an FFB stick. 

 

So - to try to summarize

 

Yes - stutter is still there with mouselook + FFB and no TrackiR.

 

 The stutter with head movement does go away when you disable FFB but that kind of makes the stick useless.    I would also like to point out that until just now I had unbound mouse x + y from head movement, as when I would set my mouse on my knee it would fight with my trackIR anytime I moved slightly.   So it's definitely not tied to any bindings, at least with the mouse.  My bindings for vertical and horizontal head motion had nothing bound to them until this test.

 

So thanks for pointing out we've been incorrectly declaring the issue was TrackIR + FFB rather than FFB + in game head movement,

 

and I'll happily do whatever else you can ask of me attempting to diagnose the issue. 

 

For anybody else struggling with this - I'll repeat it - turning up the in game settings for camera smoothness (not TrackIR or whatever alternative) should reduce the stutter to a playable point in the meantime.  Mine's set to 90 personally and while it's not perfect.. it's allowing me to scan the skies.  You can do so while flying even, hit esc, click settings->camera and in the upper right is the smoothness option. 

 

 

I can also turn on my geforce experience overlay and upload a video to youtube showing me enabling/disabling the FFB and how it's effecting head movement if that will help. 

Edited by headwarp

Share this post


Link to post
Share on other sites

Test....FFB on

Quick mission started ca 1500m.....Autolevel is on =Everything is smooth !!!As soon as I use my joystick is Autolevel off =And stutter is there !!!I switch on Autolevel and everything is smooth again ??

Autopilot on =Smooth,Autopilot off use my joystick=stutter

Clearly FFB problem !?

Edited by III./ZG1_Angus

Share this post


Link to post
Share on other sites

I can confirm that there is noticable difference regards smooth image when moving around in the cockpit when FF is on or off.

Share this post


Link to post
Share on other sites

 

 

I apologize if I came off as being disturbed or hostile. Just trying to keep this thread on track. I appreciate your willingness to help very much, but you say you're not having the issue and that you're using a Warthog while the majority of the complaints come from users using an msffb2 or perhaps other force feedback stick.

Re read my first point. I would not come on a topic talking of a FF problem if i don't use one.

 

Here is my first answer, but maybe  it was not enought clear :

 

 

01-

  • Microsoft force feedback 2, no specific driver, using native windows 7 driver. Joystick is use for BoS
  • Hotas Warthog, drivers Target : 3.0.16.615. No target profil is used. All key are defined in game. Throttle is use for Bos
  • Saitek Throttle quadrant : drivers : 6.0.6.5
  • MFG crosswing V2 rudder : drivers : v2

 

I use a MS FF2 as a stick with the force feedback enable. The warhtog is plug, but i use only the throttle from the warthog. If i ask many details, it's to find what can be the problem, and i want to know if the issue is only for the MS FF2, or any forcefeedback joystick like G940 which have the problem too (i know it because a beta tester answer in another topic).

 

As Jason said, the goal is to reproduce the bug. For that we need to compare configuration, and why some have, and some other not. With a track, or a simple flight which describe exactly where we can see the problem, we can test and give the result. And with that result compare configuration and settings. That's why i asked so many questions.

 

Finding a bug is very easy. Knowing what cause the bug is more complicated and could take many time.

Share this post


Link to post
Share on other sites

Re read my first point. I would not come on a topic talking of a FF problem if i don't use one.

 

Here is my first answer, but maybe  it was not enought clear :

 

 

I use a MS FF2 as a stick with the force feedback enable. The warhtog is plug, but i use only the throttle from the warthog. If i ask many details, it's to find what can be the problem, and i want to know if the issue is only for the MS FF2, or any forcefeedback joystick like G940 which have the problem too (i know it because a beta tester answer in another topic).

 

As Jason said, the goal is to reproduce the bug. For that we need to compare configuration, and why some have, and some other not. With a track, or a simple flight which describe exactly where we can see the problem, we can test and give the result. And with that result compare configuration and settings. That's why i asked so many questions.

 

Finding a bug is very easy. Knowing what cause the bug is more complicated and could take many time.

My apologies Habu the error and misunderstanding is mine.   For some reason my eyes fixated on "warthog" in your post. 

 

That being said, Your setup is pretty similar to mine in terms of peripherals.  Crosswinds/MSFFB2 + warthog throttle and I use TIR. 

 

 

The install is fresh with no sweetfx or anything of the sort (have never used) 

 

system 

i5-2500k, evga z68 sli, 8gb ddr3 1600, gtx 980Ti driver version 378.49

TIR 5 driver version 5.4.2.27475 

Windows 10 pro 64-bit. 

 

I almost suspected that perhaps the reason you're not experiencing it is windows 7, but there is a post in this thread from another user stating he's using win7 64-bit and getting the issue.   I will boot into win7 later to see if the problem is there as well

and I will upload a video or track showing exactly what's happening probably using mouse mode so you guys can see it's not just erratic head movements. .   The one thing we have clearly established imo is that it's not just limited to TrackIR/freetrack/open track. 

 

 

I will say that since the dx11 update I've only been able to play in borderless windowed mode and still get the full benefits and refresh rates of my Acer Predator x34 (there's another thread on this issue),  are you playing in full-screen Habu? I will also check on my end whether changing from borderless windowed to full screen will have any effect, but doing so for some reason causes my monitor to reset to 60hz refresh rate rather than the 100hz it's capable of being clocked to.  (An issue specific to 21:9 UWHD monitor users and IL-2 - here's that thread https://forum.il2sturmovik.com/topic/26784-60-fps-lock-fullscreen-setting-after-update/ )  I will test fullscreen later and edit post with findings if no other replies have been made..otherwise will leave new post in this thread with info. 

Edited by headwarp

Share this post


Link to post
Share on other sites

 

 

are you playing in full-screen Habu?

No, i'm not in full screen. See my screenshot on my answer 2, and you see my graphic settings.  Again, i know it take time, but if i ask screenshot, it's because it's quicker to detect and see difference, and there are something which could give me some information that for you it's not important. Sometimes, there are no evidence between a cause and a bug.

 

Using a protocol, and following it help a lot and can gain many times. That's why i did some question, and all are important because they can provide an information which could be usefull. At that time, i want that we work on Track ir. It's not that i don't want to solve freetrack and other solution, but it's easier because there are less variable to check.  

  • Like 1

Share this post


Link to post
Share on other sites

 

 At that time, i want that we work on Track ir. It's not that i don't want to solve freetrack and other solution, but it's easier because there are less variable to check.  

 

I've stated that even when TrackIR isn't running I'm still getting the issue with mouse look and it goes away when disabling FFB (one person even mentioned the stuttering stops while he's using autopilot) .  .    About to set up and make videos for demonstration. 

Edited by headwarp

Share this post


Link to post
Share on other sites

Men, the base statement of that post is that Trackir + DX11 = stuttering. I'm not here to try to solve all the problem which cause stuttering. So please do not add any problem which are not related to the post. We can't try to solve all the problem at one time, even if it's stuttering, and have to proceed step by step. Every problem is important, but each one need a special investigation.

Share this post


Link to post
Share on other sites

Men, the base statement of that post is that Trackir + FFB = stuttering. I'm not here to try to solve all the problem which cause stuttering. So please do not add any problem which are not related to the post. We can't try to solve all the problem at one time, even if it's stuttering, and have to proceed step by step. Every problem is important, but each one need a special investigation.

A producer stepped in and asked us to confirm whether it happens without trackir and just using mouselook. 

 

Until that point..I dont think one of us tried looking around WITHOUT TrackIR.  (habit from years of owning a head tracking unit)

 

The fact that it is still stuttering without TrackIR is relevant, and corrects us on thinking it was related to TrackIR to begin with.  It's related somehow to how the game is utilizing force feedback.  and I corrected the bolded part of your statement.  (there are posts about this issue before the DX11 update.. and the title of the thread doesn't mention dx11) 

 

It does not matter if using mouselook only, or using trackir - Only when FFB is enabled.. I get stuttering looking around using either method.  with FFB disabled I do not.  The same effect can be observed by enabling autopilot in "normal" mode flight as it seems like doing so disables force feedback until you disengage autopilot. 

 

Edit* I attempted to make a video capturing the stutter but it is harder to notice when you're watching it as opposed to experiencing it, as I also couldn't really see it from a previous poster's video, although when trying to look around in game it feels clearly noticable.  (even when trying to record to show the stutter with trackir on which is a more noticable jerkiness it isn't anywhere as noticable while watching.. but when experiencing it's super jerky)  So im going to withhold them as I don't think they'll be of much help.  I will say - the jerkiness of trackir is much more noticable (maybe do to it differing from the way my head is moving) but it is definitely still happening using only mouselook and not running TIR software. 

 

But I'll repeat it again - going to the camera settings in the game options and increasing "Smoothness" to 90 greatly diminishes this effect to a more comfortable degree, even if not completely, while being totally unnecessary if not using an FFB stick. 

Edited by headwarp

Share this post


Link to post
Share on other sites

I have the microstottern for 3 years. Since I know this thread, i am very surprised, how fluently the game can run!


 


Currently I use the 90% Camera - smoothing + FFB and Trackir.


 


 


 


System: i7-2600k, 16gb, GTX 980Ti, "TIR 5 + MS - FFB2"  Win 10  


Share this post


Link to post
Share on other sites

Here's a few things I have tried so far:

 

(My current IL2 and Nvidia settings attached below.)

 

If I start the game with MSFFB2 connected. TrackIR is ON and ready. FFB is enabled in game. This causes stuttering! Turning FFB off in the options will minimise the stuttering so it's barely noticeable. Turning FFB back on in the options with bring back the stuttering.

     Also, if TrackIR is switched off while the game is still running, turning on/off FFB in the options still has the above-mentioned effect.

     

If I start the game with just MSFFB2 connected. TrackIR is OFF. FFB is enabled in game. Using just mouse look doesn't give me any noticeable stuttering.

 

If I start the game with MSFFB2 not connected. TrackIR is OFF. FFB is enabled in game. Using mouse look doesn't give me any noticeable stuttering.

 

If I start the game with MSFFB2 not connected. TrackIR is On. FFB is enabled in game. Using TrackIR to look around doesn't give me any noticeable stuttering. Turning off FFB in the options doesn't give me any noticeable stuttering. Switching off TrackIR and using mouse look doesn't give me any noticeable stuttering.

 

post-753-0-64759600-1486701880_thumb.png

post-753-0-75658000-1486701885_thumb.png

 

 

EDIT: Added screenshots.

Edited by HippyDruid

Share this post


Link to post
Share on other sites

I gave this a try and here's my results:

 

FFB on and TrackIR on: horrible stuttering (even with 120 fps in a 1on1 quick mission)

FFB off, TrackIR on: very smooth

FFB off, trackir off: very smooth

FFB on, Trackir off, mouselook: not as bad as case #1, but still some small stuttering

 

Its hard to say for 100% certain but it seems the engine does not like FFB and that it may have nothing to do with TrackIR, its just that TrackIR makes the stuttering MUCH more noticeable since when your head movement is linked to in game head movement we are more sensitive to the stuttering due to physiological effects???.. you stil get great FPS but the microstutters feel terrible

Share this post


Link to post
Share on other sites

Here's a few things I have tried so far:

 

(My current IL2 and Nvidia settings attached below.)

 

If I start the game with MSFFB2 connected. TrackIR is ON and ready. FFB is enabled in game. This causes stuttering! Turning FFB off in the options will minimise the stuttering so it's barely noticeable. Turning FFB back on in the options with bring back the stuttering.

     Also, if TrackIR is switched off while the game is still running, turning on/off FFB in the options still has the above-mentioned effect.

     

If I start the game with just MSFFB2 connected. TrackIR is OFF. FFB is enabled in game. Using just mouse look doesn't give me any noticeable stuttering.

 

If I start the game with MSFFB2 not connected. TrackIR is OFF. FFB is enabled in game. Using mouse look doesn't give me any noticeable stuttering.

 

If I start the game with MSFFB2 not connected. TrackIR is On. FFB is enabled in game. Using TrackIR to look around doesn't give me any noticeable stuttering. Turning off FFB in the options doesn't give me any noticeable stuttering. Switching off TrackIR and using mouse look doesn't give me any noticeable stuttering.

 

attachicon.gifHippyIL2Settings.png

attachicon.gifHippyNvidiaSettings.png

 

 

EDIT: Added screenshots.

 

Could you try lowering your in game camera smoothness and running just the mouselook tests again?    For me  just because of the nature of the mouse it was hard to detect a stutter with mouselook with my smoothness at 90.   But reducing it to 15 or so and looking around slowly with the mouse with FFB would stutter and then be smooth without ffb enabled (can simply engage autopilot with the "A" key [not autolevel] to disable FFB flying in normal mode).  

Edited by headwarp

Share this post


Link to post
Share on other sites

 

That thread mentions framerate drops.   My fps stays at 99 and never below around 85 when flying in il-2 BoS with o  with limiter set to 100 in startup.cfg.  CPU load would likely decrease framerate wouldn't it?  My frames aren't dipping enough to cause the effect and with in game camera smoothness up, the effect is highly reduced with FFB still on, which I don't think the smoothness setting in the camera menu within IL-2 BoS would suddenly make the game run at higher fps.  And my monitor runs at 100hz so it's not a sync issue either. 

 

 

I just went in and tested it again.. my system generally ran on a solo flight at 99 fps.. at lowest dropping to 92 fps which g-sync synced my monitors refresh rate to. 

 

Whether or not FFB was enabled or disabled my fps stated within that range, with the majority of its time spend at 99fps.   92 fps is still rather fast and not enough to cause stutters in the game.  Doubled by the fact that even though the head motion may be choppy, the plane is still flying at what appears to be normal speeds and responding to inputs accordingly.

 

But just to double check MY results - 

 

I turned my camera smoothness down to 10 to emphasize the stutter - used autopilot to disable ffb for my testing purposes.. having already attempted this without trackir running for the mouselook I just hit f9 to disable trackir this time. 

 

FFB enabled = stutter with mouse look or trackir, no significant drops in frame rate.

FFB disabled = no stutter with mouselook or trackir, no significant drops in frame rate.

 

I can record myself looking around with the ingame fps counter, however as stated before.. for some reason trying to capture this stutter on video it does not seem anywhere near as apparent, while it's easy to feel when experiencing. So all I think is noticable via video recording is that my fps in fact stay above lag free numbers.    Thanks Tomcat but I personally don't believe the thread you linked is related (there's also mention of a patch that fixed the issue in that particular game...in which they were complaining of framerate drops.)  I'm open to being corrected if applicable.  

 

*edit* So I just looked at the camera menu in Rise of Flight for the first time.. and noticed by default the camera smoothness is maxed out in that game.    I turned it down and the same thing was happening.  So maybe this is the reason the smoothness setting was incorporated to both games in the first place, although it does seem odd that that setting doesn't seem to do much of anything afaict when I plug in my logitech extreme 3d pro or simply disable ffb on my stick.

 

Perhaps the word stutter is confusing.. it's not a system hang or anything of the sort.. its just jerky when moving the head around, while everything else in game seems to work as intended.   If CPU load IS the reason for it, it is not obvious, and it seems camera smoothness has entirely different effects for FFB and non FFB users.    Sorry for being so wordy..not trying to make anyone's life difficult.  It's really not horrible with the smoothness turned up at least on my machine.    

Edited by headwarp

Share this post


Link to post
Share on other sites

Any updates? Very excited to hear news on vr support but if this stuttering still happens in vr it will be vomit city!

  • Upvote 1

Share this post


Link to post
Share on other sites

Just out of curiosity (since I don't notice any notable stuttering with TiR and FF both on), could someone post two short videos with one having such stuttering, and another one where FF is turned off in the same scene for comprising?

 

Also keep FPS counter displayed so it is visible if it is or is not frame rate related. Since so many seem affected, it's odd that no one posted such videos yet.

You can't get proper help from anyone if we (or Devs) can't see exact issue in effect (and screenshots obviously won't help here). 

Share this post


Link to post
Share on other sites

I think it's significant present in full screen mode. I'm playing widowed mode at it's OK ish, but when I turn off ff there is significant change in image smoothness.

Share this post


Link to post
Share on other sites

Just out of curiosity (since I don't notice any notable stuttering with TiR and FF both on), could someone post two short videos with one having such stuttering, and another one where FF is turned off in the same scene for comprising?

 

Also keep FPS counter displayed so it is visible if it is or is not frame rate related. Since so many seem affected, it's odd that no one posted such videos yet.

You can't get proper help from anyone if we (or Devs) can't see exact issue in effect (and screenshots obviously won't help here). 

 

There are videos early in the thread attempting to show the stutter from other posters.   I could hardly notice any stuttering in the videos posted.  I attempted to record the crazy jerkiness I can easily replicate and got pretty much the same result as explained previously.  The jerkiness I felt like I was experiencing while actually controlling the view with my TrackIR or mouse did not seem to translate to video.  Maybe there is something in nvidia capture software that eliminates jerky movements similar to a feature in the youtube video editor, but the stutters just weren't noticable in the videos I recorded.   Again I think stutter is the wrong word.. it's jerky not smooth head movements when looking around the cockpit with ffb enabled.   My videos would have shown that at least my framerates aren't dipping beyond playable fps (i.e. in a solo flight it's rare i drop below 85 fps, usually staying at 99 fps when looking forward once I'm in the air, on a heavily populated MP server my frames may drop to around 70 fps but this is hardly enough to cause the issue being described).   And again I'll reiterate that I highly doubt changing the camera smoothness option in the camera options when hitting esc in game is going to suddenly make the game run at higher frames per second. The game isn't stuttering, just the head motion. 

 

As the videos did not show the jerky head motion as much as I felt like I was experiencing it - I chose not to upload them as they wouldn't help any more than the video posted earlier in this thread, which if taken for comparison to the actual experience doesn't highlight the problem.  But I could upload them if you don't trust my word about the framerates.  I just don't think you'll get a clear picture of the issue described from them. 

 

The described issue imo is rather easy to replicate if you own a Microsoft Sidewinder Force Feedback 2.  I'm not sure about the g940 or other ffb sticks as the only other ffb stick i can test is a Saitek evo force which requires me to boot into win7 to even get it to function.  (and it just couldn't stand up to the quality product that was the msffb2) 

 

To emphasize the jerky effect - In game go into the menu for Camera options - reduce Camera smoothness to about 15 or less.  start a quick mission on normal (or expert..normal is so autopilot is available) settings - in the air is fine -

once flying move the stick to disengage auto-level,  look around.  For me - did not matter if mouse or trackir - with FFB enabled there is a noticable jerkiness when looking around the cockpit  or landscape, and no significant changes in framerates.  The game is not stuttering, the head movement is just jerky. 

Press A to engage autopilot, which disables FFB (your stick will go limp as the plane flies itself) Or, go into the input options and disable ffb.   Camera smoothness at the same setting of 15 -

Mouselook or trackir head movement is completely smooth.  Again - showing the same framerates as when I was looking around with ffb enabled. 

 

 

in the camera options - raising the camera smoothness to around 90 seems to have mostly eliminated the jerkiness even with ffb enabled, however - but may cause your method of looking around to feel a little slower in responsiveness.  I have been flying this way and it's okay for now.  Having also replicated this issue by reducing the camera smoothness in RoF, I believe it's limited to this engine, as I don't have the issue in other sims.. my msffb2 has been getting a lot of use in DCS Blackshark 2.   DiRT Rally didn't seem to present the issue either.    I've posted enough in this thread however and most of this post is me repeating myself at this point. 

 

 

I think it's significant present in full screen mode. I'm playing widowed mode at it's OK ish, but when I turn off ff there is significant change in image smoothness.

 

 

https://forum.il2sturmovik.com/topic/26784-60-fps-lock-fullscreen-setting-after-update/

 

If you're running on a monitor with refresh rates above 60hz,   fullscreen seems to be locked at 60fps right now according to the dev's green post in that thread.

 

If your eye is keen enough to pick up the difference between 60fps and higher framerates then ALL of the graphics would seem a bit less smooth, not just the head movements.  Being someone who's enjoyed pc gaming most of my life, I could definitely tell the difference between the 60hz my monitor is limited to in fullscreen and the 100hz I currently use to fly in windowed borderless.  Not the same issue, and we at least know the devs are working towards a solution for the fullscreen limitations. 

Edited by headwarp

Share this post


Link to post
Share on other sites

I have the same problem.

 

(Track Ir 5   + MS FF2 )      

 

in game    2.008

 

  FF on =  stutter  

  FF off =  No stutter

 

Can't play without FF so    BOS unplayable. 

 

Please help !

Share this post


Link to post
Share on other sites

Can't play without FF so    BOS unplayable. 

 

 

Set camera smoothness to 90 or 100, that will mostly eliminate stutter with FFB and TIR. You may or may not like so much smoothing in the camera movement, but it makes the game playable until there is a fix.

Edited by yeikov
  • Upvote 1

Share this post


Link to post
Share on other sites

I have the same problem.

 

(Track Ir 5   + MS FF2 )      

 

in game    2.008

 

  FF on =  stutter  

  FF off =  No stutter

 

Can't play without FF so    BOS unplayable. 

 

Please help !

 

The Camera menu in the game (not your trackir software but IL-2 BoS) crank up the camera smoothness. 

Share this post


Link to post
Share on other sites

Its not a solution for me. I am used to very smooth movements by Track IR (IL2 1946, Clod, DCS...) without FF  BOS is very smooth ! I want the same with FF.

 

I payed for this soft and expect it to run smoothly !

  • Upvote 1

Share this post


Link to post
Share on other sites

The third patch and still the same error stuttering, in such a state of unplayable I'm thinking seriously uninstall and sell. Soon to be released DCS Normadie 1944 so BOS-M-K as well no one will want to fly.

Share this post


Link to post
Share on other sites

The third patch and still the same error stuttering, in such a state of unplayable I'm thinking seriously uninstall and sell. Soon to be released DCS Normadie 1944 so BOS-M-K as well no one will want to fly.

 

Please, by all means, go play DCS than.

  • Upvote 1

Share this post


Link to post
Share on other sites

 

 

Please, by all means, go play DCS than.

 

You will loose all credibility with such mentality my friend. You should try to help, this negative mindset will not help to solve the problem witch is REAL ! 

Share this post


Link to post
Share on other sites

You will loose all credibility with such mentality my friend. You should try to help, this negative mindset will not help to solve the problem witch is REAL ! 

 

HA HA HA! What a joke! Who want to talk to the PetSild's credibility? And sanctimonious, it makes me want to puke!

Share this post


Link to post
Share on other sites

The third patch and still the same error stuttering, in such a state of unplayable I'm thinking seriously uninstall and sell. Soon to be released DCS Normadie 1944 so BOS-M-K as well no one will want to fly.

 

Please, by all means, go play DCS than.

 

HA HA HA! What a joke! Who want to talk to the PetSild's credibility? And sanctimonious, it makes me want to puke!

 

 

Let's not turn this thread into a flame war please?   I have to disagree with the whole tactic of saying "don't let the door hit you on the way out" as a means of problem solving.   I also have to disagree with threatening to play other games instead.. I have several modules in DCS that I enjoy.  I have over 200 games on Steam. IL-2 is not the only thing I play. Big whoop.  The production/dev team of IL-2 is small compared to other gaming companies out there with anywhere from 100 to thousands of employees.  patience is a virtue.  The sim community is small compared to other gaming platforms and genres.  Should be easier for us to get along and work with each other right? 

 

Just flew a quick mission.. Camera smoothness set to 100.. FFB on.. seems fine.    Like..totally playable fine.  Like.. I don't seem to have a full understanding of what the smoothness setting actually does.. as I only noticed a need to adjust it after I bought my msffb2 off ebay (of which I have purchased a second, that is pretty much in Brand new condition and will likely mod the one that has obvious signs of use) and found this thread after wondering why looking around suddenly felt horrible. .   At 90'ish I was feeling a bit of a delay looking around.. at 100 it suddenly feels almost perfect to the point I almost feel silly with my participation and wordiness in this thread.  (maybe it's because I recently unchecked "Head Shake" idk.)  I'm starting to wonder if I accidentally enabled TrackIR's smoothing profile with the delay I was talking about... but seriously flying around right now with smoothness in game set to 100.. everything seems to feel like it should. 

 

Again..not talking about in TrackIR software.   In-game menu, next to the head shake option.  Will add image when photobucket or imgur decide to work with me.     Prior to getting the FFB stick I had never needed to touch this setting.. so somethings weird there for sure but.. should improve your viewing to crank it up. 

 

 

2017_3_5__9_41_43_zpsnlnvl5sj.png

Edited by headwarp

Share this post


Link to post
Share on other sites

Men, the base statement of that post is that Trackir + DX11 = stuttering. I'm not here to try to solve all the problem which cause stuttering. So please do not add any problem which are not related to the post. We can't try to solve all the problem at one time, even if it's stuttering, and have to proceed step by step. Every problem is important, but each one need a special investigation.

 

Sometime ago, I opened other thread about same problem. I´ve got that sutters from early versions, so dx9 too. Even I´d got them (and I have ...) in RoF.

 

Sidewinder FFB2, I7-6700K, 16GB RAM, GTX780, Windows10 x64.

 

In my old machine I had stutters too (same joystick, I7-920, GTX570, 6GB, Windows7 x64).

 

I´d test with other Sidewinder (I have two, grey and red trigger versions), same results.

 

Using 90% smooth camera in game hide a bit the problem but game doesn´t work as FFB disabled.

 

The video ...

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Sometime ago, I opened other thread about same problem. I´ve got that sutters from early versions, so dx9 too. Even I´d got them (and I have ...) in RoF.

 

Sidewinder FFB2, I7-6700K, 16GB RAM, GTX780, Windows10 x64.

 

In my old machine I had stutters too (same joystick, I7-920, GTX570, 6GB, Windows7 x64).

 

I´d test with other Sidewinder (I have two, grey and red trigger versions), same results.

 

Using 90% smooth camera in game hide a bit the problem but game doesn´t work as FFB disabled.

 

The video ...

 

 

I just tried to record with my phone..and geforce experience again.    I can't emphasize enough how the issue just doesn't seem to translate to video.  Even your recording of your monitor.  Like maybe if I look for them REALLY HARD I can see the slight pauses in motion when you look around.. but with the videos earlier in the thread.. with your video.. with my own videos.. watching them is nothing like what I personally experience in IL-2 BoS and RoF.

 

- going to take back what I said in my earlier post.  setting smoothness to 100 mostly eliminates the jerky movements for me.. until I decide to use time acceleration.. and then it's jerky as hell when I look around unless I engage autopilot or disable ffb (which happens when you engage autopilot.)    Same exact thing with RoF.     I tested it this time in BoS on a quick missions where I spawned zero tanks or enemy or even friendly planes.. at 6000m.  My in-game framerates were pinned at 99 at this altitude on an empty map.   Looking around did not change that fact.. regardless of whether FFB was on or off.

 

I don't use time accel alot in BoS.. in RoF single player I use it when I feel a need to engage "autopilot" as unrealistic as it may be.. so I am still completely patient regarding this as looking around at normal speed with smoothness 100 is fine for me.. but - hopefully we all do see a fix eventually, however.. as I still need to look around should I decide to speed up time. 

Share this post


Link to post
Share on other sites

Upping the smoothness does help with the stuttering a little bit, but at 100 it's like looking around whilst feeling a bit sloshed.

Share this post


Link to post
Share on other sites

Hi there,

 

MS FFB 2

TIR 5

 

Forced to play with 90% camera smoothness here too. I had "fixed the problem" going for 100%, then I read here and there that pretty much people recommanded 90% as a good setting (with a bit less of camera latency) so tried it.

Graphics settings to "Normal" :/

 

On official .eu server I can play until there are about 15-20 people then horrible stutters. I did try to tick off the FFB (in game) and it didn't seem to change anything to me... Offline I can have nice and smooth dogfights, I need to test with full grid but the things look to be much more smooth. But if I lower camera smoothness, things go terrible even offline.

Share this post


Link to post
Share on other sites

I just tried to record with my phone..and geforce experience again.    I can't emphasize enough how the issue just doesn't seem to translate to video.  Even your recording of your monitor.  Like maybe if I look for them REALLY HARD I can see the slight pauses in motion when you look around.. but with the videos earlier in the thread.. with your video.. with my own videos.. watching them is nothing like what I personally experience in IL-2 BoS and RoF.

 

To me it seems easily noticeable, but maybe it's because I know the problem. @necro : maybe you could reproduce the experience but giving us the (unlimited) FPS numbers. I see that you had it set to 60 frames, but the real numbers could be interestning to know.

 

Edit : oups, confused both posters, sry.

Edited by Solmyr

Share this post


Link to post
Share on other sites

To me it seems easily noticeable, but maybe it's because I know the problem. @necro : maybe you could reproduce the experience but giving us the (unlimited) FPS numbers. I see that you had it set to 60 frames, but the real numbers could be interestning to know.

 

Edit : oups, confused both posters, sry.

 

Seeing as how I experience the problem.. it's not like I don't know it.. but even when I reduce the smoothness to make it stutter like mad it looks about the same as either of the other two recordings anytime I try to record it.. even when using time accel which really makes it choppy even with high smoothness setting.   With reduced smoothness, while flying the plane itself.. the jitter is way more dramatic than that.. at least it feels like it to me. 

 

But at least it does show his FPS are staying at a steady 59-60 throughout his flight so it's not a performance issue, his machine is running solid. 

 

 

 

 

On official .eu server I can play until there are about 15-20 people then horrible stutters.

 

 

Are you getting FPS drops with your stutters as maps get more populated? I don't seem to experience any slow downs due to high population unless I'm ground level with max everything graphics, and at that point it's fps dips causing my game to run less smoothly.. not just headmovement.   

Edited by headwarp

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...