Jump to content
Han

Game version 2.006 discussion: DX11, Ju 52, Bf 109 G-4, Scripted Campaign, "10 Days of Autumn"

Recommended Posts

My GPU is a 780ti. Is there and will there be a solution in the (near) future for the game crashes? Or is there no solution and is the only solution a new graphics card?

Share this post


Link to post
Share on other sites

My GPU is a 780ti. Is there and will there be a solution in the (near) future for the game crashes? Or is there no solution and is the only solution a new graphics card?

 

Read what Han said, there is a workaround. Alternatively you can also try enabling "debug mode" in the driver settings (it's under "help"). Another solution from the top of my head, could be to use something like MSI Afterburner or other software to bump up the voltages on the card a little, just check online what values are safe.

 

You might also want to check this out:

http://www.tomshardware.co.uk/forum/id-1798315/fixed-gtx-780-display-driver-stopped-responding-recovered.html

Edited by Mmaruda

Share this post


Link to post
Share on other sites

Anyone else an issue with the mouse cursor being jittery or laggy? also is there a reason the menu is only getting 10fps while the game itself is much much higher? 

Share this post


Link to post
Share on other sites

I'm still trying to track down my problem. Anyone know what they mean by this answer to the question.

What is the :catalog: do they mean a folder?

13) Game crashes to desktop all the time, what's wrong?

Find the catalog where the game is installed, enter the folder properties and remove the tick from Read Only field.

 

Yes, contextually speaking it would appear they are referring to your IL2 folder.

  • Upvote 1

Share this post


Link to post
Share on other sites

Anyone else an issue with the mouse cursor being jittery or laggy? also is there a reason the menu is only getting 10fps while the game itself is much much higher? 

 

Disable exclusive mode in startup.cfg. As for FPS in menu, dunno, try setting the driver power saving option to "prefer maximum performance".

Share this post


Link to post
Share on other sites

Read what Han said, there is a workaround. Alternatively you can also try enabling "debug mode" in the driver settings (it's under "help"). Another solution from the top of my head, could be to use something like MSI Afterburner or other software to bump up the voltages on the card a little, just check online what values are safe.

 

You might also want to check this out:

http://www.tomshardware.co.uk/forum/id-1798315/fixed-gtx-780-display-driver-stopped-responding-recovered.html

Yes i read what Han said. It is a workaround. Not a solution. Edited by D.B.Cooper

Share this post


Link to post
Share on other sites

Han is getting a 780 from a Russian user so we can test in house, but with Xmas vacation coming and time running out and our lead programmer scheduled to be on a plane tomorrow, I am pessimistic we can solve this before they return from Xmas break. Just being real guys. This was a completely unexpected issue. 

 

Jason

Share this post


Link to post
Share on other sites

I just installed 2.006c directly from 2.005 on my Win 10 rig, running a GTX 980ti board.

 

Runs perfect, no graphical glitch seen yet. Frame rate is excellent and no stutters.

 

I checked the Quick Missions no problem.

 

I checked the Campaigns AND OOPS!! The three campaigns (BOM, BOS, BOS2) are locked !!

 

If I click on one of them I get a message "Theater of War Unavailable Do you want to buy it?

Does this mean that the upgrade has wiped out all my past Awards, medals, mission results, pilot level etc..

 

I have then checked the new Scripted Campaign and that worked perfectly well.

 

So please give me back my old campaigns!!

 

There is another issue with the parachute bombs launched from the Junkers. They are set on contact fuse, but they never explode on the ground.

Tried the paratroopers and all is fine from that side.


Jason just if it helps, I can have my campaigns back in January, no hurry. Merry Christmas and Happy New Year. ;) 

Share this post


Link to post
Share on other sites

Any chance the Christmas tree will re-appear in the hanger - obviously it won't be the one from last year at that one has most likely been burnt by now

Share this post


Link to post
Share on other sites

I just installed 2.006c directly from 2.005 on my Win 10 rig, running a GTX 980ti board.

 

Runs perfect, no graphical glitch seen yet. Frame rate is excellent and no stutters.

 

I checked the Quick Missions no problem.

 

I checked the Campaigns AND OOPS!! The three campaigns (BOM, BOS, BOS2) are locked !!

 

If I click on one of them I get a message "Theater of War Unavailable Do you want to buy it?

Does this mean that the upgrade has wiped out all my past Awards, medals, mission results, pilot level etc..

 

I have then checked the new Scripted Campaign and that worked perfectly well.

 

So please give me back my old campaigns!!

 

There is another issue with the parachute bombs launched from the Junkers. They are set on contact fuse, but they never explode on the ground.

Tried the paratroopers and all is fine from that side.

Jason just if it helps, I can have my campaigns back in January, no hurry. Merry Christmas and Happy New Year. ;)

 

The missing campaigns have happened twice now with the latest patches but re-starting the game has sorted out the issue

 

and the parachute 'bombs' are supply containers

 

Cheers Dakpilot

Share this post


Link to post
Share on other sites

I finally managed to get a ride with DX11 and this is a wow effect at it's best for me.

 

I managed to crank up the graphics from balanced to high, and still get twice as much fps as with Dx9.

Best part is reduced stuttering (still present but not an issue anymore) and a huge boost in fps in a thick dogfight on Berloga (from ~10-15 to 35+ now !)

The flaming planes seems to still take a toll in the department but not a game breaker as it used to be.

 

Thank you thank you thank you !

 

The only thing I'm a bit sceptical about is the tree rendering upgrade, they still "dance" a lot for me, although differently it seems.

Share this post


Link to post
Share on other sites

Any chance the Christmas tree will re-appear in the hanger - obviously it won't be the one from last year at that one has most likely been burnt by now

 

I'm sure it was already there, probably it was not in the last hotfix compiler run...

Share this post


Link to post
Share on other sites

Particle effects all fixed! This update plus the Team Fusion incorporation announcement have made this the best Christmas a sim lover could wish for. 

 

All the very best to all involved with the project.  :biggrin:

post-81420-0-21658600-1482359002_thumb.jpg

post-81420-0-88662700-1482359005_thumb.jpg

Share this post


Link to post
Share on other sites

Han is getting a 780 from a Russian user so we can test in house, but with Xmas vacation coming and time running out and our lead programmer scheduled to be on a plane tomorrow, I am pessimistic we can solve this before they return from Xmas break. Just being real guys. This was a completely unexpected issue. 

 

Jason

You guys did your best! Thank you for all your hard work. For now: enjoy your well deserved holiday.

Share this post


Link to post
Share on other sites

I finally managed to get a ride with DX11 and this is a wow effect at it's best for me.

 

I managed to crank up the graphics from balanced to high, and still get twice as much fps as with Dx9.

Best part is reduced stuttering (still present but not an issue anymore) and a huge boost in fps in a thick dogfight on Berloga (from ~10-15 to 35+ now !)

The flaming planes seems to still take a toll in the department but not a game breaker as it used to be.

 

Thank you thank you thank you !

 

The only thing I'm a bit sceptical about is the tree rendering upgrade, they still "dance" a lot for me, although differently it seems.

 

I could raise my settings as well, everything runs fine here (GTX970). Now it's also easier to follow a contact against the blue sky or over the forrests. All in all a very good update right before christmas!

 

Visuals which would be nice if could be improved in the future:

 

- The 'bubble'

- Plane textures

- Textures of big grass airfields as they seam to stutter somehow, although I have high fps

- Trees

 

 

Happy christmas Jason, dev team, moderators and pilots! And of course to your families!

 

Keep your six free :salute:

Manfred

Share this post


Link to post
Share on other sites

Han is getting a 780 from a Russian user so we can test in house, but with Xmas vacation coming and time running out and our lead programmer scheduled to be on a plane tomorrow, I am pessimistic we can solve this before they return from Xmas break. Just being real guys. This was a completely unexpected issue. 

 

Jason

 

No encouraging news for all GTX780 owners. A sustainable problem fix would be very desirable

Share this post


Link to post
Share on other sites

Han is getting a 780 from a Russian user so we can test in house, but with Xmas vacation coming and time running out and our lead programmer scheduled to be on a plane tomorrow, I am pessimistic we can solve this before they return from Xmas break. Just being real guys. This was a completely unexpected issue. 

 

Jason

 

Thank you for keeping us up to date Jason, yes it was unexpected and I appreciate all your and the team hard work on fixing the issue ASAP. :)

Edited by DrTeflon

Share this post


Link to post
Share on other sites

I've got a evga 780 OC , w7 64 , all drivers are updated, all w7 patches are installed, and even with version 2006c it keeps crashing with a black screen and showing a message indicating that trackir 5.4.2 has stopped working... (I did tried reducing 105Mhz using evga software) but it also crashed...with a black screen

Share this post


Link to post
Share on other sites

Does Win 10 and DX12 also get the fps bump? Cause I really didn't notice anything spectacular yet it can be just my old GPU (GTX 850m). 

DX 12 is only used if a game is coded in DX12 IL-2 is now DX11 not DX12. Just because you windows 10 doesn't mean you are running DX12 it just means you can run it if the game is coded for it. You need Windows 10 to be able to play BF1 in DX12 otherwise you can only run BF1 for example in DX11.

Share this post


Link to post
Share on other sites

I've just finished my first Ju-52 mission: phew! Just a simple cargo supply run, or so it seemed... 

 

I'd taken the easy option, and run it in 'normal' settings, so I didn't have to navigate, which was just as well because at 500 m in twilight with ground-level mist it would have been easy to get lost. The trip out was simple enough until about half way, when it suddenly got busy - MiGs escorting Il-2s turned up, which gave my escort (2 Bf 109s) an excuse to run off looking for glory. Not helpful, as soon after I passed over the IL-2s (who clearly had other objectives than the easy meat I'd have been) a pair of LaGGs also appeared - just as I was trying to orientate myself for landing on the delivery runway. Fortunately there was flak defending the airfield, but I didn't have much choice other than to commence my landing run with a LaGG behind me, firing! Possibly being so slow actually helped me, or maybe the flak did its job, but either way I managed to land in one piece, though my number 2 engine took a hit, and died. :(

 

The LaGGs were gone by then, so I unloaded the cargo, and struggled back onto the runway (I'm not sure whether I'd actually landed on it, but by the end of my short landing run I wasn't). There seemed to be plenty of runway ahead, and my two remaining engines seemed to be working properly, so I wound the flaps back up half way, applied full power, and crossed my fingers. Somehow I managed to get airborne again, though I've no idea what speed I was doing when I left the ground: not a lot, anyway. 

 

With only two working engines and a fair bit of fuel the rate of climb was marginal, so having got up to about 200m I decided to just throttle back a tad (it didn't seem wise to use full power for an extended period if I could avoid it), and cruise home at 150 Km/h, which was all it would do. Even with full up trim I had to pull back on the stick to stay level, which was a little awkward, but I made it back to base, and landed with no further damage. Mission complete. 40 minutes. And proof, if any were needed, that flying the Ju-52 is anything but boring. Sure, there is little glory in delivering crates of button-polish and Stahlhelm requisition forms, but the job has to be done. My sincere thanks to the development team for presenting us with this masterpiece of Teutonic iron-mongery - a worthy addition to the roster. :good:

  • Upvote 3

Share this post


Link to post
Share on other sites

Fantastic AndyJwest! I made 3 Tante Ju missions (expert full length) and so far I did not had any problems with fighters. My 2 109 buddies always did the job as planned! and no it was interesting to navigate at night... with the radio beacons and no gps (I removed it)

Share this post


Link to post
Share on other sites

No its thousands and thousands.

 

Jason.

Sorry... I stand corrected.

Share this post


Link to post
Share on other sites

I have a suggestion to GTX780 owners. Try to limit the FPS in the game. It should decrease GPU load and might fix your issue.

Edited by IvanoBulo

Share this post


Link to post
Share on other sites

I have a suggestion to GTX780 owners. Try to limit the FPS in the game. It should decrease GPU load and might fix your issue.

I have it limited up to 60 frames/s and crashing every time I fly. I'm looking forward to hearing developers finding a solution. Hopefully that's not: "buy another GPU...."

Edited by Ala13_knightcrow
  • Upvote 1

Share this post


Link to post
Share on other sites

Further to my Ju-52 mission report above, I've just had a look at the track. One of the LaGGs had actually fired at me while I was unloading the cargo, which with all the excitement I hadn't noticed. Excitement which probably accounts for me forgetting to close the cargo doors before the takeoff run. They disintegrated soon after, leaving the back end rather open plan, and possibly adding drag.  :unsure:

 

Landing under fire.

2016_12_21__23_38_35_zpsn595zhnx.jpg

 

Down on the ground. I did actually land on the runway, though at an unusual angle - just as well the Ju-52 has a short landing run.

2016_12_21__23_39_31_zpswfbf5asu.jpg

 

Airborne again on two engines, after running out of runway. The ASI reads 128 Km/h at this point. If I'd closed the cargo doors, it might have been a bit higher...

2016_12_21__23_43_28_zpse6mbt94m.jpg

  • Upvote 2

Share this post


Link to post
Share on other sites

I've got a evga 780 OC , w7 64 , all drivers are updated, all w7 patches are installed, and even with version 2006c it keeps crashing with a black screen and showing a message indicating that trackir 5.4.2 has stopped working... (I did tried reducing 105Mhz using evga software) but it also crashed...with a black screen

I get that when there is an update for the game profiles for track ir.. did you update those?

Share this post


Link to post
Share on other sites

I've heard a couple people get campaigns back after restarting the game

Thanks Cool.  After half a dozen restarts I have my campaigns back and all seems to be normal.

 

Share this post


Link to post
Share on other sites
Update 2.006c   Dear Pilots,   A day of hard work and buying videocards in stores brought some results.

Thanks Han and the rest IL-2 Dev team the rainbow issue is in fact fixed thanks (R9 Fury X)

 

I notice AMD is having the same issue as Nvidia users when it comes to using GSync or Freesync on fullscreen, it doesn't work and there is a lot of tearing. Do you guys know what's going on there?

 

----

 

If I take it off Fullscreen it seems to run in sync but I think that is Vsync not freesync as it limits my FPS to 120 but my monitor can go up to 144hz with freesync. I have my FPS limiter set to 144fps  in startup.cfg but when not running full screen it tops out at 120fps anyway.

 

Do you know what is causing the Gsync and Freesync not to work in Fullscreen? The latest AMD driver they added support for Freesync in borderless but I feel it's Vsync as it might from what i beleive be a default that Windows 10 sets borderless to run in Vsync.

 

 

For now I guess I'll run borderless untill fullscreen freesync is fixed.

 

Just like to say thank you again to all the team for all your hard work and have a happy Christmas break and well done on making IL-2 a much better product than ever!!

 

 

 

EDIT: Turning off fullscreen changed my FPS limit to 120, just noticed that in the settings, after turning that off my FPS went way over 144 but still saw no tearing lol.

Ill try and set it to 144 again in the setup.cfg (keeps getting reset to 120 after starting game) Would be nice for you guys to increase the in gamer support to 144 max fps limit.

It possibbly is Freesync after all lol

Edited by astrix_au

Share this post


Link to post
Share on other sites

Well I resisted updating till some of the issues I read about were sorted. I went ahead tonight and updated the game via the launcher. The game does not run. After hitting play it goes to the first screen indicating the game is loading. It soon goes back to the desktop where I have no mouse control till I go to task manager and shut the game down (it says its running). Turned off full screen no difference, deleted the game profile from Nvidia Inspector, no difference, checked Win 7, it says SP1, no error messages of any kind.

 

PC is:

I7 3820@ 4.3

GTX 970 FTW with 344.60 drivers Nvidia Experience not installed (Old driver I know but it's Dx11 and has been fastest for me)

Win 7 64 bit

 

Any direction or ideas will be greatly appreciated.

 

Thanks!

Edited by TheSNAFU

Share this post


Link to post
Share on other sites

Have any of the ground textures been improved? I was looking at the Moscow map and the ground seems so much more detailed for some reason.

Share this post


Link to post
Share on other sites

 

 

EDIT: Turning off fullscreen changed my FPS limit to 120, just noticed that in the settings, after turning that off my FPS went way over 144 but still saw no tearing lol. Ill try and set it to 144 again in the setup.cfg (keeps getting reset to 120 after starting game) Would be nice for you guys to increase the in gamer support to 144 max fps limit. It possibbly is Freesync after all lol
 

Weird the fps limiter is still at 144 in the startup.cfg as I set it manually but when starting the game it goes to 120. In fullscreen it tends to accept the 144fps limit I put in manually. Please increase the in game FPS milt to 144 in the future :)

 

Thanks again for the amzing work you guys have done.

Share this post


Link to post
Share on other sites

Fellow GTX780 crash sufferers, here's what I've done and the effects I've seen.

1) Crash on launch (solved by resetting Nvidia control panel settings -> Possibly had some that were increasing stress on GPU? And disabled steam overlay)

2) Periodic crash with avg frequency of 0-5 minutes.

 

Attempted:

 

Nvidia driver FLUSH and install/update -> Crash within 2 minutes (New Geforce overlay possibly altering results)
 

Geforce overlays disabled -> Nope, crash within 2 minutes

Underclock by 105mhz (core) -> Crash within 2 minutes

Underclock by 105 mhz (core) + undclk 105mhz (GPU memory) -> Same 

 

Graphics options Low/ultra/frame limiting/fullscreen/windowed -> Same

 

Audio drivers 2ch 44.1kHz -> 8ch 96kHz -> Same

 

 

In summary underclocking had 0 effect on framerate. 


GTX 780 3GB, i5 3570k, 8GB DDR3, Win 10x64 running on a HDD

Share this post


Link to post
Share on other sites

 

 

Have any of the ground textures been improved?

 

I discovered after turning super sampling on, (within my graphic card settings, and another AMD update), the visuals looked much crisper. What surprised me the most, was the performance appeared to remain just as good. In the past.. . fps would take a substantial hit doing this. Same seems to apply with the Anti Aliasing, all good!   

Share this post


Link to post
Share on other sites

Have any of the ground textures been improved? I was looking at the Moscow map and the ground seems so much more detailed for some reason.

 

I noticed that too. For quick testing I usually take a plane up from the Ventsy airstrip in QMB, and after this update I found it was more detailed than before.

Share this post


Link to post
Share on other sites

Working great here, so far... 2.006c. R9 270x, 60 fps steady and even enabled SSAO just because of the extra juice. :D

Same card..working great for me, Glad I don't own a 780!  :ph34r:  :biggrin:

Share this post


Link to post
Share on other sites

I noticed that too. For quick testing I usually take a plane up from the Ventsy airstrip in QMB, and after this update I found it was more detailed than before.

 

I thought things looked a little sharper.

 

I'm not sure... Could be how some of the sampling and filtering is being done in DX11 that is superior to DX9.

Share this post


Link to post
Share on other sites

the patch fixed the rainbow thing for me :D great job

Edited by johnmw54

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...