Jump to content
Sign in to follow this  
Meatball0311

Cannot play IL-2 Sturmovik 1946

Recommended Posts

I am having major problems trying to play this game.  When I launch the game my mouse starts to react very slow, then my resolution changes, then the game launches but when it gets to the opening scenes it does nothing when I press esc.  If I get into the game my mouse does not work.

 

I am thinking that it may have to do something with my graphics card driver.  I have a GTX 1080 and am using 376.09 driver.  I am running windows 10 64bit.

 

I have been trying to get this to work for weeks now and have tried everything.  The game use to run fine on windows 8.1.

 

Need help.....

Share this post


Link to post
Share on other sites

Alt-Tab out and in to the game if you loose control of your mouse, it's an old issue of il2 1946 to loose control of your mouse right after starting up the game.

 

Also, find the shortcut for certain options (I forgot how it's called and I'm at work now) in your main game folder to choose the right resolution and settings, if try and do it in the game itself, you'll just get the lowest resolution (I know it sounds weird).

 

:salute:

Share this post


Link to post
Share on other sites

Try this,

 

Right click desktop - select 'display settings', then change size of text, apps etc. set it to 100% (it may recommend higher, but il2 1946 won't play ball with higher than 100%). I notice you say the resolution changes, best to have the resolution the same as the desktop.

 

 

Ardmore

Edited by =FI=Ardmore

Share this post


Link to post
Share on other sites

The resolution is easy fixable in config file in game root folder also. I recommend you to go to this site and do further improvements to the game. 

Share this post


Link to post
Share on other sites

-Right-click on the shortcut that you use to start IL2
-Go to Properties
-Go to the Compatibility tab
-Check the box that says "Disable display scaling on high DPI settings"

Share this post


Link to post
Share on other sites

After switching from 8.1 to 10 I also experienced the slow mouse issue. Found out it is was a NVidia card setting.

 

And it is recommendable to ask at SAS1946 in 'The Lounge' or the 'New Members Safety Area'. 

Usually you get quick response.

 

 

The resolution is easy fixable in config file in game root folder also. I recommend you to go to this site and do further improvements to the game. 

 

Off topic: Happy B'day Lusekofte! :drink2::drinks::popcorm:

http://www.sas1946.com/main/index.php/topic,53172.0.html

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...