Jump to content
Sign in to follow this  
Cyph3r

Lower than Expected Framerate

Recommended Posts

Hey all,

 

So I've got a new laptop with a Core i7 6700HQ, 16GB DDR4, 1TB Samsung 850 Evo, nvidia GTX 1060 and on every other game I've tried (Battlefield 1, Battlefield 4, Fallout 4 etc etc) I can do max/ultra settings without any issues.

 

However on IL2, I've had to lower my settings to "balanced" and even then I only get between 40-70fps. When and the frametimes are pretty poor which leads to a obvious jerkiness/stuttering.

 

Interestingly I've noticed that when playing other games, the CPU and GPU are under obvious load, the temperatures for the GPU reach about 65c and the CPU reaches about 60-65c. Plus the fans ramp up pretty loud to deal with the load.

However in IL2 it doesn't even seem like it's taxing the hardware at all, the fans don't ramp up at all and the maximum temperature is about 55c on the GPU and 58-60c on the CPU. It's like IL2 isn't putting any load on the CPU/GPU?

 

Anyone got any ideas??

Share this post


Link to post
Share on other sites

Hi.

Is the  "Distance grass" option enabled?

 

I'll have to confirm later this afternoon but I think it's turned off.

Share this post


Link to post
Share on other sites

Check single thread CPU load.

 

Also in some cases hyperthreading can be a problem with IL2.

 

However i dont think your framerates are particularly bad for BOS

Share this post


Link to post
Share on other sites

Check single thread CPU load.

 

Also in some cases hyperthreading can be a problem with IL2.

 

However i dont think your framerates are particularly bad for BOS

 

Will do!

 

I'm not sure if my laptops BIOS allows me to disable hyperthreading to test that theory, I'll have to have a look.

 

Well considering that I'm frequently below 60fps on the "balanced" settings, I don't think that's particularly good. My main issue is the frame times though leading to stuttering/jerkiness. 

 

GPU usage is floating around 50% so isn't being taxed very hard at all, and neither is the CPU. 

Share this post


Link to post
Share on other sites

Yes, I had the frametimes issue. The only thing that did it for me was disabling HT. Hope you find a way. If its not through BIOS, then maybe some sort of software.

Share this post


Link to post
Share on other sites
It may be that your computer has a graphics card integrated ....There are laptops that have 2 graphics cards  , check the IL2 is associated with the graphics card or the 1060.

A friend felt the same, I fix associating his  gtx1060  IL2.

I hope you understand me, my English is very basic

regards...

Edited by Ala13_Antiguo

Share this post


Link to post
Share on other sites

On notebooks sometimes even if you specified via nvidia control panel to always run games using the nvidia card instead of intel hd graphics, there are games that run on intel. Try to righ click on IL2 icon and there should be a option to run via nvidia graphics processor. Give it a try!

Share this post


Link to post
Share on other sites

Yeah my old laptop with a GTX 970m flipped in between an Intel intergrated GPU (which got about 8fps in IL2, definitely not 40-70fps!!) and I had it set in the nVidia control panel to always use the nVidia card.

 

However on my new laptop it's only got the GTX 1060, no integrated option, so this isn't the issue.

Share this post


Link to post
Share on other sites

Hey all,

 

So I've got a new laptop with a Core i7 6700HQ, 16GB DDR4, 1TB Samsung 850 Evo, nvidia GTX 1060 and on every other game I've tried (Battlefield 1, Battlefield 4, Fallout 4 etc etc) I can do max/ultra settings without any issues.

 

However on IL2, I've had to lower my settings to "balanced" and even then I only get between 40-70fps. When and the frametimes are pretty poor which leads to a obvious jerkiness/stuttering.

 

Interestingly I've noticed that when playing other games, the CPU and GPU are under obvious load, the temperatures for the GPU reach about 65c and the CPU reaches about 60-65c. Plus the fans ramp up pretty loud to deal with the load.

However in IL2 it doesn't even seem like it's taxing the hardware at all, the fans don't ramp up at all and the maximum temperature is about 55c on the GPU and 58-60c on the CPU. It's like IL2 isn't putting any load on the CPU/GPU?

 

Anyone got any ideas??

 

This game is just horribly bad optimized, and that's all. Same as you I can play Battlefield 1 on high/ultra settings with 60fps + but in BoS I play on low settings ... Devs say that we will get much better performance with dx11 which will be implemented until end of this year, so let's hope it's true and we have to wait.

  • Upvote 1

Share this post


Link to post
Share on other sites

were you able to fix the issue ? planning to buy similar HW configuration and though this conf will run it on max without any issue

 

do you have DCS too ? what's the performance there ?

Share this post


Link to post
Share on other sites

were you able to fix the issue ? planning to buy similar HW configuration and though this conf will run it on max without any issue

 

do you have DCS too ? what's the performance there ?

Right now there's nothing you can do but wait for the DX11 update.

 

 

DCS had the same problem. It used DX9 and ran pretty poor. I used to have a ~20/30fps on low settings. After they updated to DX11, I easily got my nice and smooth 60fps on high settings.

 

Let's hope DX11 brings the same magic to BoS as it did to DCS.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...