Jump to content
jcomm

Nvidia DSR - are you using it ?

Recommended Posts

Didn't know about this feature until I saw this thread.  I set it to 2.0x with 33% smoothing.  My first impression was that the cockpit glass scratches were a lot less irritating to look at, the Moscow winter map snow looked almost spot on to the way snow looks when the surface turns to ice, and there was no noticeable loss of frame rate.  - MSI GTX960 4GB

Share this post


Link to post
Share on other sites
14 hours ago, -[HRAF]Roland_HUNter said:

Ah yea Override App mode with 2x SSAA:Not working, its disable AA.

I tried your options but its turning the AA off aswell.

Hi Roland.

You should choose "Enhance", not "Override" AA on nVidia Inspector. SGSSA will be applied "over" your AA settings (as it should).

See here: https://imgur.com/a/jD7H0U1

 

If you use 4xAA inside the game, then you should use 4xSGSSA on nVidia Inspector profile, and set -1.000 on LOD.

I prefer 2xAA and 2xSGSSA because the impact is really small on performance, but the results are great.

Share this post


Link to post
Share on other sites
4 hours ago, -[HRAF]Roland_HUNter said:

I ll try it, but u said do not use anisotropoic optimizations. On the screen that is enabled.

You're right, my mistake. Indeed I have them enabled... will correct the original post. They help in making the image clearer/crispier (with a little cost). Thanks for pointing the error.

  • Like 1

Share this post


Link to post
Share on other sites

But this options saying in NVC, if u turn it ON, your image quality ll be worse

Hmm I have shimemring and fragmented  textures on narrow cables,(example BF-109 cockpit-tail cable) what can I do?(Not only in BoS)

Share this post


Link to post
Share on other sites

Hi Roland. Yes, the option when ON may cause a little bit worse image, but ONLY if you have Texture Filtering Quality in other than "High-quality" setting (which I don't). Otherwise, when you're not using "high quality" in Quality setting (i.e., you're after more performance), then it's good to have the optimizations ON, reason why I usually let them ON all the time, just in case.

So, summing it all up:

 

If your card can support (with acceptable FPS) full AF quality, then use texture filtering quality at "high quality". Any other setting than this, then reduce the quality settings and activate anisotropic optimization to help aleviate the problem and get better FPS (of course you can try without optimizations, too). Keep in mind that if you have optimizations ON while using high quality, they will be ignored anyway. More info about all of this can be found here: http://www.tweakguides.com/NVFORCE_7.html

 

This site above has excellent information which will help you to understand and tailor your settings.

Also, don't forget that my settings are to be used in conjunction with the in-game's AA settings (either 2xAA or 4xAA). If using 2xAA in-game, then use 2xSGSAA in nVidia Inspector. If using 4xAA in-game, then use 4xSGSSA in nVidia Inspector. This is important, because non-similar numbers between AA and SGSSA will cause sub-optimal results.

 

On my end, inside the game I have all things on ultra/max, and together with nVidia Inspector settings from my earlier post, I don't have any jaggies. If you're still having jaggies, then it may be caused by the wrong profile being applied by nVidia Inspector when you're gaming, perhaps due to the use of some overlay or other graphic program that takes precedence over the game's on nVidia Inspector (i.e., nVidia Inspector thinks that the main app that it should be applying the settings ISN'T the game itself, but some other overlay/program, so it may be applying wrong settings, which in turn breaks your AA on game). Last time I saw this happening was with some "performance monitor" that I used to have few years back. Got rid of it since then. Try to run your game "clean" and check if the profile is being applied correctly (for instance, you can try to crank up some setting to make sure it is being applied, maybe FXAA Indicator ON, and FXAA ON, or increase LOD Bias to something weird, like +3000, whatever makes you confident that the profile is in effect).

  • Like 1

Share this post


Link to post
Share on other sites
57 minutes ago, -[HRAF]Roland_HUNter said:

Thank you for the advices.
When I Tried 2xMSAA with 2X SGSSA I had more FPs then before...its looks like the game disable the AA.

This may happen if you choose to "override application settings" on nVidia Inspector. Make sure you're using "Enhance the application setting" on Antialiasing-Mode entry, then set the MSAA inside the game and the SGSSA on Inspector. If you find that 2xAA isn't enough, increase to 4xAA and 4xSGSSA. Note: although this isn't optimal, it you hit a wall using 4xAA and 4xSGSSA in terms of performance, you can try to use 4xAA and only 2xSGSSA and adjust a little bit on the LOD Bias. It's not perfect, but still better than no SGSSA at all.

Cheers

  • Like 1

Share this post


Link to post
Share on other sites

Hi Roland. Unfortunately, Youtube compresses the video, so a lot of detail is lost, but if I understand correctly, you are referring to the shimmering (like if there were ants running over the terrain at distance)? If so, this effect is caused by looking at textures at certain angles (lower ones), and as far as I know (by experience), it can be somewhat "cured" only by applying SGSSA. That's why I don't use DSR, but prefer using SGSSA. With DSR you get good AA, but bad shimmering all the place.

Keep in mind that different game engines may require different "Antialiasing Compatibility" bits settings in Inspector in order to be able to cope with more advanced AA techniques.

"Not every game is created equal".

If you try to apply some sort of special AA technique to a game and it doesn't work, try to google to see if the game requires a special code in "AA Compatilibity" setting inside Inspector.

One such game where I use this "trick" is Euro Truck Sim 2, where I use the 0x000010C1 code as compatibility bits, and this allows me to get perfect image all the time (along with proper AA/SGSSA/etc).

 

Cheers

  • Like 1

Share this post


Link to post
Share on other sites

I know its not IL-2, but: If i want to choose " Enhance the application setting " in Inspector, for War Thunder, when I launch the game, its reseting to Application Controlled mode.
What can I do?

Share this post


Link to post
Share on other sites
On 11/20/2018 at 10:51 AM, -[HRAF]Roland_HUNter said:

I know its not IL-2, but: If i want to choose " Enhance the application setting " in Inspector, for War Thunder, when I launch the game, its reseting to Application Controlled mode.
What can I do?

Hi Roland, I don't own WT, never played it, but here you can find a discussion about your problem that seems to have good info about the matter:

I haven't read the whole thread, but if there's nothing on it pointing to a solution, I would assume that WT is part of those (rather rare) games that doesn't work with any kind of driver's settings, and the only thing you can do about it is try to discover an "AA compatibility" code to put on Inspector to "force" it to work. Keep in mind that this is a *very* time consuming process (basically trial and error) and that probably this code may not exist, indeed.

 

Sorry not to be able to help you much on this one.

Cheers

  • Like 1

Share this post


Link to post
Share on other sites

Thank you, and I understand it. I just hoped maybe u can help me.
The topic what you sent me, sadly outdated, beacuse they upgraded the engine.
WT had MSAA AA in the past, but they removed it, and u can only use  post-AA(FXAA,TAA) and only 4xSSAA. If there would be 2xSSAA I would use that.

But, really:Thank you for the helping!!! ^^

Share this post


Link to post
Share on other sites

So, before, on 180p, I was advocating DSR.

Now I got a new 1440p monitor - and its all different. In this setup I do agree that jokerBR's setting are better than the DSR - better quality at higher frame rate,

on my poor old GTX 980.

It all does really depend on a lot of things, apparently a lot on your monitor as well :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×