Jump to content
Sign in to follow this  
Frequent_Flyer

Computer Locks Up when exiting game

Recommended Posts

Hello All,

 

The game worked fine up until the last three days.The problem encountered is : the games plays fine however when I exit BOS/BOM  my computer locks up-black screen. I cannot even get the " task manager " function to respond . I have to shut down manually from the on/off switch on the computer. I should mention I am running windows 10 and have been for a year roughly. However, there  may have been a recent update that has caused some unknown issue.- not certain.

If anyone has had a similar issue and can suggest a fix ,I would be very appreciative. 

 

Thanks in advance

  • Upvote 2

Share this post


Link to post
Share on other sites

I have the same issue since updating to the Anniversary Windows 10 update. Have not found a fix as of yet but I found that if you uncheck "full screen" in the graphic settings it will exit cleanly. I have the exact same issue with ROF, however, DCS World is okay in full screen mode. I'm thinking it might be related to BOS/ROF using DX9 but I'm not sure. I re-installed DX9 software but it did not help.

Share this post


Link to post
Share on other sites

I have the same issue since updating to the Anniversary Windows 10 update. Have not found a fix as of yet but I found that if you uncheck "full screen" in the graphic settings it will exit cleanly. I have the exact same issue with ROF, however, DCS World is okay in full screen mode. I'm thinking it might be related to BOS/ROF using DX9 but I'm not sure. I re-installed DX9 software but it did not help.

Gramps, Thank you for the advice ,it  worked.

Share this post


Link to post
Share on other sites

Great! I haven't seen anyone else chime in with this particular issue. Not sure if it's related to Win 10 or maybe an issue with video drivers. Just out of curiosity what GPU are you using? Mine is a Nvidia GTX970.

Share this post


Link to post
Share on other sites

Great! I haven't seen anyone else chime in with this particular issue. Not sure if it's related to Win 10 or maybe an issue with video drivers. Just out of curiosity what GPU are you using? Mine is a Nvidia GTX970.

I have the Nvidia GTX750, I also get a the occasional micro stutter.

Share this post


Link to post
Share on other sites

Okay, thanks. Could be a driver issue. I had 368.81 installed and after the anniversary update the problem popped-up. I installed 369.09 but the problem persists. May try and roll back to an earlier driver to see. Strange that no one else has reported the issue.

Share this post


Link to post
Share on other sites

Okay, thanks. Could be a driver issue. I had 368.81 installed and after the anniversary update the problem popped-up. I installed 369.09 but the problem persists. May try and roll back to an earlier driver to see. Strange that no one else has reported the issue.

I play exclusively SP now. I am not certain if the same problem exits with the MP folks?

Share this post


Link to post
Share on other sites

Still haven't found a solution. I wouldn't think it was exclusive to SP as it seems to be related to how windows returns from full-screen D3D9 mode. Will wait for a new NVIDIA driver and see what happens.

Share this post


Link to post
Share on other sites

Same problem, Win10 64bit 1607 update, black screen after exit.

Share this post


Link to post
Share on other sites

Same problem, Win10 64bit 1607 update, black screen after exit.

 

Same.

Share this post


Link to post
Share on other sites

We can use ALT+Tab to switch to the desktop and close the game per right mouse button in the taskbar.

Share this post


Link to post
Share on other sites

We can use ALT+Tab to switch to the desktop and close the game per right mouse button in the taskbar.

Gave this a try in full-screen mode and the exit was clean! At least it is a workaround. Didn't realize that in full-screen mode that alt-tab to the desktop was now fixed.

Share this post


Link to post
Share on other sites

GTX 760 here.

Try exiting the game through the menus (through the main menu)

It's the only way I can get out of the game without the game freezing (window switching or alt-f4)

Task Manager will work if it was already open before the switch/exit however, and will read 0% cpu for il2

 

Edited by -Y29-ZdrytchX

Share this post


Link to post
Share on other sites

Just as an update I discovered that if you are in full-screen mode, then alt-tab to the desktop, then alt-tab back to IL2 it will give you a clean exit directly from IL2. IIRC in full-screen mode windows does not maintain any other screens (desktop, etc) in the background. So when you alt-tab to the desktop it takes a few seconds to build the screen. So I'm guessing that exiting directly out of IL2 in full-screen mode causes win 10 to hiccup and not draw the desktop.

Share this post


Link to post
Share on other sites

I've had the same issue since yesterday.

 

GTX970, Win 10 pro, all latest drivers and Win 10 updates installed.

 

BTW. Yesterday I installed a incremental Win 10 update. I don't know wether this could be the cause of my black screen exit.

Share this post


Link to post
Share on other sites

BTW. Yesterday I installed a incremental Win 10 update. I don't know wether this could be the cause of my black screen exit.

It seems to have started when Win 10 updated to the Anniversary edition. Still no definitive answer on how to fix it. I just alt-tab to the desktop and close IL2 from the task bar. I've tried all the latest NVIDIA drivers but the problem still exists. I'm still thinking it's related to how Win 10 handles DX9 when exiting directly from IL2 in full-screen mode.

Share this post


Link to post
Share on other sites

I have the same issue using Windows 10 anniversary and a GTX 960. Waiting for a fix and thanks for the Alt-tab trick anyway.

Share this post


Link to post
Share on other sites

I have this issue as well but Alt-Tab does not work, nor does CTRL-ALT-DEL or <windows> - p.

 

Removing HDMI cable and re-inserting works.

 

Graphics = Nvidia GTX 960 driver version 368.81

 

Windows 10 64 bit version 1607, OS build 14393.187

 

Intel core i5 - 4670K @ 3.4 GHz

 

24 Gb Ram

Share this post


Link to post
Share on other sites

I cannot Alt+Tab cleanly out of the game. If I do, I cannot open the BoS window again, and if I open Windows Task Manager then the display locks up and I only have a mouse in the taskbar at the bottom. All I can do at this point is right-click the IL-2 icon and "Close Window". 

If I exit the game window through the GUI then my screen goes black briefly and flashes, and then I am locked out of Windows and have to log-in again.
 

Windows 10 - 64bit

Asus GTX 960

Intel Xeon E3-1241v3

8GB RAM

Edited by Lippisch
  • Upvote 1

Share this post


Link to post
Share on other sites

Just reinstalled BOS to see all the improvements and having the same issue with the windows 10 update also.

Share this post


Link to post
Share on other sites
I too have experienced loger game exits with an occasional black screen. I currently have the Windows Anniversary update installed, and with latest hardware driver updates.
Alt Tab also takes a while in full screen mode. Ctrl Alt Del works, but can take some time for the Task Manager to display.
 
What I did notice helped with game exit times was: Unchecking the Full Screen mode from the launcher, before logging in an running the game, and or rebooting the system.
During game play: Visually game play still appears as full screen mode, (no task bar, and screen settings where matched to the Desktop) ?

Offline game play mode appears to have the same result as Online game play mode, when tested within the QMB.
Quite the mystery this one. All running okay here today, just tested the standard game exiting procedure moments ago.

Share this post


Link to post
Share on other sites

Same issue with PC crashing on BoS exiting. 

My workaround:

Start Launcher-->Uncheck "seed when downloaded"-->check "prefer Web distribution" (full screen IS checked already)

Click on "Play"

As soon as you load to the main screen, Alt+Tab to desktop and then go back into the game.

Continue playing.

Exit with no crash when time to quit.

  • Upvote 1

Share this post


Link to post
Share on other sites

Same here.

 

It had been a long time since I last had BoS / BoM installed ( was relly missing good flight dynamics ... ) so yesterday after a CLEAN install of Win 10 64 bit, followed by upgrade to the latest version I installed BoS/ BoM and got the same problem, but apparenty only when leaving from MP sessions.

 

It never happens when leaving from singe mission. Didn't try with Campaign mode ( I never play that ).

 

Also. reverting to windowed mode solves the problem for me.

Share this post


Link to post
Share on other sites

I've had this issue alternate between IL2 patches... The previous patch this happened to me. The patch before that it was fine. The one before that it would happen. Luckily the current patch I am good to go.

Share this post


Link to post
Share on other sites

The alt-tab BEFORE starting a mission works for me too, as a workround.

 

Ticket raised with support.

Edited by nozzil

Share this post


Link to post
Share on other sites

See issue here. Thanks Gramps for the workround.

Share this post


Link to post
Share on other sites

Same issue here.

 

Not linked to NVIDIA drivers as I use an AMD Radeon 6870...

Edited by Alex911

Share this post


Link to post
Share on other sites

What seems to have resolved it for me is disabling "full screen" so that the game runs in a window. Then just set the window to be your full screen resolution.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...