Jump to content
1Sascha

CH Pro Pedals: Game doesn't recognize one toe-brake-axis

Recommended Posts

Using old gameport CH Pro Pedals on a USB-converter, which transfers the toe brakes as x- and y-axes of a virtual "stick": Half the x-axis for the left, half the y-axis for the right brake. Works great in the Windows-joystick setup and in numerous other games, including Cliffs of Dover (*cough*) and DCS.

 

I can get the keymapper to read the x-axis, but not the y-axis. Doesn't matter if the x-axis is already mapped to left brake or if the left brake is unmapped: The game simply doesn't "see" the right brake/y-axis of the "stick", no matter how often I stomp onto the right pedal.

 

Is there any way to force the game to accept this config? Like in the keymap-file? It's been a while since I've played an IL-2-based title, so I'm a bit rusty here...

 

 

Thanks for your input!

 

EDIT: And is there a way to map half an axis as the full motion of travel in the game? Even with the X-axis the game *does* "see", it looks like it assumes that the (physical) brake being off is the center-point of the axis. Meaning the control-surface-thingy in the mapper is in the middle of the scale when I apply no brake input to the pedal. Which looks to me like I'll be taxiing with the left brake applied at 50% all the time, even when my foot is off the pedal.

 

So in short: How do I get the game to recognize the y-axis of the virtual stick and how can I tell the game that my toe brakes only send half an axis of input each?

 

Other games will let me simply map half an axis, so that would be the ideal solution. In DCS I had to work around the problem by using user-defined input curves. BoS' input mapper seems a bit less powerful than the DCS-one, but maybe there is a way to set this stuff up directly in one of the .ini-files?

 

 

 

 

 

Sascha

Edited by 1Sascha

Share this post


Link to post
Share on other sites

Strange way this USB-Converter work... "half axis"?... Anyway try set 50% deadzone for this axis, my help.

Share this post


Link to post
Share on other sites

Already tried playing with the deadzone. In-game mapper still shows the stick and the control-surface as "centered" when there is no brake-input. At full input, both the stick and the control surface are shown as "full right".

 

Plus all that won't help with the game not recognizing the Y-axis.

 

And just to clarify, here's what the converter sends to the PC and how it's recognized in Windows:

 

CH%20Pro%20Axes_zpsh5dwefxq.jpg

 

 

Pic on the left: Right brake-pedal off, left brake-pedal fully pressed down -> full negative on the X-axis

Pic on the right: Left brake-pedal off, right brake-pedal fully pressed down -> full positive on the Y-axis

 

Didn't take a screenshot of it, but when both pedals are off, the stick rests in the center at "0" on both X- and Y-axis

 

Where does the game store axes-mappings? In "confUser.ini"?

Edited by 1Sascha

Share this post


Link to post
Share on other sites

Worked it out. In case other people run into a similar problem, here's what I did:

 

Calibrated the pedals/USB-converter in Windows as usual.

 

Downloaded "DXtweak2" and used it to change Windows' calibration-values for the X- and Y-axes. Basically, I made both axes' calibration "wider" by doubling the calibration.

 

The values I used are

Min: 1

Center: 45

Max: 90

 

Now the stick's input on the X- and Y-axis is read by Windows as full X- and Y-range (from full negative to full positive) - no more "half axes". In the game's mapper, both axes are now recognized and show up "full left" when no brake is applied, "full right" when full brake is applied. I had to set some deadzones to get rid of spiking (I really need to open these pedals and clean the pots, I suppose). But the result looks good now.

 

 

Link to DXTweak:

http://www.derekspearedesigns.com/pedals---dxtweak.html

 

 

 

S.

Edited by 1Sascha
  • Thanks 1
  • Upvote 2

Share this post


Link to post
Share on other sites

Thanks for this - had similar issue with Thrustmaster TFRP pedals. 

Share this post


Link to post
Share on other sites

I installed Thrustmaster TFRP pedals tonight and was having this very issue.  This tweak works perfectly and I was tearing my hear out trying to get them working in BoS.  Ironically I posted this very fix for a similar issue with G940 pedals in DCS years ago.  If only I had remembered (must be old age).

 

Thanks 1Sascha

Share this post


Link to post
Share on other sites

same Problem here for MFG Crosswinds,the Siderudderaxis working good ,but the Breaks still not working

Edited by JG4_Widukind

Share this post


Link to post
Share on other sites

Also had this problem with my TM TFRP. And finally it's solved.

 

Thank you so much Sascha! 

Edited by nunoi

Share this post


Link to post
Share on other sites

i had the same issue with my Thrustmaster Tflight rudder pedals, the center and the max were set to the same value, i used sascha's advice and changed the center to 512, and left the maxt at 1024 using the DX tweak and it worked perfectly, thanks for solving what has been weeks of frustration.

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi All, I recently picked up some CH Pro pedals as well. I can't seem to get my toe brakes to work and I'm a little confused by this thread. I may not be understanding it or things have changed since this was last posted.

 

I can't get IL2 to recognize my toe breaks at all. Everything in windows in windows game control settings, but when I try to bind them in IL2 it doesn't seem to "detected" the toe either axis. It does detect the rudder controls fine. It sounds like the problem people are having in this thread was they were able to get IL2 to recognize one axis and had problems getting the other recognized. I can't seem to get either. Can anyone direct me to some information on where to start? Or maybe just some clarification. 

 

Thank you in advance.

Share this post


Link to post
Share on other sites

If you are using CH Control Manager, here is what I have in my .CMS file for controlling rudder and stabilizer trim on my ProThrottle's mini joystick, as well as toe brakes on my Pro Pedals:

 

// CMS Script File
//
//     Game Title: IL-2 Battle of Stalingrad
//     Written By: Kevin Watts for IL-2 Cliffs of Dover, modified by Charlo for IL-2 BoS
//           Date: Original 31-03-2011, modified by Charlo 5/17/14
//
script
CMS.B1 = [JS2.A1 < 55]; // Roll_Trim_Left (change in CMS Controls screen)
CMS.B2 = [JS2.A1 > 180]; // Roll_Trim_Right (change in CMS Controls screen)
CMS.B3 = [JS2.A2 > 180]; // Adjustable_Stabiliser_Down (change in CMS Controls screen)
CMS.B4 = [JS2.A2 < 55]; // Adjustable_Stabiliser_Up (change in CMS Controls screen)
IF ( NOT JS2.B2 ) THEN //If Button 2 is released then
CMS.A1 = JS3.A3 + A3; // add the X offset to the stick X
ENDIF
SEQUENCE
WAIT ( JS2.B2 ) ; //Wait until Button 2 Clicks
A3 = JS3.A3 - 128 ; //Calculate the Z offset and save it
ENDSEQUENCE

CMS.B5 = [JS3.A1 > 254]; // Wheel_Brake_Left (,)
CMS.B6 = [JS3.A2 > 254]; // Wheel_Brake_Right (.)
endScript

 

Share this post


Link to post
Share on other sites
On 5/30/2020 at 8:53 PM, Blake231 said:

I can't get IL2 to recognize my toe breaks at all. Everything in windows in windows game control settings, but when I try to bind them in IL2 it doesn't seem to "detected" the toe either axis.

 

Try set moving the axis inverted:

Press and hold the left pedal brake, the select in controls "Left Wheel Brake" and the release the pedal.

If work repeat for right.

After if need can invert axis by clicking in the curved arrow ahead command name.

Share this post


Link to post
Share on other sites
33 minutes ago, Sokol1 said:

Try set moving the axis inverted:

Press and hold the left pedal brake, the select in controls "Left Wheel Brake" and the release the pedal.

I think you need to have the pedal at half travel before you start to bind it.

Hold at half travel, click  to begin, full pedal travel and then release pedal

Share this post


Link to post
Share on other sites
Posted (edited)

Or assign manually editing "current.action" file (in game folder

...\IL-2 Sturmovik Battle of Stalingrad\data\input\

 

You have this three liens relatively to brakes, use the two last (left, right):

rpc_wheel_brakes,                                 joy1_axis_p,                                      0|
rpc_wheel_brakes_left,                            ,                                                 0| // Left wheel brakes
rpc_wheel_brakes_right,                           ,                                                 0| // Right wheel brakes

 

Just add pedal brakes axes names in place of ,

 

E.g. 

 

rpc_wheel_brakes_left,                           joy2_axis_rot_x,                                               0| // Left wheel brakes
rpc_wheel_brakes_right,                          joy2_axis_rot_z,                                                 0| // Right wheel brakes

 

joy# dependes on each controller, may are 1, 2...

Axes name too, look in Windows Game Controller (joy.cpl) for names used.

Edited by Sokol1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...