Jump to content
SYN_Vorlander

Best Nvidia Drivers for BOS?

Recommended Posts

evening Gents,

 

Looking for some help with BOS. My PC performance in BOS has taken a nose dive after that last BOS update or the latest NVidia drivers.

 

Looking for the best NVidia drivers to run BOS.

 

thx

 

 

Share this post


Link to post
Share on other sites

Have had no problems with latest drivers, however i once had a bad driver install, no crashes but down on performance just enough to notice a problem

 

might just be worth deleting and doing a clean install again, (which i did to cure it) my install issue/mistake was forgetting some program running when i did the update, don't remember what it was now...sorry

 

Cheers Dakpilot

Share this post


Link to post
Share on other sites

How are you updating the driver? Are you doing a complete uninstall w/DDU, or just installing over the current driver? I do a clean install w/DDU as it pretty much cleans up the junk left behind by the previous driver. Also, there is a Hotfix driver out:

GeForce Hot Fix driver version 364.96

Download:
x64:
http://international.download.nvidia...ational.hf.exe

x86:
http://international.download.nvidia...ational.hf.exe

NVIDIA Support: http://nvidia.custhelp.com/app/answers/detail/a_id/4086

 

You won't find these listed on the normal download channel at Nvidia's site. I've been running these for a few days w/o any issues.

Share this post


Link to post
Share on other sites

Have had no problems with latest drivers, however i once had a bad driver install, no crashes but down on performance just enough to notice a problem

 

might just be worth deleting and doing a clean install again, (which i did to cure it) my install issue/mistake was forgetting some program running when i did the update, don't remember what it was now...sorry

 

Cheers Dakpilot

 

TrackIR'll do it.

Share this post


Link to post
Share on other sites

I'm currently running the latest 364.96 drivers with the issue. It's I clean install with windows 7 64bit.

Edited by SYN_Vorlander

Share this post


Link to post
Share on other sites

I used to find the latest 'beta' drivers and even sometimes custom ones from the various 3D sites all in the quest for a little better performance, religiously deleting all traces of the old ones and doing a careful custom install 

 

Now I just use Nvidia experience and let it do it for me, it notifies me when a new driver is available and then select clean install and let it do it's stuff automatically at the time of my choice, I have had no bad experience at apart from the above mentioned hiccup which was my fault

 

At the end of the day Nvidia probably know more about installing drivers than me, saves me time and stress...I must be getting old LOL

 

Currently 364.72

 

Cheers Dakpilot

  • Upvote 1

Share this post


Link to post
Share on other sites

On most recent drivers, no issues. Also updated to latest version of TrackIr. Always do clean installs with the drivers. Update every new release of drivers, never had a performance slowdown.

Share this post


Link to post
Share on other sites

I'm still on 364.51 and it works fine.

Share this post


Link to post
Share on other sites

Solved the problem.

 

It's was not the nvidia driver or the OS but new memory that caused the bad performance in BOS. I have been swapping and changing Windows, ssd's, bios settings for two weeks and yesterday decided to see if the memory had anything to do with it!

 

My computer is back and eating BOS pixels again.

 

Happy gamer

Share this post


Link to post
Share on other sites

Good info for others who face a similar issue! and an easier option to check rather than doing new windows install etc.

 

Cheers Dakpilot

Share this post


Link to post
Share on other sites

Yesterday I have accepted the NVidia driver update, now I'm using 365.10

 

I noticed a big improvement ! It's much much better ! Even in other games ... NVidia has fixed some problems and it's really nice now.

 

PS: My card is a 780GTX

Edited by C6_LionHell
  • Upvote 1

Share this post


Link to post
Share on other sites

Anyone else having crashes with the new drivers(365.19)?

 

Card: GTX 970

Share this post


Link to post
Share on other sites

Anyone else having crashes with the new drivers(365.19)?

 

Card: GTX 970

Not here, at least w/BOS/BOM. In DCSW I've had a couple of "driver was restarted" messages, but no complete crashes. Also on a 970.

Share this post


Link to post
Share on other sites

Not here, at least w/BOS/BOM. In DCSW I've had a couple of "driver was restarted" messages, but no complete crashes. Also on a 970.

Odd. I've had endless CTDs since the driver update. The event said it was mvd3dumx.dll that crashed the game. And I know for sure that is a driver file from Nvidia.

 

Did a clean reinstall, run at stock clocks, changed a bunch of the nvidia settings for IL-2, tried windowed mode. I ended up reverting to 365.10 again. No crashes so far. The worst thing is I can't find anyone else so far with the same problem in IL-2, even though there are tons of 970s running it. I'm on the Gigabyte G1 Gaming version by the way. Come to think of it, it could be the Nvidia surround bugging out or something. Got a fairly unorthodox setup with three 19" 5:4s.

 

Oh well, every PC is a different beast from the next. May the next driver update bring me fortune and frame rates beyond comprehension. For now I will stick with 365.10:)

Share this post


Link to post
Share on other sites

Anyone else having crashes with the new drivers(365.19)?

 

Card: GTX 970

I have had a few crashes lately, no crashes in BoS before. I am going to roll back to the 365.10 tomorrow. 

Share this post


Link to post
Share on other sites

I have had a few crashes lately, no crashes in BoS before. I am going to roll back to the 365.10 tomorrow. 

 

Are you still having crashes with 365.19 after yesterdays hotfix in IL-2? Sadly I reverted before the update:-/

Share this post


Link to post
Share on other sites

Are you still having crashes with 365.19 after yesterdays hotfix in IL-2? Sadly I reverted before the update:-/

I had a crash after the patch even with 365.10. So it was probably not 970 issue in my case.

 

I did a complete re-install of BoS, it was a big patch after all. Something might have messed up. Flew one mission with no trouble, will continue to test.

Share this post


Link to post
Share on other sites

Might be a different issue then, I was having crashes between every 30 seconds to every 30 minutes. Sometime I could fly almost a whole sortie, other times I only got to the map screen.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...