Jump to content

Colour Problem with Simple 3rd party Mission Builder for BoS


Recommended Posts

Hello,

 

Short question:

After installing the

Simple 3rd party Mission Builder for BoS the application is runnig propperly  ..but the whole landscape is turned into blue colour. What ist wrong and how can i fix this issue ?   thanks, Regards,  Pitt

 

Pitt

 

Link to post
Share on other sites

If its what I think it is its because the SMB was built before the different season maps. This resulted in the code being modified, to tell the program which season it was

 

To fix the blue snow - you need to update the cloud config:

 

1. Either open the mission with the mission editor and go to atmospheric options screen and set new cloud config from drop down and then save the mission.

 

2. Or open .Mission file with a text editor and change:

 

CloudConfig = "01_Light_00\sky.ini";

.. to:

CloudConfig = "winter\01_Light_00\sky.ini";

 

That is, add "winter\" in front of the path.

 

Let me know if that helps

Link to post
Share on other sites

Hi Ventus, 

 

Thanks for your support.

 

STATUS:

I changed  the  CloudConfig  with the line:  "winter\01_Light_00\sky.ini"    ... and  ...    for one time i saw  the correkt colours in a winterscene.

Looks good!

 

But:  the next time i want to fly   the mission  generated with   Simple 3rd party Mission Builder for BoS    the mission -file  could not be loaded (executed) in the game-missionselector- menue:

everytime i try  sometimes  i saw the "loadscreen- wallpaper"  for -may be 1/3-second  ..then i was pushed back to the missionselector -menue with all the BoS-internal missions  .. and mine.

Don´t no, where the error is.

 

To be sure to have a clean BoS-Installation  i copiied a good and clean Bos-installation from my Bos-IL2-Backup... than   generated a new mission  ... but the problem is still alive.

 

 

may you like  to help again,

 

regards

 

Pitt

Link to post
Share on other sites

If there is an msnbin file beside the mission file in data/Multiplayer, try removing it. This file has the same content as the textual mission file, it is used by the game and the mission editor for faster loading. However, if the content of the msnbin file no longer agrees with the content of the mission file, loading errors can happen, resulting in you being thrown back to the menu.

 

Instead of editing the file with notepad, you could also open it in the mission editor, adjust the weather and time in the mission editor, maybe even changing the season, then save the mission and play it. This is the best way to ensure the mission file is correctly adjusted, and should normally guarantee that the msnbin file agrees with the mission file.

Link to post
Share on other sites

Hi coconut,

 

Tanks...but in the "Multiplayer"-folder there was no .msn.bin-file.

I found a "gen.msn.bin"  in the folder "Missions".

For a test     i deleted this file.

But the game  still stops loading    at the critical point i decribed to Ventus.

 

Don´t know the error.

 

 

 

Regards,

Pitt

Edited by Pitt61
Link to post
Share on other sites

Hi Ventus,

 

Here it is:    https://www.dropbox.com/s/ydmyrnoe92c6c1w/BoS_________---.eng?dl=0

                   https://www.dropbox.com/s/u9w9j4nqe5fy1be/BoS_________---.Mission?dl=0

 

 

As is said : don´t know , wether i was kicked back  during try to load generatetd mission  i send to you with dropbox-link. 

May you find an issue.

 

Best  Regards,

 

Pitt

Edited by Pitt61
Link to post
Share on other sites

Hi Pitt

 

Tried it and no joy failed to load into the FMB. Soooo I tried mine with the latest release and then pulled the file into the FMB to eliminate the blue snow and it worked fine.

 

Next thing is later I'll do is a very simple mission with the QMB and give you a link, so you can then try it with the FMB, that way so as we can maybe reduce the variables that are causing you the problem.

 

One more thing I'd like you to try is simply generate a mission with the QMB and then copy it to Dropbox and let me try it with the FMB.

 

If I get time I'll take a quick look at the code too, to see if I can spot any anomalies, but the chances of that are pretty slim

Link to post
Share on other sites

Ok here is a simple test flight mission created with SMB

 

Try to edit it to white snow and anything else you want then run it in the game to see if that works Ok

 

https://www.dropbox.com/sh/a9rn56xc0ibctp9/AABHT4PDqo2ppCKKD2jkoMmca?dl=0

 

If it does looks like the SMB has screwed up

 

I'd just delete it re start then try a fresh install to see if that remedies the problem

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...