Jump to content
SharpeXB

BoS Keeps Reassigning joystick numbers

Recommended Posts

 

 

So, the steps would be to plug the units in, reboot, and then assign the products. I recommend trying this yourself to see if it helps." 

 

Well, this trick worth a try.  :)

 

 

 

or just simply reassign everything when it happens 

 

This can avoided just renaming "JoyX" > "JoyY" etc, in game config files.

Share this post


Link to post
Share on other sites

Well, this trick worth a try. :)

 

 

This can avoided just renaming "JoyX" > "JoyY" etc, in game config files.

What he's describing is the very first thing I tried. If only it was that easy.

 

The trouble is sometimes it seems solved and then the numbers will just change.

 

My solution now is to just restart the PC until they appear in the right order. And then follow the Gramps procedure. They'll stay held for a while. If they scramble then just repeat the fix.

Share this post


Link to post
Share on other sites

Then what CH support say don't work - the Windows list continues change after the first reboot? 

Share this post


Link to post
Share on other sites

Then what CH support say don't work - the Windows list continues change after the first reboot?

 

When I connect the devices, I noticed the same thing as CH. They will change their order after the first restart. I think CH hasn't tested enough. I told them yes, I did the same thing you did. I even restarted the PC 10 or 20 times and everything seems fixed. But then it will break again. Let's see if they report back the same thing, it will shuffle at some point. Edited by SharpeXB

Share this post


Link to post
Share on other sites

Well, I got bit by this bug! I added a second, internal, hard-drive to my system and on boot the joystick bug bit me! After so long w/it not being an issue. Will see what happens after I re-set some windows settings.

Share this post


Link to post
Share on other sites

Well, I got bit by this bug! I added a second, internal, hard-drive to my system and on boot the joystick bug bit me! After so long w/it not being an issue. Will see what happens after I re-set some windows settings.

 

So far that fix you suggested has worked, sometimes just need to re apply it or just restart the PC and they come back in the right order

Share this post


Link to post
Share on other sites

Tried to make a map but found it complicated and since I also use a non CH controller, I don't think it would solve the problem.

 

"So, the steps would be to plug the units in, reboot, and then assign the products. I recommend trying this yourself to see if it helps." 

 

I tried this months ago several times but eventually the ids scrambled again.

Share this post


Link to post
Share on other sites

I have found so far that, since I determined the correct order. Which was the order I saw after the initial plug in and restart.

Did Fast Start fix when they're set correct and just restart if I see them messed up. Most of the time the PC starts with them set correctly.

Tried to make a map but found it complicated and since I also use a non CH controller, I don't think it would solve the problem.

Yeah, if somebody reported in with this problem who's not using CH

Then the problem isn't with CHCM.

Share this post


Link to post
Share on other sites

I'm having the problem and i have Saitek set up X52, Quadranta and rudder, and yet i have the

same reordering issue as Sharpe and others, 777 needs to make BoS/BoS set devices by it's vendor

identity, and not by it's windows assign number

Share this post


Link to post
Share on other sites

I'm having the problem and i have Saitek set up X52, Quadranta and rudder, and yet i have the

same reordering issue as Sharpe and others, 777 needs to make BoS/BoS set devices by it's vendor

identity, and not by it's windows assign number

Which version of Windows are you running?

Share this post


Link to post
Share on other sites

Dam its now happening to me , joy/2 now its joy/3 , done my keys twice already , unplugged USB sticks over the weekend , now not recognised as joy2 ..Grrrrr

Share this post


Link to post
Share on other sites

Dam its now happening to me , joy/2 now its joy/3 , done my keys twice already , unplugged USB sticks over the weekend , now not recognised as joy2 ..Grrrrr

Does BoS still work though?

 

I've had the Windows joy#s shuffle due to reinstalling or updating the Logitech Gaming Software. But BoS was not affected. It held the mapping regardless of the joy#. And after a few restarts of the PC Windows restored the original ordering.

Edited by SharpeXB

Share this post


Link to post
Share on other sites

Anyone have a good solution for the Win 10 rearranging issue? I just started having problems today after powering off my PC to swap out some parts.

Share this post


Link to post
Share on other sites

Anyone have a good solution for the Win 10 rearranging issue? I just started having problems today after powering off my PC to swap out some parts.

 

Rooster - this is a casual observation - ive done no real testing but...

 

I recently reinstalled windows - plugged in my gear in what I figured was the correct order - rebooted - and found that the "connected devices" tab had rearranged them alphabetically according to their friendly name (ED tracker, Crosswinds Hotas X Flight, HyperX USB device, Sidewinder, USB Keyboard/Mouse) -  this order then corresponded to the inputs in the game (Joystick was the ED tracker, Crosswind where joystick 1 etc)

 

Then I swapped inputs about (it was a slow day) - rebooted and the order remained the same (ie in alphabetical order) 

 

I only did it once so I'm not claiming this to be proof of life or anything - just something that may help.

 

I have all my gear plugged directly into the MOBO - no hubs BTW

 

If you use a hub - have a look in the Technical section over on ATAG  - I think one or two have found solutions for hubs.

 

Regards

 

BOO

Share this post


Link to post
Share on other sites

There is a file in D:\Games\IL-2 Sturmovik Battle of Moscow\data\input\Devices.txt that either just lists or controls these devices numbering.

i just looked in there and noticed i have double entry for throttle which might be cause of my "other" issues with phantom inputs.

Devices.txt

______________________________________________________________________________________________________
configId,guid,model|

0,%22a61d4580-a5a2-11e6-0000545345440680%22,Saitek%20ST290%20Pro|
1,%22e69358c0-a5a2-11e6-0000545345440780%22,Logitech%20Driving%20Force%20EX|
3,%22676576a0-d29d-11e6-0000545345440780%22,Saitek%20Pro%20Flight%20X-55%20Rhino%20Throttle|
4,%226765c4c0-d29d-11e6-0000545345440880%22,Saitek%20Pro%20Flight%20X-55%20Rhino%20Throttle|
2,%2264509580-d29d-11e6-0000545345440680%22,Saitek%20Pro%20Flight%20X-55%20Rhino%20Stick

Edited by =R4T=Sshadow14

Share this post


Link to post
Share on other sites

Hi guys,

 

some time ago I had the same problem.

I was so annoyed that I switched to DCS for 1.5 years. In DCS you don't have such problems.

Now I came back and get the same problem again.

IL-2 crashed and screwed up my Joystick device numbers.

 

I've changed Devices.txt and now it works again.

 

@=TBAS=OccludedLight14: Thank you for the post. It is much better then search and replace joyX/joyY.

Share this post


Link to post
Share on other sites

The Devs have since fixed this problem. Now a device set up the the controls menu will be remembered by the game. So even if Windows reassigns the joy#s you’ll be ok.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...