Jump to content
halbtorsk

Mouse lagging in menu

Recommended Posts

Hi all!

I have a Gefore GTX 860M card, 8 gig of ram and I run Elite Dangerous on my new Lenovo Y 50  laptop without a glitch on high settings. But I have big problems even getting past the menu in IL2 Stalingrad. The lag is horrible, (2-3 sec or more) and it is well nigh impossible to navigate the menus. I have got the game up and runing a couple of times though, and the in game performance is not so bad. But this mouse lag in th menu is really ruining it for me. Anyone else experience this? Any solutions?

  • Upvote 2

Share this post


Link to post
Share on other sites

+1 ... I have the same problem, the mouse lag in menus is so horrible. It seems it doesn't use the desktop settings, the mouse works perfectly if you go shift+tab in the Steam overlay for example. Even too look around in the cockpits.

Edited by WickedJeezuz

Share this post


Link to post
Share on other sites

I too have the mouse running thru mud on my menu screens. And I've lost the photoramic view where you first enter the main menu screen. Once I opt for a quick mission...then fly/cancel flight....go back the the main menu screen- all is ok except I still have a mouse that is chugging along thru syrup or mud. Had tried 3 different video drivers. 

Share this post


Link to post
Share on other sites

You can go into settings, input devices, and play with mouse sensitivity and acceleration. Might help. The mouse in BOS seems to use it's own coding.

Share this post


Link to post
Share on other sites

Seems to depend on graphics power. After switching to MSI 970 GTX, problem no longer occured.

Share this post


Link to post
Share on other sites

Somehow fps in menus are capped. I have max 33 and this appears laggy. In the air max 100+

Edited by tomcatqw

Share this post


Link to post
Share on other sites

I think they use extra polygons (versus normal game rendering scenarios) in the menu 3D scene or something

Share this post


Link to post
Share on other sites

Sorry to dig out this old topic, but I've recently bought Il2 BoX and am experiencing the same issue with the following hardware configuration: 5760x1200 triple screen, GTX 970, Intel Xeon E3-1230 4x3,3GHz, 16GB Ram.

 

The menu seems to stutter about at sub 20fps, while the actual game is running at 60fps +/-. This is really, really grating. While it thankfully doesn't impact playing the game, a menu running considerably worse than the game while simply rotating around a static plane model gives off a very poor impression. It does seem to be somewhat related to the hardware's capability. If I switch back to the single screen (1920x1200), the menu runs smoothly again.

 

Nevertheless, it's still only a "dumb" menu where I should be able to breeze through quickly and shouldn't have to concsiously concentrage on klicking the right menu option with the mouse, due to low framerate causing the pointer to stutter of all things. Something in there seems to scale so poorly, that it runs considerably less smoth than the actual game.  :wacko:  I'd agree that the menu ought to have the lowest priority of all things, but a fix for the issue would be nice nevertheless. At this point, a static 2D image would be vastly preferrable for me to the way the menu stutters about.

Edited by SnntgsflgrBurny

Share this post


Link to post
Share on other sites

Same issue here, running at 5840x1080 or thereabouts with bezel correction on a 4GB GTX 970. Something about the wide aspect ratio/triple screen rendering makes the mouse lag pretty badly. Also maps don't fit well sometimes and can't be zoomed out or panned enough in some cases. Hopefully it will be fixed up some day for us triple screen users.

Share this post


Link to post
Share on other sites

i guess most of you are running DSR or other very high Resolutions above your default desktop Res

Goto control panel (nvidia or ATI)
And set max pre frames to 1

  • Thanks 1

Share this post


Link to post
Share on other sites

i guess most of you are running DSR or other very high Resolutions above your default desktop Res

 

Goto control panel (nvidia or ATI)

And set max pre frames to 1

Not in my case, just running native resolution of the monitors - 1920x3 width, 1080 height, then bezel correction, same as my desktop.

Share this post


Link to post
Share on other sites

I am new to this simulator, and am having the same issue with mouse lag on the menu screen, but smooth in-game graphics.  Having tried many tweaks to fix it, it seems it is the POV angle causing this issue.    This also happens when I start a mission on a runway.... loss of FPS, and simply not as smooth as when up in the air.   I think a work around would be allow the changing of the POV angle (via config file or config screen) for the menus so the POV is looking down on the rotating plane rather than straight at it.

Share this post


Link to post
Share on other sites

Same here.  I'm using a less powerful machine -- Windows 10, 8GB RAM, 7th gen i7, and onboard graphics.  Still though, I get pretty decent in-flight results, and terrible menu results.  If they could just have an option to have the plane not rotate, on the menu screen, maybe that would help?  Although I also get this problem in the initial sign-in screen, which is weird.  They should find some way for the mouse to just be the OS mouse rather than a separately coded thing. 

Share this post


Link to post
Share on other sites

Seems like it's universal to have lowered frame rate at game startup. Mine is stuck on 59 fps until I click 'enter', when it drops to 30, or lower, while waiting.

(Edit: I just flew some quick missions, and closely watched the frame rate while the game was loading. It dropped briefly as low as 22.) 

Once in the hangar it's back up to 60 or 59, till the game starts, when it jumps to my set target rate of 120. 

There is no 'mouse lag' though for me.

My in-game graphics settings are on ultra, 3440x1440.

Nvidia control panel setting for 'Max pre-rendered frames' was on 'Use the 3D application setting', but I've just changed that to '1', as advised by Sshadow1

 

Edited by jaygee485
addition

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...