Jump to content

Recommended Posts

 I have a pronlem with trims not working . Ive updated to Bodenplatte   , and a couple of months back the trims started not working on the FW190s , but they still worked on the Bf109 . So I reset them in the settings . Now none of them work . I used the Keyboard to set them  - Shift + up cursor etc . Its hard to dogfight while having to push the stick forward . My game version is from the developer , not Steam . Is there a fix for this ?

Link to post
Share on other sites
2 minutes ago, pencon said:

 I have a pronlem with trims not working . Ive updated to Bodenplatte   , and a couple of months back the trims started not working on the FW190s , but they still worked on the Bf109 . So I reset them in the settings . Now none of them work . I used the Keyboard to set them  - Shift + up cursor etc . Its hard to dogfight while having to push the stick forward . My game version is from the developer , not Steam . Is there a fix for this ?

Trims are now separated between axis keybindings and switch keybindings. If the trim was on an axis in the real life aircraft, there is an axis binding in the key bindings. You probably only have it set up for one set of keybindings. The 190s and 109s have adjustable stabilizers, one of them is on an axis, one of them is adjusted by switches. 

For simplicity, bind all your pitch up/pitch down buttons to the same buttons on your keyboard or HOTAS. There will be pitch up trim switches, pitch down trim switches, and a pitch trim axis where you can set the button to put it down and to put it up. You also need to do this for the stabilizer trim - switches and axes, just like before.

See this recent thread explaining it: Joystick trim buttons do not work on two aircraft - Technical Issues and Bug Reports - IL-2 Sturmovik Forum

  • Thanks 1
Link to post
Share on other sites

I've been googling and troubleshooting for forever and I can't get this to work. Realism settings are set to expert. I found another thread here where that was the problem.  I don't see a complex engine management option as was stated in that thread so I'm guessing setting it to expert is all that's needed. 

 

None of the default key bindings work either, I can only control engine throttle. I'm so confused as to why this is so complicated...

 

Some extra info my game is running off steam, I tried re-installing nothing changed, I can set the prop pitch to manual but can't actually control it. Same for cowl flaps and mixture. I'm running a VKB sim Gladiator NXT joystick and MK2 T Rudders, track IR.

Edited by anthonymr56
Link to post
Share on other sites
3 hours ago, [DBS]Browning said:

Could you explain step by step exactly what you're doing and what isn't happening please.

 

For example, I start up a quick match, press P to pause, I bind the cowl flaps on the I16 (the specific one marked for I16) to a certain joystick button, go back to the game stop the pause and nothing happens, I check the cowl flap lever in the cockpit and no movement. I try the default key bind and that doesn't work either. This is true for all engine management controls, none of them work, all those stated in the post title. 

 

What's weird is that the exact same binds work on Rise of Flight, I can control everything on that game without issue.

Link to post
Share on other sites
6 hours ago, anthonymr56 said:

 

For example, I start up a quick match, press P to pause, I bind the cowl flaps on the I16 (the specific one marked for I16) to a certain joystick button, go back to the game stop the pause and nothing happens, I check the cowl flap lever in the cockpit and no movement. I try the default key bind and that doesn't work either. This is true for all engine management controls, none of them work, all those stated in the post title. 

 

What's weird is that the exact same binds work on Rise of Flight, I can control everything on that game without issue.

 

1 minute ago, IL2Battle said:

You do have check from difficulty options (realism), that there ain't engine auto controls on, as they could block some controls.

 

He means this:

 

1463141410_RealismPanel.thumb.jpg.14716de767cc85a167ee9ccca1ca07c6.jpg

  • Thanks 1
Link to post
Share on other sites

I had this problem some time ago, just once. Turned out that upon running the game one day just decided my overlapping keybinds won`t work at all. What I did I reset the keybinds to default, restarted the game and made all of the keybinds all over again, the same way I had it before. Worked immediately.

Link to post
Share on other sites
9 hours ago, Mac_Messer said:

I had this problem some time ago, just once. Turned out that upon running the game one day just decided my overlapping keybinds won`t work at all. What I did I reset the keybinds to default, restarted the game and made all of the keybinds all over again, the same way I had it before. Worked immediately.

 

Thanks for the reply, I tried that too a few days ago, I'll try it again tomorrow and will update this thread hopefully if it works

Link to post
Share on other sites
  • 1 month later...

Brief description:  In aircraft with bomb sights, with the GUI manually hidden via "H" key, neither bomb drop mode nor delay can be changed with key binds or the mouse-click buttons in the bomb sight.

 

Detailed description, conditions:  I've tested this in three aircraft (A-20, Ju88, Pe-2s87) and the behavior was consistent.  I also tried it in one aircraft without a bomb sight (Bf110 G2) and there was no problem.  With the GUI on, both key binds and the bomb sight controls work as intended to change the bomb mode/delay (as verified by technochat and/or bomb sight display), but once the GUI is turned off neither will change the bomb mode/delay.  Subsequently turning the GUI back on will cause them to work again.  Issue was first observed on a MP server, then tested in quick missions.

 

Additional assets (videos, screenshots, logs):  Unable to create a video showing key presses and game screen.

 

Your PC config data (OS, drivers, specific software):  Issue observed on multiple computers.

  • Thanks 1
Link to post
Share on other sites
  • 2 weeks later...

Brief description:

AI gunner in TC tanks gets permanently disabled when ordered to "Do like me" in the command menu


Detailed description, conditions:

When the gunner in any TC tank (tested with KV-1s and Panzer 4) gets ordered through the command menu to "Do like me" either in the Assign Targets menu or Fire Control menu, he does not take any orders, like assigning a new target. This is permanent for the live of the tank and can not be revoked. The only remaining way for the tank to fire then is to take over the gunners position.

 

How to reproduce:

Step 1: Spawn any TC tank as player, open command menu, point to the ground, left mouse click and order to suppress point (key: F2), choose platoon or crew and any ammo (tested with APHE), observe gunner firing correctly at point.

Step 2: Now open command menu, go to Assign targets (key: F1) and order Do like me (F4). Then repeat Step 1. Observe that gunner now will not turn turret to point anymore, or at all for that matter.

Step 3: Open command menu, open Assign targets (F1) and order any of the orders in that menu. For example Target by mission (F1). Repeat Step 1, observe same result as in step 2.

Step 4: Spawn new tank, repeat step 1, gunner behaves correctly again

Step 5: Open command menu, go to Fire control (F2) and order Do like me (F1). Repeat step 1, observe same result as in step 2.


Additional assets (videos, screenshots, logs):

How to reproduce steps 1 - 3 are shown in video


Your PC config data (OS, drivers, specific software):

IL-2 version: 4.506

  • Thanks 1
Link to post
Share on other sites
  • 2 weeks later...

Hello,

 

I would appreciate any advice on why this might be happening to me and how to fix it.

 

The issue is basically that I play the game normally (using HP Reverb as display and Thrusmaster T.16000 stick+pedals+throttle as controls) and suddenly, apparently at random (although usually, but not always, it happens during some higher G manouevre) the game just stops to react to any control input - be it the thrustmaster set, or the keyboard or a mouse. It just locks out and I can watch being stuck in the last manouver until it hits the ground or fuel goes out. 

 

The computer meanwhile responds fully to any input, I can Alt+Tab and do whatever else, just Il-2 is no longer responding. The only fix is to restart the game. After restart it works as supposed to - for a time, until it stops reacting again. Unfortunately the sessions during which I can play are rather short, lately it usually happens in less than an hour of playtime.

 

Any ideas what is going on and why? Thank you!

  • Like 1
Link to post
Share on other sites

Windows will shut off USB ports when idle by default. This is a function to save battery life on laptops and smart phones. It is not necessary for desktop computers and may be the cause of your problem.

Open Device Manager and expand the Universal Bus Controllers line to show all your USB devices. Double click on each one to display Properties. Click on the Power Management tab and uncheck the line "Allow the computer to turn off this device to save power." You will need to do that for each of your USB devices.

Hope this helps.

  • Thanks 1
Link to post
Share on other sites

Weird behavior forcing to shutdown, as the USB ports are still being active.  🤔 

If the advice from above is not working ( just plain guessing), then I think its more that your USB header can not give more power as all his USBports on that specific header are overflowing.  Normally you see at the back of an desktop 3 or 4 groups of USB ports, mostly you have then also 3 or 4 headers. If plugging one group of USB ports full with USB devices that are consuming lots of power at the same time, I can imagine the header overpower protecting is being activated. 

@VTMarvin I would try this, but I’m absolutely not the expert inhere, is to move the joystick to an separate lonely header like the from-USB ports and test again. 

This is only counting for desktops, if it is an laptop then I would suggest an powered USB hub. 

 

 

Link to post
Share on other sites
  • 2 weeks later...

No, no, no, no and no again.

 

This complete loss of all control functions has happened to me again just now and I most definitely am using a powered USB hub and all my USB extensible host controllers and USB hubs are configured with the ""allow the computer to turn off this device to save power" boxes unticked in Windows Device Manager. Every single last one of them. Fourteen in total.

 

This problem is not caused by the computer O/S switching off USB devices randomly. That is a massive red herring IMO.

 

This problem is caused by a bug in the game code causing it to lose connection to all of the user input interfaces. It is a coding issue because some function in the game is overwriting an area of dynamic memory that it should not overwrite . A dynamic memory allocation and control issue in fact, and it is most likely that the developers will need to break the code down into its most basic components to test the interaction of all coding units from the ground up in order to find out where and how it is happening.

 

They don't seem in any hurry to do that unfortunately and that is a problem with trying to build an ongoing commercial product upon a foundation of legacy code which was not sufficiently tested in the first place. So don't hold your breath waiting for a solution any time soon.

 

Sad, but true I'm afraid to say. 😟

Link to post
Share on other sites
  • 1CGS
On 4/5/2021 at 6:13 AM, [N.O.G.F]Leon_Portier said:

Brief description:

AI gunner in TC tanks gets permanently disabled when ordered to "Do like me" in the command menu


Detailed description, conditions:

When the gunner in any TC tank (tested with KV-1s and Panzer 4) gets ordered through the command menu to "Do like me" either in the Assign Targets menu or Fire Control menu, he does not take any orders, like assigning a new target. This is permanent for the live of the tank and can not be revoked. The only remaining way for the tank to fire then is to take over the gunners position.

 

How to reproduce:

Step 1: Spawn any TC tank as player, open command menu, point to the ground, left mouse click and order to suppress point (key: F2), choose platoon or crew and any ammo (tested with APHE), observe gunner firing correctly at point.

Step 2: Now open command menu, go to Assign targets (key: F1) and order Do like me (F4). Then repeat Step 1. Observe that gunner now will not turn turret to point anymore, or at all for that matter.

Step 3: Open command menu, open Assign targets (F1) and order any of the orders in that menu. For example Target by mission (F1). Repeat Step 1, observe same result as in step 2.

Step 4: Spawn new tank, repeat step 1, gunner behaves correctly again

Step 5: Open command menu, go to Fire control (F2) and order Do like me (F1). Repeat step 1, observe same result as in step 2.


Additional assets (videos, screenshots, logs):

How to reproduce steps 1 - 3 are shown in video


Your PC config data (OS, drivers, specific software):

IL-2 version: 4.506

Thank you for the detailed report, the task is in progress.

On 4/17/2021 at 6:33 PM, VTMarvin said:

Any ideas what is going on and why?

No ideas yet unfortunately (

  • Thanks 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...