Jump to content
Y-29.Silky

Esc Button Blues

Recommended Posts

This has happened to me before in multiplayer, now it just happened to me again in the campaign. I finished a very, very nice Pe-2 mission that would have given me insane XP. Right when I finished the mission by getting to the exit point (which was a fun 53km away), my Esc button doesn't work. 5 seconds later an enemy completely annihilates me (wouldn't have mattered anyways, and he also decides to pass up my 2 wingmen who were closer). But aside from the broken level bombing missions, the only option I have is Ctl+Alt+Del. If I survived, did a full mission, and landed only to notice my Esc button doesn't work.. Oooh my.. Either way = 0xp.

 

 

* Please look into this Esc button bug, I know I'm not the only one who's experienced it before. 

* Please allow unlocks to be unlocked, via playing multiplayer, because I'm losing my patience and am sick of wasting my time trying to play this broken campaign, just so I can play multiplayer. This is a futile complaint, but I thought I'd throw it in there anyways :}

Share this post


Link to post
Share on other sites

Same bug here. Psychoticshoom just told me to alt tab out. That resets it in return. Ill try that tonight.  Needs fixed I agree :)

Share this post


Link to post
Share on other sites

I find if I leave one of my switches in an 'active' mode (ie it is continually sending a command to the game) it stops the game from 'seeing' the Esc key imput. The solution is to switch the offending button off and the Esc key works again.

 

For example, I use a Warthog joystick/throttle and I have the flaps extend/retract mapped to the flaps switch on the throttle. This button has three positions and stays in whatever position you put it in.

The central position is 'neutral' and does nothing while the "UP/DOWN" positions are programed to raise/lower the flaps.

 

After landing and completing a mission if I leave the flaps button in the 'lower flaps' position my Esc key wont work (as flaps button is continually sending the 'extend flaps' command to the game). As soon as I put the switch to the 'neutral' central position the Esc key works.

 

Whenever my Esc key doesn't work it is ALWAYS because I have left a switch/button in an active position and I can always fix the problem. :)

 

I hope this helps.

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

I find if I leave one of my switches in an 'active' mode (ie it is continually sending a command to the game) it stops the game from 'seeing' the Esc key imput. The solution is to switch the offending button off and the Esc key works again.

 

For example, I use a Warthog joystick/throttle and I have the flaps extend/retract mapped to the flaps switch on the throttle. This button has three positions and stays in whatever position you put it in.

The central position is 'neutral' and does nothing while the "UP/DOWN" positions are programed to raise/lower the flaps.

 

After landing and completing a mission if I leave the flaps button in the 'lower flaps' position my Esc key wont work (as flaps button is continually sending the 'extend flaps' command to the game). As soon as I put the switch to the 'neutral' central position the Esc key works.

 

Whenever my Esc key doesn't work it is ALWAYS because I have left a switch/button in an active position and I can always fix the problem. :)

 

I hope this helps.

+1

Share this post


Link to post
Share on other sites
Put all axes assigned to hotas sliding in neutral, in my warthog happens with flaps, but by passing the neutral point is solved 

greetings.

Share this post


Link to post
Share on other sites

The Warthog Pinky switch has the same issue.

Speaking of the Warthog has there been any news about fixing the chorded inputs issue?

 

D_T

Share this post


Link to post
Share on other sites

Should not have to do any of these things.... mission success ... mission complete... esc should work most definitely. This is a bug, PLEASE fix this.

Share this post


Link to post
Share on other sites

It may sound strange, but I have found that binding the escape key to a button on my Warthog solves this altogether for me.

Strange but true.

Share this post


Link to post
Share on other sites

That is odd. I have it mapped to the button on the front of the left throttle and I have the problem. Which button do you have it mapped to?

Share this post


Link to post
Share on other sites

I just finished 3 missions successfully and the only thing I did different was test the ESC key before I took off. I set up the mission/missions spawned into the game and before I rolled down the runway I hit the ESC key and it worked at that point. I then tried the key several more times during each mission and it operated as it is supposed to. Finished the missions  and it worked all 3 times. SO, what the heck? everyone is doing something different but what is the same? Can this issue please be addressed?

 

          Thank you Dev's....  I am having a blast in BOS    S! 

Share this post


Link to post
Share on other sites

Had the same problem, mission finished, ESC key unresponsive. 

I use an X52. Please have a look at this.

 

Edit: 

I was able to resolve this after pressing O for the map and then normal map mode, not 'my plane'. This might be pure coincidence but it seemed to have worked.

I played in hardcore mode.

 

Dag

Edited by DrDag

Share this post


Link to post
Share on other sites

Wondering if this thread is being monitored, it has been around for nearly a week. Would like to hear something from the Dev's.

Share this post


Link to post
Share on other sites

Had the same problem, mission finished, ESC key unresponsive. 

I use an X52. Please have a look at this.

 

Edit: 

I was able to resolve this after pressing O for the map and then normal map mode, not 'my plane'. This might be pure coincidence but it seemed to have worked.

I played in hardcore mode.

 

Dag

It seems to me that everyone is coming up with new ways to solve this bug, but what is the one thing that we are all doing the same? Anyone have a thought?

Share this post


Link to post
Share on other sites

That is odd. I have it mapped to the button on the front of the left throttle and I have the problem. Which button do you have it mapped to?

H4U- I have not had the problem since I did this. 

Share this post


Link to post
Share on other sites

Should not have to do any of these things.... mission success ... mission complete... esc should work most definitely. This is a bug, PLEASE fix this.

Share this post


Link to post
Share on other sites

Just got bit by this myself earlier today.  Forgot to try testing the Esc key at the beginning of the mission, but after it ended and I couldn't escape I tried all the other suggestions posted above and nothing worked. Had to alt-tab out and shut BoS down. I had finally decided to try the XP grind anyway, despite all my reservations about it, and then I lost my first tutorial mission (flying a plane I didn't want to fly in the first place).  Guess I'll go install the new DCS stuff I picked up at the recent sale, and come back to this in a few weeks when hopefully things will be working better.

 

Too bad - I was looking forward to getting back to some ground-pounding action in a trusty IL-2, but it looks like I'll have to wait a bit longer.  I hope all this stuff gets sorted out before it does irreparable harm to the franchise, since as far as I can tell from the bits I've seen so far a lot of things have been done well and this could be a really fine sim if you could play it without all these distractions.

  • Upvote 1

Share this post


Link to post
Share on other sites

Aparently this is not a concern for the developers, maybe some day it will happen to the right person and get fixed. Till then I will stick with ROF.

Share this post


Link to post
Share on other sites

Well, this bug had disappeared for me since they seemed to do something to improve stability on last Friday (didn't have any CTDs or Esc key problems for the last 3 days, after suffering through lots of both problems for the past week or so), but then tonight I got bit by the Esc key bug twice in the last 3 missions.

 

Not sure what that means, but not a good sign  :(

Edited by TG-55Panthercules

Share this post


Link to post
Share on other sites

It does seem to be random... I will also have a few missions run good but then it will happen again. I have tried a few things but just when you think you have it beat there it is again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...